Αποστολέας Θέμα: Πρόβλημα με epoptes  (Αναγνώστηκε 523 φορές)

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Πρόβλημα με epoptes
« στις: 13 Νοέ 2019, 12:59:58 μμ »
Καλημέρα!

Σήμερα, ένας από τους clients μου δεν θέλει να τρέξει το epoptes-client με τίποτα. Δοκίμασα να το ξαναστήσω, αλλά εν τέλει δεν σηκώνεται.
Όταν το τρέχω με το χέρι βγάζει το παρακάτω μήνυμα:
./epoptes-client: 16: /lib/lsb/init-functions: !WeRRANDIES: not found
./epoptes-client: 7: /lib/lsb/init-functions: Syntax error: Unterminated quoted string

Μπορεί να φανταστεί κανείς τι φταίει; Ή τι μπορώ να κάνω;
Δοκίμασα και με το χέρι να αντικαταστήσω το αρχείο /usr/sbin/epoptes-client από άλλο raspberry που δουλεύει, αλλά χωρίς επιτυχία.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα με epoptes
« Απάντηση #1 στις: 13 Νοέ 2019, 01:16:31 μμ »
Κώδικας: Bash
  1. $ md5sum /lib/lsb/init-functions
  2. 9361019db96e17c3ad79c772df204481  /lib/lsb/init-functions

Με την παραπάνω εντολή βλέπω ότι το αρχείο αυτό έχει md5sum που αρχίζει από 93.
Αν την κάνεις σε όλους τους clients θα έπρεπε να βλέπεις το ίδιο νούμερο.

Στον προβληματικό client θα διαπιστώσεις άλλο νούμερο, το οποίο και σημαίνει ότι το αρχείο είναι πειραγμένο. Μπορείς και να το ανοίξεις με editor, μάλλον θα δεις και σκουπίδια μέσα.
Θεωρώ πιο πιθανό να έχει χαλάσει το filesystem, οπότε να δεις κι άλλα τέτοια προβλήματα.
Θέλει βγάλσιμο η κάρτα SD του Raspberry, sudo fsck -a για να φτιάξει, μετά debsums -s για να δεις ότι δεν έχουν πειραχτεί κι ένα σωρό άλλα.... και είτε επαναφορά τους είτε ξαναφτιάξιμο είτε πέταγμα αυτής της κάρτας.

Ένας από τους λόγους βόλευε το LTSP με τα Raspberry ήταν και αυτός, ότι χωρίς το LTSP χαλάνε πολύ γρήγορα οι κάρτες τους.

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Πρόβλημα με epoptes
« Απάντηση #2 στις: 13 Νοέ 2019, 04:03:22 μμ »
Λες δηλαδή ότι οι SD κάρτες χαλάνε με την πολλή χρήση; Και ότι η φθορά που παρατηρούμε θα επέλθει σιγά σιγά σε όλους τους clients;

Αυτό με το checksum θα το δω αύριο. Δυστυχώς την ώρα του μαθήματος δεν έχω πολλά περιθώρια. Όταν τελειώσει το μάθημα κοιτώ τα προβλήματά μου και τα ξαναβλέπω την επόμενη που θα πάω στο εργαστήριο. Οπότε αύριο θα δω τι γίνεται με αυτό το αρχείο. Δεν έχω παρατηρήσει όμως άλλα προβλήματα στο συγκεκριμένο client.
Αλήθεια, δεν μπορώ απλά να αντικαταστήσω το αρχείο αυτό αντιγράφοντάς το από έναν άλλο client?

Κι αν τελικά χρειαστεί να κάνω τα βήματα που λες (fsck -a  &  debsums -s), τα εκτελώ σε ένα άλλο PC? Έχω card reader στον server μου. Νομίζω θα είναι οκ.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα με epoptes
« Απάντηση #3 στις: 13 Νοέ 2019, 04:46:39 μμ »
Στο Linux, ξέρουμε κάθε αρχείο του σκληρού από ποιο πρόγραμμα μπαίνει:

Κώδικας: Bash
  1. $ dpkg -S /lib/lsb/init-functions
  2. lsb-base: /lib/lsb/init-functions
  3.  
  4. $ sudo apt install --reinstall lsb-base

Με την dpkg -S βρίσκουμε το όνομα του πακέτου και με την apt install το ξαναεγκαθιστούμε από το Internet, χωρίς να ασχοληθούμε να το πάρουμε από άλλον Η/Υ.

Επίσης, με apt install debsums; debsums -s lsb-base μπορούμε να κάνουμε έλεγχο των αρχείων αυτού του πακέτου αν έχουν πειραχτεί. Ή χωρίς όνομα πακέτου, για ελέγξουμε όλα τα πακέτα.

Σε κάποιες περιπτώσεις το πρόβλημα είναι μόνο ένα αρχείο· σε άλλες αυτό είναι μόνο η προειδοποίηση ότι τα παίζει η κάρτα· και σε άλλες φταίει η ποιότητα της τροφοδοσίας που δεν είναι αρκετό το ρεύμα για να γράφεται σωστά η κάρτα, και θέλει αλλαγή μετασχηματιστή και φορμάτ.

Κάνε αρχή και βλέπουμε, εγώ για 2-3 rpi που έχω στο σπίτι έχω ήδη φάει αρκετές ώρες να τους αλλάζω κάρτες. Να φανταστείς παρατήρησα ότι αν λειτουργώ πληκτρολόγιο/ποντίκι μέσω hub με ξεχωριστή τροφοδοσία, τότε οι κάρτες παρουσιάζουν πιο αραιά προβλήματα... είναι ευαισθητούλια τα καημένα.  :D

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Πρόβλημα με epoptes
« Απάντηση #4 στις: 13 Νοέ 2019, 05:21:25 μμ »
Ευχαριστώ πολύ. Θα ενημερώσω για την πρόοδό μου.

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Πρόβλημα με epoptes
« Απάντηση #5 στις: 19 Νοέ 2019, 12:23:08 μμ »
Άλκη,
αυτό που πρόλαβα να δω είναι πως όντως το checksum του αρχείου είναι διαφορετικό από όλων των άλλων και όντως το αρχείο init-functions έχει σκουπίδια μέσα.
Ωστόσο πήγα να κάνω fsck στην κάρτα και δεν μπορούσα. Την έβγαλα απο το raspberry, την έβαλα σε card reader στο Linux server μου, αλλά τρέχοντας την sudo fsck -a /dev/sdb1 (εκεί ήταν mounted) μου έλεγε πως πρέπει να την κάνω umount. Όταν την έκανα umount, έπαιρνα ένα άλλο μήνυμα λάθους (που τώρα δεν το θυμάμαι).
Έκανα κάτι λάθος; Θα το δω και αύριο που θα είμαι πάλι εκεί.

Λ.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα με epoptes
« Απάντηση #6 στις: 19 Νοέ 2019, 12:30:01 μμ »
Δοκίμασε:

Κώδικας: Bash
  1. sudo umount /dev/sdb?
  2. sudo fsck -a /dev/sdb1

...επειδή αν την κάνεις unmount από τον file manager, υπάρχει περίπτωση να κάνει πλήρη εξαγωγή της κάρτας αντί για αποπροσάρτηση, δηλαδή μετά να μην υπάρχει καν sdb1.

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Πρόβλημα με epoptes
« Απάντηση #7 στις: 25 Νοέ 2019, 12:19:51 μμ »
Καλημέρα!

Ενημερώνω για την πορεία μου, χωρίς να ξέρω γιατί τελικά δεν έχω πρόβλημα.
Έκανα umount τη κάρτα μου.
Η εντολή fsck δεν έτρεχε. Έπαιρνα κάποιο μήνυμα της μορφής "Get a newer version of e2fsck". Οπότε εγκατέστησα την τελευταία έκδοση του e2fsck και την έτρεξα με την παράμετρο -p (που όπως διάβασα είναι το αντίστοιχο του fsck -a). Πήρα μήνυμα ότι η κάρτα είναι clean.
Στη συνέχεια δοκίμασα να κάνω επαναφορά με την εντολή sudo apt install --reinstall lsb-base, της οποίας το αποτέλεσμα γράφω παρακάτω:

pi@pi5:~ $ sudo apt install --reinstall lsb-base
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                 
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Τα ακόλουθα πακέτα εγκαταστάθηκαν αυτόματα και δεν χρειάζονται πλέον:
  lxkeymap python-gobject python-xklavier realpath
Χρησιμοποιήστε 'sudo apt autoremove' για να τα διαγράψετε.
0 αναβαθμίστηκαν, 0 νέο εγκατεστημένα, 1 επανεγκατεστημένα,0 θα αφαιρεθούν και 139 δεν αναβαθμίζονται.
1 μη πλήρως εγκατεστημένα ή αφαιρέθηκαν.
Χρειάζεται να μεταφορτωθούν 28,2 kB από αρχεία.
Μετά από αυτή τη λειτουργία, θα χρησιμοποιηθούν 0 B χώρου από το δίσκο.
Φέρε:1 http://mirrors.linux-bg.org/raspbian/raspbian stretch/main armhf lsb-base all 9.20161125+rpi1 [28,2 kB]
Μεταφορτώθηκαν 28,2 kB σε 2s (9556 B/s)       
(Ανάγνωση βάσης δεδομένων ... 140753 files and directories currently installed.)
Preparing to unpack .../lsb-base_9.20161125+rpi1_all.deb ...
Unpacking lsb-base (9.20161125+rpi1) over (9.20161125+rpi1) ...
Γίνεται εγκατάσταση lsb-base (9.20161125+rpi1) ...
Γίνεται εγκατάσταση epoptes (0.5.10-2) ...
Job for epoptes.service failed because the control process exited with error code.
See "systemctl status epoptes.service" and "journalctl -xe" for details.
invoke-rc.d: initscript epoptes, action "start" failed.
● epoptes.service - LSB: Epoptes service
   Loaded: loaded (/etc/init.d/epoptes; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2019-11-20 12:41:10 EET; 72ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 865 ExecStart=/etc/init.d/epoptes start (code=exited, status=1/FAILURE)
   CGroup: /system.slice/epoptes.service
           └─873 /usr/bin/python /usr/bin/twistd --pidfile /var/run/epoptes.p…es

Νοέ 20 12:41:02 pi5 systemd[1]: Starting LSB: Epoptes service...
Νοέ 20 12:41:10 pi5 epoptes[865]: Starting the epoptes daemon:An error h…')]"
Νοέ 20 12:41:10 pi5 epoptes[865]: Please look at log file for more infor…ion.
Νοέ 20 12:41:10 pi5 epoptes[865]:  failed!
Νοέ 20 12:41:10 pi5 systemd[1]: epoptes.service: Control process exited,…us=1
Νοέ 20 12:41:10 pi5 systemd[1]: Failed to start LSB: Epoptes service.
Νοέ 20 12:41:10 pi5 systemd[1]: epoptes.service: Unit entered failed state.
Νοέ 20 12:41:10 pi5 systemd[1]: epoptes.service: Failed with result 'exi…de'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package epoptes (--configure):
 η υποδιεργασία installed post-installation script επέστρεψε κατάσταση λάθους 1
Processing triggers for python-twisted-core (16.6.0-2) ...
Προέκυψαν σφάλματα κατά την επεξεργασία του:
 epoptes
E: Sub-process /usr/bin/dpkg returned an error code (1)


Εμένα αυτό μου λέει πως λάθη συνέβησαν, που δεν ξέρω τι είναι ακριβώς. Αλλά, η διαφορά είναι πως τώρα ο epoptes-client σηκώνεται και τρέχει κανονικά.
Ειλικρινά δεν ξέρω τι συνέβη, αλλά για την ώρα η δουλειά μου γίνεται.

Λάμπρος

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα με epoptes
« Απάντηση #8 στις: 25 Νοέ 2019, 12:35:53 μμ »
Έχει κι άλλα χαλασμένα αρχεία, όταν θελήσεις τρέξε `sudo debsums -s` για να δεις ποια είναι. Στο μεταξύ κουτσοδουλεύεις με μισοχαλασμένο file system.

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Πρόβλημα με epoptes
« Απάντηση #9 στις: 25 Νοέ 2019, 01:12:57 μμ »
Τώρα δεν έχω μπροστά μου το raspberry, αλλά μπορώ να κάνω κάτι από τώρα για να μην σκάσει τελείως το filesystem? Π.χ. να αντιγράψω μια ολόκληρη άλλη κάρτα SD σε αυτήν; (μπακαλίστικο!!!)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα με epoptes
« Απάντηση #10 στις: 25 Νοέ 2019, 02:52:42 μμ »
Το επόμενο βήμα είναι η sudo debsums -s. Αυτό που ρωτάς είναι το παραεπόμενο, αφού δώσεις ανατροφοδότηση.

Όμως την αντιγραφή ολόκληρης της κάρτας μπορείς να την κάνεις και αφού χαλάσει το filesystem, αρκεί βέβαια να μην έχει χαλάσει ως hardware η κάρτα.

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Πρόβλημα με epoptes
« Απάντηση #11 στις: 29 Νοέ 2019, 10:21:53 πμ »
Καλημέρα.

Εκτέλεσα την debsums:

pi@pi5:~ $ sudo debsums -s
debsums: changed file /lib/dhcpcd/dhcpcd-hooks/02-dump (from dhcpcd5 package)
debsums: changed file /lib/dhcpcd/dhcpcd-hooks/10-wpa_supplicant (from dhcpcd5 package)
debsums: changed file /lib/dhcpcd/dhcpcd-hooks/20-resolv.conf (from dhcpcd5 package)
debsums: changed file /lib/dhcpcd/dhcpcd-hooks/30-hostname (from dhcpcd5 package)
debsums: changed file /lib/dhcpcd/dhcpcd-hooks/50-ntp.conf (from dhcpcd5 package)
debsums: changed file /lib/modules/4.14.98+/kernel/arch/arm/oprofile/oprofile.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/crypto/arc4.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/bluetooth/ath3k.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/bluetooth/bpa10x.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/bluetooth/btbcm.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/bluetooth/btmrvl_sdio.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/bluetooth/hci_uart.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/cdrom/cdrom.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/char/broadcom/bcm2835_smi_dev.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/char/hw_random/tpm-rng.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/char/tpm/tpm.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/char/tpm/tpm_tis_core.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/misc/cm109.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/misc/cma3000_d0x.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/misc/keyspan_remote.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/misc/yealink.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/serio/serio.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/touchscreen/edt-ft5x06.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/touchscreen/egalax_ts.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/touchscreen/exc3000.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/input/touchscreen/usbtouchscreen.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/mmc/host/mmc_spi.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/mtd/mtd.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/mtd/nand/nand.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/mtd/ofpart.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/mtd/ubi/ubi.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/net/wireless/atmel/at76c50x-usb.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/pinctrl/pinctrl-mcp23s08.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/tty/serdev/serdev.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/drivers/uio/uio.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/fs/ecryptfs/ecryptfs.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/fs/fuse/fuse.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/net/mac80211/mac80211.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/kernel/net/mac802154/mac802154.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/modules.alias (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/modules.alias.bin (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/modules.dep (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/modules.dep.bin (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/modules.devname (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98+/modules.softdep (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98-v7+/kernel/drivers/rtc/rtc-em3027.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98-v7+/kernel/drivers/staging/irda/drivers/stir4200.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98-v7+/kernel/drivers/staging/irda/net/ircomm/ircomm-tty.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98-v7+/kernel/drivers/staging/irda/net/irda.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98-v7+/kernel/drivers/staging/irda/net/irnet/irnet.ko (from raspberrypi-kernel package)
debsums: changed file /lib/modules/4.14.98-v7+/modules.softdep (from raspberrypi-kernel package)


Προτείνετε κάποια κίνηση;

Λάμπρος

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα με epoptes
« Απάντηση #12 στις: 29 Νοέ 2019, 11:26:14 πμ »
ΟΚ άρα μικρή φαίνεται η ζημιά, σαν να έγινε απότομο κλείσιμο όταν έκανε updates.
Νομίζω ότι με την παρακάτω εντολή θα είσαι ΟΚ και δεν θα χρειαστεί κάποια άλλη ενέργεια:

Κώδικας: Bash
  1. sudo apt install --reinstall raspberrypi-kernel dhcpcd5

ntalkos

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Πρόβλημα με epoptes
« Απάντηση #13 στις: 30 Νοέ 2019, 10:53:44 πμ »
Καλημέρα.
Κατά την εκτέλεση της εντολής πήρα αυτή την έξοδο:

pi@pi5:~ $ sudo apt install --reinstall raspberrypi-kernel dhcpcd5
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                  
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Τα ακόλουθα πακέτα εγκαταστάθηκαν αυτόματα και δεν χρειάζονται πλέον:
  lxkeymap python-gobject python-xklavier realpath
Χρησιμοποιήστε 'sudo apt autoremove' για να τα διαγράψετε.
Τα ακόλουθα πακέτα θα αναβαθμιστούν:
  raspberrypi-kernel
1 αναβαθμίστηκαν, 0 νέο εγκατεστημένα, 1 επανεγκατεστημένα,0 θα αφαιρεθούν και 149 δεν αναβαθμίζονται.
1 μη πλήρως εγκατεστημένα ή αφαιρέθηκαν.
Χρειάζεται να μεταφορτωθούν 35,4 MB/35,5 MB από αρχεία.
Μετά από αυτή τη λειτουργία, θα χρησιμοποιηθούν 7706 kB χώρου από το δίσκο.
Φέρε:1 http://archive.raspberrypi.org/debian stretch/main armhf raspberrypi-kernel armhf 1.20190819~stretch-1 [35,4 MB]
Μεταφορτώθηκαν 35,4 MB σε 31s (1122 kB/s)                                      
Reading changelogs... Done
(Ανάγνωση βάσης δεδομένων ... 147320 files and directories currently installed.)
Preparing to unpack .../dhcpcd5_1%3a6.11.5-1+rpt7_armhf.deb ...
Unpacking dhcpcd5 (1:6.11.5-1+rpt7) over (1:6.11.5-1+rpt7) ...
Preparing to unpack .../raspberrypi-kernel_1.20190819~stretch-1_armhf.deb ...
Adding 'diversion of /boot/bcm2708-rpi-b-plus.dtb to /usr/share/rpikernelhack/bcm2708-rpi-b-plus.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2708-rpi-b.dtb to /usr/share/rpikernelhack/bcm2708-rpi-b.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2708-rpi-cm.dtb to /usr/share/rpikernelhack/bcm2708-rpi-cm.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2708-rpi-zero-w.dtb to /usr/share/rpikernelhack/bcm2708-rpi-zero-w.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2708-rpi-zero.dtb to /usr/share/rpikernelhack/bcm2708-rpi-zero.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2709-rpi-2-b.dtb to /usr/share/rpikernelhack/bcm2709-rpi-2-b.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2710-rpi-3-b-plus.dtb to /usr/share/rpikernelhack/bcm2710-rpi-3-b-plus.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2710-rpi-3-b.dtb to /usr/share/rpikernelhack/bcm2710-rpi-3-b.dtb by rpikernelhack'
Adding 'diversion of /boot/bcm2710-rpi-cm3.dtb to /usr/share/rpikernelhack/bcm2710-rpi-cm3.dtb by rpikernelhack'
Adding 'diversion of /boot/kernel.img to /usr/share/rpikernelhack/kernel.img by rpikernelhack'
Adding 'diversion of /boot/kernel7.img to /usr/share/rpikernelhack/kernel7.img by rpikernelhack'
Adding 'diversion of /boot/COPYING.linux to /usr/share/rpikernelhack/COPYING.linux by rpikernelhack'
Adding 'diversion of /boot/overlays/README to /usr/share/rpikernelhack/overlays/README by rpikernelhack'
Adding 'diversion of /boot/overlays/act-led.dtbo to /usr/share/rpikernelhack/overlays/act-led.dtbo by rpikernelhack'
......
.....
Adding 'diversion of /boot/overlays/wittypi.dtbo to /usr/share/rpikernelhack/overlays/wittypi.dtbo by rpikernelhack'
Unpacking raspberrypi-kernel (1.20190819~stretch-1) over (1.20190215-1) ...
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.14.98+ /boot/kernel.img
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.14.98-v7+ /boot/kernel7.img
Γίνεται εγκατάσταση dhcpcd5 (1:6.11.5-1+rpt7) ...
Γίνεται εγκατάσταση epoptes (0.5.10-2) ...
Job for epoptes.service failed because the control process exited with error code.
See "systemctl status epoptes.service" and "journalctl -xe" for details.
invoke-rc.d: initscript epoptes, action "start" failed.
● epoptes.service - LSB: Epoptes service
   Loaded: loaded (/etc/init.d/epoptes; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2019-11-29 12:33:11 EET; 33ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 8762 ExecStart=/etc/init.d/epoptes start (code=exited, status=1/FAILURE)
   CGroup: /system.slice/epoptes.service
           └─8771 /usr/bin/python /usr/bin/twistd --pidfile /var/run/epoptes.…es

Νοέ 29 12:33:06 pi5 systemd[1]: Starting LSB: Epoptes service...
Νοέ 29 12:33:11 pi5 epoptes[8762]: Starting the epoptes daemon:An error …')]"
Νοέ 29 12:33:11 pi5 epoptes[8762]: Please look at log file for more info…ion.
Νοέ 29 12:33:11 pi5 epoptes[8762]:  failed!
Νοέ 29 12:33:11 pi5 systemd[1]: epoptes.service: Control process exited,…us=1
Νοέ 29 12:33:11 pi5 systemd[1]: Failed to start LSB: Epoptes service.
Νοέ 29 12:33:11 pi5 systemd[1]: epoptes.service: Unit entered failed state.
Νοέ 29 12:33:11 pi5 systemd[1]: epoptes.service: Failed with result 'exi…de'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package epoptes (--configure):
 η υποδιεργασία installed post-installation script επέστρεψε κατάσταση λάθους 1
Γίνεται εγκατάσταση raspberrypi-kernel (1.20190819~stretch-1) ...
Removing 'diversion of /boot/bcm2708-rpi-b-plus.dtb to /usr/share/rpikernelhack/bcm2708-rpi-b-plus.dtb by rpikernelhack'
Removing 'diversion of /boot/bcm2708-rpi-b.dtb to /usr/share/rpikernelhack/bcm2708-rpi-b.dtb by rpikernelhack'
Removing 'diversion of /boot/bcm2708-rpi-cm.dtb to /usr/share/rpikernelhack/bcm2708-rpi-cm.dtb by rpikernelhack'
Removing 'diversion of /boot/bcm2708-rpi-zero-w.dtb to /usr/share/rpikernelhack/bcm2708-rpi-zero-w.dtb by rpikernelhack'
....
Removing 'diversion of /boot/overlays/upstream.dtbo to /usr/share/rpikernelhack/overlays/upstream.dtbo by rpikernelhack'
Removing 'diversion of /boot/overlays/vc4-fkms-v3d.dtbo to /usr/share/rpikernelhack/overlays/vc4-fkms-v3d.dtbo by rpikernelhack'
Removing 'diversion of /boot/overlays/vc4-kms-kippah-7inch.dtbo to /usr/share/rpikernelhack/overlays/vc4-kms-kippah-7inch.dtbo by rpikernelhack'
Removing 'diversion of /boot/overlays/vc4-kms-v3d.dtbo to /usr/share/rpikernelhack/overlays/vc4-kms-v3d.dtbo by rpikernelhack'
Removing 'diversion of /boot/overlays/vga666.dtbo to /usr/share/rpikernelhack/overlays/vga666.dtbo by rpikernelhack'
Removing 'diversion of /boot/overlays/w1-gpio-pullup.dtbo to /usr/share/rpikernelhack/overlays/w1-gpio-pullup.dtbo by rpikernelhack'
Removing 'diversion of /boot/overlays/w1-gpio.dtbo to /usr/share/rpikernelhack/overlays/w1-gpio.dtbo by rpikernelhack'
Removing 'diversion of /boot/overlays/wittypi.dtbo to /usr/share/rpikernelhack/overlays/wittypi.dtbo by rpikernelhack'
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66+ /boot/kernel.img
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66+ /boot/kernel.img
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66-v7+ /boot/kernel7.img
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66-v7+ /boot/kernel7.img
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66-v7l+ /boot/kernel7l.img
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66-v7l+ /boot/kernel7l.img
Processing triggers for systemd (232-25+deb9u9) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for python-twisted-core (16.6.0-2) ...
Προέκυψαν σφάλματα κατά την επεξεργασία του:
 epoptes
E: Sub-process /usr/bin/dpkg returned an error code (1)


(Επισύναψα όλο το output γιατί δεν μπορούσα να το ανεβάσω εδώ).
Μάλλον κάτι δε θέλει να στρώσει.
Μετά ξαναέτρεξα την debsums -s και δεν επέστρεψε τίποτα! Όλα καθαρά μάλλον!

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα με epoptes
« Απάντηση #14 στις: 30 Νοέ 2019, 01:18:44 μμ »
Το πρώτο πρόβλημα είναι σ' εκείνη τη γραμμή που κόπηκε:

Νοέ 29 12:33:11 pi5 epoptes[8762]: Starting the epoptes daemon:An error …')]"

...την οποία θα την βλέπαμε με sudo systemctl -l status epoptes

...αλλά το δεύτερο και μεγαλύτερο πρόβλημα είναι, για ποιο λόγο να έχουν βάλει τον Επόπτη στους clients?!

Απλά απεγκατέστησέ τον:

sudo apt install epoptes-client
sudo apt purge --auto-remove epoptes