Αποστολέας Θέμα: απορία σε ασκήσεις  (Αναγνώστηκε 1436 φορές)

kkbaxr4

  • Νέος
  • *
  • Μηνύματα: 8
απορία σε ασκήσεις
« στις: 24 Φεβ 2007, 07:09:07 μμ »
Έχω δύο απορίες σε ασκήσεις από το βιβλίο του Σαβάλλα.
Ι. άσκηση 6.77 Να βρεθεί το πλήθος των όρων της παράστασης S=1+2+4+7+16+... ώστε το άθροισμα να μην ξεπερνάει το 2000.
ΙΙ. άσκηση 6.111 Να γίνει αλγόριθμος που θα δέχεται κάποιον αριθμό και θα βρίσκει το πλήθος των ψηφίων του.
Ευχαριστώ...

Christos

  • Θαμώνας
  • ***
  • Μηνύματα: 24
Απ: απορία σε ασκήσεις
« Απάντηση #1 στις: 26 Φεβ 2007, 02:38:43 πμ »
Για την πρώτη απορία σου:
Η παράσταση γράφεται και ως εξής:S=1+(1+1)+(2+2)+(4+3)+(7+4)+(11+5)+(16+6)+......
Δηλαδή κάθε όρος της ακολουθίας είναι ίδιος με τον προηγούμενο προσθέτοντας το 1, μετά το 2, μετά το 3 κ.ο.κ.
Ο αλγόριθμος είναι:
S<--0
Π<--0 !ΤΟ ΠΛΗΘΟΣ ΤΩΝ ΟΡΩΝ ΤΗΣ ΑΚΟΛΟΥΘΙΑΣ
Α<--1 !Ο 1ος ΟΡΟΣ ΤΗΣ ΑΚΟΛΟΥΘΙΑΣ
ΟΣΟ S<=2000 ΕΠΑΝΑΛΑΒΕ
S<--S+Α
Π<--Π+1
Α<--Α+Π !Ο ΕΠΟΜΕΝΟΣ ΟΡΟΣ ΤΗΣ ΑΚΟΛΟΥΘΙΑΣ ΑΥΞΑΝΕΤΑΙ ΚΑΤΑ Π ΠΡΙΝ ΠΡΟΣΤΕΘΕΙ ΣΤΟ S
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Π

Για τη δεύτερη απορία σου:

ΔΙΑΒΑΣΕ Α
Π<--0
ΟΣΟ Α<>0 ΕΠΑΝΑΛΑΒΕ
Ψ<--ΑMOD10  !ΤΕΛΕΥΤΑΙΟ ΨΗΦΙΟ ΑΠΟ ΔΕΞΙΑ
Α<--ΑDIV10   !Ο ΑΡΙΘΜΟΣ ΧΨΡΙΑ ΤΟ ΤΕΛΕΥΤΑΙΟ ΨΗΦΙΟ ΑΠΟ ΔΕΞΙΑ
Π<--Π+1    !ΠΛΗΘΟΣ ΨΗΦΙΩΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Π