Αποστολέας Θέμα: Εκχώρηση τιμής στο όνομα της συνάρτησης  (Αναγνώστηκε 67 φορές)

thanasisgr

  • Οπαδός
  • **
  • Μηνύματα: 11
Καλησπέρα σε όλους,
Θα ήθελα να ρωτήσω αν η ΤΕΛΙΚΉ τιμή που παίρνει μια συνάρτηση εκχωρείται στο όνομά της ΜΙΑ ΜΌΝΟ φορά πριν το τέλος της ΣΥΝΑΡΤΗΣΗΣ  ή Όχι.
Π.χ.

Συνάρτηση min(a, b) :ΑΚΈΡΑΙΑ
ΜΕΤΑΒΛΗΤΈΣ
ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
ΑΝ a<b ΤΟΤΕ
 min<-a
ΑΛΛΙΩΣ
min<-b
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Η

Συνάρτηση min(a, b) :ΑΚΈΡΑΙΑ
ΜΕΤΑΒΛΗΤΈΣ
ΑΚΕΡΑΙΕΣ: a, b, ελαχ
ΑΡΧΗ
ΑΝ a<b ΤΟΤΕ
 ελαχ<-a
ΑΛΛΙΩΣ
ελαχ<-b
ΤΕΛΟΣ_ΑΝ
min<-ελαχ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ





Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 680
Απ: Εκχώρηση τιμής στο όνομα της συνάρτησης
« Απάντηση #1 στις: 11 Δεκ 2019, 04:17:23 μμ »
Καλησπέρα

νομίζω και οι δύο περιπτώσεις είναι σωστές, εξάλλου στο πρώτο παράδειγμα υπάρχει ΑΝ και ΑΛΛΙΩΣ οπότε μία φορά θα γίνει η εκχώρηση ... λίγο πιο γενικός νομίζω είναι ο δεύτερος τρόπος

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: Εκχώρηση τιμής στο όνομα της συνάρτησης
« Απάντηση #2 στις: 12 Δεκ 2019, 12:51:14 πμ »
Δεν έχει σημασία αν εκχωρείται μια φορά τιμή στην συνάρτηση ή περισσότερες
Δεν θα πρέπει να γίνεται όμως το εξής γιατί είναι αναδρομή:

Συνάρτηση Πλήθος(...):ΑΚΕΡΑΙΑ


Πλήθος <-- Πλήθος + 1
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής