Αποστολέας Θέμα: μετρητής στην ΓΙΑ  (Αναγνώστηκε 1050 φορές)

anasta

  • Βετεράνος
  • ****
  • Μηνύματα: 59
  • Ok, yes... Ok, yes...
μετρητής στην ΓΙΑ
« στις: 08 Ιουν 2018, 08:55:48 μμ »
Από τις επαναληπτικές πανελλήνιες εσπερινού το 2013, θέμα Α1.β
πόσες φορές θα εμφανιστεί ο χαρακτήρας Χ;
ΓΙΑ i ΑΠΟ 0 ΜΕΧΡΙ 20
     ΓΡΑΨΕ ‘Χ’
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ j ΑΠΟ i ΜΕΧΡΙ 56
     ΓΡΑΨΕ ‘Χ’
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Το ερώτημα είναι άσκηση αντιστοίχισης και οι πιθανές απαντήσεις είναι 57 ή 58;

Η ερωτησή μου βασικά είναι τι τιμή έχει ο μετρητής της ΓΙΑ μετά το τέλος_επανάληψης, την τιμή "μέχρι" ή "μέχρι+βήμα";

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 201
Απ: μετρητής στην ΓΙΑ
« Απάντηση #1 στις: 08 Ιουν 2018, 09:10:39 μμ »
Από τις επαναληπτικές πανελλήνιες εσπερινού το 2013, θέμα Α1.β
πόσες φορές θα εμφανιστεί ο χαρακτήρας Χ;
ΓΙΑ i ΑΠΟ 0 ΜΕΧΡΙ 20
     ΓΡΑΨΕ ‘Χ’
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ j ΑΠΟ i ΜΕΧΡΙ 56
     ΓΡΑΨΕ ‘Χ’
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Το ερώτημα είναι άσκηση αντιστοίχισης και οι πιθανές απαντήσεις είναι 57 ή 58;

Η ερωτησή μου βασικά είναι τι τιμή έχει ο μετρητής της ΓΙΑ μετά το τέλος_επανάληψης, την τιμή "μέχρι" ή "μέχρι+βήμα";

για να μην μπερδευεσαι μπορεις να σκεφτεις το εξης:
για ι απο 0 μεχρι 20 με βημα 1 ειναι ισοδυναμο με το για ι απο 1 μεχρι 21 ετσι δεν ειναι??εννοω ως προς το ποσες φορες θα μπει μεσα στη για.ειναι πιο ευκολο τωρα??ακομα οταν βγαινεις απο μια δομη επαναληψης ο μετρητης πρεπει να ξεπερασει την τιμη που βρισκεται μετα το μεχρι.αφου αν δεν την ειχε ξεπερασει δεν θα ειχε βγει απο την επαναληψη.αρα οταν τελειωνει η επαναληψη το χ εχει εμφανιστει 21 φορες και το ι εχει ξεπερασει την τιμη του μεχρι.αρα το ι ειναι 21 αφου εχεις απο 0 μεχρι 20 με βημα 1.επειτα εχουμε τη για με το j απο ι μεχρι 56.το ι ειναι 21 αρα θα μπει μεσα στην επαναληψη
56-21+1 φορες.αρα το χ εμφανιζεται συνολικα 21+(56-21+1) =57 φορες

ακομα αφου ξερω οτι το ι=21 η δευτερη για μπορει να γινει
για j απο 21 μεχρι 56 που ειναι το ιδιο με το για j απο 1 μεχρι 36

ozorgnax

  • Θαμώνας
  • ***
  • Μηνύματα: 46
Απ: μετρητής στην ΓΙΑ
« Απάντηση #2 στις: 10 Ιουν 2018, 11:15:41 πμ »
Η ερωτησή μου βασικά είναι τι τιμή έχει ο μετρητής της ΓΙΑ μετά το τέλος_επανάληψης, την τιμή "μέχρι" ή "μέχρι+βήμα";
Την τιμή "μέχρι+βήμα"

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3534
  • to Iterate is human to Recurse divine
Απ: μετρητής στην ΓΙΑ
« Απάντηση #3 στις: 10 Ιουν 2018, 11:24:48 πμ »
Δεν έχει την τιμή "μέχρι + βήμα". Για παράδειγμα παρακάτω θα εμφανιστεί 13 και όχι 10+6=16

Κώδικας: Python
  1. Για ι από 1 μέχρι 10 με βήμα 6
  2. .....................
  3. Τέλος_Επανάληψης
  4. Γράψε ι

Για να καταλάβει κάποιος τι ακριβώς συμβαίνει σε αυτή την περίπτωση ένας τρόπος υπάρχει. Να μετατρέψει τη Για σε Όσο...Επανάλαβε. Τότε φαίνεται.
« Τελευταία τροποποίηση: 10 Ιουν 2018, 11:57:00 πμ από evry »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

wmaster

  • Θαμώνας
  • ***
  • Μηνύματα: 22
Απ: μετρητής στην ΓΙΑ
« Απάντηση #4 στις: 10 Ιουν 2018, 11:50:33 πμ »
Καλημέρα,

    Για ι από 1 μέχρι 10 με βήμα 6
    .....................
    Τέλος_Επανάληψης
    Γράψε ι

θα εμφανίσει 13

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3534
  • to Iterate is human to Recurse divine
Απ: μετρητής στην ΓΙΑ
« Απάντηση #5 στις: 10 Ιουν 2018, 11:56:44 πμ »
χαχα σωστά 1+6+6=13 και όχι 12, το διόρθωσα πιο πάνω
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2319
Απ: μετρητής στην ΓΙΑ
« Απάντηση #6 στις: 10 Ιουν 2018, 11:58:20 πμ »
Η τελευταία τιμή είναι:
-Μεγαλύτερη της τελικής όταν το βήμα είναι θετικό
-Μικρότερη της τελικής όταν το βήμα είναι αρνητικό
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 155
Απ: μετρητής στην ΓΙΑ
« Απάντηση #7 στις: 11 Ιουν 2018, 12:56:57 μμ »
εκτός των ειδικών περιπτώσεων των άπειρων και των μηδενικών επαναλήψεων, το πλήθος των επαναλήψεων βγαίνει ως πλ=Α_Μ(Α_Τ((τελικό-αρχικό)/βήμα))+1

και η τελική τιμή του μετρητή θα είναι αρχική+βήμα*πλ

όχι;

SPY

  • Βετεράνος
  • ****
  • Μηνύματα: 63
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: μετρητής στην ΓΙΑ
« Απάντηση #8 στις: 12 Ιουν 2018, 02:00:36 μμ »
εκτός των ειδικών περιπτώσεων των άπειρων και των μηδενικών επαναλήψεων, το πλήθος των επαναλήψεων βγαίνει ως πλ=Α_Μ(Α_Τ((τελικό-αρχικό)/βήμα))+1

και η τελική τιμή του μετρητή θα είναι αρχική+βήμα*πλ

όχι;
3 μικρές παρατηρήσεις:
1. Νομίζω ότι το Α_Τ δεν χρειάζεται.
2. Για άπειρο πλήθος επαναλήψεων το πλ δίνει άπειρο ως όριο.
3. Για μηδενικό πλήθος επαναλήψεων το πλ (χωρίς το Α_Τ) δίνει αρνητικό ή 0. Άρα μπορούμε να εξάγουμε συμπέρασμα για το πλήθος των επαναλήψεων.

Με την ευκαιρία της αυριανής εξέτασης εύχομαι στα παιδιά που προσπάθησαν καθαρό μυαλό και καλή τύχη!