Αποστολέας Θέμα: Μονοδιάστατος Πίνακας  (Αναγνώστηκε 764 φορές)

Karamali Maria

  • Νέος
  • *
  • Μηνύματα: 2
Μονοδιάστατος Πίνακας
« στις: 02 Μάρ 2018, 06:36:51 μμ »
Καλησπέρα, θα μπορούσε κάποιος να με βοηθήσει μιας κ είμαι σχετικά άπειρη.
Έχοντας ένα πίνακα με τις εισπράξεις ενός έτους , δηλαδή ΕΙΣΠΡΆΞΕΙΣ [12] , θα μπορούσαμε να βρούμε ένα αλγόριθμο να υπολογίζει τις εισπράξεις κάθε τρίμηνο ;
Ευχαριστώ πολύ εκ των προτέρων.

astakos1010

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Μονοδιάστατος Πίνακας
« Απάντηση #1 στις: 02 Μάρ 2018, 07:15:48 μμ »
ΠΡΟΓΡΑΜΜΑ ΕΙΣΠ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, ΕΙΣ[12], ΑΘΡ
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12
    ΔΙΑΒΑΣΕ ΕΙΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ     
  ΑΘΡ <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12     
    ΑΘΡ <-- ΑΘΡ + ΕΙΣ
    ΑΝ i MOD 3 = 0  ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΙΣ ',i/3, ' ΤΡΙΜΗΝΟΥ = ',ΑΘΡ
      ΑΘΡ <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ               
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

bugman

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 382
  • The Bug Eater
    • Πληροφορική Προγραμματισμός
Απ: Μονοδιάστατος Πίνακας
« Απάντηση #2 στις: 02 Μάρ 2018, 07:36:49 μμ »
Το παραπάνω πρόγραμμα εμφανίζει τις εισπράξεις, αλλά δεν τις κρατάει, για άλλους υπολογισμούς. Η λύση θα έπρεπε να περιλαμβάνει έναν πίνακα ΤΡΙΜ_ΕΙΣΠΡΑΞΕΙΣ[4], ένα διπλό ΓΙΑ το εξωτερικό θα μετράει το τρίμηνο από 1έως 4 και το εσωτερικό από 1 έως 3..
Το ερώτημα που βάζω για να λύσει η Maria:
Αρχική τιμή του ΤΡΙΜ_ΕΙΣΠΡΑΞΕΙΣ[τύπος 1]
ΤΡΙΜ_ΕΙΣΠΡΑΞΕΙΣ[τύπος 1]=ΤΡΙΜ_ΕΙΣΠΡΑΞΕΙΣ[τύπος 1]+ΕΙΣΠΡΑΞΕΙΣ[τύπος 2]
Ποιός είναι ο τύπος 1 και ποιος ο τύπος 2 με δοσμένο αρχή και τέλος επαναλήψεων. Να γραφτεί ο κώδικας από το πρώτο Για μέχρι το τελευταίο Τέλος Επανάληψης.
Δεν μας ενδιαφέρει η εμφάνιση αποτελεσμάτων, μας αρκεί ο πίνακας αποτελεσμάτων.

astakos1010

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Μονοδιάστατος Πίνακας
« Απάντηση #3 στις: 02 Μάρ 2018, 07:50:42 μμ »
Το παραπάνω πρόγραμμα εμφανίζει τις εισπράξεις, αλλά δεν τις κρατάει, για άλλους υπολογισμούς. Η λύση θα έπρεπε να περιλαμβάνει έναν πίνακα ΤΡΙΜ_ΕΙΣΠΡΑΞΕΙΣ[4], ένα διπλό ΓΙΑ το εξωτερικό θα μετράει το τρίμηνο από 1έως 4 και το εσωτερικό από 1 έως 3..

Και που κολλάς συνάδεφε, αντί να εμφανίζει θα το βάζει σε πίνακα ΕΙΣΠΡΑΞΕΩΝ. οκ:

ΠΡΟΓΡΑΜΜΑ ΕΙΣΠ
ΜΕΤΑΒΛΗΤΕΣ     
  ΑΚΕΡΑΙΕΣ: i, ΕΙΣ[12], ΑΘΡ, ΤΡΙΜ[4]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12
    ΔΙΑΒΑΣΕ ΕΙΣ(i)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ     
  ΑΘΡ <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12     
    ΑΘΡ <-- ΑΘΡ + ΕΙΣ(i)
    ΑΝ i MOD 3 = 0  ΤΟΤΕ
      ΤΡΙΜ[i DIV 3] <-- ΑΘΡ                       
      ΑΘΡ <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ ΤΡΙΜ(i)     
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

bugman

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 382
  • The Bug Eater
    • Πληροφορική Προγραμματισμός
Απ: Μονοδιάστατος Πίνακας
« Απάντηση #4 στις: 02 Μάρ 2018, 09:33:47 μμ »
Δεν κολλάω κάπου απλά θα ήθελα την λύση να τη δώσει η Maria. Έτσι έδωσα συμπληρωματική άσκηση. Ακόμα ισχύει!

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 201
Απ: Μονοδιάστατος Πίνακας
« Απάντηση #5 στις: 24 Μάι 2018, 10:07:23 μμ »
μια διαφορετικη και πιο συντομη λυση για το προβλημα των εισπραξεων

ΠΡΟΓΡΑΜΜΑ εισπραξεις
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΕΙΣΠΡΑΞΕΙΣ[12], τριμηνου[4]



ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 12
    ΓΡΑΨΕ "δωσε μου τις εισπραξεις του ", ι, "ου μηνα"
    ΔΙΑΒΑΣΕ ΕΙΣΠΡΑΞΕΙΣ[ι]
    ΑΝ ι <= 4 ΤΟΤΕ

      τριμηνου[ι] <- 0
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 0 ΜΕΧΡΙ 11
    τριμηνου[(ι + 3) div 3] <- τριμηνου[(ι + 3) div 3] + ΕΙΣΠΡΑΞΕΙΣ[ι + 1]

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ τριμηνου[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ