Αποστολέας Θέμα: ΘΕΜΑ Δ  (Αναγνώστηκε 3827 φορές)

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1095
ΘΕΜΑ Δ
« στις: 12 Ιούν 2017, 10:25:07 πμ »
Εδώ σχολιάζουμε το θέμα Δ

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 680
Απ: ΘΕΜΑ Δ
« Απάντηση #1 στις: 12 Ιούν 2017, 10:37:51 πμ »
Παιδιά πάμε καλά ??? 3 υποπρογράμματα ??????

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 63
Απ: ΘΕΜΑ Δ
« Απάντηση #2 στις: 12 Ιούν 2017, 10:59:41 πμ »
Μπορει να εχει 3 υποπρογραμματα ομως ειναι ξεκαθαρο τι τους ζητειται μονο που δεν τους το λυνει.

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 680
Απ: ΘΕΜΑ Δ
« Απάντηση #3 στις: 12 Ιούν 2017, 11:09:00 πμ »
Είναι δύσκολο το δ παιδιά ... ειδική η τελευυαία συνάρτηση είναι αρκετά...καλά το γ θεωρώ είναι το πιο δύσκολο θέμα εβερ

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Δ
« Απάντηση #4 στις: 12 Ιούν 2017, 11:21:07 πμ »
ΔΙΑΔΙΚΑΣΙΑ ΕΙΣ(ΚΩΔ[50],ΑΠ[50,6])
ΜΕΤΑΒΛΗΤΕΣ
.........
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
   ΔΙΑΒΑΣΕ κωδ
   ΚΩΔ [ i ]  <-  κωδ
   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΔΙΑΒΑΣΕ απ
      ΑΠ[i,j] <- απ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΑΝΑΖ(κωδ,ΚΩΔ[50]) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
........
ΑΡΧΗ
θέση <- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
   ΑΝ ΚΩΔ [ i ]=κωδ ΤΟΤΕ
      θέση <- i
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝΑΖ <- θέση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΣΥΝΑΠ(i,ΑΠ[50,6],ατ) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
.........
ΑΡΧΗ
s <- 0
ΓΙΑ j ΑΠΟ ατ ΜΕΧΡΙ ατ+2
   s <- s + ΑΠ [ i , ατ ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΣΥΝΑΠ <- s
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
ΜΕΤΑΒΛΗΤΕΣ
..........
ΑΡΧΗ

ΚΑΛΕΣΕ ΕΙΣ(ΚΩΔ[50],ΑΠ[50,6])

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
   σα1τ <- ΣΥΝΑΠ( i , Α[50,60] , 1)
   ΑΠΤΡ[i,1] <- σα1τ
   σα2τ <- ΣΥΝΑΠ( i , Α[50,60] , 4)
   ΑΠΤΡ[i,1] <- σα2τ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ key
ΟΣΟ key<>'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
   απ <- ΑΝΑΖ(key,ΚΩΔ[50])
   ΑΝ απ=0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΒ'
   ΑΛΛΙΩΣ_ΑΝ ΑΠΤΡ[απ,1]<10 και ΑΠΤΡ[απ,2]<10 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΣ'
   ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΟΔΣ'
   ΤΕΛΟΣ_ΑΝ
   ΔΙΑΒΑΣΕ key
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



για τυχόν διορθώσεις , θα το κοιτάξω άμεσα
« Τελευταία τροποποίηση: 12 Ιούν 2017, 11:32:13 πμ από pstasinos »

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: ΘΕΜΑ Δ
« Απάντηση #5 στις: 12 Ιούν 2017, 11:23:55 πμ »


ΣΥΝΑΡΤΗΣΗ ΑΝΑΖ(κωδ,ΚΩΔ[50]) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
........
ΑΡΧΗ
θέση <- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
   ΑΝ ΚΩΔ=κωδ ΤΟΤΕ
      θέση <- i
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝΑΖ <- θέση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ



Θεωρώ οτι θα ήταν πιο σωστό να χρησιμοποιηθέι σειριακή αναζητηση ώστε να τερματίζεται οταν βρεθεί..

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 680
Απ: ΘΕΜΑ Δ
« Απάντηση #6 στις: 12 Ιούν 2017, 11:24:15 πμ »
Στήν  τελευταία συνάρτηση δίχως μέγεθος ο πίνακας

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 680
Απ: ΘΕΜΑ Δ
« Απάντηση #7 στις: 12 Ιούν 2017, 11:25:03 πμ »
Σε όλα βασικα στις παραμέτρους....

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Δ
« Απάντηση #8 στις: 12 Ιούν 2017, 11:35:37 πμ »
Θεωρώ οτι θα ήταν πιο σωστό να χρησιμοποιηθέι σειριακή αναζητηση ώστε να τερματίζεται οταν βρεθεί..

Πάντα με καλή πρόθεση η λέξη ΠΙΟ ΣΩΣΤΑ είναι λάθος. Δεν υπάρχει πιο σωστά κατά τη γνώμη μου , υπάρχει όσο πιο απλά .
Το αναφέρω ΜΟΝΟ και ΜΟΝΟ για κανέναν περίεργο διορθωτή που μπορεί να του αρέσει η λύση με την ΟΣΟ.
Δεν μας εξετάζουν ως προς την πολυπλοκότητα του αλγορίθμου. Έχω πει και στα παιδιά μου να γράφουν απλά. Δεν το θεωρώ πιο λάθος και την όσο πιο ΣΩΣΤΟ.

jimmy

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: ΘΕΜΑ Δ
« Απάντηση #9 στις: 12 Ιούν 2017, 11:37:32 πμ »
Πρωτότυπο σίγουρα, πιο δύσκολο από πέρσι σίγουρα, αλλά έχουμε δει ίσως και δυσκολότερα (2013, 2014). Στα μάτια ενός μαθήτη μάλλον είναι ψαρωτικό βέβαια, αυτό το 3 υποπρογράμματα. Επίσης θεωρώ ότι θα γίνει ένα μικρό μπάχαλο με το αν επιτρέπεται ή όχι να βάλουμε σε συνάρτηση αριθμούς ως παραμέτρους. Γιατί το σχολικό βιβλίο λέει ότι οι παράμετροι είναι μεταβλητές...

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: ΘΕΜΑ Δ
« Απάντηση #10 στις: 12 Ιούν 2017, 11:38:08 πμ »
Εγώ το λέω επειδή στην εκφώνηση αναφέρει οτι καθε ένας έχει μοναδικό αλφαριθμητικό κωδικό... Εννοείται όμως οτι η λύση με Για δε θεωρείται λάθος..

progmat

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: ΘΕΜΑ Δ
« Απάντηση #11 στις: 12 Ιούν 2017, 11:47:04 πμ »
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ_2017
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, ΑΠ[50, 6], ΑΠΤΡ[50, 2], ΘΕΣΗ
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔ[50], Κ

ΑΡΧΗ
  ΚΑΛΕΣΕ ΕΙΣ(ΚΩΔ, ΑΠ)
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 50
    ΑΠΤΡ[Ι, 1] <- ΣΥΝΑΠ(Ι, ΑΠ, 1)
    ΑΠΤΡ[Ι, 2] <- ΣΥΝΑΠ(Ι, ΑΠ, 4)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΔΙΑΒΑΣΕ Κ
  ΟΣΟ Κ <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
    ΘΕΣΗ <- ΑΝΑΖ(Κ, ΚΩΔ)
    ΑΝ ΘΕΣΗ <> 0 ΤΟΤΕ
      ΑΝ ΑΠΤΡ[ΘΕΣΗ, 1] < 10 ΚΑΙ ΑΠΤΡ[ΘΕΣΗ, 2] < 10 ΤΟΤΕ
        ΓΡΑΨΕ 'ΕΧΕΙ ΔΙΚΑΙΩΜΑ ΣΥΜΜΕΤΟΧΗΣ'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΔΕΝ ΕΧΕΙ ΔΙΚΑΙΩΜΑ ΣΥΜΜΕΤΟΧΗΣ'
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΔΕΝ ΒΡΕΘΗΚΕ'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ Κ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ ΕΙΣ(ΚΩΔ, ΑΠ)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔ[50]
  ΑΚΕΡΑΙΕΣ: Ι, J, ΑΠ[50, 6]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 50
    ΔΙΑΒΑΣΕ ΚΩΔ[Ι]
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
      ΔΙΑΒΑΣΕ ΑΠ[Ι, J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΑΝΑΖ(Κ, ΚΩΔ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔ[50], Κ
  ΛΟΓΙΚΕΣ: Φ
  ΑΚΕΡΑΙΕΣ: Ι, Θ
ΑΡΧΗ
  Φ <- ΨΕΥΔΗΣ
  Ι <- 1
  ΟΣΟ Ι <= 50 ΚΑΙ Φ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΚΩΔ[Ι] = Κ ΤΟΤΕ
      Φ <- ΑΛΗΘΗΣ
      Θ <- Ι
    ΑΛΛΙΩΣ
      Ι <- Ι + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Φ = ΑΛΗΘΗΣ ΤΟΤΕ
    ΑΝΑΖ <- Θ
  ΑΛΛΙΩΣ
    ΑΝΑΖ <- 0
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΣΥΝΑΠ(Κ, ΑΠ, ΤΡ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΠ[50, 6], ΤΡ, ΑΘ, J, Κ
ΑΡΧΗ
  ΑΘ <- 0
  ΓΙΑ J ΑΠΟ ΤΡ ΜΕΧΡΙ ΤΡ + 2
    ΑΘ <- ΑΘ + ΑΠ[Κ, J]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΣΥΝΑΠ <- ΑΘ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 117
Απ: ΘΕΜΑ Δ
« Απάντηση #12 στις: 12 Ιούν 2017, 03:43:25 μμ »
Η ΣΥΝΑΠ βέβαια βγαίνει και σε μία γραμμή...

ΣΥΝΑΡΤΗΣΗ ΣΥΝΑΠ (χ, ΑΠ, μ):ΑΚΕΡΑΙΑ
...
ΣΥΝΑΠ <-- ΑΠ[χ,μ] + ΑΠ[χ,μ+1) + ΑΠ[χ,μ+2]
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Rathaniel

  • Βετεράνος
  • ****
  • Μηνύματα: 77
  • Έπρεπε να είχα γίνει Χημικός......
Απ: ΘΕΜΑ Δ
« Απάντηση #13 στις: 12 Ιούν 2017, 04:07:01 μμ »
Η ΣΥΝΑΠ μπορεί να γραφεί και αλλιώς:


ΑΡΧΗ
    Σ <- 0
   Αν αρ_τριμ = 1 τότε
      Σ <- (άθροισμα 3ων πρώτων στηλών της  i γραμμης)
   Αλλιώς
      Σ<- (άθροισμα 4ης,5ης,6ης στήλης της i γραμμης)
   Τέλος_αν
   ΣΥΝΑΠ <-Σ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Χρηστίδης Αλέξανδρος,
Μηχανικός Επ/κών και Πλη/κών Συστημάτων,
Msc Στα Προηγμένα Συστήματα Πληροφορικής

Rathaniel

  • Βετεράνος
  • ****
  • Μηνύματα: 77
  • Έπρεπε να είχα γίνει Χημικός......
Απ: ΘΕΜΑ Δ
« Απάντηση #14 στις: 12 Ιούν 2017, 04:08:32 μμ »
Θεωρώ ότι η σύνθετη επιλογή με το pos/done στην ΑΝΑΖ είναι λίγο περιττή, χωρίς να είναι λάθος φυσικά.

Με μία ανάθεση του pos στην ΑΝΑΖ είναι όλα καλά
Χρηστίδης Αλέξανδρος,
Μηχανικός Επ/κών και Πλη/κών Συστημάτων,
Msc Στα Προηγμένα Συστήματα Πληροφορικής