Αποστολέας Θέμα: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015  (Αναγνώστηκε 6027 φορές)

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Για να ξεφύγουμε λίγο απ' τους προβληματισμούς για το νέο σύστημα στο Λύκειο.
Επισυνάπτεται αρχείο pdf με κάποιες μικρές τροποποιήσεις της προηγούμενης εκδοχής του.
Προσπαθήστε να λύσετε το Β2 με μία επανάληψη.
Και το Δ3 λύνεται χωρίς χρήση παραπάνω από μιας απλής δομής επιλογής.
Επισυνάπτω και τις λύσεις.
« Τελευταία τροποποίηση: 25 Απρ 2015, 07:10:12 μμ από Κανένας »
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #1 στις: 17 Απρ 2015, 04:42:50 μμ »
Το Β2 είναι ωραίο θεματάκι! (να σου πω την αλήθεια, δυσκολεύομαι να σκεφτώ πώς θα το έλυνα με περισσότερες επαναλήψεις)
Επίσης, ψάχνοντας πιθανές απαντήσεις για το Α2, μου προέκυψε μια ωραία ασκησούλα με... τελεστές! και σου την "επιστρέφω" σε αντάλλαγμα για τις ωραίες ιδέες που πήρα. :)

Παρακάτω, δίνονται αριθμημένες, τρεις λογικές εκφράσεις για να ελέγχουν αν οι τιμές δύο μεταβλητών Α, Β είναι η μία άρτια και η άλλη περιττή (θεωρούμε τις τιμές των Α και Β θετικές και ακέραιες). Σε κάθε λογική έκφραση υπάρχει ένα κενό (που δηλώνεται με τρεις τελείες) απ’ όπου λείπει ένας τελεστής.
1.   (A mod 2 = 0 και B mod 2 = 1) … (A mod 2 = 1 και B mod 2 = 0)
2.   A mod 2  …  B mod 2
3.   A mod 2  …  B mod 2 = 1
Να γράψετε στην κόλλα σας τον αριθμό κάθε λογικής έκφρασης και δίπλα τον τελεστή (λογικό, συγκριτικό ή αριθμητικό) που τη συμπληρώνει σωστά.
 :D
Φιλικά,
Γιώργος Θαλασσινός

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 131
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #2 στις: 17 Απρ 2015, 05:53:14 μμ »
Να προσθέσω και το
(Α+Β) mod 2 = 1
Με κενό σε έναν ( ή περισσότερους) τελεστή.

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #3 στις: 18 Απρ 2015, 12:23:52 πμ »
Το Β2 με τρεις επαναλήψεις (με βοηθητικό πίνακα έχει πολλές λύσεις):
κ<-1
Για ι απο 1 μέχρι 50
   Β[κ]<-Π[ι]
   κ<-κ+2
Τέλος_επανάληψης
κ<-2
Για ι απο 51 μέχρι 100
   Β[κ]<-Π[ι]
   κ<-κ+2
Τέλος_επανάληψης
Για ι απο 1 μέχρι 100
   Π[ι]<-Β[ι]
Τέλος_επανάληψης

Και το Α2 με στοιχειώδη γνώση θεωρίας αριθμών (που δεν κάνουν)
γίνεται όντως ενδιαφέρον (gthal,michaeljohn).
Αναδεικνύει και τη δύναμη του μαθήματος (διαθεματικότητα).
   
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #4 στις: 20 Απρ 2015, 02:23:43 μμ »
Για να ξεφύγουμε λίγο απ' τους προβληματισμούς για το νέο σύστημα στο Λύκειο.
Επισυνάπτεται αρχείο pdf με κάποιες μικρές τροποποιήσεις της προηγούμενης εκδοχής του.
Προσπαθήστε να λύσετε το Β2 με μία επανάληψη.
Και το Δ3 λύνεται χωρίς χρήση παραπάνω από μιας απλής δομής επιλογής.
Θα ακολουθήσουν και λύσεις.

Επισυνάπτω και τις απαντήσεις του επαναληπτικού διαγωνίσματος.
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 86
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #5 στις: 20 Απρ 2015, 08:10:01 μμ »
Πολύ καλό! Ιδιαίτερα μου άρεσαν τα Β2 και Δ. Θα το χρησιμοποιήσω.
Όσο για τη συνάρτηση στο Δ τη σκέφτηκα χωρίς έξτρα πίνακα, όμως η προτεινόμενη λύση είναι πολύ καλύτερη.
Μια μικρή ερώτηση στις λύσεις του Δ: αφού η μεταβλητή Μ είναι δηλωμένη ακέραια, τι νόημα έχει ο έλεγχος Α_Μ(Μ)=Μ;

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #6 στις: 21 Απρ 2015, 05:55:12 μμ »
Πολύ καλό! Ιδιαίτερα μου άρεσαν τα Β2 και Δ. Θα το χρησιμοποιήσω.
Όσο για τη συνάρτηση στο Δ τη σκέφτηκα χωρίς έξτρα πίνακα, όμως η προτεινόμενη λύση είναι πολύ καλύτερη.
Μια μικρή ερώτηση στις λύσεις του Δ: αφού η μεταβλητή Μ είναι δηλωμένη ακέραια, τι νόημα έχει ο έλεγχος Α_Μ(Μ)=Μ;

Έχεις δίκιο ο έλεγχος είναι περιττός και χωρίς νόημα.
Απλώς τον έβαλα επειδή θυμήθηκα το εξεζητημένο θέμα στις επαναληπτικές των εσπερινών! του 2005 που ζητούσε να ελεγχθεί αν μια τιμή που καταχωρήθηκε σε μια πραγματική μεταβλητή είναι ακέραια.
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

Nf

  • Νέος
  • *
  • Μηνύματα: 2
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #7 στις: 21 Απρ 2015, 08:22:18 μμ »
Για το Β2
Για ι από 2 μέχρι 50 με_βήμα 2
Π[ι]<- (-1)*Π[ι]
Τέλος_επανάληψης
Για ι απο 51 μέχρι 100 με_βήμα 2
Π[ι]<- (-1)*Π[ι]
Τέλος_επανάληψης

έχω κάπου λάθος;

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #8 στις: 21 Απρ 2015, 08:53:57 μμ »
Για το Β2
Για ι από 2 μέχρι 50 με_βήμα 2
Π[ι]<- (-1)*Π[ι]
Τέλος_επανάληψης
Για ι απο 51 μέχρι 100 με_βήμα 2
Π[ι]<- (-1)*Π[ι]
Τέλος_επανάληψης

έχω κάπου λάθος;
Ναι, έτσι απλώς αλλάζεις το πρόσημο των αριθμών, δηλαδή δεν αναδιατάσσεις τους αριθμούς στον πίνακα αλλά τους τροποποιείς.

Βοήθεια:
Στη δεύτερη θέση του πίνακα πρέπει να βάλεις κάποιον (οποιονδήποτε) απ' αυτούς που είναι στις θέσεις 51-100.
Στην τέταρτη θέση του πίνακα πρέπει να βάλεις κάποιον (οποιονδήποτε) απ' αυτούς που είναι στις θέσεις 51-100 εκτός απ' αυτόν  που ήδη έβαλες στη δεύτερη και έτσι συνεχίζεις...
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

Nf

  • Νέος
  • *
  • Μηνύματα: 2
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #9 στις: 22 Απρ 2015, 01:03:58 μμ »
ι<-2
Όσο ι<=50 επανάλαβε
Αντιμετάθεσε (Π[ι],Π[ι+49])
ι<-ι+2
Τέλος_επανάληψης

Τώρα;;  :)
« Τελευταία τροποποίηση: 22 Απρ 2015, 02:08:38 μμ από Nf »

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #10 στις: 22 Απρ 2015, 11:49:02 μμ »
ι<-2
Όσο ι<=50 επανάλαβε
Αντιμετάθεσε (Π[ι],Π[ι+49])
ι<-ι+2
Τέλος_επανάληψης

Τώρα;;  :)
Σωστά!
Λίγο πιο συνοπτικά Με Για..
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

FORTRAN_ONE_LOVE

  • Νέος
  • *
  • Μηνύματα: 1
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #11 στις: 25 Απρ 2015, 02:10:16 μμ »
2

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1057
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #12 στις: 25 Απρ 2015, 06:38:20 μμ »
Για ι  από 2 μέχρι 49 με_βήμα 2
   Αντιμετάθεσε ( Π[ι],Π[101-ι] )
Τέλος_επανάληψης

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #13 στις: 25 Απρ 2015, 07:11:42 μμ »
Για ι  από 2 μέχρι 49 με_βήμα 2
   Αντιμετάθεσε ( Π[ι],Π[101-ι] )
Τέλος_επανάληψης
Πρέπει ν' αλλάξει και το 50στό στοιχείο.
« Τελευταία τροποποίηση: 25 Απρ 2015, 07:52:02 μμ από Κανένας »
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1057
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #14 στις: 25 Απρ 2015, 09:18:08 μμ »
Ναι !

Για ι  από 2 μέχρι 50 με_βήμα 2
   Αντιμετάθεσε  Π[ι],Π[101-ι]
Τέλος_επανάληψης

Α

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 66
    • Νικηφόρος Μανδηλαράς (blog)
Απ: ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΓΙΑ ΠΡΟΠΟΝΗΜΕΝΟΥΣ ΜΑΘΗΤΕΣ-2015
« Απάντηση #15 στις: 27 Απρ 2015, 02:46:06 μμ »
Για να ξεφύγουμε λίγο απ' τους προβληματισμούς για το νέο σύστημα στο Λύκειο.
Επισυνάπτεται αρχείο pdf με κάποιες μικρές τροποποιήσεις της προηγούμενης εκδοχής του.
Προσπαθήστε να λύσετε το Β2 με μία επανάληψη.
Και το Δ3 λύνεται χωρίς χρήση παραπάνω από μιας απλής δομής επιλογής.
Επισυνάπτω και τις λύσεις.
Επισυνάπτω εκ νέου το διαγώνισμα με μια μικρή τροποποίηση του θέματος Α5.
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/