Αποστολέας Θέμα: Πανελλήνιες Θέμα Γ 2013  (Αναγνώστηκε 1257 φορές)

deniaa

  • Νέος
  • *
  • Μηνύματα: 9
Πανελλήνιες Θέμα Γ 2013
« στις: 21 Μάρ 2014, 01:34:25 μμ »
Για i από 2 μέχρι 30
Για j από 30 μέχρι i με βήμα -1
Αν ΜΟ[j-1,1]< ΜΟ[j,1] τότε
Αντιμετάθεσε ΜΟ[j-1,1], ΜΟ[j,1]
Αντιμετάθεσε ΜΟ[j-1,2], ΜΟ[j,2]
Αντιμετάθεσε ΚΩΔ[j-1], ΚΩΔ[j]
Τέλος_αν
Τέλος_Επανάληψης
Τέλος_Επανάληψης
Εμφάνισε ΚΩΔ[1], ΜΟ[1,1], ΚΩΔ[2], ΜΟ[2,1], ΚΩΔ[3], ΜΟ[3,1]
Για i από 2 μέχρι 30
Για j από 30 μέχρι i με βήμα -1
Αν ΜΟ[j-1,2]< ΜΟ[j,2] τότε
Αντιμετάθεσε ΜΟ[j-1,1], ΜΟ[j,1]
Αντιμετάθεσε ΜΟ[j-1,2], ΜΟ[j,2]
Αντιμετάθεσε ΚΩΔ[j-1], ΚΩΔ[j]
Τέλος_αν
Τέλος_Επανάληψης
Τέλος_Επανάληψης
Εμφάνισε ΚΩΔ[1], ΜΟ[1,2], ΚΩΔ[2], ΜΟ[2,2], ΚΩΔ[3], ΜΟ[3,2]



Ο παραπάνω κώδικας είναι η λύση του τελευταίου ερωτήματος του τρίτου θέματος.

H ερώτησή μου είναι η εξής: Αφού η λογική είναι ότι πρώτα ταξινομούμε τα στοιχεία της πρώτης στήλης και μετά αυτά της δεύτερης, γιατί στον πρώτο βρόχο επανάληψης (αφορά πρώτη στήλη) εμπλέκονται και τα στοιχεία της δεύτερης;Και αντίστοιχα, γιατί στο δεύτερο βρόχο εμπλέκονται τα στοιχεία της πρώτης στήλης;
 

Δεν μπορώ δηλαδή να καταλάβω γιατί υπάρχει στον πρώτο βρόχο η γραμμή Αντιμετάθεσε ΜΟ[j-1,2], ΜΟ[j,2] και στον δεύτερο η γραμμή Αντιμετάθεσε ΜΟ[j-1,1], ΜΟ[j,1].

Όποιος μπορεί, ας με βοηθήσει!

Ευχαριστώ πολύ!


Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #1 στις: 21 Μάρ 2014, 02:17:40 μμ »
Το θέμα είναι πως οι δύο στήλες και οι κωδικοί είναι αρχικά παράλλλοι μεταξύ τους...αν δεν κάνεις αντιμετάθεση και την άλλη στήλη, τότε οι κωδικοί δεν είνια πλέον παράλληλοι με την στήλη αυτή...οπότε κάνεις αντιμετάθεση και τις δύο στήλες και τους κωδικούς για να είναι παράλληλοι μεταξύ τους οι κωδικοί με τις στήλες....

αν δεν κάνω κάποιο λάθος   :P :D ;D

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #2 στις: 21 Μάρ 2014, 02:27:13 μμ »
δεν κανείς κανένα λάθος
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

deniaa

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #3 στις: 21 Μάρ 2014, 03:22:59 μμ »
Ευχαριστώ πάρα πολύ, αλλά και πάλι κάπου μπλέκομαι. :( Μετά το τέλος του πρώτου βρόχου εμφανίζω κωδικούς και στοιχεία μόνο της πρώτης στήλης. Όχι της δεύτερης. Συνεπώς γιατί στον πρώτο βρόχο χρειάζεται και αντιμετάθεση των στοιχείων της δεύτερης στήλης; Και αντίστοιχα και για τον δεύτερο βρόχο. Μετά το τέλος του εμφανίζω κωδικούς και στοιχεία της δεύτερης στήλης μόνο. Άρα γιατί χρειάζεται να αντιμεταθέσω αυτά της πρώτης; (τα οποία σημειωτέον ότι τα έχω ήδη αντιμεταθέσει στον πρώτο βρόχο!)

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #4 στις: 21 Μάρ 2014, 03:38:04 μμ »
στην πρώτη επανάληψη εμφανίζεις στοιχέια της πρώτης στήλης.... μέχρι αυτό το καμμάτι δεν χρειάζεται η αντιμετάθεση της άλλης στήλης....όμως στην συνέχεια, πρέπει να ταξινομήσεις ΚΑΙ την δεύτερη στήλη....η οποία αν δεν κάνεις αντιμετάθεση στον πρώτο βρόγχο ΔΕΝ θα είναι πλέον παράλληλη με τους κωδικούς... δηλαδή η αντιμετάθεση στον πρώτο βρόγχο, χρειάζεται για να μπορεί να γίνει η δεύτρεη στήλη σωστά ...

τώρα καλύτερα ???   :) :)


deniaa

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #5 στις: 21 Μάρ 2014, 03:54:10 μμ »
Τώρα το κατάλαβα νομίζω. Αλλά τότε γιατί στον δεύτερο βρόχο ξαναγίνεται ταξινόμηση των στοιχείων της πρώτης στήλης; Δεν είναι πλεονασμός αφού τα στοιχεία της πρώτης στήλης ήδη έχουν εμφανιστεί;

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #6 στις: 21 Μάρ 2014, 03:58:22 μμ »
Στον δεύτερο ίσως και να είναι πλεονασμός, μπορείς όμως να τα βάλεις σε ένα Για και τις δυο ταξινομήσεις επαναληπτικά, οπότε χρειάζεται....έτσι που έχεις την λύση η δεύτερη αντιμετάθεση μάλλον δεν χρειάζεται, όμως τα στοιχεία της πρώτης στήλης δεν είνια παράλληλα με τους κωδικούς, βέβαια δεν σου χρειάζεται από και και κάτω

deniaa

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #7 στις: 21 Μάρ 2014, 04:10:25 μμ »
Συνεπώς η παρακάτω λύση είναι σωστή! Σωστά; :)





Για i από 2 μέχρι 30
Για j από 30 μέχρι i με βήμα -1
Αν ΜΟ[j-1,1]< ΜΟ[j,1] τότε
Αντιμετάθεσε ΜΟ[j-1,1], ΜΟ[j,1]
Αντιμετάθεσε ΜΟ[j-1,2], ΜΟ[j,2]
Αντιμετάθεσε ΚΩΔ[j-1], ΚΩΔ[j]
Τέλος_αν
Τέλος_Επανάληψης
Τέλος_Επανάληψης
Εμφάνισε ΚΩΔ[1], ΜΟ[1,1], ΚΩΔ[2], ΜΟ[2,1], ΚΩΔ[3], ΜΟ[3,1]
Για i από 2 μέχρι 30
Για j από 30 μέχρι i με βήμα -1
Αν ΜΟ[j-1,2]< ΜΟ[j,2] τότε
Αντιμετάθεσε ΜΟ[j-1,2], ΜΟ[j,2]
Αντιμετάθεσε ΚΩΔ[j-1], ΚΩΔ[j]
Τέλος_αν
Τέλος_Επανάληψης
Τέλος_Επανάληψης
Εμφάνισε ΚΩΔ[1], ΜΟ[1,2], ΚΩΔ[2], ΜΟ[2,2], ΚΩΔ[3], ΜΟ[3,2]

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #8 στις: 21 Μάρ 2014, 04:13:14 μμ »
Νομίζω πως ναι...

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 656
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #9 στις: 21 Μάρ 2014, 06:27:07 μμ »
Σωστοτατη!!!!
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

deniaa

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Πανελλήνιες Θέμα Γ 2013
« Απάντηση #10 στις: 21 Μάρ 2014, 07:05:48 μμ »
Τέλεια!  :) Σας ευχαριστώ πάρα πολύ!