Αποστολέας Θέμα: κυριακάτικο διαγώνισμα - μονοδιάστατοι πίνακες  (Αναγνώστηκε 1819 φορές)

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 155
άντε τώρα να διορθώσω 45 γραπτά


(διόρθωσα πρώτα 2 λάθη που είχα, 1 στις εκφωνήσεις κι ένα στις λύσεις)
« Τελευταία τροποποίηση: 20 Ιαν 2014, 10:29:36 μμ από epsilonXi »

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 567
  • There can be only one...may it be AEPP.
Απ: κυριακάτικο διαγώνισμα - μονοδιάστατοι πίνακες
« Απάντηση #1 στις: 20 Ιαν 2014, 11:39:28 πμ »
Πολύ ωραία θέματα. Ευχαριστούμε πάρα πολύ! :)
Μερεντίτης Νικόλαος
Πληροφορικός

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 129
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: κυριακάτικο διαγώνισμα - μονοδιάστατοι πίνακες
« Απάντηση #2 στις: 21 Ιαν 2014, 03:31:18 μμ »
Σε ευχαριστούμε που μοιράστηκες μαζί μας τη δουλειά σου. Σου στέλνω 2 παρατηρήσεις:

1) το Θέμα 1, το 6.2 μπορεί να γίνει και χωρίς πίνακα

Διάβασε x
max <- x
p <- 1
Για κ από 2 μέχρι 100
      Αν x > max τότε
          max <- x
          p <- 1
     αλλιώς_αν x = max τότε
          p <- p + 1
     Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε p


2) Θέμα 1 , 1.5 μου φαίνεται για ΛΑΘΟΣ

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 155
Απ: κυριακάτικο διαγώνισμα - μονοδιάστατοι πίνακες
« Απάντηση #3 στις: 22 Ιαν 2014, 09:11:42 πμ »
καλημέρα

για το 1.6.2 έχεις δίκιο και το έχω ήδη διορθώσει

για το 1.1.5 δεν έχεις δίκιο:

μ <-- 0
οποιοδήποτε loop {
  διάβασε φύλο
  αν φύλο = 'αντρας' τότε
    μ <-- μ+1
  αλλιώς
    μ <-- μ-1
  τέλος_αν
}
αν μ > 0 τότε
  γράψε 'περισσότερα σερνικά'
αλλιώς_αν μ < 0 τότε
  γράψε 'περισσότερα θηλυκά'
αλλιώς
  γράψε 'ίσα όλα'
τέλος_αν

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: κυριακάτικο διαγώνισμα - μονοδιάστατοι πίνακες
« Απάντηση #4 στις: 22 Ιαν 2014, 03:09:08 μμ »
Αν δε κατάλαβα λάθος ο ikariofil δεν αναφέρεται στο 5ο από τα Σ/Λ αλλά στο 5ο ερώτημα του 1ου θέματος με τον ταξινομημένο πίνακα όπου τοποθετούμε σε νέο πίνακα τις διαφορετικές τιμές του αρχικού.

Το θέμα με αυτό το υποερώτημα είναι ότι "χάνεις" την πρώτη τιμή. ;)

Πρέπει να αλλάξει η αρχή σε κάτι τέτοιο:

Κώδικας: [Επιλογή]
ν <- 1
Β[ν] <- Α[ν]

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 155
Απ: κυριακάτικο διαγώνισμα - μονοδιάστατοι πίνακες
« Απάντηση #5 στις: 27 Ιαν 2014, 01:35:43 μμ »
μπα
ο ikariofil αναφέρθηκε σε αυτό που τού απάντησα

σ' αυτό που λες, συμφωνώ ότι χάνω την πρώτη τιμή, αλλά αυτό δεν είναι κάτι που με ενδιαφέρει...
δε τους ζήτησα να κάνουν διαχωρισμό και να τοποθετήσουν στο Β τις διαφορετικές τιμές του Α

το ερώτημα αυτό υπήρχε μόνο για να χτυπήσει ένα καμπανάκι
για τους λίγους που θα μπορούσαν να ασχοληθούν με το τελευταίο ερώτημα του τέταρτου θέματος