Αποστολέας Θέμα: ΑΝ ΤΟΤΕ ΑΛΛΙΩΣ_ΑΝ ......  (Αναγνώστηκε 1342 φορές)

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
ΑΝ ΤΟΤΕ ΑΛΛΙΩΣ_ΑΝ ......
« στις: 18 Νοέ 2013, 12:41:02 μμ »
Γειά στους φίλους του φόρουμ.
Θα ήθελα να ρωτήσω ποια είναι η λειτουργία της δομής πολλαπλής επιλογής ( Αν .. τότε..αλλιώς_αν)

Αν έχω

Αν {συνθήκη1} τότε
            {μπλοκ εντολών-1}
αλλιώς
             Αν {συνθήκη2} τότε
                   {μπλόκ εντολών-2}
             Τέλος_αν
{μπλοκ εντολών-3}
Τέλος_αν

Αυτό σε τί διαφέρει από το παρακάτω :

Αν {συνθήκη1} τότε
            {μπλοκ εντολών-1}
αλλιώς_αν {συνθήκη2} τότε
[/b]                   {μπλόκ εντολών-2}
αλλιώς
{μπλοκ εντολών-3}
Τέλος_αν
« Τελευταία τροποποίηση: 18 Νοέ 2013, 12:53:56 μμ από landreou »

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: ΑΝ ΤΟΤΕ ΑΛΛΙΩΣ_ΑΝ ......
« Απάντηση #1 στις: 18 Νοέ 2013, 12:52:45 μμ »
Στην πρώτη περίπτωση το μπλόκ εντολών -3 θα εκτελεστεί στην περίπτωση όπου η συνθήκη 1 είναι ψευδής και ανεξάρτητα απο την συνθήκη 2.
Στην δεύτερη περίπτωση το μπλόκ εντολών -3 θα εκτελεστεί στην περίπτωση όπου η συνθήκη 1 και η συνθήκη 2 είναι ψευδής.
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
Απ: ΑΝ ΤΟΤΕ ΑΛΛΙΩΣ_ΑΝ ......
« Απάντηση #2 στις: 18 Νοέ 2013, 12:56:56 μμ »
στη δεύτερη περίπτωση το μπλοκ_εντολών 2 δε θα εκτελεστεί αν δεν ισχεύει η συνθήκη 1 και ισχύει η συνθήκη 2 ;
Πως λείτουργεί η Αν τότε αλλιως_αν ;

Εχω και μία άσκηση
Αν ( μ='@] ) Η (μ=' ! ') τότε

        α <- 100

αλλιώς_αν μ = '*' τότε

       α <- 90

αλλιώς_αν (μ='+') Η (μ='&') Η (μ='$') τοτε

      α <- 80

αλλιώς

       α <- 70

Τέλος_αν

ΝΑ ΓΡΑΦΕΙ ΙΣΟΔΥΝΑΜΑ ΜΕ ΕΜΦΩΛΕΥΜΕΝΕΣ ΕΝΤΟΛΕΣ Αν..τοτε_αλλιώς
« Τελευταία τροποποίηση: 18 Νοέ 2013, 01:35:51 μμ από landreou »

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
Απ: ΑΝ ΤΟΤΕ ΑΛΛΙΩΣ_ΑΝ ......
« Απάντηση #3 στις: 19 Νοέ 2013, 07:34:15 πμ »
Γενικά πως αντιμετωπίζουμε μετετροπές μεταξύ δομών επιλογής ;

Gnirut

  • Επισκέπτης
Απ: ΑΝ ΤΟΤΕ ΑΛΛΙΩΣ_ΑΝ ......
« Απάντηση #4 στις: 19 Νοέ 2013, 10:06:05 πμ »
Κώδικας: [Επιλογή]
αν μ='@' ή μ='!' τότε
   α<--100
αλλιώς
   αν μ='*' τότε
       α<--90
   αλλιώς
       αν μ='+' ή μ='&' ή μ='$' τότε
           α<--80
       αλλιώς
           α<--70
       τέλος_αν
   τέλος_αν
τέλος_αν