Αποστολέας Θέμα: πανελληνιες 2013 σχολιασμος θεμάτων  (Αναγνώστηκε 6812 φορές)

ΑλεξανδροςΑναστΓ

  • Νέος
  • *
  • Μηνύματα: 8
Απ: πανελληνιες 2013 σχολιασμος θεμάτων
« Απάντηση #30 στις: 25 Ιούν 2013, 02:39:36 πμ »
Παραθέτω μια "κομψή" λύση για το Β2, που δώσαμε ως εξεταστές των Φ. Α.
j <- 0
Για i από 1 μέχρι 100
     Αν Π[ i ] = ΑΛΗΘΗΣ τότε
          j <- j+1
          Αντιμετάθεσε Π[ i ], Π[ j ]
     Τέλος_αν
Τέλος_επανάληψης

τρομερή

Jimbo

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 34
  • O αγώνας τώρα ξεκινά...
Απ: πανελληνιες 2013 σχολιασμος θεμάτων
« Απάντηση #31 στις: 25 Ιούν 2013, 12:55:53 μμ »
Παράθεση από: cets89 στις 01 Ιουν 2013, 04:11:27 pm

    Παραθέτω μια "κομψή" λύση για το Β2, που δώσαμε ως εξεταστές των Φ. Α.
    j <- 0
    Για i από 1 μέχρι 100
         Αν Π[ i ] = ΑΛΗΘΗΣ τότε
              j <- j+1
              Αντιμετάθεσε Π[ i ], Π[ j ]
         Τέλος_αν
    Τέλος_επανάληψης


τρομερή

και όμως κάποιος  τη βαθμολόγησε αυτή τη λύση με 0!!!!
Δημήτρης Μπούζιος
ΓΕΛ Άστρους