Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Μήνυμα ξεκίνησε από: sstauross στις 29 Μάι 2013, 08:50:54 μμ

Τίτλος: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: sstauross στις 29 Μάι 2013, 08:50:54 μμ
πως κρίνετε τα θέματα σήμερα;
πως γράψατε; (για τους μαθητές)
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: tkon στις 30 Μάι 2013, 12:29:55 πμ
3 ερωτηματα για μαθητες αστέρια.
Ειναι "να το έχεις το μάθημα"
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: gthal στις 30 Μάι 2013, 12:33:24 πμ
Είσαι μαθητής; Μας ενδιαφέρει η γνώμη σου.
Σε ποια ερωτήματα αναφέρεσαι;
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: petrosp13 στις 30 Μάι 2013, 10:57:07 πμ
Νομίζω Α2, Α4, Β2
Στο Γ και Δ πάντα περιμένεις δύσκολα
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 31 Μάι 2013, 09:30:33 μμ
Είμαι μαθητής της Γ Λυκείου και έδινα προχθές.Μπορώ να πω ότι τα θέματα μου φάνηκαν βατά αν και η εκφώνηση στο Γ3 ήταν λίγο περίεργη.Παράλλη υπήρχαν μερικά έξυπνα ερωτήματα όπως αυτό με τον τετραγωνικό πίνακα και το Β2.Στο Β2 στη σημείωση που έλεγε να μην χρησιμοποιήσουμε τους "αλγορίθμους ταξινόμησης" φαντάζομαι εννούσε τη γνωστή ταξινόμηση του σχολικού ,αφού τελικά το τμήμα του αλγορίθμου που γράφαμε ταξινομούσε τον πίνακα,έτσι δεν είναι;
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: itt στις 31 Μάι 2013, 10:01:17 μμ
Είμαι μαθητής της Γ Λυκείου και έδινα προχθές.Μπορώ να πω ότι τα θέματα μου φάνηκαν βατά αν και η εκφώνηση στο Γ3 ήταν λίγο περίεργη.Παράλλη υπήρχαν μερικά έξυπνα ερωτήματα όπως αυτό με τον τετραγωνικό πίνακα και το Β2.Στο Β2 στη σημείωση που έλεγε να μην χρησιμοποιήσουμε τους "αλγορίθμους ταξινόμησης" φαντάζομαι εννούσε τη γνωστή ταξινόμηση του σχολικού ,αφού τελικά το τμήμα του αλγορίθμου που γράφαμε ταξινομούσε τον πίνακα,έτσι δεν είναι;

Εξαρτάται το πώς εννοείς το "ταξινομούσε".Ο πίνακας δεν μπορεί σε καμμια περίπτωση να είναι ταξινομημένος,γιατί δεν ορίζεται διάταξη λογικὠν μεταβλητών.Έχει γίνει μια συζήτηση, εδώ. (https://alkisg.mysch.gr/steki/index.php?topic=5230.60)
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 31 Μάι 2013, 10:12:43 μμ
Εξαρτάται το πώς εννοείς το "ταξινομούσε".Ο πίνακας δεν μπορεί σε καμμια περίπτωση να είναι ταξινομημένος,γιατί δεν ορίζεται διάταξη λογικὠν μεταβλητών.Έχει γίνει μια συζήτηση, εδώ. (https://alkisg.mysch.gr/steki/index.php?topic=5230.60)
Κατάλαβα.Εγώ χρησιμοποίησα μια εξωτερίκη επανάληψη(με όσο) έβαλα μια απλή επιλογή για το αν θα είναι η Π ΨΕΥΔΗΣ και στη συνέχεια χρησιμοποίησα μια εμφωλευμένη επανάληψη ψάχνοντας να βρω το αμέσως επόμενο στοιχείο του πίνακα που είναι  ΑΛΗΘΗΣ,ωστέ να αντιμεταθέσω.Για την εμφωλευμένη επανάληψη χρησιμοποιούσα και μια flag που την ειχα αρχικοποιήσει με την τιμή ΨΕΥΔΗΣ και εβαλα μια επιλογή έτσι ώστε αν η flag παρέμενε ΨΕΥΔΗΣ να τερματίζεται και η εξωτερική επανάληψη ,αφού ο πίνακας θα είχε την μορφή που ζητούσε η ασκηση.Η λύση μου είναι "λανθασμένη" απο τους περιορισμούς της εκφώνησης ;
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 31 Μάι 2013, 10:44:24 μμ
Εξαρτάται το πώς εννοείς το "ταξινομούσε".Ο πίνακας δεν μπορεί σε καμμια περίπτωση να είναι ταξινομημένος,γιατί δεν ορίζεται διάταξη λογικὠν μεταβλητών.Έχει γίνει μια συζήτηση, εδώ. (https://alkisg.mysch.gr/steki/index.php?topic=5230.60)
i<-1
Όσο i<=100 επανάλαβε
Αν Π[ i ]=ΨΕΥΔΗΣ τότε
   j<-i+1
   flag<-ΨΕΥΔΗΣ
   Όσο j<=100 και flag=ΨΕΥΔΗΣ επανάλαβε
       Αν Π[j]=ΑΛΗΘΗΣ
          Αντιμετάθεσε Π[ i ],Π[j]
          flag<-ΑΛΗΘΗΣ
       Τέλος_αν
       j<-j+1
   Τέλος_επανάληψης
   Αν flag=ΨΕΥΔΗΣ τότε
      i<-101
   Τέλος_αν
Τέλος_αν
i<-i+1
Τελος_επανάληψης
Aν έχετε χρόνο ριξτε μια ματιά στη λύση μου,να μου πείτε τη γνώμη σας.
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: P.Tsiotakis στις 31 Μάι 2013, 11:25:23 μμ
είσαι πολύ μάγκας για την πολύ ωραία σκέψη
με το -κουρτκουτιασμένο μου- μυαλό αυτή την ώρα, φαίνεται σωστή και η υλοποίηση της σκέψης σου

αυτή κατά τη γνώμη μου ειναι η πιο "καλή" λύση για το ζήτημα

Καλά αποτελέσματα
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 31 Μάι 2013, 11:31:23 μμ
είσαι πολύ μάγκας για την πολύ ωραία σκέψη
με το -κουρτκουτιασμένο μου- μυαλό αυτή την ώρα, φαίνεται σωστή και η υλοποίηση της σκέψης σου

Καλά αποτελέσματα
Σας ευχαριστώ πολυ!Απλά είχα την ανησυχία μήπως ο αλγόριθμοός μου εντάσσεται στην κατηγορία "αλγόριθμοι ταξινόμησης".
Καλό σας βράδυ και ευχαριστώ για το χρόνο σας :)
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: tdrivas στις 31 Μάι 2013, 11:48:11 μμ
είναι νομίζω η πιο έξυπνη λύση αυτή που ανέρτησες..Γενικά πρόκειται για ωραίο θέμα που λύνεται με πολλούς τρόπους (μέτρηση πλήθους των ΑΛΗΘΗΣ , δημιουργία νέων πινάκων και συνένωση τους κτλ.)
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: itt στις 31 Μάι 2013, 11:55:18 μμ
Παράθεση
Αν Π=ΨΕΥΔΗ

Tι είναι το Π;Εννοείς Π[ i ] ;
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 31 Μάι 2013, 11:58:35 μμ
είναι νομίζω η πιο έξυπνη λύση αυτή που ανέρτησες..Γενικά πρόκειται για ωραίο θέμα που λύνεται με πολλούς τρόπους (μέτρηση πλήθους των ΑΛΗΘΗΣ , δημιουργία νέων πινάκων και συνένωση τους κτλ.)
Ευχαριστώ πολύ για τα καλά σας λόγια!.Μου πέρασε από το μυαλό η δημιουργία νέων πινάκων αλλά προσπάθησα αν είναι δυνατόν να το αποφύγω για να μην δεσμεύω άσκοπα μνήμη(ανεξάρτητα με το αν βαθμολογείται στα πλαίσια των πανελληνίων ή όχι)
Καλό σας βράδυ :)
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 31 Μάι 2013, 11:59:34 μμ
Tι είναι το Π;Εννοείς Π;
Ναι αυτό εννοώ αλλα για κάποιο λόγο δεν μου εμφανίζεται  :-\
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: P.Tsiotakis στις 01 Ιούν 2013, 12:06:43 πμ
το [ι (λατινικο i) εκφράζει πλάγια γραφή στον editor
θελει ένα κενο αναμεσα για να μενουν ως γραμματα
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 01 Ιούν 2013, 12:09:42 πμ
το [ι (λατινικο i) εκφράζει πλάγια γραφή στον editor
θελει ένα κενο αναμεσα για να μενουν ως γραμματα
Ok ευχαριστώ! Θα το έχω υπ' όψιν μου .
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: itt στις 01 Ιούν 2013, 12:13:50 πμ
το [ι (λατινικο i) εκφράζει πλάγια γραφή στον editor
θελει ένα κενο αναμεσα για να μενουν ως γραμματα

Αχά,την πάτησα και εγώ.
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: Πανάγος94 στις 01 Ιούν 2013, 11:54:00 πμ
στο ερώτημα Γ3 θα ήταν αποδεκτή η παρακάτω απάντηση?

Για ι από 1 μέχρι 30
  Εμφάνισε ΚΩΔ[ι]
  Αν ΜΟ[ι, 1] > 2 ή ΜΟ[ι, 2] > 4 τότε
    Εμφάνισε "Εκτος οριων"
  αλλιώς_αν (ΜΟ[ι, 1] > 1.8 και ΜΟ[ι, 1] ≤ 2) ή (ΜΟ[ι, 2] > 3.6 και ΜΟ[ι, 2] ≤ 4) τότε
    Εμφάνισε "Κοντα στα ορια"
  αλλιώς
    Εμφάνισε "Χαμηλος SAR"
  Τέλος_αν
Τέλος_επανάληψης
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: cets89 στις 01 Ιούν 2013, 04:11:27 μμ
Παραθέτω μια "κομψή" λύση για το Β2, που δώσαμε ως εξεταστές των Φ. Α.
j <- 0
Για i από 1 μέχρι 100
     Αν Π[ i ] = ΑΛΗΘΗΣ τότε
          j <- j+1
          Αντιμετάθεσε Π[ i ], Π[ j ]
     Τέλος_αν
Τέλος_επανάληψης
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: tdrivas στις 02 Ιούν 2013, 11:36:51 πμ
στο ερώτημα Γ3 θα ήταν αποδεκτή η παρακάτω απάντηση?

Για ι από 1 μέχρι 30
  Εμφάνισε ΚΩΔ[ι]
  Αν ΜΟ[ι, 1] > 2 ή ΜΟ[ι, 2] > 4 τότε
    Εμφάνισε "Εκτος οριων"
  αλλιώς_αν (ΜΟ[ι, 1] > 1.8 και ΜΟ[ι, 1] ≤ 2) ή (ΜΟ[ι, 2] > 3.6 και ΜΟ[ι, 2] ≤ 4) τότε
    Εμφάνισε "Κοντα στα ορια"
  αλλιώς
    Εμφάνισε "Χαμηλος SAR"
  Τέλος_αν
Τέλος_επανάληψης


ναι!!!!είναι η πιο γρήγορη λύση..όμως ενδεχομένως να σου κόψει 1 μόριο, καθώς η συνθήκη ΜΟ[ι, 1] ≤ 2 και η συνθήκη ΜΟ[ι, 2] ≤ 4 είναι ΠΕΡΙΤΤΕΣ...αφού δεν  ικανοποιήθηκε το πρώτο "αν" και εξετάζεται το δεύτερο,τότε σίγουρα ισχύουν οι 2 αυτές συνθήκες..
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: Σπύρος Δουκάκης στις 02 Ιούν 2013, 12:22:07 μμ
Δεν νομίζω ότι αφαιρούνται μονάδες για περιττές συνθήκες.

ναι!!!!είναι η πιο γρήγορη λύση..όμως ενδεχομένως να σου κόψει 1 μόριο, καθώς η συνθήκη ΜΟ[ι, 1] ≤ 2 και η συνθήκη ΜΟ[ι, 2] ≤ 4 είναι ΠΕΡΙΤΤΕΣ...αφού δεν  ικανοποιήθηκε το πρώτο "αν" και εξετάζεται το δεύτερο,τότε σίγουρα ισχύουν οι 2 αυτές συνθήκες..
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: igeorgi στις 04 Ιούν 2013, 12:05:09 μμ
ναι!!!!είναι η πιο γρήγορη λύση..όμως ενδεχομένως να σου κόψει 1 μόριο, καθώς η συνθήκη ΜΟ[ι, 1] ≤ 2 και η συνθήκη ΜΟ[ι, 2] ≤ 4 είναι ΠΕΡΙΤΤΕΣ...αφού δεν  ικανοποιήθηκε το πρώτο "αν" και εξετάζεται το δεύτερο,τότε σίγουρα ισχύουν οι 2 αυτές συνθήκες..

Θα τα πάρει όλα τα μόρια η λύση, δεν υπάρχει περίπτωση να αφαιρεθεί κάτι. Διορθώνω και αν βλέπατε αυτά που βλέπαμε θα καταλαβαίνατε. Τα φετινά θέματα ήταν ο καταποντισμός του μέτριου μαθητή, έχω διορθώσει 75 γραπτά ως τώρα και ένα 30% των βαθμών είναι από 80 και πάνω, ένα 10% από 40 ως 80 και το υπόλοιπο 60% κάτω από 40/100. Τεράστιο χάσμα στους βαθμούς. Οι μέτριοι μαθητές καταποντίστηκαν φέτος, αυτό προκύπτει και από συζητήσεις με συναδέλφους..
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: igeorgi στις 04 Ιούν 2013, 12:14:40 μμ
Λύση που έδωσε μαθητής μου στο Γ3 και την είδα και σε γραπτό χθες. Εκμεταλλεύεται το γεγονός ότι τα μηνύματα βρίσκονται σε αντίστροφη αλφαβητική σειρά:

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
   ΑΝ ΜΟ[Ι,1] <= 1,8 ΤΟΤΕ
      ΜΗΝΥΜΑ1 <- 'ΧΑΜΗΛΟΣ SAR'
   ΑΛΛΙΩΣ_ΑΝ ΜΟ[Ι,1] <=2 ΤΟΤΕ
      ΜΗΝΥΜΑ1 <- 'ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ'
   ΑΛΛΙΩΣ
      ΜΗΝΥΜΑ1 <- 'ΕΚΤΟΣ ΟΡΙΩΝ'
   ΤΕΛΟΣ_ΑΝ
   ΑΝ ΜΟ[Ι,2] <= 3,6 ΤΟΤΕ
      ΜΗΝΥΜΑ2 <- 'ΧΑΜΗΛΟΣ SAR'
   ΑΛΛΙΩΣ_ΑΝ ΜΟ[Ι,2] <=4 ΤΟΤΕ
      ΜΗΝΥΜΑ2 <- 'ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ'
   ΑΛΛΙΩΣ
      ΜΗΝΥΜΑ2 <- 'ΕΚΤΟΣ ΟΡΙΩΝ'
   ΤΕΛΟΣ_ΑΝ
   ΑΝ ΜΗΝΥΜΑ1 > ΜΗΝΥΜΑ2 ΤΟΤΕ
      ΕΜΦΑΝΙΣΕ ΚΩΔ[Ι], ΜΗΝΥΜΑ2
   ΑΛΛΙΩΣ
      ΕΜΦΑΝΙΣΕ ΚΩΔ[Ι], ΜΗΝΥΜΑ1
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: kostas_sparti στις 14 Ιούν 2013, 01:23:06 μμ
διδάσκω το μάθημα από το 2006 σε φροντιστήριο. Κατά την γνώμη μου οι "αδύνατοι"¨μαθητές που "πόνταραν" στο κλασικό 2ο θέμα με πίνακα τιμών την πάτησαν άγρια.... Το θέμα 1 μου άρεσε αρκετά... Τα θέματα 3 και 4 ήταν βατά αλλά θα προτιμούσα κάτι πιο έξυπνο στο Γ3...
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: CyberMove στις 17 Ιούν 2013, 02:37:31 πμ
Καλησπέρα σε όλους.
Έγραφα φέτος Πανελλήνιες.

Μου άρεσαν αρκετά τα θέματα,ειδικά στο Β ΘΕΜΑ με τα Αληθής - Ψευδής και το Γ.4 το οποίο το έλυσα με κάπως περίεργο τρόπο και πήρε ελάχιστα λεπτά σε σχέση με την κλασσική ταξινόμιση.
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: DaKnOb στις 22 Ιούν 2013, 02:17:17 μμ
Παιδιά, ήταν σχετικά δύσκολα για τον κανονικό μαθητή. Εγώ πήγα, έγραψα ένα γραπτό που σύμφωνα με εμένα, τον καθηγητή του σχολείου και του φροντιστηρίου άξιζε 100 καθαρό. Βγαίνουν χθες τα αποτελέσματα, και ο ένας μου έκοψε στο Α4 το β όλο (και να πω ήθελε σκέψη, από τις λύσεις που του έδωσαν το έβλεπε) και το Γ3 ολόκληρο πάλι. Στο Δ έκοψε ο άλλος διορθωτής ενώ ο προηγούμενος μου έβαλε 20/20. Γενικά σε κάθε υποερώτημα τουλάχιστον ένας μου έβαζε όλες τις μονάδες και ο άλλος κάτι έκοβε. Με αυτά και με αυτά πήρα 91. Και οι δύο καθηγητές μου είπαν έπεσα θύμα κακής βαθμολόγησης αλλά δεν μπορώ να κάνω κάτι.
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: evry στις 22 Ιούν 2013, 02:41:13 μμ
Καταρχήν, συγχαρητήρια. στα άλλα μαθήματα πως πήγες?

Από περιέργεια, πως έμαθες πόσα σου έβαλε ο καθένας σε κάθε ερώτημα? Είχα την εντύπωση ότι αυτά δεν ανακοινώνονται

Παιδιά, ήταν σχετικά δύσκολα για τον κανονικό μαθητή. Εγώ πήγα, έγραψα ένα γραπτό που σύμφωνα με εμένα, τον καθηγητή του σχολείου και του φροντιστηρίου άξιζε 100 καθαρό. Βγαίνουν χθες τα αποτελέσματα, και ο ένας μου έκοψε στο Α4 το β όλο (και να πω ήθελε σκέψη, από τις λύσεις που του έδωσαν το έβλεπε) και το Γ3 ολόκληρο πάλι. Στο Δ έκοψε ο άλλος διορθωτής ενώ ο προηγούμενος μου έβαλε 20/20. Γενικά σε κάθε υποερώτημα τουλάχιστον ένας μου έβαζε όλες τις μονάδες και ο άλλος κάτι έκοβε. Με αυτά και με αυτά πήρα 91. Και οι δύο καθηγητές μου είπαν έπεσα θύμα κακής βαθμολόγησης αλλά δεν μπορώ να κάνω κάτι.
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: Dinos στις 22 Ιούν 2013, 06:24:23 μμ
Παιδιά, ήταν σχετικά δύσκολα για τον κανονικό μαθητή. Εγώ πήγα, έγραψα ένα γραπτό που σύμφωνα με εμένα, τον καθηγητή του σχολείου και του φροντιστηρίου άξιζε 100 καθαρό. Βγαίνουν χθες τα αποτελέσματα, και ο ένας μου έκοψε στο Α4 το β όλο (και να πω ήθελε σκέψη, από τις λύσεις που του έδωσαν το έβλεπε) και το Γ3 ολόκληρο πάλι. Στο Δ έκοψε ο άλλος διορθωτής ενώ ο προηγούμενος μου έβαλε 20/20. Γενικά σε κάθε υποερώτημα τουλάχιστον ένας μου έβαζε όλες τις μονάδες και ο άλλος κάτι έκοβε. Με αυτά και με αυτά πήρα 91. Και οι δύο καθηγητές μου είπαν έπεσα θύμα κακής βαθμολόγησης αλλά δεν μπορώ να κάνω κάτι.

Συγχαρητήρια, ελπίζω να τα πήγες το ίδιο καλά και στα άλλα μαθήματα.
Όσον αφορά στη βαθμολογία σου.
Το 100 καθαρό, σημαίνει ότι το γραπτό όχι μόνο πρέπει να πάρει 100 από τους 2 βαθμολογητές, αλλά όποιοσδήποτε άλλος και να το βαθμολογήσει θα του βάλει 100.
Άρα καθαρό (με την έννοια της ολοκληρωμένης, σωστής σε κάθε περίπτωση και εύληπτης λύσης) το γραπτό σου δεν ήταν.
Ο βαθμολογητής τώρα βλέπει πράγματα, τα οποία εσύ είτε μπορεί να παραβλέπεις, είτε να πιστεύεις ότι είναι σωστά και να μην είναι, είτε ακόμα ακόμα και να μην τα ξέρεις.
Επίσης ακόμα και στη μεταφορά αυτών που έγραψες προς τους καθηγητές σου, μπορεί να μην ήσουν ακριβής.
Βέβαια λάθη γίνονται, ατυχίες υπάρχουν αλλά και το 91 είναι ένας πάρα πολύ καλός βαθμός με τα θέματα που έπεσαν
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: nick41 στις 23 Ιούν 2013, 02:44:24 μμ
Τελικά εγώ πήρα 99.5(100 ο ένας ,99 ο άλλος).Ένας συμμαθητής μου πήρε καθαρό 100σταρι και γενικά στο σχολείο μου οι βαθμολογίες ήταν αρκετά καλές.Ένα παιδί μόνο που περίμενε πανω από 19(ίσως και 20) πήρε τελικά 16.7 και δεν ήξερε από που του ήρθε.
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: ΑλεξανδροςΑναστΓ στις 25 Ιούν 2013, 02:35:43 πμ
Μαθητής Γ' λυκείου τα θέματα ήταν πολλά και πιο απαιτητικά απο τα προηγούμενα!20 έγραψα

Λύση για το Β3
μ<--0
Για ι απο 1 μεχρι 100
αν Π[ι]=αληθης τοτε
μ<--μ+1
τελος_αν
τελος_επαναληψης
Για ι απο 1 μεχρι 100
Π[ι]<--ι<=μ
τελος_επαναληψης

Αν έχετε χρόνο ρίξτε μια ματιά
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: ΑλεξανδροςΑναστΓ στις 25 Ιούν 2013, 02:39:36 πμ
Παραθέτω μια "κομψή" λύση για το Β2, που δώσαμε ως εξεταστές των Φ. Α.
j <- 0
Για i από 1 μέχρι 100
     Αν Π[ i ] = ΑΛΗΘΗΣ τότε
          j <- j+1
          Αντιμετάθεσε Π[ i ], Π[ j ]
     Τέλος_αν
Τέλος_επανάληψης

τρομερή
Τίτλος: Απ: πανελληνιες 2013 σχολιασμος θεμάτων
Αποστολή από: Jimbo στις 25 Ιούν 2013, 12:55:53 μμ
Παράθεση από: cets89 στις 01 Ιουν 2013, 04:11:27 pm

    Παραθέτω μια "κομψή" λύση για το Β2, που δώσαμε ως εξεταστές των Φ. Α.
    j <- 0
    Για i από 1 μέχρι 100
         Αν Π[ i ] = ΑΛΗΘΗΣ τότε
              j <- j+1
              Αντιμετάθεσε Π[ i ], Π[ j ]
         Τέλος_αν
    Τέλος_επανάληψης


τρομερή

και όμως κάποιος  τη βαθμολόγησε αυτή τη λύση με 0!!!!