Αποστολέας Θέμα: Θέμα Α  (Αναγνώστηκε 3241 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2452
  • I 'm not young enough to know everything
Θέμα Α
« στις: 29 Μάι 2013, 10:19:07 πμ »
Εδώ μιλάμε για θέμα Α

thCnd

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Θέμα Α
« Απάντηση #1 στις: 29 Μάι 2013, 12:48:05 μμ »
Στο Α1 το 5 είναι σωστό ή λάθος;

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 676
Απ: Θέμα Α
« Απάντηση #2 στις: 29 Μάι 2013, 12:51:51 μμ »
Η πρόταση είνια μέσα από το σχολικό, σελ 156...σύμφωνα με αυτό ΣΩΣΤΟ

eara

  • Βετεράνος
  • ****
  • Μηνύματα: 79
Απ: Θέμα Α
« Απάντηση #3 στις: 29 Μάι 2013, 01:11:44 μμ »
Αν το ευαγγέλιο έγραφε "ο γάϊδαρος πετάει" θα είχαμε γεμίσει με ιπτάμενους γαϊδάρους;

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 892
Απ: Θέμα Α
« Απάντηση #4 στις: 29 Μάι 2013, 04:07:26 μμ »
Στο Α4β
όλες οι λύσεις που είδα, στη γραμμή 3 προτείνουν Α <- Β
και θέλω να προσθέσω ότι θα μπορούσε να είναι και αντιμετάθεσε Α, Β
(λύση την οποία προτιμώ, καθώς με την Α<- Β χάνουμε τη μία από τις δύο τιμές που δόθηκαν, πράγμα όχι και πολύ σοφό στη γενική περίπτωση)
sorry αν μου διέφυγε κάποια η οποία ήδη το έχει προτείνει. ..
Φιλικά,
Γιώργος Θαλασσινός

GEG

  • Βετεράνος
  • ****
  • Μηνύματα: 88
Απ: Θέμα Α
« Απάντηση #5 στις: 29 Μάι 2013, 07:03:34 μμ »
Στο A2 μαθητής μου έκανε το εξής:

k<--1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
     ΑΝ Π[i,j]<>0 ΤΟΤΕ
         Α[k]<-- i
         Α[k+20]<-- j
         Α[k+40]<-- Π[i,j]
         k<-- k+1
    ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Ξαναδιάβασα την εκφώνηση και νομίζω οτι μπορεί να θεωρηθεί ως σωστό. Ποιά η γνώμη σας;
« Τελευταία τροποποίηση: 29 Μάι 2013, 07:26:17 μμ από GEG »
Hey! It compiles! Ship it! :-)

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Θέμα Α
« Απάντηση #6 στις: 29 Μάι 2013, 07:55:50 μμ »
Στο Α4β
όλες οι λύσεις που είδα, στη γραμμή 3 προτείνουν Α <- Β
και θέλω να προσθέσω ότι θα μπορούσε να είναι και αντιμετάθεσε Α, Β
(λύση την οποία προτιμώ, καθώς με την Α<- Β χάνουμε τη μία από τις δύο τιμές που δόθηκαν, πράγμα όχι και πολύ σοφό στη γενική περίπτωση)
sorry αν μου διέφυγε κάποια η οποία ήδη το έχει προτείνει. ..

Ένας μαθητής στο Α4β έγραψε
Κώδικας: [Επιλογή]
αντιμετάθεσε Α, Β θα θεωρηθεί σωστό ή θα χάσει μονάδες;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2224
Απ: Θέμα Α
« Απάντηση #7 στις: 29 Μάι 2013, 07:57:54 μμ »
Γιατί να θεωρηθεί λάθος;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Θέμα Α
« Απάντηση #8 στις: 29 Μάι 2013, 08:03:29 μμ »
Επειδή για μερικούς είναι ταμπού η εντολή αντιμετάθεσε.
 :)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 892
Απ: Θέμα Α
« Απάντηση #9 στις: 29 Μάι 2013, 08:04:35 μμ »
@GEG
Τοποθετεί στην πρώτη 20 άδα τις γραμμές, στη δεύτερη 20αδα τις στήλες και στην 3η 20άδα τις τιμές
Η άσκηση δεν ορίζει πώς θέλει να περαστούν τα δεδομένα, οπότε θα πρέπει να ληθφεί σωστό.
Φιλικά,
Γιώργος Θαλασσινός

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 71
Απ: Θέμα Α
« Απάντηση #10 στις: 29 Μάι 2013, 08:05:21 μμ »
Η αντιμετάθεσε είναι εντολή της ψευδογλώσσας; Είχα την εντύπωση πως τη χρησιμοποιούμε μόνο στη ΓΛΩΣΣΑ
Σωκράτης

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Θέμα Α
« Απάντηση #11 στις: 29 Μάι 2013, 08:05:52 μμ »
Η αντιμετάθεσε είναι εντολή της ψευδογλώσσας; Είχα την εντύπωση πως τη χρησιμοποιούμε μόνο στη ΓΛΩΣΣΑ

Το αντίθετο.
:)

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 117
Απ: Θέμα Α
« Απάντηση #12 στις: 29 Μάι 2013, 08:15:58 μμ »
Στο A2 μαθητής μου έκανε το εξής:

k<--1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
     ΑΝ Π[i,j]<>0 ΤΟΤΕ
         Α[k]<-- i
         Α[k+20]<-- j
         Α[k+40]<-- Π[i,j]
         k<-- k+1
    ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

κι εμένα, ένας από τους καλύτερους μου μαθητές έκανε το ίδιο
εγώ σωστό θα το έλεγα, κατά τη γνώμη μου δικαιολογείται που έκανε τη συγκεκριμένη ερμηνεία της εκφώνησης...

αυτό που δε μου αρέσει και τού εξηγούσα, είναι ότι έτσι, τα όποια κενά μείνουν μέσα στον πίνακα θα είναι μοιρασμένα κάποια στο 1/3 χοντρικά του πίνακα, καποια άλλα στα 2/3 χοντρικά του πίνακα, και κάποια άλλα στο τέλος του πίνακα, πράγμα ελαφρώς άκομψο και πιθανώς πηγή κινδύνου, αν υποθέσουμε ότι στο μέλλον επιθυμούσαμε περαιτέρω επεξεργασία του πίνακα...

πάντως η ίδια η ιδέα της εκφώνησης, του να τοποθετείς σε έναν πίνακα στήλες, γραμμές και τιμές ενός άλλου πίνακα, είναι κατ' εμέ εξ ίσου άκομψη για δύο λόγους:

1. βάζεις στοιχεία σε μονοδιάστατο πίνακα, ενώ σου είναι χρήσιμα ανά τριάδες... ας ήτανε καλύτερα και ο νέος πίνακας δισδιάστατος, με 20 γραμμές και 3 στήλες, αν και ούτε κι αυτό μού αρέσει... νομίζω θα προτιμούσα να τους ζητούσαν να δημιουργήσουν τρεις νέους μονοδιάστατους πίνακες 20 θέσεων, έναν για τις μη-μηδενικές τιμές, έναν για τις στήλες, κι έναν για τις γραμμές

2. σε ένα βαθμό καταστρατηγεί το ότι ένας πίνακας πρέπει-επιτρέπεται να περιέχει ομοειδή στοιχεία... ναι μεν θα μού πείτε ότι είναι ομοειδή αφού είναι αριθμητικά στοιχεία, αλλά προσωπικά το βρίσκω κακή πρακτική και προτιμώ να υπάρχει μια αυστηρότερη λογική συσχέτιση μεταξύ των περιεχομένων ενός πίνακα

αυτά

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 117
Απ: Θέμα Α
« Απάντηση #13 στις: 29 Μάι 2013, 08:17:05 μμ »
Επειδή για μερικούς είναι ταμπού η εντολή αντιμετάθεσε.
 :)

κατ' εμέ η αντιμετάθεση ενδείκνυται στο συγκεκριμένο ερώτημα, ώστε να μη χαθεί η μία από τις δύο τιμές

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 71
Απ: Θέμα Α
« Απάντηση #14 στις: 29 Μάι 2013, 08:19:13 μμ »
Σωκράτης