Αποστολέας Θέμα: ΜΙΑ ΑΣΚΗΣΗ ΜΕ ΠΑΙΚΤΕΣ ΟΜΑΔΑΣ  (Αναγνώστηκε 763 φορές)

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
ΜΙΑ ΑΣΚΗΣΗ ΜΕ ΠΑΙΚΤΕΣ ΟΜΑΔΑΣ
« στις: 29 Μάι 2013, 07:59:42 πμ »

Μια ποδοσφαιρική ομάδα διαθέτει 22 ποδοσφαιριστές για κάθε έναν από τους οποίους αποθηκεύουμε

[Α] το ονοματεπώνυμό τους,
[Β] τα λεπτά συμμετοχής τους και
[Γ] τη θέση στην οποία παίζουν (“Ε” για επίθεση, “Α” για άμυνα, “Κ” για κέντρο και “Τ” όταν ο παίκτης είναι τερματοφύλακας).

Να γίνει αλγόριθμος που
θα διαβάζει τα παραπάνω δεδομένα και
θα εντοπίζει τους παίκτες που έχουν τα περισσότερα λεπτά συμμετοχής για κάθε θέση.

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
ΜΙΑ ΑΣΚΗΣΗ ΜΕ ΠΑΙΚΤΕΣ ΟΜΑΔΑΣ
« Απάντηση #1 στις: 30 Μάι 2013, 07:49:15 πμ »
Αλγόριθμος ΠΑΙΚΤΕΣ

μεγ_Τ <- -10
θεση_Τ <- 0

μεγ_Κ <- -10
θεση_Κ <- 0

μεγ_Ε <- -10
θεση_Ε <- 0

μεγ_Α <- -10
θεση_Α <- 0

Για ι από 1 μέχρι 22

   Αν ΘΕΣΗ[ι] = "Τ" τοτε

      Αν ΛΕΠΤΑ[ι] > μεγ_Τ τοτε

         μεγ_Τ <- ΛΕΠΤΑ[ι]

         θεση_Τ <- ι

      Τέλος_αν
   
   Τέλος_αν

   Αν ΘΕΣΗ[ι] = "Κ" τοτε

      Αν ΛΕΠΤΑ[ι] > μεγ_Κ τοτε

         μεγ_Κ <- ΛΕΠΤΑ[ι]

         θεση_Κ <- ι

      Τέλος_αν
   
   Τέλος_αν

   Αν ΘΕΣΗ[ι] = "Ε" τοτε

      Αν ΛΕΠΤΑ[ι] > μεγ_Τ τοτε

         μεγ_Ε <- ΛΕΠΤΑ[ι]

         θεση_Ε <- ι

      Τέλος_αν
   
   Τέλος_αν

   Αν ΘΕΣΗ[ι] = "Α" τοτε

      Αν ΛΕΠΤΑ[ι] > μεγ_Α τοτε

         μεγ_Α <- ΛΕΠΤΑ[ι]

         θεση_Α <- ι

      Τέλος_αν
   
   Τέλος_αν
   

Τέλος_επανάληψης
   

Τέλος ΠΑΙΚΤΕΣ