Αποστολέας Θέμα: ΘΕΜΑΤΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΠΕΚΑΠ ΝΟΤΙΟΥ ΑΙΓΑΙΟΥ  (Αναγνώστηκε 4990 φορές)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 893
Απ: ΘΕΜΑΤΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΠΕΚΑΠ ΝΟΤΙΟΥ ΑΙΓΑΙΟΥ
« Απάντηση #15 στις: 14 Μάι 2013, 11:49:59 πμ »
Συγχαρητήρια!
Είναι πολυ καλό διαγώνισμα. Το έδωσα κι εγώ σε μαθητές μου για εξάσκηση.
Ευχαριστώ για την προσφορά σας!
Φιλικά,
Γιώργος Θαλασσινός

alfabit

  • Θαμώνας
  • ***
  • Μηνύματα: 32
Απ: ΘΕΜΑΤΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΠΕΚΑΠ ΝΟΤΙΟΥ ΑΙΓΑΙΟΥ
« Απάντηση #16 στις: 27 Μάι 2013, 12:46:09 μμ »
Καλησπέρα συνάδελφοι. Να προτείνω και εγώ μια λύση για το Δ4:

!φτιάχνουμε ένα πίνακα ΕΒΔ[49] και αρχικά τον μηδενίζουμε
για κ απο 1 μέχρι 49
  εβδ[Κ] <-- 0
τέλος_επανάληψης

! έπειτα σε κάθε θέση του πίνακα ΕΒΔ που αναπαριστά τους 49 αριθμούς καταχωρώ την εβδομάδα που παρουσιάζεται:

για i από 1 μέχρι 2300
  για j από 1 μέχρι 49
     ΕΒΔ[ Λ[i,j] ] <-- i
  τέλος_επανάληψης
τέλος_επανάληψης

! αφού πλέον ξέρουμε για κάθε αριθμό την εβδομάδα που παρουσιάστηκε αρκεί να βρούμε ελάχιστο στον πίνακα ΕΒΔ (δηλ την πιο παλιά εβδομάδα)

min <-- EΒΔ [1]
για i από 2 μέχρι 49
  αν ΕΒΔ < min  τότε
      min <-- ΕΒΔ
  τέλος_αν
τέλος_επανάληψης

! έπειτα εμφανίζουμε τον/τους αριθμό/ους που παρουσιάστηκαν την πιο παλιά βδομάδα

για κ από 1 μέχρι 49
  αν ΕΒΔ[κ] = min τότε
      εμφάνισε "αριθμός:" , κ
   τέλος_αν
τέλος_επανάληψης

Επειδή το σκέφτηκα και το έγραψα λίγο γρήγορα, αν έχω κάποιο λαθάκι με συγχωρείτε εκ των προτέρων.