Αποστολέας Θέμα: Εκλογές για 15μελές(Άσκηση με κλήση υποπρογραμμάτων)  (Αναγνώστηκε 1025 φορές)

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 548
  • There can be only one...may it be AEPP.
Μια άσκηση που σκέφτηκα, για την ανάδειξη του 15μελούς στο λύκειο.
Θα ήθελα τις απόψεις σας πάνω στην εκφώνηση και τυχόν παρατηρήσεις και διορθώσεις. :)

Ακολουθεί η εκφώνηση και μια ενδεικτική λύση( :D)
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 548
  • There can be only one...may it be AEPP.
Απ: Εκλογές για 15μελές(Άσκηση με κλήση υποπρογραμμάτων)
« Απάντηση #1 στις: 18 Μάρ 2013, 01:52:01 μμ »
Σχετικά με την κλήση της διαδικασίας στο παραπάνω πρόγραμμα.
Ο κώδικας με τον οποίο ήθελα να την επιλύσω είναι ο κάτωθι:
Κώδικας: [Επιλογή]
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 3
      ΚΑΛΕΣΕ ΔΙΑΔ(ΑΑ, J, Π)
      ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 180
        ΑΝ J = 1 ΤΟΤΕ
          ΠΑ[I] <- Π[I]
        ΑΛΛΙΩΣ_ΑΝ J = 2 ΤΟΤΕ
          ΠΒ[I] <- Π[I]
        ΑΛΛΙΩΣ
          ΠΓ[I] <- Π[I]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Έβαλα τη διαδικασία να καλείται επαναληπτικά όπως στο θέμα 4 πανελ. 2009 με την ξενοδοχειακή επιχείρηση. Απλά εκεί ήθελε συνάρτηση.
Κάθε φορά που καλείται επιστρέφει και ενα νεο πίνακα. Αυτομάτως τα στοιχεία αυτού του πίνακα αντιγράφονται στους ΠΑ, ΠΒ και ΠΓ πίνακες. Αλλά εαν είχα 10 ή παραπάνω επαναλήψεις τότε έπρεπε να κάνω 10 αντιγραφές. Ακόμη και αν έβαζα την επανάληψη μέσα στη Διαδικασία έτσι ώστε να μην εκτελείται επαναληπτικά θα έπρεπε να επιστρέφω 10 πίνακες.
 
Υπάρχει περίπτωση να επιστρέφεται πίνακας ο οποίος για κάθε κλήση της διαδικασίας, να είναι διαφορετικός; Δηλαδή με κάποιο τρόπο να αλλάζει ο πίνακας από ΠΑ σε ΠΒ και σε ΠΓ κλπ οπότε να αποφύγουμε τις αντιγραφές πινάκων μέσα στο κυρίως πρόγραμμα;

Υ.Γ. Όποιος συνάδελφος κατάλαβε τί ρωτάω παραπάνω είναι ήρωας! :o
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής