Αποστολέας Θέμα: ΜΕΤΑΤΡΟΠΗ ΑΠΟΚΛΕΙΣΤΙΚΑ ΜΕ ΓΙΑ ΟΣΟ ΜΕΧΡΙ  (Αναγνώστηκε 799 φορές)

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
ΜΕΤΑΤΡΟΠΗ ΑΠΟΚΛΕΙΣΤΙΚΑ ΜΕ ΓΙΑ ΟΣΟ ΜΕΧΡΙ
« στις: 27 Φεβ 2013, 01:37:30 μμ »
1.      χ ← 3
2.       Αρχή_επανάληψης
3.          χ ← χ + 2
4.          y ← χ + 2     
5.          Όσο y < 15 επανάλαβε
6.               y ← y + 4
7.             Εμφάνισε y
8.          Τέλος_επανάληψης
9.          Αν χ > 6 τότε
10.          Εμφάνισε y – χ
11.       Τέλος_αν
12.       χ ← χ + 3
13.    Μέχρις_ότου χ mod 8 >= 5

Να μετατρέψετε ισοδύναμα το παραπάνω τμήμα αλγορίθμου ώστε να εκτυπώνονται οι ίδιες ακριβώς τιμές,  χρησιμοποιώντας όμως αποκλειστικά τη δομή επανάληψης Για αντί της δομής Μέχρις_ότου και της δομής Όσο, χωρίς όμως να χρησιμοποιήσετε άλλες μεταβλητές πέρα των χ και y.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2305
Απ: ΜΕΤΑΤΡΟΠΗ ΑΠΟΚΛΕΙΣΤΙΚΑ ΜΕ ΓΙΑ ΟΣΟ ΜΕΧΡΙ
« Απάντηση #1 στις: 27 Φεβ 2013, 02:37:54 μμ »
Νομίζω ότι ο πιο ασφαλής τρόπος για να μετατρέψεις μη τυποποιημένες μορφές των δομών επανάληψης είναι να κάνεις ένα πίνακα τιμών για το τμήμα που σου δίνεται και να γράψεις κατόπιν τον κώδικα που σου ζητάνε, ώστε να κάνει ακριβώς τα ίδια πράγματα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3302
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: ΜΕΤΑΤΡΟΠΗ ΑΠΟΚΛΕΙΣΤΙΚΑ ΜΕ ΓΙΑ ΟΣΟ ΜΕΧΡΙ
« Απάντηση #2 στις: 27 Φεβ 2013, 06:16:35 μμ »
πρσωπικά δε μου αρέσει η άσκηση.
Η δομή Για έχει δημιουργηθεί για άλλο σκοπό...