Αποστολέας Θέμα: ΜΕΘΟΔΟΛΟΓΙΕΣ ΜΕΤΑΤΡΟΠΩΝ  (Αναγνώστηκε 996 φορές)

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
ΜΕΘΟΔΟΛΟΓΙΕΣ ΜΕΤΑΤΡΟΠΩΝ
« στις: 04 Φεβ 2013, 12:23:57 μμ »
Γεια σε όλους τους φίλους του ΣτΠ. Θα ήθελα να σας ρωτήσω αν υπαρχει μεθοδολογία για μετατροπές

[1] Από goto σε δομημένο προγρμματισμό

[2] Από Συνθήκες επιλογής  με λογικούς τελεστές σε απλές Συνθήκες επιλογής

Γενικά , μετατροπές όπως πχ σε ένα θέμα του 2011 που λέει :

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Αν Χ>1 τότε
Κ <-- Αληθής
Αλλιώς
Κ <-- Ψευδής
Τέλος_αν

Να γράψετε στο τετράδιό σας συμπληρωμένη την παρακάτω εντολή εκχώρησης, ώστε να έχει το ίδιο αποτέλεσμα με το παραπάνω τμήμα αλγορίθμου.
Κ <-- .....

Σας ευχαριστώ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: ΜΕΘΟΔΟΛΟΓΙΕΣ ΜΕΤΑΤΡΟΠΩΝ
« Απάντηση #1 στις: 04 Φεβ 2013, 02:27:43 μμ »
Αυτό το θέμα (2011) μην το αναφέρεις καν, έβγαλαν από την μύγα ξύγκι και έβαλαν φοβερά μυαλά να ψάχνουν λύση σε κάτι που σχεδόν όλοι δεν διδάχθηκαν
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
Απ: ΜΕΘΟΔΟΛΟΓΙΕΣ ΜΕΤΑΤΡΟΠΩΝ
« Απάντηση #2 στις: 05 Φεβ 2013, 10:39:47 πμ »
Αν δείς τη λύση είναι κ <--- χ < 1 άρα μιλάμε για θέμα του δευτερολέπτου που μόλις το βλέπεις κομπλαρεις . Η λύση ήταν ο τύπος της εκχώρησης , δηλαδή Μεταβλητή  <-- Έκφραση .
Για ανάλογες ασκησούλες ψάχνομαι ........ όποιος ξέρει κάτι ας το παραθέσει .
Σας ευχαριστώ ....

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 563
  • There can be only one...may it be AEPP.
Απ: ΜΕΘΟΔΟΛΟΓΙΕΣ ΜΕΤΑΤΡΟΠΩΝ
« Απάντηση #3 στις: 05 Φεβ 2013, 02:41:47 μμ »
Αν Χ>1 τότε
Κ <-- Αληθής
Αλλιώς
Κ <-- Ψευδής
Τέλος_αν

Να γράψετε στο τετράδιό σας συμπληρωμένη την παρακάτω εντολή εκχώρησης, ώστε να έχει το ίδιο αποτέλεσμα με το παραπάνω τμήμα αλγορίθμου.
Κ <-- .....



Αυτό μου θυμίζει και την περίπτωση

Αν flag τότε
....
Αλλιώς
....
Τέλος_αν

Γιατί τα εύκολα δύσκολα. Για λίγες εντολές λιγότερες;

Για ανάλογες ασκησούλες ψάχνομαι ........ όποιος ξέρει κάτι ας το παραθέσει .

Κάνε την ίδια αλλά με χαρακτήρες. Κάτι άλλο δεν μπορώ να σκεφτώ αυτή στιγμή.
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής