Αποστολέας Θέμα: Ορθότητα αλγορίθμου  (Αναγνώστηκε 991 φορές)

denia_k

  • Βετεράνος
  • ****
  • Μηνύματα: 84
Ορθότητα αλγορίθμου
« στις: 10 Οκτ 2012, 10:50:52 μμ »
Αλγόριθμος Παράδειγμα_8
Διάβασε a,b,c
s← a + b + c
Αν s > 0 τότε
   m← (a+b+c)/3
   Εκτύπωσε "Ο μέσος όρος είναι ", m
Αλλιώς
   Αν a < b τότε
      Αν b < c τότε
         Εμφάνισε "Ο μεγαλύτερος είναι ο ", c
      Αλλιώς
         Εμφάνισε "Ο μεγαλύτερος είναι ο ", b
      Τέλος_αν
   Αλλιώς
      Αν a > c τότε
         Εμφάνισε "Ο μεγαλύτερος είναι ο ", a
      Αλλιώς
         Εμφάνισε "Ο μεγαλύτερος είναι ο ", c
      Τέλος_αν
   Τέλος_αν
Τέλος Παράδειγμα_8


Ο παραπάνω αλγόριθμος είναι σωστός;;;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2319
Απ: Ορθότητα αλγορίθμου
« Απάντηση #1 στις: 11 Οκτ 2012, 01:07:18 πμ »
Σωστός ως προς τι;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

denia_k

  • Βετεράνος
  • ****
  • Μηνύματα: 84
Απ: Ορθότητα αλγορίθμου
« Απάντηση #2 στις: 11 Οκτ 2012, 01:32:22 πμ »
Συντακτικά εννοώ! Για να γίνω πιο συγκεκριμένη, η εκφώνηση της άσκησης ήταν η εξής: "Να γράψετε αλγόριθμο ο οποίος θα παίρνει ως είσοδο τρεις πραγματικούς αριθμούς και θα υπολογίζει το άθροισμά τους. Αν το άθροισμα αυτό είναι μεγαλύτερο του μηδενός, τότε θα υπολογίζει τον μέσο όρο των τριών αυτών αριθμών, ενώ, σε διαφορετική περίπτωση, θα εμφανίζει τον μέγιστο αριθμό".
« Τελευταία τροποποίηση: 11 Οκτ 2012, 01:48:16 πμ από despoina »

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2319
Απ: Ορθότητα αλγορίθμου
« Απάντηση #3 στις: 11 Οκτ 2012, 01:46:35 πμ »
Λείπει Τέλος_Αν στο εξωτερικό Αν
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

denia_k

  • Βετεράνος
  • ****
  • Μηνύματα: 84
Απ: Ορθότητα αλγορίθμου
« Απάντηση #4 στις: 11 Οκτ 2012, 01:51:26 πμ »
Ευχαριστώ πάρα πολύ!