Αποστολέας Θέμα: Θέμα Α  (Αναγνώστηκε 15837 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2452
  • I 'm not young enough to know everything
Θέμα Α
« στις: 01 Ιούν 2012, 10:02:52 πμ »
Εδώ μιλάμε για θέμα Α

geoAlex

  • Ομάδα διαγωνισμάτων 2012
  • *
  • Μηνύματα: 23
Απ: Θέμα Α
« Απάντηση #1 στις: 01 Ιούν 2012, 01:09:56 μμ »
Θέμα Α1
1. Λάθος     (δες σελίδα 56).
2. Λάθος     (δες σελίδα 174).
3. Σωστή    (δες σελίδα 191).
4. Λάθος     (δες σελίδα 56).
5. Σωστό    (δες σελίδα 60).

Θέμα Α2
Για τους τύπους δεδομένων δες σελίδα 148.

Χ <- 'ΑΛΗΘΗΣ'     Χαρακτήρας     ΑΛΗΘΗΣ
Χ<- 11.0-13.0     Πραγματική      -2.0         Λειτουργία εντολής εκχώρησης δες σελ 154.
Χ<- 7>4              Λογική             ΑΛΗΘΗΣ
Χ<- ΨΕΥΔΗΣ       Λογική              ΨΕΥΔΗΣ
Χ<- 4                  Ακέραια            4

Θέμα Α3.α
Α[3] <- 3+Α[6]
Α[9]<- Α[7]-2
Α[8]<- Α[3]-5
Α[4]<- 5+Α[9]
Α[5]<- (Α[3]+Α[7]) div 2  ή (Α[2]+Α[7]) div 2


Θέμα Α3.β
   Για i από 1 μέχρι 5
        αντιμετάθεσε Α[ι], Α[11-ι]
   Τέλος_επανάληψης

θέμα Α4.α
   ι <- 99
   Όσο ι >= 1 επανάλαβε
       χ<- ι^2
      εμφάνισε χ
      ι <- ι – 2
   Τέλος_επανάληψης

Θέμα Α4.β
   ι <- 99
   Αρχή_επανάληψης
       χ <- ι^2
      εμφάνισε χ
      ι <- ι – 2
   Μέχρις_ότου ι < 1

Θέμα Α5
Δες σελίδα 60 σχολικού.
« Τελευταία τροποποίηση: 01 Ιούν 2012, 02:31:41 μμ από geoAlex »
Γιώργος Αλεξίου

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: Θέμα Α
« Απάντηση #2 στις: 01 Ιούν 2012, 01:39:21 μμ »
Ένας μαθητής στο Α3.β. έγραψε:

Για ι από 1 μέχρι 5
      αντιμετάθεσε Α[ι],Α[Α[ι]]
Τέλος_επανάληψης

Αν και εξαρτάται από την υλοποίηση του αλγορίθμου (π.χ. με διαδικασία swap), δε μπορώ παρά να τον συγχαρώ για την πρωτοτυπία του. Ελπίζω να μην του κόψουν μονάδες πάντως...
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: Θέμα Α
« Απάντηση #3 στις: 01 Ιούν 2012, 01:41:32 μμ »
Δεν θα του κόψεις κανένας μονάδες! Καταπληκτικό!
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

kkkerm

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 18
Απ: Θέμα Α
« Απάντηση #4 στις: 01 Ιούν 2012, 01:45:07 μμ »
Νομίζω ότι έχουν γίνει λάθακια ... στη λύση που πρότεινε ο geoAlex

Χ <- 'ΑΛΗΘΗΣ'     Χαρακτήρας     ΑΛΗΘΗΣ  :)
Χ<- 11.0-13.0     Πραγματική      -2.0   
Χ<- 7>4              Λογική             ΑΛΗΘΗΣ
Χ<- ΨΕΥΔΗΣ       Λογική              ΨΕΥΔΗΣ  :)
Χ<- 4                  Ακέραια            4


merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: Θέμα Α
« Απάντηση #5 στις: 01 Ιούν 2012, 01:50:03 μμ »
Πέτρο κατάλαβες γιατί το λέω...
Παίζει ρόλο πότε θα αλλάξει τιμή το Α[ι]. Δηλαδή υλοποιώντας την αντιμετάθεσε με temp μεταβλητή (όχι κλήση σε διαδικασία) αν κάνει πρώτα την
Α[ι]<--Α[Α[ι]]
ή την
Α[Α[ι]]<--Α[ι]

Μακάρι να μην του κόψουν τίποτα γιατί κρίμα το καμάρι που έκανε!!! :)
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

geoAlex

  • Ομάδα διαγωνισμάτων 2012
  • *
  • Μηνύματα: 23
Απ: Θέμα Α
« Απάντηση #6 στις: 01 Ιούν 2012, 02:03:10 μμ »
Νομίζω ότι έχουν γίνει λάθακια ... στη λύση που πρότεινε ο geoAlex

Χ <- 'ΑΛΗΘΗΣ'     Χαρακτήρας     ΑΛΗΘΗΣ  :)
Χ<- 11.0-13.0     Πραγματική      -2.0   
Χ<- 7>4              Λογική             ΑΛΗΘΗΣ
Χ<- ΨΕΥΔΗΣ       Λογική              ΨΕΥΔΗΣ  :)
Χ<- 4                  Ακέραια            4

Σωστή η παρατήρηση και διορθώθηκε  :-[
Γιώργος Αλεξίου

mour

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 179
Απ: Θέμα Α
« Απάντηση #7 στις: 01 Ιούν 2012, 02:22:04 μμ »
Το Α[5]<- (Α[...]+Α[7]) div 2
παιζει σωστά και με 2 και με 3

geoAlex

  • Ομάδα διαγωνισμάτων 2012
  • *
  • Μηνύματα: 23
Απ: Θέμα Α
« Απάντηση #8 στις: 01 Ιούν 2012, 02:33:31 μμ »
Το Α[5]<- (Α[...]+Α[7]) div 2
παιζει σωστά και με 2 και με 3

Έχεις απόλυτο δίκο, συμπεριέλαβα και αυτή την λύση, ευχαριστώ.
Γιώργος Αλεξίου

anasta

  • Βετεράνος
  • ****
  • Μηνύματα: 58
  • Ok, yes... Ok, yes...
Απ: Θέμα Α
« Απάντηση #9 στις: 01 Ιούν 2012, 03:01:19 μμ »
δείτε απάντηση στο Α.3.β
Για i από 1 μέχρι 5
αντιμετάθεσε Α, A[6 - i]
Τέλος_επανάληψης

http://www.ert.gr/exams/images/stories/themata-lyseis-2012/aepp_c_lyseis_2012.pdf

μάλλον πρόκειται για τυπογραφικό λάθος!!!

mour

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 179
Απ: Θέμα Α
« Απάντηση #10 στις: 01 Ιούν 2012, 03:03:13 μμ »
Το Α[5]<- (Α[...]+Α[7]) div 2
παιζει σωστά και με 2 και με 3
Το δώσαμε ως παρατήρηση στην ΚΕΕ, αλλά δεν βγήκε διευκρίνηση αν μπορούν να δοθούν 2 απαντήσεις

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Α
« Απάντηση #11 στις: 01 Ιούν 2012, 03:10:51 μμ »
δείτε απάντηση στο Α.3.β
Για i από 1 μέχρι 5
αντιμετάθεσε Α, A[6 - i]
Τέλος_επανάληψης

http://www.ert.gr/exams/images/stories/themata-lyseis-2012/aepp_c_lyseis_2012.pdf

μάλλον πρόκειται για τυπογραφικό λάθος!!!

είναι τυπογραφικό σίγουρα!!

MsGladButterfly

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα Α
« Απάντηση #12 στις: 01 Ιούν 2012, 03:18:22 μμ »
Στο ερώτημα Α2, στη δεύτερη γραμμή και την τρίτη στήλη του πίνακα που μας δίνεται, δηλαδή εκεί που ζητείται το περιεχόμενο της μεταβλητής Χ<- 'ΑΛΗΘΗΣ' , εγώ έγραψα σκέτο ΑΛΗΘΗΣ, χωρίς τα εισαγωγικά, σκεπτόμενη ότι ζητείται μόνο το περιεχόμενο και όχι η μεταβλητή. Είναι σωστό; Γιατί έχω δει ορισμένες λύσεις στις οποίες βάζουν τα εισαγωγικά.

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Α
« Απάντηση #13 στις: 01 Ιούν 2012, 03:26:11 μμ »
τελείως σωστό, καλά αποτελέσματα

MsGladButterfly

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα Α
« Απάντηση #14 στις: 01 Ιούν 2012, 03:30:44 μμ »
τελείως σωστό, καλά αποτελέσματα
Αχ ωραία!Σας ευχαριστώ πολύ!