Αποστολέας Θέμα: ΠΙΝΑΚΕΣ Η ΟΧΙ  (Αναγνώστηκε 1190 φορές)

ds_10

  • Οπαδός
  • **
  • Μηνύματα: 10
ΠΙΝΑΚΕΣ Η ΟΧΙ
« στις: 12 Μάρ 2012, 06:36:01 μμ »
Σε ασκήσεις οι οποίες ζητούν να κάνεις κάτι επαναληπτικά π.χ. για πολλούς μαθητές ή υπαλλήλους κτλ, στις οποίες μπορείς και να μη χρησιμοποιήσεις πίνακες, δεν υπάρχει πρόβλημα να τις λύσεις με πίνακες; Σε ένα ενδεχόμενο τρίτο θέμα στις πανελλήνιες που ίσως να έχει και υποπρόγραμμα δεν θα ήταν λάθος η χρήση πινάκων Π.Χ.
Για ι από 1 μέχρι 100                                                           Για ι από 1 μέχρι 100
       κ<- fun(array)                                                                   Διαβασε χ
τέλος_επανάληψης                                                                      κ<-fun(x)
                                                                                            τέλος_επανάληψης


ρωτώ γιατί συνήθως τέτοιου τύπου ασκήσεις τις βλέπω να λύνονται ΧΩΡΙΣ πίνακες, πράγμα που οι μαθητές μου συνήθως δεν το κάνουν.
Σας ευχαριστώ!

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1133
Απ: ΠΙΝΑΚΕΣ Η ΟΧΙ
« Απάντηση #1 στις: 21 Μάρ 2012, 11:16:58 πμ »
Σε ασκήσεις στις οποίες  είναι γνωστό το πλήθος των επαναλήψεων που πρέπει να πραγματοποιηθούν, μπορούν να χρησιμοποιηθούν οι πίνακες (αρκεί να γίνει σωστή χρήση των πινάκων), και δεν είναι λανθασμένη η λύση.

Με τα υποπρογράμματα, χρειάζεται λίγο προσοχή για να γίνει το σωστό πέρασμα του πίνακα ή ενός στοιχείου του πίνακα ως παράμετρο.



gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 947
Απ: ΠΙΝΑΚΕΣ Η ΟΧΙ
« Απάντηση #2 στις: 21 Μάρ 2012, 03:36:09 μμ »
Προσωπικά, έχω πάντα την εντύπωση ότι το βιβλίο γενικά αποτρέπει τη χρήση των πινάκων αν τα δεδομένα δεν χρειάζεται να επαναχρησιμοποιηθούν.
Σ' αυτό το πνεύμα, προτείνω στους μαθητές μου, αν μπορούν να λύσουν την άσκηση χωρίς πίνακες, να το προτιμήσουν, καθώς πιστεύω ότι μπορεί να βρεθούν βαθμολογητές οι οποίοι πατώντας πάνω στις συγκεκριμένες αναφορές του βιβλίου, μπορεί να αφαιρέσουν μόρια (1-2 φαντάζομαι) για περιττή χρήση πίνακα.
Αλλά στην πράξη, δεν ξέρω... Τι λένε συνάδελφοι που έχουν υπάρξει σε βαθμολογικά κέντρα;
Φιλικά,
Γιώργος Θαλασσινός

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1133
Απ: ΠΙΝΑΚΕΣ Η ΟΧΙ
« Απάντηση #3 στις: 22 Μάρ 2012, 10:38:27 πμ »
Τα παραπάνω κείμενο  που έγραψα, τα ανέφερα ως βαθμολογητής.
Δεν γίνεται καμία αφαίρεση μονάδων από τη (περιττή ) χρήση πίνακα σε άσκηση που μπορεί να ληθεί με δομή επανάληψης.



gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 947
Απ: ΠΙΝΑΚΕΣ Η ΟΧΙ
« Απάντηση #4 στις: 22 Μάρ 2012, 11:44:54 πμ »
Α, οκ Γιώργο, ευχαριστώ.
Και, υποθέτω, αυτό δίνεται ως οδηγία προς όλους τους βαθμολογητές, ε;
Φιλικά,
Γιώργος Θαλασσινός