Αποστολέας Θέμα: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011  (Αναγνώστηκε 5724 φορές)

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #15 στις: 23 Μάι 2011, 09:31:35 μμ »
βασικα το 3ο θεμα το ελυσα με αρχη_επαναληψης αλλά μέσα στο βροχο για να αποφυγω τη "βαρεμαρα" του χειριστη όλη τη διαδικασια την έβαλα σε μια Αν ονομα<>"ΤΕΛΟΣ" τοτε

...και μετα όλα τα άλλα


???

Σύμφωνα με το βιβλίο η τιμή φρουρός λύνεται με ΌΣΟ αλλά και με Μέχρις_ότου όπου μέσα
υπάρχει μια ΑΝ (Ακόμα και έξω) είναι μια χαρά
δηλ
Αρχή_επ
Διάβασε ΟΝ
Αν ΟΝ<>'ΤΕΛΟΣ' τότε
.......
Τέλος_αν
Μέχρις_ότου ΟΝ="ΤΕΛΟΣ"

ή

Διάβασε ΟΝ
Αν ΟΝ<>"ΤΕΛΟΣ" επ
Αρχή_επ
   ..........
   Διάβασε ΟΝ
Μέχρις_ότου ΟΝ="ΤΕΛΟΣ"
Τέλος_αν

ge0_

  • Οπαδός
  • **
  • Μηνύματα: 11
    • tk0world.com
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #16 στις: 23 Μάι 2011, 10:32:42 μμ »
μάλιστα δηλαδή προγραμματισμό να περιμένω πάνω από 19....yeah!!!
πάντως σχετικά τα βρήκα εύκολα...
αφού κοιταζα και ξανακοιταζα να δω μηπως έχω ξεχάσει κανα θέμα...
κι όλο να ξάχνω να βρω ερωτημα με υποπρογραμμα και να λέω δεν μπορεί να μην βάλανε καθόλου....αλλά τελος καλο όλα καλά

bill_m

  • veteran
  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #17 στις: 24 Μάι 2011, 11:11:27 μμ »
Τις πληκτρολογούσα ταυτόχρονα.
Χειρόγραφο υποθέτω κάνα 40 λεπτο πάνω κάτω
Άρα για τους μαθητές ο χρόνος ήταν άνετος

Εγω παιδια που εγραφα πηραμε τα θεματα 8:55 και 9:45 ειχα τελειώσει!!! Ηταν πολυ ανετα στο ζήτημα του χρονου [σσ. εκανα και πινακα τιμών στο 2ο που ηταν χρονοβόρο].