Αποστολέας Θέμα: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011  (Αναγνώστηκε 5718 φορές)

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« στις: 23 Μάι 2011, 02:36:19 μμ »
Καλησπέρα
δίνω κάποιες λύσεις μου για τα φετινά θέματα σε ΑΕΠΠ
Σχετικά αναμενόμενα τα θέματα με μικρές δυσκολίες.
Το 3ο Θέμα έχει ένα μικρό πρόβλημα σχετικά με τι θα εμφανίσει
αν δεν υπάρχει κανένας επιτυχών αλλά μιας και λέει ότι
είναι μοναδικός θεωρέ ότι υπάρχει σίγουρα επιτυχών
(οπότε ότι έβαλα μετά από ! δεν χρειάζεται)
Βάζω και το χρόνο μου για την επίλυσή τους (στο word)
Σημ. το  είναι η εκχώρηση

Σε αρχείο
http://dl.dropbox.com/u/21708959/%CE%9B%CE%A5%CE%A3%CE%95%CE%99%CE%A3%20%CE%A0%CE%91%CE%9D%CE%95%CE%9B%CE%9B%CE%97%CE%9D%CE%99%CE%95%CE%A3%20%CE%95%CE%9E%CE%95%CE%A4%CE%91%CE%A3%CE%95%CE%99%CE%A3%202011.doc

Ηλίας

ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ΄  ΤΑΞΗΣ
ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ
∆ΕΥΤΕΡΑ 23 MAΪΟΥ 2011
ΛΥΣΕΙΣ

ΘΕΜΑ Α
Α1.  1-Σ, 2-Σ, 3-Λ, 4-Λ, 5-Λ

Α2. 1-Σ, 2-Σ, 3-Σ, 4-Λ, 5-Λ

Α3. 1-ΑΛΗΘΗΣ,  2-ΨΕΥΔΗΣ, 3-ΑΛΗΘΗΣ,  4-ΨΕΥΔΗΣ, 5-ΑΛΗΘΗΣ

Α4. Κ<-(Χ>1)

Α5. 10ο ΚΕΦ
Α. Τμηματικός προγραμματισμός ονομάζεται μία τεχνική σχεδίασης και ανάπτυξης προγραμμάτων ως ένα σύνολο από απλούστερα τμήματα προγραμμάτων.
Β. Υποπρόγραμμα είναι ένα τμήμα προγράμματος που επιτελεί ένα αυτόνομο έργο και έχει γραφεί χωριστά από το υπόλοιπο πρόγραμμα.
Γ. Παράμετρος είναι μία μεταβλητή που επιτρέπει το πέρασμα τιμής από ένα τμήμα προγράμματος σε ένα άλλο.

ΘΕΜΑ Β
Β1.
Αρχή_επανάληψης
   Σ0
   Κ1
   Όσο Κ<=100 επανάλαβε
      Διάβασε Χ
      ΣΣ+Χ
      ΚΚ+1
   Τέλος_επανάληψης
Μέχρις_ότου Σ>1000   ΑΛΛΗ ΛΥΣΗ
Αρχή_επανάληψης
   Σ0
   Για Κ από 1 μέχρι 100
      Διάβασε Χ
      ΣΣ+Χ
   Τέλος_επανάληψης
Μέχρις_ότου Σ>1000

Β2.
ΑΡΙΘΜΟΣ ΕΠ   ΚΥΡΙΟ ΠΡΟΓΡΑΜΜΑ   ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ   ΟΘΟΝΗ
   Z   W   W   Z   
ΑΡΧ/ΣΕΙΣ   1   3         
1η         1   3   
         4   5   5
   4   5         4
2η          4   5   
         9   7   7
   9   7         9
3η          9   7   
         16   9   9
   16   9         16
4η         16   9   
         25   11   11
   25   11         25
5η         25   11   
         36   13   13
   36   13         36

ΘΑ ΕΜΦΑΝΙΣΤΟΥΝ : 5, 4, 7, 9, 9, 16, 11, 25, 13, 36 
(ΧΡΟΝΟΣ ΕΠΙΛΥΣΗΣ ΘΕΜΑ Α-Β : 25ΛΕΠΤΑ)

ΘΕΜΑ Γ

Αλγόριθμος ΤΙΜΗΦΡΟΥΡΟΟΟΟΟΟΟΟΟΟΟΟΟΟΣ
ΜΙΝ101
! Αν Θέλω να βάλω και την περίπτωση που δεν υπάρχει κανένας επιτυχών
! Κ0
Διάβασε ΟΝ
Όσο ΟΝ<> «ΤΕΛΟΣ» επανάλαβε
Διάβασε Μ1, Μ2, Μ3
Αν Μ1>=Μ2 και Μ1>=Μ3 τότε
         Εμφάνισε Μ1
   αλλιώς_αν Μ2>=Μ1 και Μ2>=Μ3 τότε
      Εμφάνισε Μ2
   αλλιώς
      Εμφάνισε Μ3
   Τέλος_αν
   ΜΟ (Μ1+Μ2+Μ3)/3
   Αν ΜΟ>=55 και Μ1>=50 και Μ2>=50 και Μ3>=50 τότε
      Εμφάνισε ΟΝ, ΜΟ
      ΚΚ+1
      Αν ΜΟ<=ΜΙΝ τότε
         ΜΙΝΜΟ
         ΝΜΙΝΟΝ
   Τέλος_αν
   Διάβασε ΟΝ
Τέλος_επανάληψης
! Αν Κ>0 τότε
Εμφάνισε «Ο επιτυχόντας με την μικρότερη συνολική βαθμολογία ο/η », ΝΜΙΝ   
! αλλιώς
!    Εμφάνισε «Δεν υπάρχει επιτυχών»
!Τέλος_αν

(ΧΡΟΝΟΣ ΕΠΙΛΥΣΗΣ ΘΕΜΑ Γ : 15 ΛΕΠΤΑ)

ΘΕΜΑ Δ
Αλγόριθμος ΚΑΛΑ_ΜΠΑΝΙΑ
! Δ1
Για γ από 1 μέχρι 22
   Για σ α 1 μέχρι 22
       Αρχή_επανάληψης
         Διάβασε Ψ[γ,σ]
      Μέχρις_ότου Ψ[γ,σ]=1 ή Ψ[γ,σ]=0
   Τέλος_επανάληψης
Τέλος_επανάληψης
! Δ2
ΚΑΝΕΝΑΝ 0
Για γ από 1 μέχρι 22
   Κ0
   Για σ από 1 μέχρι 22
      Αν Ψ[γ,σ]=0 τότε
         ΚΚ+1
      Τέλος_αν
   Τέλος_επανάληψης
   Αν Κ=22 τότε ΚΑΝΕΝΑΝΚΑΝΕΝΑΝ+1
Τέλος_επανάληψης
Εμφάνισε ΚΑΝΕΝΑΝ

! Δ3                     ΕΑ0
ΕΑ0                     Για γ από 1 μέχρι 22
Για γ από 1 μέχρι 22               Για σ από 1 μέχρι 22
   Αν Ψ[γ,γ]=1 τότε ΕΑΕΑ+1      ή   Αν γ=σ τότε
Τέλος_επανάληψης               Αν Ψ[γ,σ]=1 τότε ΕΑΕΑ+1  …..κλπ
! Δ4 ΚΑΤΑ ΣΤΗΛΕΣ ΜΕΤΡΑΩ ΤΑ 1 ΚΑΙ ΦΤΙΑΧΝΩ ΒΟΗΘΗΤΙΚΟ
Για σ από 1 μέχρι 22
   Π0
   Για γ από 1 μέχρι 22
      Αν Ψ[γ,σ]=1 τότε
         ΠΠ+1
      Τέλος_αν
   Τέλος_επανάληψης
   ΣΠ[σ]Π
   ΠΑΙΚΤΗΣ[σ]σ
Τέλος_επανάληψης
!Ταξινόμηση Φθίνουσα
Για i από 2 μέχρι 22
   Για j από 22 μέχρι i με_βήμα -1
      Αν ΣΠ[j-1]<ΣΠ[j] τότε
         Αντιμετάθεσε  ΣΠ[j-1], ΣΠ[j]
         Αντιμετάθεσε  ΠΑΙΚΤΗΣ[j-1], ΠΑΙΚΤΗΣ[j]
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για α από 1 μέχρι 3
   Εμφάνισε ΠΑΙΚΤΗΣ[α]
Τέλος_επανάληψης
Αλγόριθμος ΚΑΛΑ_ΜΠΑΝΙΑ

(ΧΡΟΝΟΣ ΕΠΙΛΥΣΗΣ ΘΕΜΑ Δ: 20 ΛΕΠΤΑ)
« Τελευταία τροποποίηση: 23 Μάι 2011, 02:55:43 μμ από ipoulis »

vtsakan

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 273
  • printf("Smile");
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #1 στις: 23 Μάι 2011, 02:46:45 μμ »
ipoulis, καλή δουλειά.

Νομίζω πως το Δ4 δεν λύνεται με ταξινόμηση, μιας και θέλει και τους αριθμούς των παιχτών. Θα το έλυνα με τρείς φορές εύρεση του max και μετά βάζοντας -1 στην αντίστοιχη θέση του πίνακα.
Βασίλης Τσακανίκας
Ηλεκτρολόγος Μηχανικός και Μηχανικός Υπολογιστών Ε.Μ.Π.

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #2 στις: 23 Μάι 2011, 02:54:19 μμ »
Έφτιαξα παράλληλο μονοδιάστατο ΠΑΙΚΤΗΣ[22] με τον α/α κάθε παίκτη
οπότε ταξινομώ το σύνολο των ψήφων και συμπαρασύρω και την σειρά δηλ το α/α
π.χ.      1 -   2  -  3 - 4 - 5 - 6    η σειρά
           8 - 17 -  20- 2 - 4 - 10 οι ψήφοι θα γίνει μετά την ταξινόμηση

           3  -  2  -  6  -  1   -  5  -  4    ==>   ο 3ος, 2ος και 6ος
          20 - 17 -  10 κλπ


Πάντως και με 3 φορές max και thesimax είναι σωστό

vtsakan

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 273
  • printf("Smile");
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #3 στις: 23 Μάι 2011, 02:55:54 μμ »
Πολύ σωστά! Βιάστηκα!
Βασίλης Τσακανίκας
Ηλεκτρολόγος Μηχανικός και Μηχανικός Υπολογιστών Ε.Μ.Π.

dimpapadop

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 60
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #4 στις: 23 Μάι 2011, 02:57:09 μμ »
ipoulis, καλή δουλειά.

Νομίζω πως το Δ4 δεν λύνεται με ταξινόμηση, μιας και θέλει και τους αριθμούς των παιχτών. Θα το έλυνα με τρείς φορές εύρεση του max και μετά βάζοντας -1 στην αντίστοιχη θέση του πίνακα.

λύνεται με πίνακες όπως έκανε ο φίλος και χρησιμοποίησε έναν βοηθητικό πίνακα, όπου πρίν την ταξινόμηση του τοποθέτησε στις 22 θέσεις του, τους αα αριθμούς των υποψηφίων από 1-22.

μπράβο φίλε, καλή δουλειά!

μόνο που υπερβάλει λίγο στο χρόνο λύσης... χεχε   sum xronou /3 ή /4 είναι ρεαλιστικότερο.

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #5 στις: 23 Μάι 2011, 03:01:43 μμ »
Τις πληκτρολογούσα ταυτόχρονα.
Χειρόγραφο υποθέτω κάνα 40 λεπτο πάνω κάτω
Άρα για τους μαθητές ο χρόνος ήταν άνετος

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #6 στις: 23 Μάι 2011, 03:35:03 μμ »
Μια χαρά παίζει η ταξινόμηση, αφού δεν χρησιμοποίησες πίνακες στο 3ο θεμα (  >:D ) φτιάχνεις δύο νέους ο ένας με συνολικές ψήφους και ο άλλος με αύξοντα αριθμό και κάνεις ταξινόμηση με βάση τις ψήφους (ταξινόμηση παράλληλων)  :P

Γιάννης Σ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 146
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #7 στις: 23 Μάι 2011, 04:44:46 μμ »
Σωστός! Για το 3ο θέμα, που ρωτάς, δόθηκε διευκρίνιση στα παιδιά ότι υπάρχει τουλάχιστον ένας επιτυχών...

Γιάννης Σ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 146
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #8 στις: 23 Μάι 2011, 04:57:57 μμ »
Κοιτώντας καλύτερα...
1. Το Γ.Δ2 το έλυσες δύσκολα, καλύτερα με λογική μεταβλητή
2. Ο χρόνος που δίνεις είναι πολύ λίγος, 20 λεπτά για το 4ο θέμα; Τα παιδιά κάναν καμιά ώρα...

depy_f

  • Νέος
  • *
  • Μηνύματα: 3
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #9 στις: 23 Μάι 2011, 08:11:37 μμ »
Καλησπέρα ,

!ΔΕΙΤΕ ΜΙΑ ΛΥΣΗ ΓΙΑ ΤΟ Δ4 ΠΟΥ ΔΩΘΗΚΕ ΑΠΟ ΜΑΘΗΤΗ

!Ο ΠΙΝΑΚΑΣ SB[22] ΕΧΕΙ ΤΟ ΑΘΡΟΙΣΜΑ ΤΩΝ ΨΗΦΩΝ ΠΟΥ ΕΛΑΒΑΝ ΟΙ ΥΠΟΨΗΦΙΟΙ

Για Χ από 1 μέχρι 3
MAX<-  -1
   Για j από 1 μέχρι 22
      Αν SB[j]>MAX τότε
              Θεση<- j
         MAX <- SB[j]
      Τέλος_αν
Τέλος_επανάληψης
Eμφανισε Θεση, SB[Θεση]
SB[Θεση]<-  -2
Τέλος_επανάληψης

! ΑΠΛΑ ΣΩΣΤΟΤΑΤΗ
! ΚΑΙ ΤΗΝ ΠΑΡΑΘΕΤΩ ΔΙΟΤΙ ΚΑΤΑ ΤΗ ΒΑΘΜΟΛΟΓΗΣΗ ΘΑ ΔΟΥΜΕ ΠΟΛΛΕΣ ΠΑΡΑΛΛΑΓΕΣ

!ΜΠΡΑΒΟ ΣΤΟΝ ΜΑΘΗΤΗ

ge0_

  • Οπαδός
  • **
  • Μηνύματα: 11
    • tk0world.com
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #10 στις: 23 Μάι 2011, 08:28:13 μμ »
να ρωτισω...
εγω το Δ4 έλυσα έτσι.....
Για j από 1 μέχρι 22
 sum<--0
 Για i από 1 μέχρι 22
   sum<--sum + ΨΗΦΟΣ[i,j]
Τέλος_επαν
MAX[j]<--sum
ΑΡΙΘΜ[j]<--j
Tέλος_επαν
Τέλος_επαν

και μετα εκανα ταξινομηση σε αυτους τους 2...Σωστό...?

το 3ο θεμα λύνεται και με αρχή_επανάληψης ??

dimpapadop

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 60
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #11 στις: 23 Μάι 2011, 08:46:24 μμ »
να ρωτισω...
εγω το Δ4 έλυσα έτσι.....
Για j από 1 μέχρι 22
 sum<--0
 Για i από 1 μέχρι 22
   sum<--sum + ΨΗΦΟΣ[i,j]
Τέλος_επαν
MAX[j]<--sum
ΑΡΙΘΜ[j]<--j
Tέλος_επαν
Τέλος_επαν

και μετα εκανα ταξινομηση σε αυτους τους 2...Σωστό...?

το 3ο θεμα λύνεται και με αρχή_επανάληψης ??


και σωστό και καλό...
άντε καλά αποτελέσματα

υ.γ. το 3ο και ναι και όχι.... με Αρχή_επανάληψης χεχεχε δλδ μπορεί ο χειριστής να βαρέθηκε πρίν την ώρα του και να βάλει τον κύριο "ΤΕΛΟΣ", 1η τιμή στην εκτέλεση για να πάει για καφέ.... ;-)

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #12 στις: 23 Μάι 2011, 08:48:35 μμ »
Μπράβο! Πάντως σκέφτομαι πόσοι μαθητές έκανα σχήμα στο πρόχειρο

ge0_

  • Οπαδός
  • **
  • Μηνύματα: 11
    • tk0world.com
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #13 στις: 23 Μάι 2011, 09:10:24 μμ »
βασικα το 3ο θεμα το ελυσα με αρχη_επαναληψης αλλά μέσα στο βροχο για να αποφυγω τη "βαρεμαρα" του χειριστη όλη τη διαδικασια την έβαλα σε μια Αν ονομα<>"ΤΕΛΟΣ" τοτε

...και μετα όλα τα άλλα


???

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #14 στις: 23 Μάι 2011, 09:18:18 μμ »
Μα αυτή είναι η λύση  :D

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #15 στις: 23 Μάι 2011, 09:31:35 μμ »
βασικα το 3ο θεμα το ελυσα με αρχη_επαναληψης αλλά μέσα στο βροχο για να αποφυγω τη "βαρεμαρα" του χειριστη όλη τη διαδικασια την έβαλα σε μια Αν ονομα<>"ΤΕΛΟΣ" τοτε

...και μετα όλα τα άλλα


???

Σύμφωνα με το βιβλίο η τιμή φρουρός λύνεται με ΌΣΟ αλλά και με Μέχρις_ότου όπου μέσα
υπάρχει μια ΑΝ (Ακόμα και έξω) είναι μια χαρά
δηλ
Αρχή_επ
Διάβασε ΟΝ
Αν ΟΝ<>'ΤΕΛΟΣ' τότε
.......
Τέλος_αν
Μέχρις_ότου ΟΝ="ΤΕΛΟΣ"

ή

Διάβασε ΟΝ
Αν ΟΝ<>"ΤΕΛΟΣ" επ
Αρχή_επ
   ..........
   Διάβασε ΟΝ
Μέχρις_ότου ΟΝ="ΤΕΛΟΣ"
Τέλος_αν

ge0_

  • Οπαδός
  • **
  • Μηνύματα: 11
    • tk0world.com
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #16 στις: 23 Μάι 2011, 10:32:42 μμ »
μάλιστα δηλαδή προγραμματισμό να περιμένω πάνω από 19....yeah!!!
πάντως σχετικά τα βρήκα εύκολα...
αφού κοιταζα και ξανακοιταζα να δω μηπως έχω ξεχάσει κανα θέμα...
κι όλο να ξάχνω να βρω ερωτημα με υποπρογραμμα και να λέω δεν μπορεί να μην βάλανε καθόλου....αλλά τελος καλο όλα καλά

bill_m

  • veteran
  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: ΛΥΣΕΙΣ ΑΕΠΠ ΓΕΛ 2011
« Απάντηση #17 στις: 24 Μάι 2011, 11:11:27 μμ »
Τις πληκτρολογούσα ταυτόχρονα.
Χειρόγραφο υποθέτω κάνα 40 λεπτο πάνω κάτω
Άρα για τους μαθητές ο χρόνος ήταν άνετος

Εγω παιδια που εγραφα πηραμε τα θεματα 8:55 και 9:45 ειχα τελειώσει!!! Ηταν πολυ ανετα στο ζήτημα του χρονου [σσ. εκανα και πινακα τιμών στο 2ο που ηταν χρονοβόρο].