Αποστολέας Θέμα: Συχνότητες Σε Μονοδιάστατο Πίνακα  (Αναγνώστηκε 1049 φορές)

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Συχνότητες Σε Μονοδιάστατο Πίνακα
« στις: 22 Μάρ 2010, 11:13:54 μμ »
Καλησπέρα
χάζευα ένα διαγώνισμα με ένα θέμα συχνότητα εμφάνισης αριθμών
(το οποίο είναι αρκετά καλό ως θέμα - όχι στο διαγώνισμα)
και είδα κατι "ψιλοτραγικό"
Σε μέτρηση συχνότητα αριθμών ρουλέτα με 38 περιπτώσεις
'0' , '00' και 1 ως 36 είχε τη λύση
για 100 μετρήσεις

Για i από 1 μέχρι 100
Αρχή_Επανάληψης
Διάβασε x
Μέχρις_ότου x >= ‘0’ ή x <= ‘36’ ή x = ‘00’
Αν x = ‘0’ τότε
Π[37] <-- Π[37] + 1
Πράσινο <-- Πράσινο + 1
αλλιώς_αν x = ‘00’ τότε
Π[38] <-- Π[38] + 1
Πράσινο <-- Πράσινο + 1
αλλιώς
Π
  • <-- Π
  • + 1

...........
Αν x mod 2 = 0 τότε
Μαύρο <-- Μαύρο + 1
Τέλος_αν
Αν x mod 2 = 1 τότε
Κόκκινο <-- Κόκκινο + 1
Τέλος_αν
Τέλος_αν
Τέλος_Επανάληψης


Δηλαδή το χ μια συγκρίνεται με '0' (χαρακτήρα) και μια είναι δείκτης Πίνακα.
Ακόμα χειρότερο x mod 2
Αν και ωραία ιδέα η ρουλέτα οι 2 παραπάνω περιπτώσεις το έκαψαν.
Ίσως να θεωρούσε το '0' ότι θα εισάγονταν ως 0 και το '00' ως -1
και ας τα έβαζε 37 και 38 θέση
Κάτι γίνεται.