Αποστολέας Θέμα: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ  (Αναγνώστηκε 16095 φορές)

Yuris

  • Νέος
  • *
  • Μηνύματα: 5
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΜΕΤΑΤΡΟΠΗ_ΑΠΟ_ΔΕΚΑΔΙΚΟ_ΣΕ_ΔΥΑΔΙΚΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , Κ , Ξ , Τ , Ρ , ΜΑΧ , Δ[100] , Ψ[100]  , Μ , Π , Χ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ AKERAIO ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΜΕΤΑΤΡΑΠΕΙ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΥΣΤΗΜΑ ΣΤΟ ΔΥΑΔΙΚΟ'
  ΔΙΑΒΑΣΕ Τ
  ΟΣΟ Α_Μ(Τ) <> Τ ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΕΝ ΕΔΩΣΕΣ ΑΚΕΡΑΙΟ ΑΡΙΘΜΟ , ΤΟ ΠΡΟΓΡΑΜΜΑ ΔΕΝ ΜΠΟΡΕΙ ΝΑ ΕΚΤΕΛΕΣΘΕΙ , ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΕ'
    ΔΙΑΒΑΣΕ Τ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Χ <-- Τ
  Π <-- 0
  Ι <-- 0
  ΜΑΧ <-- 0                                                           
  ΟΣΟ Χ-Π<>0 ΚΑΙ Χ>0 ΕΠΑΝΑΛΑΒΕ
    Ι <-- Ι + 1
    Μ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Μ <-- Μ + 1
      Π <-- 2^Μ
    ΜΕΧΡΙΣ_ΟΤΟΥ Π>=Χ
    ΑΝ ΜΑΧ<Μ ΤΟΤΕ
      ΜΑΧ <-- Μ - 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Π>Χ ΤΟΤΕ
      Ψ[Ι] <-- Μ - 1
      Χ <-- Χ - 2^(Μ-1)
    ΑΛΛΙΩΣ_ΑΝ Χ=Π ΤΟΤΕ
      Ψ[Ι] <-- Μ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΜΑΧ MOD 7 = 0 ΤΟΤΕ
    Κ <-- ΜΑΧ DIV 8
  ΑΛΛΙΩΣ
    Κ <-- (ΜΑΧ DIV 7)+1
  ΤΕΛΟΣ_ΑΝ
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Κ*8
    Δ[Ξ] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Ι
    Ρ <-- Ψ[Ξ]
    Δ[Ρ+1] <-- 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ',Τ,'ΣΤΟ ΔΥΑΔΙΚΟ ΣΥΣΤΗΜΑ ΓΡΑΦΕΤΑΙ:'
  ΓΙΑ Ξ ΑΠΟ Κ*8 ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
    ΑΝ Ξ MOD 8 = 0 ΤΟΤΕ
      ΓΡΑΨΕ_ ''
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ_ Δ[Ξ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΕΚΤΕΣ ΟΛΕΣ ΟΙ ΠΑΡΑΤΗΡΗΣΕΙΣ ΚΑΙ ΟΙ ΔΙΟΡΘΩΣΕΙΣ  :)
« Τελευταία τροποποίηση: 31 Μάρ 2009, 10:56:19 πμ από Yuris »
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy." -
-- Martin Luther King Jr.

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Μία μόνο παρατήρηση. Ο Τ πραγματικός αλλιώς δεν έχει και νόημα ο έλεγχος που κάνεις. Δοκιμασέ το να δεις.
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

Yuris

  • Νέος
  • *
  • Μηνύματα: 5
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙ&#
« Απάντηση #2 στις: 31 Μάρ 2009, 10:52:22 πμ »
ΝΑΙ ,  :-[ :-[ :-[ , ΕΙΧΑ ΚΑΝΕΙ ΛΑΘΟΣ ΣΤΗΝ ΔΗΛΩΣΗ ΜΕΤΑΒΛΗΤΩΝ , ΕΠΡΕΠΕ ΚΑΙ Ο Χ ΝΑ ΕΙΝΑΙ ΑΚΕΡΑΙΟΣ, ΑΝ ΤΟ ΠΡΟΓΡΑΜΜΑ ΕΚΤΕΛΕΣΘΕΙ ΓΙΑ ΠΡΑΓΜΑΤΙΚΟ ΘΑ ΒΓΑΛΕΙ ΛΑΘΟΣ ΑΠΟΤΕΛΕΣΜΑΤΑ , ΤΣΕΚΑΡΕ ΤΟ ΑΝ ΘΕΣ . ΤΩΡΑ ΝΟΜΙΖΩ ΕΙΝΑΙ ΠΙΟ ΣΩΣΤΟ  :-\ :-\ :-\
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy." -
-- Martin Luther King Jr.

Cloud_Strife

  • Επισκέπτης
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #3 στις: 21 Απρ 2010, 01:22:45 μμ »
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΜΕΤΑΤΡΟΠΗ_ΑΠΟ_ΔΕΚΑΔΙΚΟ_ΣΕ_ΔΥΑΔΙΚΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , Κ , Ξ , Τ , Ρ , ΜΑΧ , Δ[100] , Ψ[100]  , Μ , Π , Χ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ AKERAIO ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΜΕΤΑΤΡΑΠΕΙ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΥΣΤΗΜΑ ΣΤΟ ΔΥΑΔΙΚΟ'
  ΔΙΑΒΑΣΕ Τ
  ΟΣΟ Α_Μ(Τ) <> Τ ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΕΝ ΕΔΩΣΕΣ ΑΚΕΡΑΙΟ ΑΡΙΘΜΟ , ΤΟ ΠΡΟΓΡΑΜΜΑ ΔΕΝ ΜΠΟΡΕΙ ΝΑ ΕΚΤΕΛΕΣΘΕΙ , ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΕ'
    ΔΙΑΒΑΣΕ Τ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Χ <-- Τ
  Π <-- 0
  Ι <-- 0
  ΜΑΧ <-- 0                                                           
  ΟΣΟ Χ-Π<>0 ΚΑΙ Χ>0 ΕΠΑΝΑΛΑΒΕ
    Ι <-- Ι + 1
    Μ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Μ <-- Μ + 1
      Π <-- 2^Μ
    ΜΕΧΡΙΣ_ΟΤΟΥ Π>=Χ
    ΑΝ ΜΑΧ<Μ ΤΟΤΕ
      ΜΑΧ <-- Μ - 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Π>Χ ΤΟΤΕ
      Ψ[Ι] <-- Μ - 1
      Χ <-- Χ - 2^(Μ-1)
    ΑΛΛΙΩΣ_ΑΝ Χ=Π ΤΟΤΕ
      Ψ[Ι] <-- Μ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΜΑΧ MOD 7 = 0 ΤΟΤΕ
    Κ <-- ΜΑΧ DIV 8
  ΑΛΛΙΩΣ
    Κ <-- (ΜΑΧ DIV 7)+1
  ΤΕΛΟΣ_ΑΝ
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Κ*8
    Δ[Ξ] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Ι
    Ρ <-- Ψ[Ξ]
    Δ[Ρ+1] <-- 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ',Τ,'ΣΤΟ ΔΥΑΔΙΚΟ ΣΥΣΤΗΜΑ ΓΡΑΦΕΤΑΙ:'
  ΓΙΑ Ξ ΑΠΟ Κ*8 ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
    ΑΝ Ξ MOD 8 = 0 ΤΟΤΕ
      ΓΡΑΨΕ_ ''
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ_ Δ[Ξ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΕΚΤΕΣ ΟΛΕΣ ΟΙ ΠΑΡΑΤΗΡΗΣΕΙΣ ΚΑΙ ΟΙ ΔΙΟΡΘΩΣΕΙΣ  :)
Σωστός. Δεν το είχα σκεφτεί. Αλήθεια η μετατροπή (έστω και σαν διαδικασία, όχι αλγόριθμος ή πρόγραμμα) αναφέρεται στο βιβλίο? Είναι προφανώς (έτσι πιστεύω) εκτός ύλης, αλλά ρωτάω μήπως έχει κάποια αναφορά σ' αυτό. Για δυαδικό με αριθμό θυμάμαι μόνο μια αναφορά στην ολίσθηση.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2457
  • I 'm not young enough to know everything
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #4 στις: 21 Απρ 2010, 02:22:52 μμ »
Να σου θέσω ένα προβληματισμό:

Πες πως έχεις ένα αριθμό στο δεκαδικό σύστημα αρίθμησης και θέλεις να βρεις τα ψηφία του. Τι θα κάνεις; Θα παίξεις με div/mod και θα τα βρεις. Υποθέτω πως έχεις δει την άσκηση.

Φαντάσου τώρα ότι έχεις ένα αριθμό στο δυαδικό σύστημα αρίθμησης και θέλεις να βρεις τα ψηφία του στο δυαδικό. Εδώ το 2 γράφεται 10. Σε τι διαφέρει από το προηγούμενο πρόβλημα; Σε τίποτα. Ούτε καν που θα καταλάβεις ότι είσαι στο δυαδικό.

Αλλά το αποτέλεσμα μια διαίρεσης (εννοώ το πηλίκο και το υπόλοιπο) σαν αξία είναι το ίδιο και δεν εξαρτάται από το σύστημα αρίθμησης. Είτε διαιρέτης και διαιρετέος είναι γραμμένοι στο δυαδικό είτε στο δεκαδικό το div και το mod θα είναι ο ίδιο σαν αξία (απλά θα είναι γραμμένο σε άλλο σύστημα αρίθμησης).

Άρα το να βρεις τα ψηφία στο δυαδικό ενός αριθμού που είναι γραμμένος στο δεκαδικό, είναι σαν να βρίσκεις τα δεκαδικά του ψηφία με μόνη αλλαγή το ότι διαιρείς με 2 αντί για 10.

Στο διδακτικό πακέτο ότι πιο σχετικό με το θέμα έχω δει είναι στο τετράδιο μαθητή κεφάλαιο 9 ΔΣ4.

poursali

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 920
    • Στέφανος-Κων/νος Πουρσαλίδης
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #5 στις: 21 Απρ 2010, 04:05:11 μμ »
οταν παμε απο μια βαση β1 σε βαση β2 και
β1 > β2, τοτε διαιρουμε με β2 (οπως πχ απο δεκαδικο σε δυαδικο)

ενω αν β1 < β2, τοτε πολλαπλασιαζουμε απλα με αυξανομενες δυναμεις του β1 τα ψηφια του αριθμου οπως απο δυαδικο σε δεκαδικο
μετρον αριστον
είμαι τζαμπατζής, χρησιμοποιώ λίνουξ

Yuris

  • Νέος
  • *
  • Μηνύματα: 5
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #6 στις: 21 Απρ 2010, 07:31:28 μμ »
Καλησπέρα αγαπητοί "όχι συνάδελφοι ακόμη". Αυτό το πρόγραμμα το είχα δημοσιεύσει πέρυσι σε αυτό το forum απλά για να δείξω σε άλλους μαθητές έναν άλλο τρόπο σκέψης σε ένα πρόβλημα . Σαφώς και αναγνωρίζω πως δεν είναι καθόλου αποδοτική - πόσο μάλλον κατανοητή - υλοποίηση και την έκανα καθαρά και μόνο για πειραματισμό.
Δεν θυμάμαι αν το βιβλίο παρουσιάζει κάποιον τρόπο-αλγόριθμο για να κάνεις αυτή την μετατροπή, αλλά σίγουρα το παιχνίδι με τα div/mod είναι πιο καλό και αποδοτικό.
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy." -
-- Martin Luther King Jr.

poursali

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 920
    • Στέφανος-Κων/νος Πουρσαλίδης
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #7 στις: 21 Απρ 2010, 10:21:20 μμ »
α, καλα δεν ειχα προσεξει οτι ειναι τοσο παλιο θεμα... χεχε

μου θυμισε την τελευταια προταση σε αυτο -->> http://www.insomnia.gr/forum/showthread.php?p=3229346#post3229346

ΥΓ: εκανα κοπο να το ξαναβρω
μετρον αριστον
είμαι τζαμπατζής, χρησιμοποιώ λίνουξ

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1057
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #8 στις: 21 Απρ 2010, 10:44:47 μμ »
Τετράδιο Μαθητή
Κεφ. 9 σελ. 96  * *  ΔΣ4
! Βλέπε "Εφαρμογές Πληροφορικής" Α΄ Λυκείου  Κεφ. 2 σελ.50-52 και ΟΧΙ ατέρμονο και παλινδρομικό fb ....
  θ <- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    θ <- θ + 1
    ψ[θ] <- d MOD b
    d <- d DIV b
  ΜΕΧΡΙΣ_ΟΤΟΥ d = 0

όπου  d   θετικός ακέραιος του δεκαδικού συστήματος, ο οποίος
μετατρέπεται σε σύστημα αρίθμησης με βάση b.

Τα της εμφάνισης , αφήνονται στο μαθητή.

Υ.Γ.  Προς πάσαν επιτροπήν .

 Αυτές τις ασκήσεις γιατί τις 'ξεχνάτε' ή αν θέλετε 'προσπερνάτε' ;

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2457
  • I 'm not young enough to know everything
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #9 στις: 21 Απρ 2010, 11:15:41 μμ »
Νομίζω ότι δεν έχει να κάνει με το μεγαλύτερο και το μικρότερο αλλά με το αν αναλύεις τον αριθμό σε ψηφία ή  συνθέτεις τον αριθμό απο τα ψηφία.

Κατά τη δική μου κατανόηση, αν έχουμε αριθμό (δηλαδή αξία σε κάποιο οποιοδήποτε σύστημα αρίθμησης) και θέλουμε τα ψηφία σε κάποιο (ενδεχομένως και άλλο σύστημα) κάνουμε διαιρέσεις (div/mod) με τη νέα βάση για διαιρέτη. Πχ αν έχεις αριθμό στο δεκαδικό και θέλεις τα ψηφία στο δεκαεξάρικο θα κάνεις διαιρέσεις με 16. Θα γίνει λίγο κουλουβάχατα γιατί το σύστημα που είναι ριζωμένο στον εγκέφαλο μας είναι τα δεκαδικό. Δε σου έρχεται εύκολο να πεις το 16 στο 250 χωράει F (=15) φόρες. Σκέψου ότι θα πρέπει να ξέρεις την προπαίδεια μέχρι το F και να τη χρησιμοποιείς αυθόρμητα όταν κάνεις διαιρέσεις.

Αντίθετα όταν έχεις τα ψηφία σε κάποιο σύστημα και θέλεις να βρεις την αξία του αριθμού  πολλαπλασιάζεις τα ψηφία με τις διαδοχικές δυνάμεις της βάσης και προσθέτεις.

Για να δεις τι γίνεται νομίζω ότι πρέπει να δουλέψεις αφαιρετικά χωρίς να έχεις στο νου σου κάποιο σύστημα αρίθμησης. Αν ψ0, ψ1, ψ2 κλπ τα ψηφία κάποιου αριθμού στο b-άδικο σύστημα τότε η ψηφία του είναι ψ0*b^0 + ψ1*b^1  + ψ2*b^2 +…
Τα ακριβή ψηφία εξαρτώνται από το συγκεκριμένο σύστημα αρίθμησης που χρησιμοποιούμε. Δες ότι αν την άξια την κάνεις mod b τότε και εφαρμόσεις επιμεριστική ιδιότητα στους όρους τότε ο πρώτος θα δώσει το ψ0 ενώ οι άλλοι διαιρούνται ακριβώς. Το div b δίνει ψ1*b^0  + ψ2*b^1 +… δηλαδή τα υπόλοιπα ψηφιά πολλαπλασιασμένα με μια δύναμη παρακάτω. Όποτε συνεχίζεται η διαδικασία και παίρνουμε ένα ένα τα ψηφία ανάποδα.

poursali

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 920
    • Στέφανος-Κων/νος Πουρσαλίδης
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #10 στις: 21 Απρ 2010, 11:24:25 μμ »
συμφωνουμε κατα βαση. παιζει ρολο και τι δυνατοτητες σου δινει η εκαστοτε γλωσσα που θα υλοποιησεις την μετατροπη - τι δυνατοτητες σου δινει.
αλλα αλγοριθμικα ολα αυτα δουλευουν
μετρον αριστον
είμαι τζαμπατζής, χρησιμοποιώ λίνουξ

dimat

  • Νέος
  • *
  • Μηνύματα: 1
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #11 στις: 04 Ιαν 2011, 10:06:04 πμ »
Πρόγραμμα για μετατροπή ενός ακεραίου από το δεκαδικό στο δυαδικό

Διερμηνευτής της ΓΛΩΣΣΑΣ:

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Μετατροπή_Από_Δεκαδικό_Στο_Δυαδικό

ΣΤΑΘΕΡΕΣ
  βάση = 2

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αριθμός, πλήθος_ψηφίων, ι, χ[100], υπόλοιπο

ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε ακέραιο αριθμό για μετατροπή από το δεκαδικό στο δυαδικό:'
  ΔΙΑΒΑΣΕ αριθμός
  πλήθος_ψηφίων <- 0

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    υπόλοιπο <- αριθμός MOD βάση
    πλήθος_ψηφίων <- πλήθος_ψηφίων + 1
    χ[πλήθος_ψηφίων] <- υπόλοιπο
    αριθμός <- αριθμός DIV βάση
  ΜΕΧΡΙΣ_ΟΤΟΥ αριθμός = 0
 
  ΓΡΑΨΕ 'Η δυαδική αναπαράσταση του αριθμού είναι:  '
  ΓΙΑ ι ΑΠΟ πλήθος_ψηφίων ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -1
    ΓΡΑΨΕ χ[ι], ' '
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Γλωσσομάθεια:

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Μετατροπή_Από_Δεκαδικό_Στο_Δυαδικό

ΣΤΑΘΕΡΕΣ
  βάση = 2

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αριθμός, πλήθος_ψηφίων, ι, χ[100], υπόλοιπο

ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε ακέραιο αριθμό για μετατροπή από το δεκαδικό στο δυαδικό:'
  ΔΙΑΒΑΣΕ αριθμός
  πλήθος_ψηφίων <-- 0

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    υπόλοιπο <-- αριθμός MOD βάση
    πλήθος_ψηφίων <-- πλήθος_ψηφίων + 1
    χ[πλήθος_ψηφίων] <-- υπόλοιπο
    αριθμός <-- αριθμός DIV βάση
  ΜΕΧΡΙΣ_ΟΤΟΥ αριθμός = 0

  ΓΡΑΨΕ 'Η δυαδική αναπαράσταση του αριθμού είναι:  '
  ΓΙΑ ι ΑΠΟ πλήθος_ψηφίων ΜΕΧΡΙ 1  ΜΕ ΒΗΜΑ -1
    ΓΡΑΨΕ_ χ[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

« Τελευταία τροποποίηση: 04 Ιαν 2011, 10:21:38 πμ από dimat »

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #12 στις: 04 Ιαν 2011, 11:50:33 πμ »
Γιατί δύο ξεχωριστοί κώδικες για ΔτΓ και ΓλσΜθ ?  Το έιδα βιαστικά ή υπάρχουν διαφορές ;
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #13 στις: 04 Ιαν 2011, 11:51:00 πμ »
Καμιά ιδέα για λύση χωρίς πίνακες ;;
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

lykos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 143
  • Καλύτερα ταξιδάκια, παρά project
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #14 στις: 04 Ιαν 2011, 08:31:24 μμ »
Καλή Χρονιά σ' όλους!!!!!!
Παράθεση
Καμιά ιδέα για λύση χωρίς πίνακες ;;
Στέργιο, καλή η ιδέα σου (παρεπιπτόντως: Χαθήκαμε!...). Ο παρακάτω αλγόριθμος δουλεύει μιά χαρά:
Κώδικας: [Επιλογή]
Αλγόριθμος δε2δυ
Διάβασε α10
a2<- 0
Dyn<- 0
Οσο a10>0 Επανάλαβε
  Flag<- α10 MOD 2
  α10<- α10 DIV 2
  Αν Flag=1 Τότε
    α2<- α2+10^Dyn
  Τέλος_Αν
  Dyn<- Dyn+1
Τέλος_Επανάληψης
Γράψε α2
Τέλος δε2δυ
Βασίλης Λυκοστράτης

(Για να μην παρεξηγηθώ: Φυσικά και δεν μετατρέπει τον δεκαδικό σε δυαδικό, αλλά εμφανίζει αυτό που θέλουμε!)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: ΜΕΤΑΤΡΟΠΗ ΕΝΟΣ ΑΡΙΘΜΟΥ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΤΟ ΔΥΑΔΙΚΟ
« Απάντηση #15 στις: 04 Ιαν 2011, 09:07:04 μμ »
ακριβώς  :)
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)