Αποστολέας Θέμα: Παράδειγμα με αραιούς πίνακες σελ 32  (Αναγνώστηκε 2578 φορές)

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Παράδειγμα με αραιούς πίνακες σελ 32
« στις: 19 Φεβ 2009, 02:04:53 πμ »
Καλησπέρα σε όλους,οι βραδινές ανησυχίες για εμάς τους καινούργιους συνεχίζονται.... :'(
Στο παράδειγμα 5 του τετραδίου του μαθητή σελ 32 γιατί τα κάνει όλα αυτά;Δε θέλει κάτι τέτοιο(να γίνει η μετατροπή;)Εκτός και αν έχω καταλάβει κάτι άλλο!
κ<--1
Για I απο 1 μεχρι Μ
Για J απο 1 μεχρι Ν
  Αν Α[I,J]<>0 τοτε
      Β[κ]<--I
      Β[κ+1]<--J
      Β[κ+2]<--A[I,J]
      k<--k+3
Τέλος_επανάληψης
Τέλος_επανάληψης



Καλή δύναμη σε όλους

« Τελευταία τροποποίηση: 19 Φεβ 2009, 02:27:03 πμ από tina28 »

papet

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 48
    • Σεληνιακό Πάρκο - Σκέψεις και Ημέρες
Απ: Παράδειγμα με αραιούς πίνακες σελ 32
« Απάντηση #1 στις: 19 Φεβ 2009, 05:10:35 πμ »
tina28, το τμήμα του αλγορίθμου που παραθέτεις μετατρέπει έναν αραιό διαδιάστατο πίνακα σε μονοδιάστατο. Το παράδειγμα του τετραδίου κάνει την "αντίθετη" δουλειά. Ψάχνει στο μονοδιάστατο πίνακα για ένα στοιχείο, σύμφωνα με τη θέση που θα είχε το στοιχείο αυτό αν βρισκόταν στο διασδιάστατο...
May the Force b with u...
papet

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Απ: Παράδειγμα με αραιούς πίνακες σελ 32
« Απάντηση #2 στις: 19 Φεβ 2009, 01:24:38 μμ »
ευχαριστώ, δε διάβασα τις 3 τελευταίες γραμμές....το διδάσκεις το συγκεκριμένο κομμάτι;

papet

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 48
    • Σεληνιακό Πάρκο - Σκέψεις και Ημέρες
Απ: Παράδειγμα με αραιούς πίνακες σελ 32
« Απάντηση #3 στις: 20 Φεβ 2009, 02:49:48 πμ »
Συνήθως το αναφέρω, αλλά δεν επιμένω... εκτός αν εκδηλώσουν οι μαθητές την επιθυμία (σπάνιο) ή είναι στιγμή που θέλω να τους "ξυπνήσω" τη σκέψη με κάτι πέρα από τα τετριμμένα...
Η αλήθεια βέβαια είναι πως δεν ξέρω τι κάνουν οι περισσότεροι συνάδελφοι με αυτό το κομμάτι, οπότε η στάση μου ενδέχεται να μην είναι η ορθότερη...
May the Force b with u...
papet