Αποστολέας Θέμα: ΤΑΞΙΝΟΜΗΣΗ ΣΕ ΠΑΡΑΛΛΗΛΟΥΣ ΠΙΝΑΚΕΣ  (Αναγνώστηκε 3781 φορές)

Nikos

  • Νέος
  • *
  • Μηνύματα: 6
  • Γράψτε το προσωπικό σας σλόγκαν!
ΤΑΞΙΝΟΜΗΣΗ ΣΕ ΠΑΡΑΛΛΗΛΟΥΣ ΠΙΝΑΚΕΣ
« στις: 31 Μάρ 2008, 08:17:13 μμ »
ΣΤΗ ΠΕΡΙΠΤΩΣΗ ΠΟΥ ΕΧΟΥΜΕ Π.Χ ΕΝΑ ΠΙΝΑΚΑ ΟΝΟΜΑΤΩΝ ΟΝΟΜ[100] ΕΝΑΝ ΠΙΝΑΚΑ ΒΑΘΜΩΝ ΒΑΘ[100,5] ΚΑΙ ΕΝΑΝ ΠΙΝΑΚΑ ΜΕΣΩΝ ΟΡΩΝ ΜΟ[100] ΚΑΙ ΖΗΤΗΘΕΙ ΝΑ ΕΜΦΑΝΙΣΤΟΎΝ ΟΙ ΜΑΘΗΤΕΣ ΜΕ ΣΕΙΡΆ ΒΑΘΜΟΛΟΓΙΑΣ. ΠΡΩΤΟΣ ΑΥΤΟΣ ΜΕ ΜΕΓΑΛΥΤΕΡΟ ΜΕΣΟ ΟΡΟ Κ.Λ.Π. ΠΡΟΦΑΝΩΣ ΤΑΞΙΝΟΜΟΥΜΕ ΤΟΝ ΠΊΝΑΚΑ ΜΟ[] ΜΕ ΠΑΡΑΛΛΗΛΗ ΑΝΤΜΕΤʼΘΕΣΗ ΤΟΥ ΠΙΝΑΚΑ ΟΝΟΜ[]. ΤΟ ΕΡΩΤΗΜΑ ΠΟΥ ΘΕΤΩ ΕΙΝΑΙ ΟΤΙ ΛΟΓΙΚΑ ΘΑ ΠΡΕΠΕΙ ΝΑ ΓΊΝΟΥΝ ΟΙ ΑΝΤΙΜΕΤΑΘΕΣΕΙΣ ΚΑΙ ΤΩΝ ΑΝΤΊΣΤΟΙΧΩΝ ΓΡΑΜΜΩΝ ΤΟΥ ΠΊΝΑΚΑ ΒΑΘ[] ΏΣΤΕ ΝΑ ΜΗΝ ΧΑΘΕΊ Η ΑΝΤΙΣΤΟΙΧΕΙΑ ΤΩΝ ΔΕΔΕΟΜΕΝΩΝ. ΔΕΔΟΜΕΝΟΥ ΟΤΙ  ΑΥΤΟ ΔΕΝ ΧΡΕΙΑΖΕΤΑΙ ΓΙΑ ΤΟ ΣΥΓΚΕΚΡΙΜΕΝΟ ΕΡΩΤΗΜΑ, ΠΡΕΠΕΙ ΝΑ ΓΙΝΕΙ Η ΟΧΙ.

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: ΤΑΞΙΝΟΜΗΣΗ ΣΕ ΠΑΡΑΛΛΗΛΟΥΣ ΠΙΝΑΚΕΣ
« Απάντηση #1 στις: 31 Μάρ 2008, 08:49:03 μμ »
οχι δεν χρειάζεται, αφού η ταξινόμηση σου λέει η άσκηση να γίνει στους ΜΟ και στα ονόματα. Πάντως αν ήθελες να αλλάζεις κάθε φορά και όλες τις βαθμολογίες τότε θα έπρεπε να συμπεριλάβεις:

Για περ απο 2 μέχρι Ν
Για ι απο Ν μέχρι περ με_βήμα -1
Αν ΜΟ [ ι ] > ΜΟ [ι-1] τότε

Αντιμετάθεσε Ον[ ι ], Ον[ ι-1 ]
Αντιμετάθεσε ΜΟ[ ι ], ΜΟ[ ι-1 ]
     Για j από 1 μέχρι Μ
       Αντιμετάθεσε Βαθ[ ι, j ], Βαθ[ ι-1,j ]
     τέλος_επανάληψης
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης

Δε νομίζω όμως ότι θα ζητηθεί κάτι τέτοιο. Ξεφεύγει ίσως.   
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: ΤΑΞΙΝΟΜΗΣΗ ΣΕ ΠΑΡΑΛΛΗΛΟΥΣ ΠΙΝΑΚΕΣ
« Απάντηση #2 στις: 01 Απρ 2008, 12:22:06 μμ »
Κάτι τέτοιο θα χρειαστεί μόνο αν υπάρχουν επόμενα ερωτήματα που χρειάζονται την αντιστοιχία των ονομάτων με τις γραμμές του δισδιάστατου, κάτι που η ταξινόμηση το αλλάζει
Πάντως, και τέτοια ερωτήματα να υπάρχουν, η συμβουλή που δίνω εγώ στους μαθητές μου είναι να αφήσουν το ερώτημα αυτό τελευταίο, βάζοντας σχόλια σε όλα τα κομμάτια του προγράμματος αναφέροντας τι επιλύουν σε καθένα από αυτά
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: ΤΑΞΙΝΟΜΗΣΗ ΣΕ ΠΑΡΑΛΛΗΛΟΥΣ ΠΙΝΑΚΕΣ
« Απάντηση #3 στις: 03 Απρ 2008, 09:24:39 πμ »
Σωστά, αν και το θεωρώ ιδιαίτερο παρατραβηγμένο
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Απ: ΤΑΞΙΝΟΜΗΣΗ ΣΕ ΠΑΡΑΛΛΗΛΟΥΣ ΠΙΝΑΚΕΣ
« Απάντηση #4 στις: 26 Μάι 2008, 10:48:04 μμ »
Δεν το θεωρώ πλεον πολύ τραβηγμένο.
Πάντως μια προσέγγιση (αν υπάρχουν επόμενα ερωτήματα)
να αντιγράψεις τους 2 μονοδ σε 2 νέους (π.χ. ΟΝ2 και ΜΟ2)
να τους ταξινομήσεις όπως θες και στα επόμενα
υποτιθέμενα ερωτήματα να ξαναασχοληθείς με τους "απέιραχτους"
πίνακες ΟΝΟΜ και ΜΟ.

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: ΤΑΞΙΝΟΜΗΣΗ ΣΕ ΠΑΡΑΛΛΗΛΟΥΣ ΠΙΝΑΚΕΣ
« Απάντηση #5 στις: 27 Μάι 2008, 01:53:28 μμ »
Και αυτό γίνεται
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19