Αποστολέας Θέμα: Επαναληπτικό Κεφάλαια 1ο & 2ο  (Αναγνώστηκε 5231 φορές)

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Επαναληπτικό Κεφάλαια 1ο & 2ο
« στις: 06 Δεκ 2007, 12:42:41 πμ »
Το επαναληπτικό διαγώνισμα για τη χρονιά 2007-2008 στα κεφάλαια  1 και 2 από το στέκι των πληροφορικών.

Με  νέο   format.

Ανδρέας
« Τελευταία τροποποίηση: 09 Δεκ 2007, 09:34:16 πμ από andreas_p »

Giounis22

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Επαναληπτικό Κεφάλαια 1ο & 2ο
« Απάντηση #1 στις: 06 Ιαν 2009, 02:03:10 πμ »
lisis den iparxoun
tha ithela poli na mou apantisi euxaristo

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1511
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Επαναληπτικό Κεφάλαια 1ο & 2ο
« Απάντηση #2 στις: 06 Ιαν 2009, 07:56:05 μμ »
Αν περιμένεις κανα μήνα ίσως δημοσιευτούν οι λύσεις ... ;)
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

Giounis22

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Επαναληπτικό Κεφάλαια 1ο & 2ο
« Απάντηση #3 στις: 07 Ιαν 2009, 04:47:45 μμ »
kala toso poli ke tis xriazome euxaristo.

lykos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 143
  • Καλύτερα ταξιδάκια, παρά project
Απ: Επαναληπτικό Κεφάλαια 1ο & 2ο
« Απάντηση #4 στις: 07 Ιαν 2009, 07:35:59 μμ »
Ρε παιδιά, τι λύσεις και ιστορίες λέτε?
Το διαγώνισμα το δημοσίευσε πρόπερσι ο συνάδελφος... « Τελευταία τροποποίηση: 09 Δεκ 2007, 09:34:16 πμ από andreas_p »

Αν ήταν να δημοσιεύσει λύσεις σ' ένα μήνα, θάγραφε - πρόπερσι - "οι λύσεις σε 14 μήνες"  (δεν ξέρω και ποιο smiley συμβολίζει "καλαμπούρι"...)



Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1511
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Επαναληπτικό Κεφάλαια 1ο & 2ο
« Απάντηση #5 στις: 07 Ιαν 2009, 08:30:57 μμ »
Οπς ζητώ συγγνώμη
νόμιζα ότι αφορά το νέο διαγώνισμα 2008-2009 στο 1ο και 2ο κεφάλαια.
Λύσεις για διαγωνίσματα παλαιότερων ετών δεν έχουν δοθεί απο το στέκι εκτός αν κάποιος συνάδελφος έχει λύσει τα θέματα και τα προωθήσει.

Συγγνώμη και πάλι
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

Teoubas

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Επαναληπτικό Κεφάλαια 1ο & 2ο
« Απάντηση #6 στις: 04 Νοέ 2009, 10:09:12 μμ »
Κάλλιω αργά παρά ποτε;p Εδώ βρίσκεται η λύση του προβλήματος με το ζάχαρο και την πίεση.

Κώδικας: [Επιλογή]
Αλγόριθμος Υγεία
   Διάβασε ζάχαρη,πίεση
   ! Έλεγχος Ζάχαρης...
   Αν ζάχαρη < 60 ή ζάχαρη > 120 τότε
στάδιο_ζαχ ←  3
    Αλλιώς_αν (ζάχαρη >= 60 και ζάχαρη < 70) ή (ζάχαρη >= 110 και ζάχαρη <= 120) τότε
στάδιο_ζαχ ← 2
    αλλιώς
στάδιο_ζαχ ← 1
    τέλος_αν
    ! Έλεγχος Πίεσης
    Αν πίεση < 8 ή  πίεση > 14 τότε
στάδιο_πιεσ ← 3
    αλλιώς_αν (πίεση >= 8 και πίεση < 10) ή (πίεση >= 12 και πίεση <= 14) τότε
στάδιο_πιεσ ← 2
    αλλιώς
στάδιο_πιεσ ← 1
    τέλος_αν
    ! Get worst...
     Αν στάδιο_ζαχ > στάδιο_πιεσ τότε
χειρότερο ←  στάδιο_ζαχ
    αλλιώς
χειρότερο ←  στάδιο_πιεσ
    τέλος_αν
    ! Show results
    Αν χειρότερο = 1 τότε
Εμφάνισε "Οι εξετάσεις είναι φυσιολογικές"
    αλλιώς_αν χειρότερο = 2 τότε
Εμφάνισε "Οι εξετάσεις είναι λίγο έξω από τα όρια"
    αλλιώς
Εμφάνισε "Πρέπει να επισκεφθείτε το γιατρό"
    τέλος_αν
Τέλος Υγεία

Υ.Γ Πολύ καλό πρόβλημα για να κτλβεις την δομή επιλογής...