Αποστολέας Θέμα: Τρόπος υπολογισμού γιά μέγιστο σε δισδιάστατο πίνακα  (Αναγνώστηκε 3556 φορές)

miekb

  • Νέος
  • *
  • Μηνύματα: 4
Ένας μαθητής μου έγραψε τον παρακάτω αλγόριθμο για να βρεί το μέγιστο στοιχείο ενός δισδιάστατου πίνακα διαστάσεων 5x8, καθώς και τη γραμμή και τη στήλη στην οποία βρίσκεται το στοιχείο αυτό.

max_γραμμη <-1
max_στήλη<-1
Για ι από 1 μέχρι 5
  Για j από 1 μέχρι 8
     Αν Π[ι, j]>Π[ max_γραμμη, max_στήλη] τότε
         max_γραμμη<-ι
         max_στήλη<-j
     Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
Εμφάνισε Π[ max_γραμμη, max_στήλη], max_γραμμη, max_στήλη

Η λύση που εμφανίζεται είναι σωστή, θα υπάρξει πρόβλημα λέτε στις Πανελλαδικές αν δοθεί μια τέτοια λύση?
Ευχαριστώ

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1429
  • There are always possibilities...
Απ: Τρόπος υπολογισμού γιά μέγιστο σε δισδιάστατο πίνακα
« Απάντηση #1 στις: 21 Νοέ 2007, 10:25:16 μμ »
Γιατί να υπάρξει πρόβλημα; Μια χαρά φαίνεται.
Programs must be written for people to read, and only incidentally for machines to execute - Harold Abelson

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2457
  • I 'm not young enough to know everything
Απ: Τρόπος υπολογισμού γιά μέγιστο σε δισδιάστατο πίνακα
« Απάντηση #2 στις: 22 Νοέ 2007, 11:34:45 πμ »
Δεν μπορώ να μην ρωτήσω:
Πίνακες 2 διαστάσεων από τις 21/11;  ??? Καλύφθηκαν οι εντολές επανάληψης; Εγώ είμαι στις εντολές επανάληψης ακόμα και θέλω ψωμί για να πω ότι τους έκανα να καταλάβουν.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Τρόπος υπολογισμού γιά μέγιστο σε δισδιάστατο πίνακα
« Απάντηση #3 στις: 22 Νοέ 2007, 04:19:12 μμ »
Είναι πολύ σωστό. Κρατάμε κατά τη διαδικασία, μόνο τις θέσεις του υποτιθέμενου μεγίστου και όχι το ίδιο..

Δεν θα υπάρξει κάποιο πρόβλημα στη διόρθωση των εξετάσεων. (Η μήπως θα υπάρξει;)

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Τρόπος υπολογισμού γιά μέγιστο σε δισδιάστατο πίνακα
« Απάντηση #4 στις: 26 Απρ 2012, 09:28:12 μμ »
Πάντως, καλό είναι να πεις σε αυτόν τον μαθητή, να βάζει εσωτερικά σχόλια στον αλγόριθμο, για να αποφύγει την περίπτωση που κάποιος βαθμολογητής δεν καταλάβει το σκεπτικό του.
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com