Αποστολέας Θέμα: Λάθος θέμα στις εξετάσεις ;;  (Αναγνώστηκε 9412 φορές)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Λάθος θέμα στις εξετάσεις ;;
« στις: 20 Ιαν 2011, 04:31:10 μμ »
2006, Εσπερινά, επαναληπτικές:

Δεν μπορεί να χρησιμοποιηθεί η ίδια μεταβλητή ως μετρητής δύο ή περισσότερων βρόχων που ο ένας βρίσκεται στο εσωτερικό του άλλου.

Το θεωρώ λάθος. Το έχω δει σε πηγές απαντημένο ως Σωστό. Θεωρώ ότι είναι σωστό ΜΟΝΟ για την περίπτωση της ΓΙΑ και όχι ΚΑΘΕ βρόχου.

Χάνω κάτι ;
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2384
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #1 στις: 20 Ιαν 2011, 05:04:30 μμ »
Είναι κλασική (λάθος) φράση που ζητάνε να έχεις παπαγαλίσει από το βιβλίο
Κάθε χρόνο βάζουν κάτι που να έχεις μάθει τυφλά από το βιβλίο
Απλά, εκείνη την χρονιά διάλεξαν κάτι που είναι λάθος διατυπωμένο
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #2 στις: 20 Ιαν 2011, 05:18:06 μμ »
Στο βιβλίο δε νομίζω ότι είναι λάθος διατυπωμένο.. Περισσότερο θα το χαρακτήριζα αβλεψία της επιτροπής, γιατί στο βιβλίο, η συγκεκριμένη φράση βρίσκεται στην παράγραφο 8.2.3 Εντολή ΓΙΑ ...ΑΠΟ...ΜΕΧΡΙ  (σελ.180)

Βέβαια οι πρώτοι 2 κανόνες που αναφέρονται στην ίδια παράγραφο αφορούν σε όλους τους βρόχους  >:D
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3325
    • P.Tsiotakis
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #3 στις: 20 Ιαν 2011, 06:10:57 μμ »
άλλαξε η γεώτρηση υδροδότησης της Λάρισας αδερφέ;

μόνο με μαγικό ζωμό θα άνοιγες τόσα νέα θέματα σε τόσο λίγο χρόνο!

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #4 στις: 20 Ιαν 2011, 06:41:26 μμ »
Μου ξύπνησε μία .. νοσταλγία ξαφνικά.   Αναπόλησα τις εποχές που γράφαμε 10 μηνύματα τη μέρα.  Ωραίες εποχές φίλε μου. 

Τώρα όμως ζούμε πιό ωραίες!! Ούτε στα πιό τρελλά όνειρά μας δε θα ελπίζαμε από 20,000 επισκέψεις τότε, να βρεθούμε τόσο κοντά στα 5,000,000 τώρα, ούτε να συγκεντρωθούν τόσα πολλά και τόσο αξιόλογα και δραστήρια νέα μέλη.  Το Στέκι μας απέκτησε τρελλή αναγνώριση και υπέροχη ζωντάνια. 

Για λόγους που λίγο πολύ γνωρίζεις, εγώ απήχα αισθητά τα τελευταία χρόνια.. τώρα όμως μου βγήκε το .. come-back !! Περιμένω όμως και το δικό σου ;) 
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3325
    • P.Tsiotakis
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #5 στις: 21 Ιαν 2011, 09:01:21 πμ »
είναι προφανώς ατόφια θεωρία, αναφέρεται ακριβώς έτσι στο βιβλίο και όπως (με πρόλαβες) επισημαίνεις δεν αφορά μόνο στη δομή Για.

Όμως, να ρωτήσω κάτι... Όταν αναπτύσσεις εμφωλευμένους βρόχους, πόσο συχνό είναι να χρησιμοποιείς την ίδια μεταβλητή ελέγχου και για τις δυο. και αν συμβαίνει κάποιες φορές, πόσες από αυτές είναι σωστό;

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #6 στις: 21 Ιαν 2011, 09:42:05 πμ »
Η πιο συχνή περίπτωση είναι να χρησιμοποιείς τιμή φρουρό και στο εσωτερικό να κάνεις έλεγχο εγκυρότητας της μεταβλητής της συνθήκης. Τώρα όσον αφορά της πρόταση αυτή, είναι σωστή για όλες τις δομές επανάληψης. Αν χρησιμοποιείς για παράδειγμα την δομή όσο και την μεταβλητή της συνθήκης την χρησιμοποιείς ως μετρητή των επαμαλήψεών της, δεν μπορείς να έχεις και μία εμφωλευμένη επανάληψη η οποία να χρησιμοποιεί αυτή τη μεταβλητή ως μετρητή των επαναλήψεών της.

Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #7 στις: 21 Ιαν 2011, 09:55:36 πμ »
Προσπάθησα να φτιάξω τρία σχετικά τμήματα αλγόριθμου τα οποία παραθέτω
Κώδικας: [Επιλογή]
Για i από 1 μέχρι 3
i ← -2
Όσο i ≤ 5 επανάλαβε
Εμφάνισε i
i ← i + 1
Τέλος_επανάληψης
Τέλος_επανάληψης

το οποίο δουλεύει ικανοποιητικά και θα μπορούσε να αποτελεί ένα ερώτημα του τύπου πόσες φορές εκτελείται η εντολή Εμφάνισε.

Κώδικας: [Επιλογή]
i ← -2
Όσο i ≤ 5 επανάλαβε
Για i από  1 μέχρι 3
Εμφάνισε i
Τέλος_επανάληψης
i ← i + 1
Τέλος_επανάληψης

το οποίο είναι ατέρμονας... χωρίς όμως να επηρεάζω την αρχική, την τελική τιμή και το βήμα της Για

Κώδικας: [Επιλογή]
i ← -2
Όσο i ≤ 5 επανάλαβε
i ← i + 1
Όσο i ≤ 10 επανάλαβε
    Εμφάνισε i
    i ← i + 3
Τέλος_επανάληψης
Τέλος_επανάληψης

το οποίο θα μπορούσε να έχει το ίδιο ερώτημα με το πρώτο.

Τώρα το δικό μας θέμα είναι:
α) αν μπορούν να γραφούν (μήπως παραβιάζεται ο τρίτος κανόνας;)
β) αν έχουν εκπαιδευτική αξία... (εκτός από το να βρούμε λάθη, στην περίπτωση που συμφωνήσουμε ότι παραβιάζεται ο τρίτος κανόνας).

ΥΓ: Από την άλλη έχει κάποιος παράδειγμα παραβίασης του δεύτερου κανόνα: Η είσοδος σε κάθε βρόχο υποχρεωτικά γίνεται από την αρχή του;

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #8 στις: 21 Ιαν 2011, 10:06:09 πμ »
Παράθεση
: Από την άλλη έχει κάποιος παράδειγμα παραβίασης του δεύτερου κανόνα: Η είσοδος σε κάθε βρόχο υποχρεωτικά γίνεται από την αρχή του;

Αυτή η απαίτηση έχει να κάνει με την εντολή GOTO. Δεν μπορείς(δεν πρέπει) να οδηγήσεις την εκτέλεση σε εντολή που βρίσκεται μέσα σε βρόχο.

εντολή1
πήγαινε εντολή3
για κ από 1 μέχρι 10
......εντολή2
......εντολή3
τέλος_επανάληψης
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3325
    • P.Tsiotakis
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #9 στις: 21 Ιαν 2011, 10:19:32 πμ »
...
Τώρα το δικό μας θέμα είναι:
α) αν μπορούν να γραφούν (μήπως παραβιάζεται ο τρίτος κανόνας;)
β) αν έχουν εκπαιδευτική αξία... (εκτός από το να βρούμε λάθη, στην περίπτωση που συμφωνήσουμε ότι παραβιάζεται ο τρίτος κανόνας).

...

για τα πρώτα 2: κατά τη γνώμη μου δε μπορούν να γραφούν και δεν έχουν εκπαιδευτική αξία

το τρίτο μπορεί να γραφεί αλλά και αυτό τι αξία έχει; Ίσως ο μαθητής να δει τις απρόβλεπτες συνέπειες που έχει το ζευγάρωμα των μετρητών εμφωλευμένων βρόχων.

εγώ πιο πριν εννοούσα αλγόριθμο που να επιλύει κάποιο πρόβλημα. Εν ολίγοις, ποια είναι η εκφώνηση
;D  γελάω για την αντίστοιχη συζήτηση σε άλλο thread με το αγαπημένο θέμα συζήτησης)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #10 στις: 21 Ιαν 2011, 10:35:20 πμ »
Κώδικας: [Επιλογή]
Για i από 1 μέχρι 3
i ← -2
Όσο i ≤ 5 επανάλαβε
Εμφάνισε i
i ← i + 1
Τέλος_επανάληψης
Τέλος_επανάληψης

...χωρίς όμως να επηρεάζω την αρχική, την τελική τιμή και το βήμα της Για

Η διευκρύνιση που ήρθε πέρισυ από το ΠΙ και αφορούσε στον "χρόνιο" προβληματισμό των συναδέλφων σχετικά με τη ΓΙΑ, αφορούσε στο τελευταίο σχόλιο της παραγράφου 8.3 του ΤΕΤΡΑΔΙΟΥ μαθητή το οποίο αναφέρεται σε ".. εντολές που αλλάζουν την αρχική τιμή, την τελική τιμή, το βήμα ή τη μεταβλητή που ελέγχει την επανάληψη μέσα σε ένα βρόχοΓΙΑ.."

Στο παράδειγμα που δίνεται παραπάνω, υπάρχουν "εντολές που αλλάζουν τη μεταβλητή που ελέγχει την επανάληψη μέσα σε ένα βρόχιο ΓΙΑ"..

Νομίζω λοιπόν ότι το συγκεκριμένο παράδειγμα είναι λάθος
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #11 στις: 21 Ιαν 2011, 10:37:05 πμ »
;D  γελάω για την αντίστοιχη συζήτηση σε άλλο thread με το αγαπημένο θέμα συζήτησης)
>:( θα σε μαλλώσω  :police:
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #12 στις: 21 Ιαν 2011, 10:40:46 πμ »
ΥΓ: Από την άλλη έχει κάποιος παράδειγμα παραβίασης του δεύτερου κανόνα: Η είσοδος σε κάθε βρόχο υποχρεωτικά γίνεται από την αρχή του;

Συμφωνώ απολύτως με την άποψη του Κώστα

Αυτή η απαίτηση έχει να κάνει με την εντολή GOTO. Δεν μπορείς(δεν πρέπει) να οδηγήσεις την εκτέλεση σε εντολή που βρίσκεται μέσα σε βρόχο.

Είναι μία εξειδίκευση του γενικότερου όρου ότι κάθε πρόγραμμα όπως και κάθε ενότητα προγράμματος έχι μόνο μία είσοδο και μία έξοδο (σελ. 135) που αποτελεί βασικό στοιχείο του δομημένου προγραμματισμού
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #13 στις: 21 Ιαν 2011, 10:47:56 πμ »
Κώδικας: [Επιλογή]
i ← -2
Όσο i ≤ 5 επανάλαβε
i ← i + 1
Όσο i ≤ 10 επανάλαβε
    Εμφάνισε i
    i ← i + 3
Τέλος_επανάληψης
Τέλος_επανάληψης

Τώρα το δικό μας θέμα είναι:
α) αν μπορούν να γραφούν (μήπως παραβιάζεται ο τρίτος κανόνας;)
β) αν έχουν εκπαιδευτική αξία... (εκτός από το να βρούμε λάθη, στην περίπτωση που συμφωνήσουμε ότι παραβιάζεται ο τρίτος κανόνας).

Πολύ ωραίο παράδειγμα.

Συμφωνώ ότι είναι δύσκολο να βρεθεί κατάσταση στην οποία κάποιος θα χρειαστεί να χρησιμοποιήσει την ίδια μεταβλητή σε κάποια περίπτωση που αφορά στις άλλες δύο εντολές επανάληψης (εκτός της ΓΙΑ) όμως αν χρειαστεί... μπορεί. Η φράση που συζητάμε λέει ρητά ότι δεν μπορεί.  Γι αυτό θεωρώ ότι ο 3ος κανόνας αφορά αποκλειτικά τους βρόχους ΓΙΑ.

Όσο για τη διδακτική αξία, νομίζω ότι έχειτε ένα point, όμως θα το μελετήσω λίγο και αν σκεφτώ κάτι, επανέρχομαι..
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3325
    • P.Tsiotakis
Απ: Λάθος θέμα στις εξετάσεις ;;
« Απάντηση #14 στις: 21 Ιαν 2011, 10:50:42 πμ »
Σέργιο, όταν δεν πρόκειται για τη δομή Για, προφανώς και ΜΠΟΡΕΙ.

Το απαγορευτικό στο βιβλίο, το εισπράττω όπως το αντίστοιχο για τις σύνθετες -περιττές- συνθήκες στο κεφάλαιο 8