Γενικό Λύκειο > Τμηματικός προγραμματισμός

Διαδικασία και στοιχεία πινάκων

<< < (2/3) > >>

NickTG:
Δεν ξέρω αν πρέπει να ανοίξω καινούριο θέμα.
Επείδη είναι κάτι αντίστοιχο (και επειδη εκανα και κοπο να το βρω το θεμα :P )..

Αν εχω εναν δισδιάστατο πίνακα μπορώ να στελνω σε διαδικασια καποια γραμμη και αυτη να τη διαχειριζεται σαν μονοδιαστατο?

Εστω ενας πινακας ακεραιων πχ. ΔΙΣΔΙΑΣΤΑΤΟΣ[10,25]
πχ για τη ι-η γραμμη (ισως η  γραμμη να δινεται απο το χρηστη ή οτιδηποτε) μπορω να κανω :
....
ΓΙΑ ι ΑΠΟ 3 ΜΕΧΡΙ 7
  ΚΑΛΕΣΕ ΔΙΑΔ(ΔΙΣΔΙΑΣΤΑΤΟΣ[ι])
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...
ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ(ΜΟΝ_ΠΙΝ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΜΟΝ_ΠΙΝ[25]
ΑΡΧΗ
 
  ΓΡΑΨΕ "......................."
 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
...
Φανταζομαι οχι?
Δηλαδη ασχετως με το τι θελω να κανω σε εναν δισδιαστατο μεσω συναρτησης ή διαδικασίας παντα πρεπει να στελνω ολοκληρο τον δισδιαστατο και μετα αναλογα παιζω με γραμμες και στηλες?

Ευχαριστώ..

andreas_p:
ΟΧΙ !

ΓΙΑ ι ΑΠΟ 3 ΜΕΧΡΙ 7
  ΚΑΛΕΣΕ ΔΙΑΔ(ΔΙΣΔΙΑΣΤΑΤΟΣ[ι])
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...
ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ(ΜΟΝ_ΠΙΝ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΜΟΝ_ΠΙΝ[25]
ΑΡΧΗ
 
  ΓΡΑΨΕ "......................."
 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
.
ΝΑΙ.

ΓΙΑ ι ΑΠΟ 3 ΜΕΧΡΙ 7
  ΚΑΛΕΣΕ ΔΙΑΔ(ΔΙΣΔΙΑΣΤΑΤΟΣ, ι)
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...
ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ(ΠΙΝ, Γ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΙΝ[10,25], Γ
ΑΡΧΗ
 
  ΓΡΑΨΕ "......................."
 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
...

NickTG:
Άρα η εκφώνηση του τύπου :

Α) Δημιουργήσετε υποπρόγραμμα που να δέχεται μονοδιάστατο πίνακα ακεραίων και να κάνει ταξινόμηση κατά αύξουσα των στοιχείων του.
Β)να χρησιμοποιήσετε το υποπρόγραμμα του παραπάνω ερωτήματος για τη ταξινόμηση ενός δισδιάστατου πίνακα ο οποίος αρχικοποιειται στο αρχικό πρόγραμμα το οποίο και να υλοποιηθεί.

Είναι λανθασμένη?

petrosp13:
Λανθασμένη δεν είναι αλλά απαιτεί να αντιγράψεις τον δισδιάστατο σε μονοδιάστατο, να καλέσεις το υποπρόγραμμα και να αντιγράψεις τον μονοδιάστατο πίσω στον δισδιάστατο!!
Εκτός αν εννοείς ότι θα ταξινομεί κάθε γραμμή (ή στήλη), οπότε η μόνη αλλαγή είναι ότι θα αντιγράφεις μέσα σε επανάληψη την γραμμή (ή στήλη) σε μονοδιάστατο, θα καλείς το υποπρόγραμμα και θα αντιγράφεις τελικά πίσω τον μονοδιάστατο στην γραμμή (ή στήλη)

ripper:

--- Παράθεση από: NickTG στις 10 Απρ 2021, 05:49:19 μμ ---Φανταζομαι οχι?
Δηλαδη ασχετως με το τι θελω να κανω σε εναν δισδιαστατο μεσω συναρτησης ή διαδικασίας παντα πρεπει να στελνω ολοκληρο τον δισδιαστατο και μετα αναλογα παιζω με γραμμες και στηλες?

--- Τέλος παράθεσης ---

Πρέπει να έχεις ίδιο τύπο παραμέτρων και προφανώς, αν μιλάμε για πίνακες, ίδιες διαστάσεις.
2 ιδέες, έστω πως βρίσκεις και τυπώνεις άθροισμα κάθε γραμμής :


--- Κώδικας: ---ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
  ΚΑΛΕΣΕ ΔΙΑΔ(ΔΙΣΔΙΑΣΤΑΤΟΣ,ι)
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...
ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ(Π,Ι)
ΜΕΤΑΒΛΗΤΕΣ
  ......
ΑΡΧΗ
  ΑΘΡ <- 0
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ 25
      ΑΘΡ <- ΑΘΡ + Π[Ι,Ξ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ ΑΘΡ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
--- Τέλος κώδικα ---




--- Κώδικας: ---ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ 25
      ΝΕΟ[Ξ] <- ΔΙΣΔΙΑΣΤΑΤΟΣ[Ι,Ξ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ         
  ΚΑΛΕΣΕ ΔΙΑΔ(ΝΕΟ)
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...
ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ(Π)
ΜΕΤΑΒΛΗΤΕΣ
  ...
ΑΡΧΗ
  ΑΘΡ <- 0
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ 25
      ΑΘΡ <- ΑΘΡ + Π[Ξ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ ΑΘΡ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
--- Τέλος κώδικα ---

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση