Γενικό Λύκειο > Εξετάσεις 2006-2007

Θέμα 3ο, Απορία

(1/1)

Muldy:
Σας παραθέτω την δική μου απάντηση στο θεμα τρίτο, αν κάποιος θα μπορούσε να το κοιτάξει, θα ήμουν ευγνόμων.

Αλγόριθμος Θεμα_3
Sum<-0
nf<-0
ng<-0
Όσο Sum < 1500 επανέλαβε
 Διάβασε Τιμή, Προέλευση
    Αν (τιμή+sum)<= 1500 τότε
        Aν Προέλευση = "ελληνικό" τότε
            ng<-ng+1
        Αλλιώς
            nf<-nf+1
        Τέλος_Αν
       Sum<-Sum+τιμή
       SumA<-Sum
   Αλλιώς
       Εμφάνισε "Τέλος αγορών"
       Sum<-1501  !γενικά οτιδήποτε >=1500
   Τελος_Αν
Τέλος_επανάληψης
Εμφάνισε SumA
Εμφάνισε ng,nf
Ποσο_Περ<-1500-SumA
Αν Ποσο_Περ>0 τότε
  Εμφάνισε Ποσο_περ
Αλλιώς
 Εμφάνισε "εξαντλήθηκε το ποσό"
Τέλος_αν
Τέλος θεμα_3

evry:
 Σωστό μου φαίνεται αν και όχι κομψό, μην ανησυχείς πάντως δουλεύει μια χαρά

Muldy:
Πάλι καλά, πήρα μία τρομάρα.... λέω κοίτα να μην έκανα το 3ο και να έκανα όλα τα άλλα... Ευχαριστώ πολύ!

P.Tsiotakis:

Μια ερώτηση φίλε μου..

Αφού θέλεις να σπάσεις την επανάληψης και έχεις διαγνώσει και το πότε: γιατί δεν παίρνεις μια λογική μεταβλητή που έχει ακριβώς αυτό το ρόλο;
Καταλαβαίνω το άγχος και όλα τα συναφή, αλλά το να χρησιμοποιήσεις άλλη μεταβλητή για να κρατάς το Σ και μετά να αλλάζεις την τιμή του, μου φαίνεται λίγο πιο σύνθετο...
Αν άλλαζες ελάχιστα τη σκέψη σου, θα απλοποιούσες πολύ τα πράγματα, αυτό...

Καλά αποτελέσματα...

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση