Γενικό Λύκειο > Εξετάσεις 2004-2005

Επαναληπτικές Εσπερινών 2005

(1/3) > >>

amanou:
Είναι διαθέσιμα από την σελίδα του Υπουργείου  http//www.ypepth.gr/docs/them_plir_kat_d_esp_epan_0705.pdf  τα θέματα των επαναληπτικών του εσπερινού

Θα ακολουθήσουν και οι λύσεις τους εντός ολίγου

Φιλικά

Αντώνης Μανουσάκης

Ηλεκτρονικός Μηχανικός &
Μηχανικός Υπολογιστών

amanou:
Α.
   1. Σ
   2. Σ
   3. Λ
   4. Σ
   5. Σ

Β.
  1. γ
  2. β
  3. δ
  4. α
  5. στ

Γ.
 ΔΙΑΒΑΣΕ : Με την εντολή αυτή δίνουμε είσοδο στον υπολογιστή
 ΓΡΑΨΕ: Με την εντολή αυτή δίνουμε έξοδο στον υπολογιστή

Δ.
Σωστή είναι η 2
στις άλλες δεν υπάρχουν παρενθέσεις ή δεν είναι σε σωστή θέση.

Ε.

   S <- 0
   K <- 1
   ΟΣΟ Κ <= 5 ΕΠΑΝΑΛΑΒΕ
          L <- 1
          ΟΣΟ L <= 7 ΕΠΑΝΑΛΑΒΕ
                      S <- S + 1
                      L <- L + 1
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Κ <- Κ + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ S





amanou:
Αλγόριθμος Άσκηση
 Αρχή_επανάληψης
    Διάβασε Χ
 Μέχρις_ότου Χ>0 και Χ<= 1000
 Αν Α_Μ( Χ ) = Χ τότε
    Εμφάνισε "ΑΚΕΡΑΙΟΣ"
    Aν Χ mod 2 = 0 τότε
          Εμφάνισε "ΑΡΤΙΟΣ"
    Αλλιώς
          Εμφάνισε "ΠΕΡΙΤΤΟΣ"
    Τέλος_Αν
  Αλλιώς
          Εμφάνισε "ΠΡΑΓΜΑΤΙΚΟΣ"            
  Τέλος_Αν
Τέλος Άσκηση

amanou:
Θεωρώ ότι το θέμα 1 ήταν αρκετά εύκολο με μόνη εξαίρεση το ερώτημα Ε το οποίο είχε εμφωλευμένη επανάληψη και δεν είναι τόσο απλό.

Το θέμα 2 για μια ακόμα φορά είναι άσκηση, όπως και στις επαναληπτικές των ενιαίων και έτσι βλέπω από του χρόνου να πηγαίνουμε σε αυτήν την κατεύθυνση, της μικρής άσκησης (άρα τέρμα οι ασκήσεις του στυλ τι θα εμφανιστεί που βοηθούσαν αρκετά τους μαθητές). Ωστόσο θεωρώ ότι το θέμα δεν έχει διεκρινήσεις και είναι λίγο ασαφές. Εγώ το έλυσα χρησιμοποιώντας την συνάρτηση Α_Μ (ακέραιου μέρους) γιατί η χρήση του τελεστή MOD που θα μπορούσε να χρησιμοποιηθεί εναλλακτικά δεν είναι ξεκάθαρη αν είναι μόνο για ακεραίους ή γενικά για όλους τους αριθμούς συμπεριλαμβανομένους και τους πραγματικούς.

Πάντως θεωρώ ότι είναι καλή άσκηση και ειδικά για 2ο θέμα αρκετά απαιτητική αλλά λίγο ασαφής. Θα μπορούσε να δωθεί διευκρίνηση για το τι θα πρέπει να χρησιμοποιηθεί από τους μαθητές.

amanou:
Αλγόριθμος Θέμα3
Σ1 <- 0!συνολική προμήθεια προϊόντος Χ
Σ2 <- 0!συνολική προμήθεια προϊόντος Ψ
Σ3 <- 0!συνολική προμήθεια προϊόντος Ζ
Διάβασε Πρ, Τπ! Προϊόν , τιμή πώλησης
Όσο Πρ <> "T" επανάλαβε
     Αν Πρ = "X" τότε
        Αν Τπ <= 5000 τότε
                   Σ1 <- Σ1 + 0
        Αλλιώς_αν Τπ <= 10000 τότε
         Σ1 <- Σ1 + 0,05*Τπ
        Αλλιώς_αν Τπ > 10000 τότε
         Σ1 <- Σ1 + 0,1*Τπ
        Τέλος_αν
      Αλλιώς_αν Πρ = "Ψ" τότε
        Αν Τπ <= 5000 τότε
                   Σ1 <- Σ1 + 0,02*Τπ
        Αλλιώς_αν Τπ <= 10000 τότε
         Σ1 <- Σ1 + 0,06*Τπ
        Αλλιώς_αν Τπ > 10000 τότε
         Σ1 <- Σ1 + 0,07*Τπ
        Τέλος_αν
      Αλλιώς_αν Πρ = "Ζ" τότε
        Αν Τπ <= 5000 τότε
                   Σ1 <- Σ1 + 0,04*Τπ
        Αλλιώς_αν Τπ <= 10000 τότε
         Σ1 <- Σ1 + 0,06*Τπ
        Αλλιώς_αν Τπ > 10000 τότε
         Σ1 <- Σ1 + 0,08*Τπ
        Τέλος_αν
      Τέλος_αν
   Διάβασε Πρ, Τπ
Τέλος_επανάληψης
Εμφάνισε Σ1,Σ2,Σ3,
Σ <- Σ1+Σ2+Σ3
Εμφάνισε Σ
Τέλος Θέμα3

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση