Αποστολέας Θέμα: Εξετάσεις Εσπερινών 2010  (Αναγνώστηκε 5446 φορές)

makryd

  • Οπαδός
  • **
  • Μηνύματα: 10
Εξετάσεις Εσπερινών 2010
« στις: 22 Μαΐ 2010, 11:07:43 μμ »
Θέματα και λύσεις στο :
http://docs.google.com/View?id=drzr6wf_3384t2pp274

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #1 στις: 22 Μαΐ 2010, 11:09:41 μμ »
Διόρθωσε το Α3.3

makryd

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #2 στις: 22 Μαΐ 2010, 11:11:49 μμ »
Έγινε...Ευχαριστώ!

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #3 στις: 22 Μαΐ 2010, 11:14:25 μμ »
Επίσης, αν τρέξω το Θ3 σε έτος μεταγενέστερο του 2010 θα προκύψει λογικό λάθος ! (Σχετικά με το ερώτημα Γ4)
Θα πρέπει πρωτίστως να τροποποιήσω το πρόγραμμα ...

Σχετικά με την αρχικοποίηση του min ...

! αρχικά επιλέγω το 2011 ως το μικρότερο έτος (παλαιότερο αυτοκίνητο)
    min  <- 2011   

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #4 στις: 22 Μαΐ 2010, 11:18:14 μμ »
Επίσης ...
Δ3.α

πληθος1 ← πληθος1  + 1 + ?

Δ3.β

πληθος2 ← πληθος2  + 1 + ?


makryd

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #5 στις: 22 Μαΐ 2010, 11:20:40 μμ »
Συμφωνώ με την παρατήρηση σου, αλλά αφού δεν απαιτεί έλεγχο εγκυρότητας και αναφέρει " Σε ΚΤΕΟ της χώρας το 2010 ...", δέχομαι οτι δεν θα μπορούσε από τον χρήστη να δοθεί τέτοιο έτος (έτος μεγαλυτερο του 2010).

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #6 στις: 22 Μαΐ 2010, 11:21:22 μμ »
Επίσης, αν τρέξω το Θ3 σε έτος μεταγενέστερο του 2010 θα προκύψει λογικό λάθος ! (Σχετικά με το ερώτημα Γ4)

Αν και μου φαίνεται τραβηγμένο λίγο... Ας μπει τότε αρχική τιμή το έτος 3000.... Μέχρι τότε ποιος ζει ποιος πεθαίνει! Αν και τώρα που το σκέφτομαι έτσι την πάτησαν και κάποιοι άλλοι και μετά μιλάγαμε για το πρόβλημα του έτους 2000!  ;D

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #7 στις: 22 Μαΐ 2010, 11:28:25 μμ »
Νομίζω ότι είμαστε σε λάθος θέση (Εξετάσεις 2008-2009). Δεν κολλάει κάποιος το θέμα αυτό με το σχετικό στο https://alkisg.mysch.gr/steki/index.php?topic=2916 ;;;  :police:

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #8 στις: 22 Μαΐ 2010, 11:59:46 μμ »
    Σ ← 0
    Για i από  1 μέχρι 15 με_βήμα 3
        Σ ← Σ + A
    Τέλος_Επανάληψης
     Εμφάνισε Σ


Δες το λίγο .....

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #9 στις: 23 Μαΐ 2010, 12:01:48 πμ »
Για i από  1 μέχρι 15 με_βήμα 3

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #10 στις: 23 Μαΐ 2010, 12:06:49 πμ »
Θέμα Γ:

   ΑΝ min <> 2011 TOTE
       ΓΡΑΨΕ κατηγορία_παλαιότερου
   ΤΕΛΟΣ_ΑΝ


Το συνολικό πρόστιμο ;;;;

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #11 στις: 23 Μαΐ 2010, 12:07:17 πμ »
Για i από  1 μέχρι 15 με_βήμα 3


Α αντί για i ...

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #12 στις: 23 Μαΐ 2010, 12:13:19 πμ »
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Θεμα_3

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #13 στις: 23 Μαΐ 2010, 12:15:34 πμ »
Θέμα Γ:

   ΑΝ min <> 2011 TOTE
       ΓΡΑΨΕ κατηγορία_παλαιότερου
   ΤΕΛΟΣ_ΑΝ


Το συνολικό πρόστιμο ;;;;

Το πλήθος των φορτηγών και το συνολικό πρόστιμο θα πρέπει να εμφανίζονται μέσα στο Αν.


andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Εξετάσεις Εσπερινών 2010
« Απάντηση #14 στις: 23 Μαΐ 2010, 12:18:56 πμ »
Και έξω μπορεί να είναι. Αφού οι αντίστοιχες μεταβλητές έχουν αρχικοποιηθεί. (με 0)