Γενικό Λύκειο > Αναζήτηση

ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ

(1/9) > >>

giannhs555:
ΚΑΛΗΣΠΕΡΑ,

ΠΑΡΑΚΟΛΟΥΘΩ ΤΙΣ ΣΥΖΗΤΗΣΕΙΣ  ΠΟΥ ΕΧΟΥΝ ΓΙΝΕΙ ΣΧΕΤΙΚΑ ΜΕ ΤΗ ΣΕΙΡΙΑΚΗ ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ. ΕΠΕΙΔΗ ΕΧΟΥΝ ΔΙΑΤΥΠΩΘΕΙ ΔΙΑΦΟΡΕΣ ΓΝΩΜΕΣ ΚΑΙ ΔΙΑΦΟΡΟΙ ΑΛΓΟΡΙΘΜΟΙ, ΤΕΛΙΚΑ ΥΠΑΡΧΕΙ ΚΑΤΙ ΣΥΓΚΕΚΡΙΜΕΝΟ ΤΟ ΟΠΟΙΟ ΜΠΟΡΟΥΜΕ ΝΑ ΔΙΔΑΣΚΟΥΜΕ ΣΤΟΥΣ ΜΑΘΗΤΕΣ?

ΕΥΧΑΡΙΣΤΩ ΓΙΑ ΤΟΝ ΧΡΟΝΟ ΣΑΣ.

Laertis:
Συγκεκριμένος αλγόριθμος δεν υπάρχει στο βιβλίο αλλά υπάρχουν οι οδηγίες για να τον φτιάξεις (Κεφ. 3 σελ. 64).  Στην ουσία είναι ο αλγόριθμος σειριακής αναζήτησης που δίνεται στο βιβλίο με την προσθήκη μιας ακόμη συνθήκης όπου το στοιχείο του πίνακα είναι μεγαλύτερο της τιμής αναζήτησης.
Δες στο παρακάτω link απο το site του Παναγιώτη :

http://users.kor.sch.gr/ptsiotakis/aepp/aepp_theory3b.htm

sstergou:
Δες και αυτόν, ίσως σου φανεί χρήσιμος

--- Κώδικας: ---Αλγόριθμος σειριακή_αναζήτηση_ταξινομημένος
Δεδομένα //π, Ν, τιμή//

ξεπέρασε ← Ψευδής
βρέθηκε ← Ψευδής
θέση ← 0
ι ← 1

Όσο όχι βρέθηκε και όχι ξεπέρασε και ι ≤ Ν επανάλαβε
Αν π[ι] = τιμή τότε
βρέθηκε ←  Αληθής
θέση ← ι
αλλιώς_αν π[ι] > τιμή τότε
ξεπέρασε ← Αληθής
Τέλος_αν
ι← ι + 1
Τέλος_επανάληψης

Αποτελέσματα //βρέθηκε, θέση//
Τέλος σειριακή_αναζήτηση_ταξινομημένος
--- Τέλος κώδικα ---

giannhs555:
ΕΧΩ ΔΕΙ ΤΟΝ ΑΛΓΟΡΙΘΜΟ ΤΟΥ ΠΑΝΑΓΙΩΤΗ. ΕΙΝΑΙ ΜΙΑ ΚΑΛΗ ΛΥΣΗ.

ΝΟΜΙΖΩ ΟΜΩΣ ΟΤΙ ΔΕΝ ΚΑΛΥΠΤΕΙ ΤΗΝ ΠΕΡΙΠΤΩΣΗ ΝΑ ΒΡΕΙ ΟΛΕΣ ΤΙΣ ΘΕΣΕΙΣ ΤΟΥ ΣΤΟΙΧΕΙΟΥ ΠΡΟΣ ΑΝΑΖΗΤΗΣΗ, ΟΤΑΝ ΑΥΤΟ ΥΠΑΡΧΕΙ ΣΕ ΠΕΡΙΣΣΟΤΕΡΕΣ ΑΠΟ ΜΙΑ.

ΜΗΠΩΣ ΤΟ ΠΟΤΕ ΘΑ ΣΤΑΜΑΤΑ Ο ΑΛΓΟΡΙΘΜΟΣ ΘΑ ΕΠΡΕΠΕ ΝΑ ΕΙΝΑΙ ΑΝΕΞΑΡΤΗΤΗ ΛΟΓΙΚΗ ΜΕΤΑΒΛΗΤΗ ΑΠΟ ΑΥΤΗ ΠΟΥ ΔΗΛΩΝΕΙ ΟΤΙ ΤΟ ΣΤΟΙΧΕΙΟ ΒΡΕΘΗΚΕ?

Laertis:
Στην περίπτωση αυτή η λύση του Στάθη είναι ενδεδειγμένη βάζοντας μάλιστα σε πίνακα με δείκτη μετρητή τις θέσεις των στοιχείων που βρέθηκαν. Μεταφέρω απο τη λύση του Στάθη:
.......
κ <--0
Όσο όχι βρέθηκε και όχι ξεπέρασε και ι ≤ Ν επανάλαβε
   Αν π[ι] = τιμή τότε
      βρέθηκε ←  Αληθής
      κ <-- κ +1
      θέση[κ] ← ι
   αλλιώς_αν π[ι] > τιμή τότε
........

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση