Γενικό Λύκειο > Εισαγωγή στοιχείων, εμφάνιση και υπολογισμοί

Αλλαγή των στοιχείων σε μονοδιάστατο πίνακα

(1/2) > >>

nikolasmer:
Έβαλα αυτή την ασκησούλα και το 90% των μαθητών έβγαλαν ως αποτέλεσμα το Α Ι Ρ Ι Α. Μερικοί έκαναν και πίνακα τιμών για αυτό.  :(
Πώς πρέπει τέλος πάντων να τους το δείξεις;

Π[1] <- "Μ"
Π[2] <- "Α"
Π[3] <- "Ρ"
Π[4] <- "Ι"
Π[5] <- "Α"
Για Ι από 1 μέχρι 5
   Π[ Ι ] <- Π[ 6 - Ι]
Τέλος_επανάληψης
Για Ι από 1 μέχρι 5
   Εμφάνισε Π[ Ι ]
Τέλος_επανάληψης

petrosp13:
Ποιο είναι το λάθος;;

andreas_p:
Π[ Ι ] <- Π[ 6 - Ι]

Αλλάζει το περιεχόμενο του πίνακα Π !

nikolasmer:
Συγνώμη. Από ταχύτητα έγραψα το σωστό. Ήθελα να γραψω πως οι περισσοτεροι μου έδωσαν ως απάντηση το Α Ι Ρ Α Μ. Στις απαντήσεις τους είδα πως σχεδίασαν από κάτω τον πίνακα και έβαλαν τα καινούρια στοιχεία του στην ουσία σε ένα αντίγραφο του αρχικού πίνακα Π.

petrosp13:
Πες τους ότι τα στοιχεία των πινάκων είναι θέσεις μνήμης και (όπως οι μεταβλητές) αποθηκεύουν την τελευταία τιμή που τους δόθηκε και μόνο

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση