Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 14949 φορές)

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #45 στις: 06 Ιούν 2014, 06:05:47 μμ »
Evry συμφωνώ απόλυτα με αυτά που γράφεις τόσο για τον τρόπο που χρησιμοποιείται ο πίνακας όσο και για τις μονάδες που πρέπει να κοπούν.
Τώρα σχετικά με λύσεις που δίνουν μερικές φορές οι μαθητές, δεν σταματούν να μας εκπλήσουν.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: ΘΕΜΑ Γ
« Απάντηση #46 στις: 06 Ιούν 2014, 06:09:34 μμ »
Παιδιά μην μπερδεύετε το συγκεκριμένο θέμα με του 2010, δεν μοιάζουν. Φέτος έχουμε επανάληψη με τιμή φρουρό.

Είναι ξεκάθαρο ότι πρέπει να κοπούν κάποιες μονάδες για τη χρηση πίνακα.

+1

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: ΘΕΜΑ Γ
« Απάντηση #47 στις: 06 Ιούν 2014, 06:19:53 μμ »
Επίσης κατά τη γνώμη μου υπάρχει πρόβλημα στην εκφώνηση του θέματος Γ . Έτσι όπως δίνεται πολλοί μαθητές νόμισαν ότι ο λογαριασμός δεν είναι ο συνολικός αλλά είναι διαφορετικός για κάθε προιόν, άρα τα έκαναν όλα μέσα στην επανάληψη. Αυτό είναι πρόβλημα της εκφώνησης.

+1

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: ΘΕΜΑ Γ
« Απάντηση #48 στις: 06 Ιούν 2014, 07:03:27 μμ »
Συνάδελφοι και πάλι με το θέμα Γ προκύπτει το πρόβλημα με την χρήση πινάκων ή όχι.
Η άποψή μου είναι ότι από την μια σε όλη την διάρκεια της χρονιάς "πιπιλάμαι" τα μυαλά των μαθητών ότι η χρήση πίνακα σε μη γνωστό αριθμό επαναλήψεων καλό θα είναι να αποφεύγεται.
Από την άλλη όμως σε επίλυση αλγορίθμου δεν είναι απαγορευτικό να λύσουμε ένα πρόβλημα χρησιμοποιώντας πίνακα Ν στοιχείων,εφόσον το Ν θα είναι πεπερασμένο.
Από την στιγμή λοιπόν που η επιτροπή εξετάσεων δεν αναφέρει σε μια σημείωση : ο αλγόριθμος να γίνει χωρίς την χρήση πινάκων (τόσο απλό, με μια σημείωση), θα πρέπει να θεωρούμε και τις δυο λύσεις σωστές.

niaboc99

  • Νέος
  • *
  • Μηνύματα: 1
Απ: ΘΕΜΑ Γ
« Απάντηση #49 στις: 06 Ιούν 2014, 07:16:37 μμ »
Αλγόριθμος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ
ι ← 1
π ← 0
Διάβασε κ[ι]
Αρχή_επανάληψης
  Αν κ[ι] ≠ 0 τότε
    Αρχή_επανάληψης
      Διάβασε α[ι]
    Μέχρις_ότου α[ι] > 0 και α[ι] = Α_Μ(α[ι])
    Αρχή_επανάληψης
      Διάβασε τ[ι]
    Μέχρις_ότου τ[ι] > 0
    ι ← ι + 1
    π ← π + 1
    Διάβασε κ[ι]
  Τέλος_αν
Μέχρις_ότου κ[ι] = 0
λογαριασμος ← 0
Για ι από 1 μέχρι π
  λογαριασμος ← λογαριασμος + (τ[ι] * α[ι])
Τέλος_επανάληψης
Αν λογαριασμος ≤ 500 τότε
  Εμφάνισε "μετρητα"
αλλιώς
  σ ← 0
  δοση ← 20
  ν ← 0
  Όσο σ < λογαριασμος επανάλαβε
    σ ← σ + δοση
    ν ← ν + 1
    δοση ← δοση + 5
  Τέλος_επανάληψης
  Εμφάνισε "αριθμός δόσεων:", ν
Τέλος_αν

σ ← 0
μαξ ← -1
Για ι από 1 μέχρι π
  Αν τ[ι] > 10 τότε
    σ ← σ + α[ι]
  Τέλος_αν
  Αν τ[ι] > μαξ τότε
    μαξ ← τ[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμος τεμαχιων με τιμη μεγαλυτερη των 10:", σ
σ ← 0
Για ι από 1 μέχρι π
  Αν τ[ι] = μαξ τότε
    σ ← σ + α[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμοσ τεμαχιων με την μεγιστη τιμη:", σ
Τέλος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ



Όταν τρέχω τον παραπάνω αλγόριθμο στο pc σε γλώσσα δεν εμφανίζει κάποιο λάθος και τον τρέχει κανονικά.
Αυτό δεν σημαίνει ότι θα έπρεπαι να κοπούν(αυστηρά) το πολύ 3 μονάδες ?

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 786
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: ΘΕΜΑ Γ
« Απάντηση #50 στις: 06 Ιούν 2014, 07:19:54 μμ »
Απο τη στιγμή που η επιτροπή δεν αναφέρει ότι ζητείται η σωστή επίλυση του προβλήματος, κάθε λύση πρέπει να θεωρηθεί δεκτή!

manu

  • Νέος
  • *
  • Μηνύματα: 7
Απ: ΘΕΜΑ Γ
« Απάντηση #51 στις: 06 Ιούν 2014, 07:29:00 μμ »
Εάν είναι να κοπούν μονάδες πόσες θα κοπούν το πολύ στις 100??  ???

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 540
  • There can be only one...may it be AEPP.
Απ: ΘΕΜΑ Γ
« Απάντηση #52 στις: 06 Ιούν 2014, 09:17:05 μμ »
Παράθεση
...Πάλι τα ίδια...(με το 2010 Θέμα Γ)...Τί πείραζε ένα ερώτημα στο τέλος:
"Γ5. Να γραφεί (ξέχωρα) το τμήμα δήλωσης μεταβλητών  που χρησιμοποιεί ο αλγόριθμος"
(Από τηλεφωνική συνομιλία με Φανίκο)
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: ΘΕΜΑ Γ
« Απάντηση #53 στις: 06 Ιούν 2014, 09:18:27 μμ »
(Από τηλεφωνική συνομιλία με Φανίκο)

Προφανώς γιατί κάποιοι πιστεύουν ότι το να βάζεις τέτοια θέματα ειναι χαριτωμένο.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #54 στις: 06 Ιούν 2014, 09:20:38 μμ »
ακόμα καλύτερα, θα έλεγα:
Να γραφτεί πρόγραμμα
και έτσι λύνονται όλα τα προβλήματα.

Παρεμπιπτόντως αν δεν κάνω λάθος (διορθώστε με) δεν έβαλαν τίποτα από τα κεφάλαια
  1, 7, 8, 9, 10

(το ότι μπήκε ένα ΣΛ από το 10 δε σημαίνει κάτι)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: ΘΕΜΑ Γ
« Απάντηση #55 στις: 06 Ιούν 2014, 09:23:38 μμ »
ακόμα καλύτερα, θα έλεγα:
Να γραφτεί πρόγραμμα

και έτσι λύνονται όλα τα προβλήματα.

Παρεμπιπτόντως αν δεν κάνω λάθος (διορθώστε με) δεν έβαλαν τίποτα από τα κεφάλαια
  1, 7, 8, 9, 10

(το ότι μπήκε ένα ΣΛ από το 10 δε σημαίνει κάτι)

+1

Σαφώς και αυτή θα έπρεπε να ήταν η αντιμετώπισή για να πάρουν απάντηση χωρίς πίνακες. Το όλο θέμα ειναι εντελώς τσίρκο.

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: ΘΕΜΑ Γ
« Απάντηση #56 στις: 06 Ιούν 2014, 09:55:08 μμ »


Παρεμπιπτόντως αν δεν κάνω λάθος (διορθώστε με) δεν έβαλαν τίποτα από τα κεφάλαια
  1, 7, 8, 9, 10

(το ότι μπήκε ένα ΣΛ από το 10 δε σημαίνει κάτι)

κεφ 8 σελ 180 εμφωλευμένοι βρόχοι
VR in Computing

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #57 στις: 06 Ιούν 2014, 10:46:22 μμ »
ουπς, μ'έπιασες, μάλλον το καλοκαίρι πρέπει να κάτσω να διαβάσω λίγο θεωρία :-)

κεφ 8 σελ 180 εμφωλευμένοι βρόχοι
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Pavlos1908

  • Νέος
  • *
  • Μηνύματα: 4
Απ: ΘΕΜΑ Γ
« Απάντηση #58 στις: 06 Ιούν 2014, 11:17:46 μμ »
Και εγω μαθητης ειμαι και το εκανα με πινακα που μετα που τελειωσα καταλαβα οτι δεν επρεπε λογω στατικοτητας να βαλω πινακα ομως ετσι οπως ηταν διατυπωμενο το Γ4 δεν μπορουσα να σκεφτω κατι αλλο.

Εκανα το εξης και θα ηθελα την γνωμη σας οσον αφορα ποσα μορια θα μου κοψουν:
i<--o
διαβασε κωδ
οσο κωδ<>0 επαναλαβε
i<--i+1
διαβασε αρτεμ1 ,τιμτεμ1 , κωδ
ΤΙΜ[Ι]<-- τιμτεμ1
ΑΡΤΕΜ[Ι]<-- αρτεμ1


και χρησιμοποιησα τον πινακα στο Γ4 ομως και στο Γ3 καθως το εβαλα σε ξεχωριστη δομη ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ I ( οπου I ηταν γνωστο απο πανω ) και θεωρησα τους πινακες δεδομενους. Ποσα μορια πιστευετε στα 100 οτι θα χασω;

σημειωση: θεωρω κι εγω απαραδεκτη την εκφωνηση, με οσα παιδια εχω μιλησει το 90% το εχει κανει με πινακες, στο κατω κατω ας εβαζαν μια σημειωση "δεν ενδεικνυεται λυση με χρηση πινακων", ποσο δυσκολο θα ηταν ωστε να αποφυγουμε τις παρερμηνειες; Οπως ειπατε και εσεις πιο πανω, δυστυχως καλοι μαθητες με αλγοριθμικοι σκεψη την πατησαν λογω της "στενης" υλης περι στατικοτητας.

alex goug

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #59 στις: 06 Ιούν 2014, 11:52:24 μμ »
Τι γινεται με αυτους που στο γ4 δεν εξετασαν την ισοτητα?