Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 15411 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2452
  • I 'm not young enough to know everything
ΘΕΜΑ Γ
« στις: 06 Ιούν 2014, 09:08:42 πμ »
Εδώ σχολιάζουμε το θέμα Γ

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Γ
« Απάντηση #1 στις: 06 Ιούν 2014, 11:06:02 πμ »
Γ4, οεφε 2014?

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 679
Απ: ΘΕΜΑ Γ
« Απάντηση #2 στις: 06 Ιούν 2014, 11:11:29 πμ »
το Γ2 θα το υπολογίσουμε έξω από την επανάληψη σωστά??
αναφέρεται για τα συνολοκό ποσό έτσι ???

επίσης το Γ3 είναι απλός μετρητής???κάτι μου διαφεύγει ??

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 679
Απ: ΘΕΜΑ Γ
« Απάντηση #3 στις: 06 Ιούν 2014, 11:13:20 πμ »
βασικά για το Γ3

αν τιμή>10 τότε
   αθρ<--αθρ+τεμ
τέλος_αν

σωστά ??? αθροιστής είνια μάλλον

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #4 στις: 06 Ιούν 2014, 11:15:18 πμ »
To Γ4 τι νόημα έχει;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Γ
« Απάντηση #5 στις: 06 Ιούν 2014, 11:16:15 πμ »
Γ3, Γ4, αθροιστες, όχι μετρητες

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 679
Απ: ΘΕΜΑ Γ
« Απάντηση #6 στις: 06 Ιούν 2014, 11:16:56 πμ »
σωστά παναγίωτη αθροιστές

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #7 στις: 06 Ιούν 2014, 11:18:25 πμ »
αθροιστές σε τι; σε αυτό που έχει την μαξ τιμή ή σε ΑΥΤΑ που έχουν την μαξ τιμή;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

papaluk

  • Μηχ. Η/Υ & Πληρ. ΠΕ19
  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 94
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ΘΕΜΑ Γ
« Απάντηση #8 στις: 06 Ιούν 2014, 11:19:49 πμ »
Το Γ4 απαιτητικό.. είχε παρόμοιο σε επαναληπτικό διαγώνισμα από το στέκι,.
Το Γ2 ίσως έχει μικρή ασάφεια αν το ποσό δεν αντιστοιχεί ακριβώς σε δόσεις..οπότε θεωρούμε ότι η τελευταία είναι μικρότερη από το ποσό??
Σατ<--0 ! συνολικος αριθμος τεμαχιων
Σεξ<--0 ! συνολικά έξοδα
πλμαχ<--0
μαχ<-- -1
αρχη_επαναληψης
  διαβασε κωδ
  αν κωδ <>0 τοτε
       διαβασε τιμ, τεμ
       Σεξ<-- Σεξ + τιμ*τεμ
        αν τιμ>10 τοτε
             Σατ<--Σατ+τεμ
        τελος_Αν
         αν τιμ>μαχ τοτε
            μαχ<-- τιμ
            πλμαχ<--τεμ
        αλλιως_αν τιμ=μαχ τοτε
             πλμαχ<--τεμ+πλμαχ
        τελος_αν
   τελος_Αν
μεχρις_οτου κωδ=0
εμφανισε πλμαχ, Σατ
αν Σεξ<=500 τοτε
  εμφάνισε " ριξτα όλα με τη μια  :D "
αλλιώς
   πλδ<--0
   δ<--20
   αρχη_επαναληψης
      Σεξ<--Σεξ - δ
       πλδ<--πλδ+1
       δ<--δ+5
   μεχρις_οτου Σεξ<=0
   εμφανισε πλδ
τελος_Αν

« Τελευταία τροποποίηση: 06 Ιούν 2014, 11:36:33 πμ από papaluk »

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Γ
« Απάντηση #9 στις: 06 Ιούν 2014, 11:23:06 πμ »
αθροιστές σε τι; σε αυτό που έχει την μαξ τιμή ή σε ΑΥΤΑ που έχουν την μαξ τιμή;

σε ολα τα ισα με το μαξ

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: ΘΕΜΑ Γ
« Απάντηση #10 στις: 06 Ιούν 2014, 11:30:51 πμ »
Το Γ4 απαιτητικό.. είχε παρόμοιο σε επαναληπτικό διαγώνισμα από το στέκι,.
Το Γ2 ίσως έχει μικρή ασάφεια αν το ποσό δεν αντιστοιχεί ακριβώς σε δόσεις..οπότε θεωρούμε ότι η τελευταία είναι μικρότερη από το ποσό??
Σατ<--0 ! συνολικος αριθμος τεμαχιων
Σεξ<--0 ! συνολικά έξοδα
πλμαχ<--0
μαχ<-- -1
αρχη_επαναληψης
  διαβασε κωδ
  αν κωδ <>0 τοτε
       διαβασε τιμ, τεμ
       Σεξ<-- Σεξ + τιμ*τεμ
        αν τιμ>10 τοτε
             Σατ<--Σατ+τεμ
        τελος_Αν
         αν τιμ>μαχ τοτε
            μαχ<-- τιμ
            πλμαχ<--ατ
        αλλιως_αν τιμ=μαχ τοτε
             πλμαχ<--ατ+πλμαχ
        τελος_αν
   τελος_Αν
μεχρις_οτου κωδ=0
εμφανισε πλμαχ, Σατ
αν Σεξ<=500 τοτε
  εμφάνισε " ριξτα όλα με τη μια  :D "
αλλιώς
   πλδ<--0
   δ<--20
   αρχη_επαναληψης
      Σεξ<--Σεξ - δ
       πλδ<--πλδ+1
       δ<--δ+5
   μεχρις_οτου Σεξ<=0
   εμφανισε πλδ
τελος_Αν



ατ ???
Ανδροκλής Πολυμένης

Πληροφορικός

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Γ
« Απάντηση #11 στις: 06 Ιούν 2014, 11:35:21 πμ »
Έκανα λάθος στο Γ1 , οπότε μου αλλάζει το Γ4 , επιστρέφω σε λίγο ευχαριστώ για τις παρατηρήσεις. το σβήνω για να μην μπερδέψω τους μαθητές.

πιστεύω πως τώρα είναι σωστό

Αλγόριθμος ΘΕΜΑΓ   

smax<-0
συντεμ<-0
δοσεις<- 0
maxτιμη<- 0


!ερώτημα Γ1

λογ<-0

Αρχή επανάληψης

 Διάβασε κωδ
 Αν κωδ<> 0 τότε
   Διάβασε αρτεμ
   Διάβασε τιμη

   λογ<- λογ+αρτεμ*τιμη

!ερώτημα Γ3

   συντεμ<-0
   Αν τιμη>10 τότε
      συντεμ<-συντεμ+αρτεμ
   Τέλος αν

! ερώτημα Γ4

   Αν τιμη>maxτιμη τότε
      maxτιμη<- τιμη
      smax<- αρτεμ
   αλλιώς αν τιμη=max τοτε
      smax<- smax+αρτεμ
   Τέλος αν
 
Τέλος αν

Μέχρις_ότου κωδ=0

   
!ερώτημα Γ2

Αν λογ <= 500 τότε
   Εμφάνισε “ΠΛΗΡΩΜΗ ΜΕΤΡΗΤΟΙΣ”
αλλιώς
   δοσεις<- 0
   temp<- λογ
   i<-0
   Αρχή_επανάληψης
      temp<- temp-(20+i*5)
      δοσεις<-δοσεις+1
   Μέχρις_ότου δοσεις<=0
   Εμφάνισε “Αριθμός δόσεων :” , δοσεις
Τέλος_αν
 

!Γ3
Εμφάνισε “Συνολικά τεμάχια με τιμή μεγαλύτερη των 10 ευρώ ”, συντεμ

!Γ4
Εμφάνισε “Συνολικός αριθμός τεμαχίων με την μέγιστη τιμή τεμαχίου”,smax

Τέλος ΘΕΜΑΓ
« Τελευταία τροποποίηση: 06 Ιούν 2014, 12:18:02 μμ από pstasinos »

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Γ
« Απάντηση #12 στις: 06 Ιούν 2014, 11:37:30 πμ »

papaluk

  • Μηχ. Η/Υ & Πληρ. ΠΕ19
  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 94
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ΘΕΜΑ Γ
« Απάντηση #13 στις: 06 Ιούν 2014, 11:38:13 πμ »
ατ ???

οπου ατ... τεμ ... ήταν  αριθμός τεμαχίων στο χαρτί και στον υπολογιστή έγινε τεμ..αλλα όχι παντου

papaluk

  • Μηχ. Η/Υ & Πληρ. ΠΕ19
  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 94
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ΘΕΜΑ Γ
« Απάντηση #14 στις: 06 Ιούν 2014, 11:39:44 πμ »
Αλγόριθμος ΘΕΜΑΓ   

smax<-0
συντεμ<-0
δοσεις<- 0

!ερώτημα Γ1

Διάβασε κωδ
Διάβασε αρτεμ
Διάβασε τιμη
maxτιμη<- τιμη ! χρειάζεται στο ερώτημα Γ4


Όσο κωδ<>ο επανάλαβε
   
   !ερώτημα Γ2

   λογ<- αρτεμ*τιμη
   Αν λογ <= 500 τότε
      Εμφάνισε “ΠΛΗΡΩΜΗ ΜΕΤΡΗΤΟΙΣ”
   αλλιώς
      δοσεις<- 0
      temp<- λογ
      i<-0
      Αρχή_επανάληψης
         temp<- temp-(20+i*5)
         δοσεις<-δοσεις+1
      Μέχρις_ότου δοσεις<=0
      Εμφάνισε “Αριθμός δόσεων :” , δοσεις
   Τέλος_αν
 
   !ερώτημα Γ3

   συντεμ<-0
   Αν τιμη>10 τότε
      συντεμ<-συντεμ+αρτεμ
   Τέλος αν
   
   ! ερώτημα Γ4

   Αν τιμη>max τότε
      smax<- 0
   αλλιώς αν τιμη=max τοτε
      smax<- smax+αρτεμ
   Τέλος αν

   Διάβασε κωδ
   Διάβασε αρτεμ
   Διάβασε τιμη

Τέλος επανάληψης

!Γ3
Εμφάνισε “Συνολικά τεμάχια με τιμή μεγαλύτερη των 10 ευρώ ”, συντεμ

!Γ4
Εμφάνισε “Συνολικός αριθμός τεμαχίων με την μέγιστη τιμή τεμαχίου”,smax

Τέλος ΘΕΜΑΓ

Πιθανή λύση , την έγραψα γρήγορα , οποιαδήποτε παρατήρηση δεκτή για να κάνω αλλαγές.

τα διαβασε εκτός από τον κωδικό θεωρώ πρέπει να μπουν μια φορά μέσα στην επανάληψη..ώστε αν δίνει κωδικό  0 να σταματάει κ να μην διαβάζει τεμάχια και τιμή..
τον λογ τον ελέγχεις αφού τελειώσει τα ψώνια του ...

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #15 στις: 06 Ιούν 2014, 11:41:22 πμ »
Ο λογαριασμός είναι μετά το τέλος της επανάληψης
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 679
Απ: ΘΕΜΑ Γ
« Απάντηση #16 στις: 06 Ιούν 2014, 12:04:24 μμ »
τα διαβασε εκτός από τον κωδικό θεωρώ πρέπει να μπουν μια φορά μέσα στην επανάληψη..ώστε αν δίνει κωδικό  0 να σταματάει κ να μην διαβάζει τεμάχια και τιμή..
τον λογ τον ελέγχεις αφού τελειώσει τα ψώνια του ...

μια μικρή παρατήρηση....όταν βρει max,
Αν τιμη>max τότε
      smax<- 0
   αλλιώς αν τιμη=max τοτε
      smax<- smax+αρτεμ
   Τέλος αν

τότε smax<--1 και όχι 0....έχω ένα μέγιστο....σωστά???

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Γ
« Απάντηση #17 στις: 06 Ιούν 2014, 12:08:21 μμ »
τότε smax<--1 και όχι 0....έχω ένα μέγιστο....σωστά???

αν βρεθεί maxτιμη μεγαλύτερη από αυτή που είχα μέχρι τώρα ,το smax να γίνει ο τρέχον αριθμός τεμαχίων και να αλλάξει η τιμή του maxτιμη
και αν τιμή είναι ίση με την maxτιμη να προσθέτει τον αριθμό των τεμαχίων

   Αν τιμη>maxτιμη τότε
      maxτιμη<- τιμη
      smax<- αρτεμ
   αλλιώς αν τιμη=maxτιμη τοτε
      smax<- smax+αρτεμ
   Τέλος αν

« Τελευταία τροποποίηση: 06 Ιούν 2014, 12:28:50 μμ από pstasinos »

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 679
Απ: ΘΕΜΑ Γ
« Απάντηση #18 στις: 06 Ιούν 2014, 12:10:58 μμ »
Σωστά συν πόσότητα

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Γ
« Απάντηση #19 στις: 06 Ιούν 2014, 12:16:28 μμ »
 .

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #20 στις: 06 Ιούν 2014, 01:33:39 μμ »
μπορεί το θέμα Γ να λυθεί με πίνακες??

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #21 στις: 06 Ιούν 2014, 01:34:24 μμ »
Δεν υπάρχει μέγεθος πίνακα όταν έχουμε άγνωστο αριθμό επαναλήψεων κι επειδή ο πίνακας είναι στατική δομή, είναι λάθος
Αντίστοιχο θέμα είχε δημιουργηθεί με το 3ο θέμα του 2010, όπου μάλιστα η άσκηση ήταν με Για
Τελικά, για λύση με πίνακα κόπηκαν 2 μονάδες
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #22 στις: 06 Ιούν 2014, 01:40:20 μμ »
Δηλαδή αν η άσκηση λυθεί με πίνακες θα χαθούν όλες οι μονάδες και αν οχι τότε πόσες περίπου?

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #23 στις: 06 Ιούν 2014, 01:41:34 μμ »
Θα κριθεί από το βαθμολογικό κέντρο αυτό, ας απαντήσει κάποιος πιο έμπειρος
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #24 στις: 06 Ιούν 2014, 01:42:38 μμ »
αν γίνεται ας απαντήσει κάποιος ευχαριστώ..

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #25 στις: 06 Ιούν 2014, 01:52:44 μμ »
είναι λάθος αυτό;;

Αλγόριθμος κπ
ι ← 1
π ← 0
Διάβασε Κ[ι]
Αρχή_επανάληψης
  ι ← ι + 1
  π ← π + 1
  Διάβασε Κ[ι]
Μέχρις_ότου Κ[ι] = 0
Για ι από 1 μέχρι π
  Εμφάνισε Κ[ι]
Τέλος_επανάληψης
Τέλος κπ

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: ΘΕΜΑ Γ
« Απάντηση #26 στις: 06 Ιούν 2014, 02:19:28 μμ »
" Δηλαδή αν η άσκηση λυθεί με πίνακες θα χαθούν όλες οι μονάδες και αν οχι τότε πόσες περίπου? "

η εμπειρία λέει ότι σε ανάλογες περιπτώσεις η γραμμή είναι 1 με 2 μόρια ποινή, ακόμη και όταν υπάρχει οδηγία από την ΚΕΕ να κοπούν οι μισές μονάδες
Φυσικά ο κάθε βαθμολογητής έχει την ελευθερία να βαθμολογήσει κατά βούληση.
« Τελευταία τροποποίηση: 06 Ιούν 2014, 04:30:56 μμ από spantoulis »
Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

tsabatman

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 108
Απ: ΘΕΜΑ Γ
« Απάντηση #27 στις: 06 Ιούν 2014, 02:45:35 μμ »
είναι κρίμα ένας μαθητής που έχει αποκτήσει τέτοια ευχέρεια να δημιουργεί πίνακα και να χάσει μονάδες επειδή οι πίνακες είναι στατική δομή.
Βαθμολογούμε την αλγοριθμική σκέψη του παιδιού τελικά ή όχι???

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #28 στις: 06 Ιούν 2014, 02:56:19 μμ »
...σας στέλνω και όλη την επίλυση και ο θεός ή (μάλλον ο διορθωτής) ας βάλει το χέρι του .. :'( :'(

Αλγόριθμος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ
ι ← 1
π ← 0
Διάβασε κ[ι]
Αρχή_επανάληψης
  Αν κ[ι] ≠ 0 τότε
    Αρχή_επανάληψης
      Διάβασε α[ι]
    Μέχρις_ότου α[ι] > 0 και α[ι] = Α_Μ(α[ι])
    Αρχή_επανάληψης
      Διάβασε τ[ι]
    Μέχρις_ότου τ[ι] > 0
    ι ← ι + 1
    π ← π + 1
    Διάβασε κ[ι]
  Τέλος_αν
Μέχρις_ότου κ[ι] = 0
λογαριασμος ← 0
Για ι από 1 μέχρι π
  λογαριασμος ← λογαριασμος + (τ[ι] + α[ι])
Τέλος_επανάληψης
Αν λογαριασμος ≤ 500 τότε
  Εμφάνισε "μετρητα"
αλλιώς
  σ ← 0
  δοση ← 20
  ν ← 0
  Όσο σ < λογαριασμος επανάλαβε
    σ ← σ + δοση
    ν ← ν + 1
    δοση ← δοση + 5
  Τέλος_επανάληψης
  Εμφάνισε "αριθμός δόσεων:", ν
Τέλος_αν

σ ← 0
μαξ ← -1
Για ι από 1 μέχρι π
  Αν τ[ι] > 10 τότε
    σ ← σ + α[ι]
  Τέλος_αν
  Αν τ[ι] > μαξ τότε
    μαξ ← τ[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμος τεμαχιων με τιμη μεγαλυτερη των 10:", σ
σ ← 0
Για ι από 1 μέχρι π
  Αν τ[ι] = μαξ τότε
    σ ← σ + α[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμοσ τεμαχιων με την μεγιστη τιμη:", σ
Τέλος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ





petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #29 στις: 06 Ιούν 2014, 03:04:02 μμ »
Μια προφανής ανοησία που υπάρχει στην εκφώνηση του θέματος είναι ότι οι δόσεις, ενώ είναι άτοκες, θα ξεπεράσουν τελικά σαν σύνολο το ποσό του λογαριασμού. Ίσως θα έπρεπε να δοθεί οδηγία να αφαιρείται η διαφορά από την τελευταία δόση, αν και το ερώτημα ήταν μόνο ο αριθμός των δόσεων
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

themata

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: ΘΕΜΑ Γ
« Απάντηση #30 στις: 06 Ιούν 2014, 03:20:53 μμ »
Γεια σας,

Επειδή ακούγονται ΠΑΛΙ (όπως το 2010) διάφορα, To θέμα ΔΕΝ πρέπει να λυθεί με πίνακες.
Και αναφερόμαστε στην χρήση πινάκων με βαση την ύλη του μαθήματος όχι με βάση την επιστήμη της πληροφορικής.

Dimitrissl

  • Νέος
  • *
  • Μηνύματα: 1
Απ: ΘΕΜΑ Γ
« Απάντηση #31 στις: 06 Ιούν 2014, 03:58:59 μμ »
Γεια σας,

Επειδή ακούγονται ΠΑΛΙ (όπως το 2010) διάφορα, To θέμα ΔΕΝ πρέπει να λυθεί με πίνακες.
Και αναφερόμαστε στην χρήση πινάκων με βαση την ύλη του μαθήματος όχι με βάση την επιστήμη της πληροφορικής.

Συμφωνώ απολύτως. Η λύση με πίνακες δεν οδηγεί μόνο σε μη υλοποιήσιμη εκτέλεση αλλά διευκολύνει (σχετικά) και το ερώτημα Γ4. 

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: ΘΕΜΑ Γ
« Απάντηση #32 στις: 06 Ιούν 2014, 04:03:55 μμ »
Συμφωνώ απολύτως. Η λύση με πίνακες δεν οδηγεί μόνο σε μη υλοποιήσιμη εκτέλεση αλλά διευκολύνει (σχετικά) και το ερώτημα Γ4. 

Μα λόγω του Γ4 οι περισσοτεροι οδηγήθηκαν σε πίνακα. θεωρω ότι καποια μορια πρεπει να κοπουν. σε καμια περιπτωση όμως ολόκληρη ή η μιση ασκηση. 2 μορια θεωρω ειναι αρκετα! όσα θα εχαναν αν δεν εγραφαν:
αλλιως_αν τιμή = max τοτε
     s<- s + ατ

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: ΘΕΜΑ Γ
« Απάντηση #33 στις: 06 Ιούν 2014, 04:11:03 μμ »
Για το συγκεκριμένο ζήτημα έχω εκφράσει την άποψή μου παλαιότερα εδώ μέσα και δεν έχει νόημα να επαναλαμβανόμαστε.
 Η ουσία είναι ότι τελικά παρά τις ατέρμονες συζητήσεις, οι μεν δεν έχουν πείσει τους δε, και οι περισσότεροι συμβιβάζονται με τη γραμμή που λέει ποινή 1 με 2 μόρια. Φυσικά υπάρχει ένα  ποσοστό βαθμολογητών που δεν κόβει ούτε μόριο και ένα άλλο που κόβει τα μισά μόρια του ερωτήματος.
Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: ΘΕΜΑ Γ
« Απάντηση #34 στις: 06 Ιούν 2014, 04:16:47 μμ »
Δε νομίζω να λέει κάποιος ότι πρέπει να κοπεί όλη η άσκηση (ή ακόμα και η μισή). Το κρίσιμο ερώτημα με το max έπιανε 6 μονάδες (από το οποίο περίπου οι μισές φαντάζομαι είναι να βρεις σκέτο max με ένα Αν, ενώ αν κάνεις και το αλλιώς_αν τιμή=max θα πάρεις και τις άλλες 3). Άρα όντως μιλάμε για 1-2 μονάδες πιστεύω (αυτός που το έκανε με πίνακα έχει καταλάβει ακριβώς τι ζητά η άσκηση).
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: ΘΕΜΑ Γ
« Απάντηση #35 στις: 06 Ιούν 2014, 04:29:57 μμ »
Παιδιά μην μπερδεύετε το συγκεκριμένο θέμα με του 2010, δεν μοιάζουν. Φέτος έχουμε επανάληψη με τιμή φρουρό.

Είναι ξεκάθαρο ότι πρέπει να κοπούν κάποιες μονάδες για τη χρηση πίνακα.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

GEG

  • Βετεράνος
  • ****
  • Μηνύματα: 88
Απ: ΘΕΜΑ Γ
« Απάντηση #36 στις: 06 Ιούν 2014, 04:32:39 μμ »

Κάποιοι μαθητές θεώρησαν οτι έχουμε πολλούς πελάτες με ένα προιον ο καθένας ενω προφανώς προκειται για έναν πελάτη που αγοράζει αρκετά προιόντα. Έτσι υπολόγισαν το λογαριασμό καθενός ως τεμχ*τιμή και για τον κάθε λογαριασμό αυτό υπολόγισαν σωστά το πλήθος των δόσεων μέσα στην Όσο (ή την Μέχρις_οτου).
Νομίζω πρέπει να υπάρξει κάποια επιείκια όπως σε ανάλογες περιπτώσεις στο παρελθόν  (Θέμα Δ 2012)
Hey! It compiles! Ship it! :-)

dg69

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 71
  • Όλα καλά, όλα ανθηρά
Απ: ΘΕΜΑ Γ
« Απάντηση #37 στις: 06 Ιούν 2014, 04:34:01 μμ »
Πόσες όμως; Ειδικά το Γ4 είναι πιθανό πολλοί μαθητές να χρησιμοποίησαν πίνακες για βρούνε το max...Θα δούμε αύριο στις συναντήσεις μας

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #38 στις: 06 Ιούν 2014, 04:34:21 μμ »
Κάποιοι μαθητές θεώρησαν οτι έχουμε πολλούς πελάτες με ένα προιον ο καθένας ενω προφανώς προκειται για έναν πελάτη που αγοράζει αρκετά προιόντα. Έτσι υπολόγισαν το λογαριασμό καθενός ως τεμχ*τιμή και για τον κάθε λογαριασμό αυτό υπολόγισαν σωστά το πλήθος των δόσεων μέσα στην Όσο (ή την Μέχρις_οτου).
Νομίζω πρέπει να υπάρξει κάποια επιείκια όπως σε ανάλογες περιπτώσεις στο παρελθόν  (Θέμα Δ 2012)

Μα αναφέρεται 2 φορές η λέξη "πελάτης"
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

GEG

  • Βετεράνος
  • ****
  • Μηνύματα: 88
Απ: ΘΕΜΑ Γ
« Απάντηση #39 στις: 06 Ιούν 2014, 04:42:45 μμ »
Μα αναφέρεται 2 φορές η λέξη "πελάτης"
Πέτρο Ναι αναφέρεται ρητά ειδικά στην αρχη της εκφώνησης .... απλά νομίζω οτι δεν πρέπει να αφαιρεθούν περισσότερες απο 2 μονάδες
Hey! It compiles! Ship it! :-)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #40 στις: 06 Ιούν 2014, 04:44:33 μμ »
Λυπάμαι τους βαθμολογητές κάθε χρόνο γιατί οι παρερμηνείες των μαθητών και τα πιθανά λάθη είναι ατελείωτα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #41 στις: 06 Ιούν 2014, 04:59:26 μμ »
Και οι πιθανές σωστές λύσεις που μπορούν να δώσουν οι μαθητές είναι ατελείωτες. Ακόμη και με χρήση πινάκων!!! Αντιγράφω το κομμάτι του υπολογισμού του πλήθους των μεγίστων.

Αλγόριθμος ΘΓ
! Θεωρώ ως μέγιστο μέγεθος πίνακα το 100.
Αρχή_επανάληψης
Διάβασε Ν!στο Ν δίνουμε τη τιμή του μεγέθους του πίνακα που θέλουμε να χρησιμοποιήσουμε
Μέχρις_ότου Ν ≥ 1 και Ν ≤ 100

max_previous ← 0
pmax_previous ← 0
Για κ από 1 μέχρι Ν
  Τ[κ] ← 0
Τέλος_επανάληψης
πλ_επ ← 1
ι ← 1
Διάβασε κωδ
Όσο κωδ ≠ 0 επανάλαβε
  Διάβασε Τ[ι], αρ_τεμ[ι]
  ι ← ι + 1
  Διάβασε κωδ

  Αν ι = πλ_επ* Ν + 1 ή κωδ = 0 τότε
    max ← Τ[1]
    Για κ από 1 μέχρι Ν
      Αν max < Τ[κ] τότε
        max ← Τ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    pmax ← 0
    Για κ από 1 μέχρι Ν
      Αν max = Τ[κ] τότε
        pmax ← pmax + αρ_τεμ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    Αν max_previous = max τότε
      pmax_previous ← pmax_previous + pmax
    αλλιώς_αν max_previous < max τότε
      max_previous ← max
      pmax_previous ← pmax
    Τέλος_αν
    Για κ από 1 μέχρι Ν
      Τ[κ] ← 0
    Τέλος_επανάληψης
    ι ← 1
    πλ_επ ← πλ_επ + 1
  Τέλος_αν

Τέλος_επανάληψης
Εμφάνισε pmax_previous
Τέλος ΘΓ

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: ΘΕΜΑ Γ
« Απάντηση #42 στις: 06 Ιούν 2014, 05:12:23 μμ »
Την παραπάνω λύση την έδωσε μαθητής ή την προτείνεις ως σωστή; Τι είναι το Ν; Γιατί μέγιστο 100; κλπ κλπ
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #43 στις: 06 Ιούν 2014, 05:21:58 μμ »
Την παραπάνω λύση την έδωσε μαθητής ή την προτείνεις ως σωστή; Τι είναι το Ν; Γιατί μέγιστο 100; κλπ κλπ

Παραθέτω τη λύση επειδή βλέπω ότι καταγράφεται γενικά η άποψη, ότι η χρήση πινάκων είναι λάθος.
Το Ν είναι το μέγεθος ενός προσωρινού πίνακα που χρησιμοποιείται για την εύρεση του μεγίστου. Το μέγεθος του εξαρτάται αποκλειστικά από τον προγραμματιστή.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #44 στις: 06 Ιούν 2014, 05:53:45 μμ »
Νομίζω ότι υπάρχει μια παρανόηση σχετικά με τη χρήση πινάκων. Το θέμα είναι πως ο μαθητής θα χρησιμοποιήσει τους πίνακες.
Προφανώς ένας μαθητής που έχει χρησιμοποιήσει πίνακα όπως προτείνει ο aperdos είναι σίγουρα αρκετά καλός για να βρει τη λύση και χωρίς πίνακες.
Το πρόβλημα εδώ είναι το εξής
Αν ο μαθητής χρησιμοποιεί πίνακα και θεωρεί γνωστό πλήθος οπότε έχει Για τότε ακυρώνει σχεδόν τα μισά ερωτήματα, οπότε εκεί θα κοπούν μονάδες από όλα τα ερωτήματα. Υπολογίζω σε αυτή την περίπτωση να χάνει 8-10 μονάδες

Αν όμως ο μαθητής χρησιμοποιεί πίνακα ο οποίος μεγαλώνει δυναμικά σε κάθε επανάληψη (άρα έχει κάνει κανονικά την ΌΣΟ όπως προβλέπεται) τα πράγματα είναι διαφορετικά. Εκεί θα πρέπει να κοπούν πολύ λιγότερες μονάδες και πάντα σε συνάρτηση με την εικόνα του γραπτού, δηλαδή σε αυτή την περίπτωση υπολογίζω το πολύ 5 μονάδες δεδομένου ότι ο μαθητής ξεγλιστράει μόνο από το τελευταίο ερώτημα και όχι από τα άλλα.

Γενικά πάντως όποιος χρησιμοποιεί πίνακα με γνωστό μέγεθος από την στιγμή που υπάρχει τιμή φρουρός θα χάσει πολλές μονάδες. Αυτό το λέω όχι ως άποψη αλλά ως συμπέρασμα από την συζήτηση που κάναμε σήμερα στο βαθμολογικό

Επίσης κατά τη γνώμη μου υπάρχει πρόβλημα στην εκφώνηση του θέματος Γ . Έτσι όπως δίνεται πολλοί μαθητές νόμισαν ότι ο λογαριασμός δεν είναι ο συνολικός αλλά είναι διαφορετικός για κάθε προιόν, άρα τα έκαναν όλα μέσα στην επανάληψη. Αυτό είναι πρόβλημα της εκφώνησης.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #45 στις: 06 Ιούν 2014, 06:05:47 μμ »
Evry συμφωνώ απόλυτα με αυτά που γράφεις τόσο για τον τρόπο που χρησιμοποιείται ο πίνακας όσο και για τις μονάδες που πρέπει να κοπούν.
Τώρα σχετικά με λύσεις που δίνουν μερικές φορές οι μαθητές, δεν σταματούν να μας εκπλήσουν.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2787
  • Πύργος Ηλείας
Απ: ΘΕΜΑ Γ
« Απάντηση #46 στις: 06 Ιούν 2014, 06:09:34 μμ »
Παιδιά μην μπερδεύετε το συγκεκριμένο θέμα με του 2010, δεν μοιάζουν. Φέτος έχουμε επανάληψη με τιμή φρουρό.

Είναι ξεκάθαρο ότι πρέπει να κοπούν κάποιες μονάδες για τη χρηση πίνακα.

+1

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2787
  • Πύργος Ηλείας
Απ: ΘΕΜΑ Γ
« Απάντηση #47 στις: 06 Ιούν 2014, 06:19:53 μμ »
Επίσης κατά τη γνώμη μου υπάρχει πρόβλημα στην εκφώνηση του θέματος Γ . Έτσι όπως δίνεται πολλοί μαθητές νόμισαν ότι ο λογαριασμός δεν είναι ο συνολικός αλλά είναι διαφορετικός για κάθε προιόν, άρα τα έκαναν όλα μέσα στην επανάληψη. Αυτό είναι πρόβλημα της εκφώνησης.

+1

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: ΘΕΜΑ Γ
« Απάντηση #48 στις: 06 Ιούν 2014, 07:03:27 μμ »
Συνάδελφοι και πάλι με το θέμα Γ προκύπτει το πρόβλημα με την χρήση πινάκων ή όχι.
Η άποψή μου είναι ότι από την μια σε όλη την διάρκεια της χρονιάς "πιπιλάμαι" τα μυαλά των μαθητών ότι η χρήση πίνακα σε μη γνωστό αριθμό επαναλήψεων καλό θα είναι να αποφεύγεται.
Από την άλλη όμως σε επίλυση αλγορίθμου δεν είναι απαγορευτικό να λύσουμε ένα πρόβλημα χρησιμοποιώντας πίνακα Ν στοιχείων,εφόσον το Ν θα είναι πεπερασμένο.
Από την στιγμή λοιπόν που η επιτροπή εξετάσεων δεν αναφέρει σε μια σημείωση : ο αλγόριθμος να γίνει χωρίς την χρήση πινάκων (τόσο απλό, με μια σημείωση), θα πρέπει να θεωρούμε και τις δυο λύσεις σωστές.

niaboc99

  • Νέος
  • *
  • Μηνύματα: 1
Απ: ΘΕΜΑ Γ
« Απάντηση #49 στις: 06 Ιούν 2014, 07:16:37 μμ »
Αλγόριθμος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ
ι ← 1
π ← 0
Διάβασε κ[ι]
Αρχή_επανάληψης
  Αν κ[ι] ≠ 0 τότε
    Αρχή_επανάληψης
      Διάβασε α[ι]
    Μέχρις_ότου α[ι] > 0 και α[ι] = Α_Μ(α[ι])
    Αρχή_επανάληψης
      Διάβασε τ[ι]
    Μέχρις_ότου τ[ι] > 0
    ι ← ι + 1
    π ← π + 1
    Διάβασε κ[ι]
  Τέλος_αν
Μέχρις_ότου κ[ι] = 0
λογαριασμος ← 0
Για ι από 1 μέχρι π
  λογαριασμος ← λογαριασμος + (τ[ι] * α[ι])
Τέλος_επανάληψης
Αν λογαριασμος ≤ 500 τότε
  Εμφάνισε "μετρητα"
αλλιώς
  σ ← 0
  δοση ← 20
  ν ← 0
  Όσο σ < λογαριασμος επανάλαβε
    σ ← σ + δοση
    ν ← ν + 1
    δοση ← δοση + 5
  Τέλος_επανάληψης
  Εμφάνισε "αριθμός δόσεων:", ν
Τέλος_αν

σ ← 0
μαξ ← -1
Για ι από 1 μέχρι π
  Αν τ[ι] > 10 τότε
    σ ← σ + α[ι]
  Τέλος_αν
  Αν τ[ι] > μαξ τότε
    μαξ ← τ[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμος τεμαχιων με τιμη μεγαλυτερη των 10:", σ
σ ← 0
Για ι από 1 μέχρι π
  Αν τ[ι] = μαξ τότε
    σ ← σ + α[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμοσ τεμαχιων με την μεγιστη τιμη:", σ
Τέλος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ



Όταν τρέχω τον παραπάνω αλγόριθμο στο pc σε γλώσσα δεν εμφανίζει κάποιο λάθος και τον τρέχει κανονικά.
Αυτό δεν σημαίνει ότι θα έπρεπαι να κοπούν(αυστηρά) το πολύ 3 μονάδες ?

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 786
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: ΘΕΜΑ Γ
« Απάντηση #50 στις: 06 Ιούν 2014, 07:19:54 μμ »
Απο τη στιγμή που η επιτροπή δεν αναφέρει ότι ζητείται η σωστή επίλυση του προβλήματος, κάθε λύση πρέπει να θεωρηθεί δεκτή!

manu

  • Νέος
  • *
  • Μηνύματα: 7
Απ: ΘΕΜΑ Γ
« Απάντηση #51 στις: 06 Ιούν 2014, 07:29:00 μμ »
Εάν είναι να κοπούν μονάδες πόσες θα κοπούν το πολύ στις 100??  ???

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 548
  • There can be only one...may it be AEPP.
Απ: ΘΕΜΑ Γ
« Απάντηση #52 στις: 06 Ιούν 2014, 09:17:05 μμ »
Παράθεση
...Πάλι τα ίδια...(με το 2010 Θέμα Γ)...Τί πείραζε ένα ερώτημα στο τέλος:
"Γ5. Να γραφεί (ξέχωρα) το τμήμα δήλωσης μεταβλητών  που χρησιμοποιεί ο αλγόριθμος"
(Από τηλεφωνική συνομιλία με Φανίκο)
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: ΘΕΜΑ Γ
« Απάντηση #53 στις: 06 Ιούν 2014, 09:18:27 μμ »
(Από τηλεφωνική συνομιλία με Φανίκο)

Προφανώς γιατί κάποιοι πιστεύουν ότι το να βάζεις τέτοια θέματα ειναι χαριτωμένο.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #54 στις: 06 Ιούν 2014, 09:20:38 μμ »
ακόμα καλύτερα, θα έλεγα:
Να γραφτεί πρόγραμμα
και έτσι λύνονται όλα τα προβλήματα.

Παρεμπιπτόντως αν δεν κάνω λάθος (διορθώστε με) δεν έβαλαν τίποτα από τα κεφάλαια
  1, 7, 8, 9, 10

(το ότι μπήκε ένα ΣΛ από το 10 δε σημαίνει κάτι)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: ΘΕΜΑ Γ
« Απάντηση #55 στις: 06 Ιούν 2014, 09:23:38 μμ »
ακόμα καλύτερα, θα έλεγα:
Να γραφτεί πρόγραμμα

και έτσι λύνονται όλα τα προβλήματα.

Παρεμπιπτόντως αν δεν κάνω λάθος (διορθώστε με) δεν έβαλαν τίποτα από τα κεφάλαια
  1, 7, 8, 9, 10

(το ότι μπήκε ένα ΣΛ από το 10 δε σημαίνει κάτι)

+1

Σαφώς και αυτή θα έπρεπε να ήταν η αντιμετώπισή για να πάρουν απάντηση χωρίς πίνακες. Το όλο θέμα ειναι εντελώς τσίρκο.

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: ΘΕΜΑ Γ
« Απάντηση #56 στις: 06 Ιούν 2014, 09:55:08 μμ »


Παρεμπιπτόντως αν δεν κάνω λάθος (διορθώστε με) δεν έβαλαν τίποτα από τα κεφάλαια
  1, 7, 8, 9, 10

(το ότι μπήκε ένα ΣΛ από το 10 δε σημαίνει κάτι)

κεφ 8 σελ 180 εμφωλευμένοι βρόχοι
VR in Computing

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #57 στις: 06 Ιούν 2014, 10:46:22 μμ »
ουπς, μ'έπιασες, μάλλον το καλοκαίρι πρέπει να κάτσω να διαβάσω λίγο θεωρία :-)

κεφ 8 σελ 180 εμφωλευμένοι βρόχοι
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Pavlos1908

  • Νέος
  • *
  • Μηνύματα: 4
Απ: ΘΕΜΑ Γ
« Απάντηση #58 στις: 06 Ιούν 2014, 11:17:46 μμ »
Και εγω μαθητης ειμαι και το εκανα με πινακα που μετα που τελειωσα καταλαβα οτι δεν επρεπε λογω στατικοτητας να βαλω πινακα ομως ετσι οπως ηταν διατυπωμενο το Γ4 δεν μπορουσα να σκεφτω κατι αλλο.

Εκανα το εξης και θα ηθελα την γνωμη σας οσον αφορα ποσα μορια θα μου κοψουν:
i<--o
διαβασε κωδ
οσο κωδ<>0 επαναλαβε
i<--i+1
διαβασε αρτεμ1 ,τιμτεμ1 , κωδ
ΤΙΜ[Ι]<-- τιμτεμ1
ΑΡΤΕΜ[Ι]<-- αρτεμ1


και χρησιμοποιησα τον πινακα στο Γ4 ομως και στο Γ3 καθως το εβαλα σε ξεχωριστη δομη ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ I ( οπου I ηταν γνωστο απο πανω ) και θεωρησα τους πινακες δεδομενους. Ποσα μορια πιστευετε στα 100 οτι θα χασω;

σημειωση: θεωρω κι εγω απαραδεκτη την εκφωνηση, με οσα παιδια εχω μιλησει το 90% το εχει κανει με πινακες, στο κατω κατω ας εβαζαν μια σημειωση "δεν ενδεικνυεται λυση με χρηση πινακων", ποσο δυσκολο θα ηταν ωστε να αποφυγουμε τις παρερμηνειες; Οπως ειπατε και εσεις πιο πανω, δυστυχως καλοι μαθητες με αλγοριθμικοι σκεψη την πατησαν λογω της "στενης" υλης περι στατικοτητας.

alex goug

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #59 στις: 06 Ιούν 2014, 11:52:24 μμ »
Τι γινεται με αυτους που στο γ4 δεν εξετασαν την ισοτητα?

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1095
Απ: ΘΕΜΑ Γ
« Απάντηση #60 στις: 07 Ιούν 2014, 01:13:02 πμ »
Γιατί όμως, ακόμα μας απασχολεί η χρήση ή όχι των πινάκων σε τέτοιου είδος ασκήσεων;

Αυτό είχε ξεκαθαριστεί το 2010 , στο θέμα Γ της τότε χρονιάς. Με μια αναζήτηση στο ΣΤΕΚΙ  μπορεί κάποιος να δει τι σάλος είχε προκληθεί. Τότε είχαν δοθεί και ξεκάθαρες οδηγίες για τη βαθμολόγηση.
Το ίδιο και το 2011, και τις επόμενες χρονιές.

Και όμως το πρόβλημα υπάρχει και επανεμφανίζεται.
Γιατί άραγε;

Μήπως πρέπει να αναρωτηθούμε να  φταίμε εμείς ( οι καθηγητές);
Μήπως ακόμα διδάσκουμε στους  μαθητές μας ότι όλες οι ασκήσεις λύνονται με πίνακες.
Μήπως εκμεταλλευόμαστε την ψευδογλώσσα που παρέχει ελευθερία γραφής και όλα συγχωρούνται;

Νομίζω αυτά πρέπει να μας ανησυχήσουν..

dg69

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 71
  • Όλα καλά, όλα ανθηρά
Απ: ΘΕΜΑ Γ
« Απάντηση #61 στις: 07 Ιούν 2014, 02:00:24 πμ »
Στους μαθητές μας αναφέρουμε στο κεφάλαιο 1: Η κατανόηση είναι συνάρτηση μπλα μπλα... της σωστής διατύπωσης  μπλα μπλα..

Η εκφώνηση του Β2: Να κωδικοποιήσετε τον παραπάνω αλγόριθμο σε ψευδογλώσσα.

Δεν αναφέρει πουθενά τη λέξη ισοδύναμο. Δεν πρέπει να μπούμε (με την εμπειρία που έχουμε) εμείς στο πνεύμα της επιτροπής, (ναι συμφωνώ ότι το πνεύμα της επιτροπής είναι να γίνει ΟΣΟ ή ΓΙΑ), αλλά να μπούμε στη φιλοσοφία των μαθητών. Γιατί να είναι λάθος, ΣΤΟ ΣΥΓΚΕΚΡΙΜΕΝΟ (τονίζω) διάγραμμα ροής, η χρήση της ΜΕΧΡΙΣ_ΟΤΟΥ, όταν δίνει το ίδιο αποτέλεσμα; Τελικά, δεν αλλάζουμε (συμφωνώ με τον freedomst) και εμείς κάτι για να το κάνουμε ΟΣΟ;
Διαφωνώ με πνεύμα της επιτροπής (λες και τη νοιάζει...), παρότι κάνω το μάθημα τόσα χρόνια, όσα υπάρχει.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #62 στις: 07 Ιούν 2014, 09:21:00 πμ »
αν όλα τα άλλα τα έχεις σωστά τότε υπολόγιζε από 2 εώς 3 μόρια, που είναι το πιθανότερο.
Επειδή όμως όλη η ιδέα του θέματος είναι αυτή μπορεί κάποιος να σου κόψει και λίγο παραπάνω, π.χ. 4 αν και αυτό μου φαίνεται ακραίο.

Τι γινεται με αυτους που στο γ4 δεν εξετασαν την ισοτητα?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #63 στις: 07 Ιούν 2014, 09:31:55 πμ »
Πολύ σωστά Γιώργο.
Όσοι καθηγητές δίδάσκαν στους μαθητές τους ότι μπορούν να χρησιμοποιούν πίνακες σε τέτοιες ασκήσεις που δεν γνωρίζουν το μέγεθος του πίνακα εξαρχής, νομίζω ότι
είναι υπεύθυνοι για την κατάσταση αυτή, και δεν πρέπει να κατηγορούν για όλα την επιτροπή που είναι ο εύκολος στόχος για τις δικές μας παραλείψεις.
Σίγουρα φέτος η επιτροπή έκανε πολλά φάουλ αλλά δεν φταίει και για αυτό. Απλά είναι πιο εύκολο να πούμε σε έναν μαθητή ότι "φταίνε οι άσχετοι που έβαλαν τα θέματα" και όχι ότι "φταίω εγώ που στο δίδασκα λάθος".

Από την εμπειρία που έχω στη συζήτηση με μαθητές για το θέμα αυτό σε όσα σχολεία έχω πάει είναι ότι η συντριπτική πλειοψηφία που χρησιμοποιούσε τέτοιες λύσεις δεν τις είχαν σκεφτεί μόνοι τους αλλά κάποιος τους τις είχε δείξει. Πολλοί καθηγητές λένε στα παιδιά ότι "αν κολλήσεις και δεν σου βγαίνει χωρίς πίνακα, πάρε πίνακα, ειδικά αν είναι αλγόριθμος, εκεί μπορείς".
Ας αναλάβουν τώρα τις ευθύνες τους.

Άσχετα με τον αν διαφωνείς ή συμφωνείς με κάτι όταν ξέρεις ότι είναι γκρίζα ζώνη και ότι κάποιοι μπορεί να κόψουν για αυτό στον μαθητή σου, δεν το λες, τον προστατεύεις.

ΥΓ. Εξαιρώ έναν μαθητή που γνώρισα κάποτε που έκανε το ίδιο αλλά τον είχε επηρεάσει η Python :laugh:


Γιατί όμως, ακόμα μας απασχολεί η χρήση ή όχι των πινάκων σε τέτοιου είδος ασκήσεων;

Αυτό είχε ξεκαθαριστεί το 2010 , στο θέμα Γ της τότε χρονιάς. Με μια αναζήτηση στο ΣΤΕΚΙ  μπορεί κάποιος να δει τι σάλος είχε προκληθεί. Τότε είχαν δοθεί και ξεκάθαρες οδηγίες για τη βαθμολόγηση.
Το ίδιο και το 2011, και τις επόμενες χρονιές.

Και όμως το πρόβλημα υπάρχει και επανεμφανίζεται.
Γιατί άραγε;

Μήπως πρέπει να αναρωτηθούμε να  φταίμε εμείς ( οι καθηγητές);
Μήπως ακόμα διδάσκουμε στους  μαθητές μας ότι όλες οι ασκήσεις λύνονται με πίνακες.
Μήπως εκμεταλλευόμαστε την ψευδογλώσσα που παρέχει ελευθερία γραφής και όλα συγχωρούνται;

Νομίζω αυτά πρέπει να μας ανησυχήσουν..

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: ΘΕΜΑ Γ
« Απάντηση #64 στις: 07 Ιούν 2014, 02:51:50 μμ »
Μήπως εκμεταλλευόμαστε την ψευδογλώσσα που παρέχει ελευθερία γραφής και όλα συγχωρούνται;

Προφανώς και εκμεταλλεύεσε την ελευθερία γραφής. Ο λόγος ύπαρξης της ψευδογλώσσας είναι για να εξαφανίζει τον θόρυβο που προκαλεί η διαχείρηση της υλοποίησης. Εαν εγώ θέλω να γράφω πινακες που δεν γνωρίζω το μέγεθός του απλούστατα δεν υπάρχει κανένα πρόβλημα για μένα. Εγώ απλώς χρησιμοποιώ μια δομή με καλά ορισμένα semantics και αδιαφορώ για το πώς υλοποιείται. Δεν υπάρχει μνήμη και επεξεργαστής και compiler όταν γράφεις σε ψευδογλώσσα. Άν κάποιος απο κει και πέρα θέλει να μεταφράσει τον αλγόριθμο της ψευδογλώσσα σε μία υλοποίηση που δεν παρέχει dynamic memory allocation, ε τότε σαφώς και έχει πρόβλημα.

Όταν θες ανθρώπους να σου γράψουν μια λύση υπό τη πρίσμα της μη ύπαρξης dynamic memory allocation τους αναγκάζεις να την γράψουν σε κάτι που δεν έχει αυτό το περιθώριο. Δεν μπορεί να σου δίνω να μου γράψεις ένα σονέτο και μετά να σου κάνω και παρατήρηση επειδή η νότα αυτή πχ δεν παίζει καλά στο πιάνο μου επειδή βαριόμουν να την κουρδίσω, οπότε βρες τρόπο να την παρακάμψεις.

vrepantis

  • Νέος
  • *
  • Μηνύματα: 2
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ΘΕΜΑ Γ
« Απάντηση #65 στις: 07 Ιούν 2014, 03:32:36 μμ »
Kαλημέρα,
(Τροποποιώ το σχόλιο και αφήνω την ουσία της άποψής μου)... Για έναν μαθητή με εξαιρετική γνώση αλγοριθμικής και δομών δεδομένων.  Παρόλο που πολλές φορές φέτος λέμε στην τάξη "όχι πίνακες" σε τέτοια προβλήματα, υπάρχουν περιπτώσεις που λύνουν με πίνακα το Γ.  Η απάντηση: "Μα αφού δε χρειάζεται να δηλώσω το μέγεθος του πίνακα σε ψευδοκώδικα".

Και όντως δε χρειάζεται. Και εδώ είναι το πρόβλημα. Να ζητάμε να θυμάται διαρκώς ο μαθητής μια δομή ως δέσμευση μνήμης πεπερασμένου μεγέθους χωρίς να πρέπει να δηλώσει το ίδιο το μέγεθος αυτό. Ας ζητούσαμε (4 χρόνια από τότε που είχε ανακύψει το ίδιο θέμα) να δηλώνονται εξ’ αρχής έστω οι μεταβλητές και οι δομές δεδομένων, στον ψευδοκώδικα. Όχι όμως, καθότι υπάρχει και η διαμάχη ανάμεσα στη Γλώσσα και στον «ψευδοκώδικα». «Ας έκανε Γλώσσα»… Ναι, αλλά λέει αλγόριθμος το θέμα. «Αφού αλγόριθμος σημαίνει κάνε ψευδογλώσσα ή Γλώσσα»… Ναι, αλλά αλγόριθμος σε ψευδογλώσσα πρέπει «υποχρεωτικά» να ξεκινάει με τη λέξη Αλγόριθμος (και ας ξέρουμε πως όταν οι μαθητές μας λένε αλγόριθμος εννοούν ψευδοκώδικα). Πόσοι μέχρι την τελευταία μέρα υπενθυμίζουμε πως όταν λέει αλγόριθμος, μπορούν να κάνουν Γλώσσα ή ψευδοκώδικα; Σαν να υπηρετούμε ένα κράμα από οδηγίες που βασικά τα αγχώνουν περισσότερο τα παιδιά. Αλήθεια, γιατί δεν ρωτούσε το θέμα πρόγραμμα σε ΓΛΩΣΣΑ; Να τέλειωνε εκεί το ζήτημα.

Απλά αρνούμαι από συναδέλφους να ζητάνε ευθύνες από τους διδάσκοντες για την κατάσταση αυτή. Όσοι το είπαμε στη τάξη (η πλειοψηφία είμαι σίγουρος μετά την ιστορία του 2010), ξέρουμε πως πάλι υπάρχουν μαθητές μας που έκαναν πίνακα (γιατί άραγε;). Αρνούμαι επίσης εκ μέρους των διδασκόντων την ευθύνη για το ό,τι ένας μαθητής μας μπορεί να μετέτρεψε το διάγραμμα ροής σε Αρχή_επανάληψης ή Για και όχι Οσο αν είναι ισοδύναμο, αν έκανε τρισδιάστατο πίνακα για το Δ, κοκ. Αν κάτι στέκει θα το πιάσουμε λάθος; Πού υπάρχουν οδηγίες να ΜΗΝ τα κάνουν αυτά οι καλοί μαθητές; Θεωρώ πως φέτος ειδικά, θα πρέπει όσοι συμμετέχουν στη βαθμολόγηση να έχουμε ανοιχτό μυαλό. Και ό,τι είναι επιστημονικώς ορθό, ό,τι στέκει αλγοριθμικά να το δεχθούμε.
« Τελευταία τροποποίηση: 08 Ιούν 2014, 01:08:39 μμ από vrepantis »

manu

  • Νέος
  • *
  • Μηνύματα: 7
Απ: ΘΕΜΑ Γ
« Απάντηση #66 στις: 07 Ιούν 2014, 08:47:32 μμ »
Τελικά έχει δωθεί κάποια διευκρίνιση για το θέμα Γ σε ότι αφορά την χρήση πινάκωνν?? Εγώ το έλυσα με πίνακα και  τον χρησιμοποίησα στα Γ3 και Γ4 .. θα μπορούσε κάποιος καθηγητής που εμπλέκεται στην φετινή βαθμολόγηση των γραπτών να μου προσωπική άποψη για το πόσα μόρια θα έκοβε από το κάθε ερώτημαααα?   :(

arisbasil

  • Θαμώνας
  • ***
  • Μηνύματα: 28
  • 1+1=10
Απ: ΘΕΜΑ Γ
« Απάντηση #67 στις: 07 Ιούν 2014, 10:47:44 μμ »
Πάντως στο αντίστοιχο θέμα στο εσπερινό υπάρχει καλύτερη διατύπωση λέγοντας "...να εμφανίζει τον τελικό λογαριασμό...".
Θα μπορούσε να γίνει το ίδιο και στα ημερήσια, δηλαδή να δοθεί "Αν ο τελικός λογαριασμός..."

Rathaniel

  • Βετεράνος
  • ****
  • Μηνύματα: 77
  • Έπρεπε να είχα γίνει Χημικός......
Απ: ΘΕΜΑ Γ - Βαθμολόγηση για τους Φ.Α.
« Απάντηση #68 στις: 07 Ιούν 2014, 11:47:46 μμ »
σας παραθέτω πως έγινε η βαθμολόγηση για το ΘΕΜΑ Γ για τους σημερινούς Φ.Α. μετά από αρκετή κουβέντα με τους 27 συναδέλφους των επιτροπών (Συγχωρήστε αν γράφω τα προφανή):

Γ1. Το επαναληπτικό Διάβασε Κωδ, με Όσο (2 μονάδες). Αν λυνόταν με Μέχρις_ότου τέθηκε θέμα για να κόψουμε κάτι
      1 μονάδα για τα άλλα δύο (τεμάχια, τιμή)

Γ2. Η δομή επιλογής  (Αν Λ<=500...Αλλιώς ) έπιανε 1 μονάδα.
      Οι μετρητές στο Αλλιώς και η αρχικοποίηση τους για μία μονάδα.
      Η επανάληψη μέσα στο αλλιώς και οι αλλαγές μετρητών για 3 μονάδες.
      Οι εμφανίσεις ήταν  και οι δύο μαζί για 1 μονάδα (και η "Πληρωμη μετρητοίς και η εμφάνισε στο αλλιώς μετά την επανάληψη)

Γ3. Η Αρχικοποίηση αθροιστών πήρε μία μονάδα.
      Ο έλεγχος με επιλογή και αύξηση αθροιστή πήρε 3 μονάδες.
      Η εμφάνιση 1 μονάδα.

Γ4. Η αρχικοποίηση του max  και του αθροιστή  1  μονάδα.
      Κάθε κλάδος της δομής επιλογής ( ή κάθε απλή) πήρε απο 2 μονάδες.
      Η εμφάνιση 1 μονάδα.
Χρηστίδης Αλέξανδρος,
Μηχανικός Επ/κών και Πλη/κών Συστημάτων,
Msc Στα Προηγμένα Συστήματα Πληροφορικής

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #69 στις: 08 Ιούν 2014, 01:52:15 πμ »
O κύριος λόγος που πολλά παιδιά επιλέγουν πίνακες σε κάθε άσκηση δεν είναι μόνο γιατί κάποιος τους το δίδαξε, αλλά γιατί:

1. Οι πίνακες διδάσκονται μεταγενέστερα από την δομή επανάληψης, άρα σαν πιο πρόσφατη γνώση, έχει αποκτήσει μεγαλύτερη βαρύτητα.
2. Οι πίνακες δημιουργούν μεγαλύτερη ευκολία στον τρόπο επίλυσης, διότι επιτρέπουν πολλαπλές επαναλήψεις.
3. Οι πίνακες δίνουν την ψευδαίσθηση πιο οργανωμένης επεξεργασίας δεδομένων
4. Οι ασκήσεις των πινάκων με τις οποίες ασχολείται ένας μαθητής είναι συνήθως πολύ περισσότερες από του προηγούμενου κεφαλαίου.

Ακόμα και δυνατοί μαθητές δεν στέκονται στην λεπτομέρεια και χρησιμοποίησαν πίνακες γιατί έτσι έχουν οργανώσει στο μυαλό τους τον προγραμματισμό, παρά τις αντίθετες παραινέσεις μας
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

vrepantis

  • Νέος
  • *
  • Μηνύματα: 2
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ΘΕΜΑ Γ
« Απάντηση #70 στις: 08 Ιούν 2014, 01:42:47 μμ »
Προσωπικά, εξέφρασα μια θέση για την επίλυση του συγκεκριμένου θέματος και για τα προβλήματα που προκύπτουν αν επιτρέπουμε την αναπαράσταση μιας τέτοιας λύσης μέσω ψευδοκώδικα, όπως αυτός  "ορίζεται" στο σχ. εγχειρίδιο. Δεν πιστεύω πως τα προβλήματα αυτά συνδέονται με την προτίμηση των μαθητών γενικά (ούτε την προτίμηση των καθηγητών), αλλά με τη συνέπεια, τη λογική και τη σαφήνεια στις οδηγίες που έχουν τα παιδιά.

Έχει βγει κάποια οδηγία από την ΚΕΕ για τη βαθμολόγηση του συγκ. θέματος;

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: ΘΕΜΑ Γ
« Απάντηση #71 στις: 08 Ιούν 2014, 06:14:07 μμ »
Τελικά έχει δωθεί κάποια διευκρίνιση για το θέμα Γ σε ότι αφορά την χρήση πινάκωνν?? Εγώ το έλυσα με πίνακα και  τον χρησιμοποίησα στα Γ3 και Γ4 .. θα μπορούσε κάποιος καθηγητής που εμπλέκεται στην φετινή βαθμολόγηση των γραπτών να μου προσωπική άποψη για το πόσα μόρια θα έκοβε από το κάθε ερώτημαααα?   :(

Αν το γραπτό είναι σωστό χωρίς λάθος (για το Θέμα Γ) και γίνεται χρήση πινάκων τότε δεν νομίζω να αφαιρεθούν μονάδες (κι αν ναι πάνω από 2 δεν το πιστεύω).

arisbasil

  • Θαμώνας
  • ***
  • Μηνύματα: 28
  • 1+1=10
Απ: ΘΕΜΑ Γ
« Απάντηση #72 στις: 08 Ιούν 2014, 08:55:08 μμ »
Επειδή για τον υπολογισμό των δόσεων έχω αριθμητική πρόοδο με πρώτο όρο το 20 και διαφορά το 5, μπορώ να βγάλω τύπο που δίνει το πλήθος των δόσεων, είναι το ακέραιο μέρος της παράστασης:

(-35+Τ_Ρ(40*Λ+1225))/10 +1

όπου Λ ο λογαριασμός.
« Τελευταία τροποποίηση: 08 Ιούν 2014, 09:07:08 μμ από arisbasil »

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #73 στις: 08 Ιούν 2014, 09:05:56 μμ »
ακριβώς :)
υποθέτω ότι υπολόγισες το άθροισμα των όρων της αριθμητικης προόδου με άγνωστο το N και κατέληξες σε ένα τριώνυμο ως προς N.
Εκεί θέλει λίγο προσοχή γιατί ουσιαστικά λύνεις μια ανίσωση.
Τες πα, αν είσαι μαθητής έχεις δώσει τέτοια λύση?
και αν έδωσες εξηγείς λεπτομερώς τι κάνεις?

Επειδή για τον υπολογισμό των δόσεων έχω αριθμητική πρόοδο με πρώτο όρο το 20 και διαφορά το 5, μπορώ να βγάλω τύπο που δίνει το πλήθος των δόσεων, είναι το ακέραιο μέρος της παράστασης:

(-35+Τ_Ρ(40*Λ+1255))/10 +1

όπου Λ ο λογαριασμός.

Επίσης το +1 δουλεύει πάντα? μήπως σε κάποιες περιπτώσεις που οι δόσεις βγάζουν ακριβώς το ποσό βάζει μια δόση παραπάνω?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

arisbasil

  • Θαμώνας
  • ***
  • Μηνύματα: 28
  • 1+1=10
Απ: ΘΕΜΑ Γ
« Απάντηση #74 στις: 08 Ιούν 2014, 09:15:28 μμ »
ακριβώς :)
υποθέτω ότι υπολόγισες το άθροισμα των όρων της αριθμητικης προόδου με άγνωστο το N και κατέληξες σε ένα τριώνυμο ως προς N.
Εκεί θέλει λίγο προσοχή γιατί ουσιαστικά λύνεις μια ανίσωση.
Τες πα, αν είσαι μαθητής έχεις δώσει τέτοια λύση?
και αν έδωσες εξηγείς λεπτομερώς τι κάνεις?


Είμαι συνάδελφος, όχι μαθητής και διορθώνω γραπτά.

Απλά χρησιμοποίησα μαθηματικά για να βρω έναν τύπο. Αν κάποιος μαθητής κατάλαβε την πρόοδο και ήξερε τους τύπους της αριθμητικής προόδου δεν αποκλείεται να έδωσε μια τέτοια λύση.

Χρησιμοποίησα τον τύπο του αθροίσματος:

(2*α1+(κ-1)*ω)/2*κ=Λ

όπου α1=20 και ω=5 , κάνω πράξεις, φτάνω σε τριώνυμο ως προς κ και παίρνω τη θετική ρίζα. Στο τέλος ό,τι περισσέψει θα είναι η τελευταία δόση.

edit:  Δεν το έχω τσεκάρει...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #75 στις: 08 Ιούν 2014, 09:27:21 μμ »
α οκ,
το σκεπτικό είναι σωστό, απλά θέλει λίγες δοκιμές για κάποιες ακραίες περιπτώσεις για να είμαστε σίγουροι
εννοείται ότι αν το δούμε προσκυνάμε  :laugh:

Είμαι συνάδελφος, όχι μαθητής και διορθώνω γραπτά.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

arisbasil

  • Θαμώνας
  • ***
  • Μηνύματα: 28
  • 1+1=10
Απ: ΘΕΜΑ Γ
« Απάντηση #76 στις: 08 Ιούν 2014, 09:38:14 μμ »
α οκ,
το σκεπτικό είναι σωστό, απλά θέλει λίγες δοκιμές για κάποιες ακραίες περιπτώσεις για να είμαστε σίγουροι
εννοείται ότι αν το δούμε προσκυνάμε  :laugh:


Αν Α_Μ(Τ_Ρ(40*Λ+1225))=Τ_Ρ(40*Λ+1225) τότε βγάλε 1 δόση

Νομίζω ότι τώρα δουλεύει...

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2787
  • Πύργος Ηλείας
Απ: ΘΕΜΑ Γ
« Απάντηση #77 στις: 08 Ιούν 2014, 10:28:30 μμ »
α οκ,
το σκεπτικό είναι σωστό, απλά θέλει λίγες δοκιμές για κάποιες ακραίες περιπτώσεις για να είμαστε σίγουροι
εννοείται ότι αν το δούμε προσκυνάμε  :laugh:


Εξαρτάται ποιος θα το έβλεπε!  ;)

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #78 στις: 09 Ιούν 2014, 01:45:36 πμ »
Οι ακολουθίες διδάσκονται στην πρώτη λυκείου.
Έτσι ισχύει Σ = ν/2 * (α1 + αν) για το άθροισμα και αν = α1 + (ν-1)*ω
Στο συγκεκριμένο πρόβλημα α1=20, ω=5
Αντικαθιστώντας το αν στην πρώτη εξίσωση έχουμε μια δευτεροβάθμια ως προς ν με αποδεκτή λύση την (-35+Τ_Ρ(1225 + 40*Σ))/10
Το ν όμως πρέπει να είναι ακέραιο και αυξημένο κατά ένα ώστε να ξεπεραστεί το Σ.
Έτσι ν = Α_Μ((-35+Τ_Ρ(1225 + 40*Σ))/10)+1

Την λύση την έχω δει από μαθήτρια μου στο αντίστοιχο θέμα του 2001 ή του 2002 νομίζω.

Βέβαια χρειάζεται και ένας έλεγχος στο φετεινό όπως γράφτηκε παραπάνω για την περίπτωση που το άθροισμα είναι ίδιο με τον τελικό λογαριασμό.

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 786
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: ΘΕΜΑ Γ
« Απάντηση #79 στις: 09 Ιούν 2014, 06:58:05 μμ »
Για το συγκεκριμένο ζήτημα έχω εκφράσει την άποψή μου παλαιότερα εδώ μέσα και δεν έχει νόημα να επαναλαμβανόμαστε.
 Η ουσία είναι ότι τελικά παρά τις ατέρμονες συζητήσεις, οι μεν δεν έχουν πείσει τους δε, και οι περισσότεροι συμβιβάζονται με τη γραμμή που λέει ποινή 1 με 2 μόρια. Φυσικά υπάρχει ένα  ποσοστό βαθμολογητών που δεν κόβει ούτε μόριο και ένα άλλο που κόβει τα μισά μόρια του ερωτήματος.
Συμφωνώ και εγω 1-2 μόρια ... απο κάθε ερώτημα (εκτός του Γ2 που δεν αλλάζει η λογική του αλγορίθμου)

Για να μπορούμε να υποστηρίζουμε ότι διδάσκουμε αλγοριθμική σκέψη ... εκτός αν κάνω λάθος και δεν διδάσκουμε

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: ΘΕΜΑ Γ
« Απάντηση #80 στις: 09 Ιούν 2014, 08:58:31 μμ »
Συμφωνώ και εγω 1-2 μόρια ... απο κάθε ερώτημα (εκτός του Γ2 που δεν αλλάζει η λογική του αλγορίθμου)

Για να μπορούμε να υποστηρίζουμε ότι διδάσκουμε αλγοριθμική σκέψη ... εκτός αν κάνω λάθος και δεν διδάσκουμε

Vangelis ίσως θυμάσαι ότι το 2010 ήμουν από τους λίγους που διαφωνούσα με τη χρήση πίνακα (ακόμη περισσότερο τώρα). Ας είμαστε όμως και λογικοί. Το Γ1 ερώτημα πως ακριβώς λύνεται ευκολότερα με πίνακες, δεδομένου ότι χρησιμοποιεί ο μαθητής κανονικά την όσο με την τιμή φρουρό; Το Γ3 δεν είναι μια απλή δομή επιλογής και ένας μετρητής, άσχετα με το αν έχουμε πίνακα ή όχι;
Τελικά μόνο το τελευταίο ερώτημα (και μάλιστα το 2ο μισό του) θέλει "πονηριά" και δεν πρέπει να βαθμολογηθεί ολόκληρο αν κάποιος χρησιμοποιήσει πίνακες. Εκτός κι αν θέλουμε να "τιμωρήσουμε" τους μαθητές για τη χρήση πίνακα και πρέπει να κόψουμε από όλα για να μοιράσουμε την τιμωρία. Δεν ξέρω αν είναι σωστό αυτό, δεν έχω βαθμολογήσει ποτέ, θα ήθελα όμως την άποψή σου.
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1095
Απ: ΘΕΜΑ Γ
« Απάντηση #81 στις: 10 Ιούν 2014, 12:42:35 πμ »
Μέσα από τη συζήτηση αυτή, αναδεικνύεται ένα σημαντικό κατά την άποψή μου πρόβλημα: η ασυνεννοησία μεταξύ βαθμολογικών κέντρων. Ναι μεν υπάρχει μια άτυπη επικοινωνία, η πράξη αποδεικνύει πως είναι ανύπαρκτη.
 
Αυτό έχει ως πρόβλημα τη διαφορετική αντιμετώπιση ενός θέματος από βαθμολογικό σε βαθμολογικό με κάποιους να μην κόβουν μονάδες στη λύση με πίνακες, άλλοι κόβουν μισό θέμα, άλλοι 1-2 μονάδες. Το θεωρείται σωστό αυτό;

Στα δικά μας: Δυστυχώς μετά από 15 περίπου έτη ύπαρξης του μαθήματος, ακόμα δεν υπάρχει κοινή γραμμή μεταξύ μας στην αντιμετώπιση ενός θέματος είτε αυτό είναι διάγραμμα ροής είτε χρήση πίνακα. Αναρωτιέμαι :
δεν θέλουμε να υπάρχει συνεννόηση;
δεν μας βολεύει;
 Είμαστε όλοι αυθεντίες στον χώρο μας και δεν ακούμε κάποιον άλλον;

Τι φταίει;






Rathaniel

  • Βετεράνος
  • ****
  • Μηνύματα: 77
  • Έπρεπε να είχα γίνει Χημικός......
Απ: ΘΕΜΑ Γ
« Απάντηση #82 στις: 10 Ιούν 2014, 06:50:59 πμ »
Νομίζω είναι και η φύση του μαθήματος τέτοια που χωρούν παρερμηνείες.
Σε αρκετούς μαθητές μου λέω χαριτολογώντας ότι "το γραπτό σας στον προγραμματισμό είναι μια ζωγραφια", είναι δηλαδή κάτι υποκειμενικό μέχρι ενός σημείου. Μία πνευματική δημιουργία είναι δύσκολο να την χαρακτηρίσεις ως αδρανειακός παρατηρητής.

Το θέμα είναι το εξής : Δίνουμε δημασία στο αποτέλεσμα ΜΟΝΟ ; Ή μήπως πρέπει να βαθμολογείται και ο τρόπος αντιμετώπισης ενός θέματος, ενδεχομένως να βραβεύεται μια δύσκολη και αποδοτική-τολμηρή λύση με παραπάνω μόρια.

Πόσοι απο εμάς είχαμε δει προγράμματα που ο κώδικας ήταν αχανής, κακογραμμένος, χωρίς σχόλια και δούλευε; Άλλοι θα χαρακτήριζαν τον προγραμματιστή αυτόν πολύ καλό γιατί δουλεύει το πρόγραμμα, ενώ άλλοι πολύ κακό γιατί δεν μπορούν να τον διορθώσουν ή να καταλάβουν τι ακριβώς κάνει.

Συμφωνώ με τα ερωτήματα του κου.Καρκαμάνη και προσθέτω ένα επίπεδο ακόμα: την φύση του μαθήματος.
Χρηστίδης Αλέξανδρος,
Μηχανικός Επ/κών και Πλη/κών Συστημάτων,
Msc Στα Προηγμένα Συστήματα Πληροφορικής

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: ΘΕΜΑ Γ
« Απάντηση #83 στις: 10 Ιούν 2014, 02:04:20 μμ »
Θα ήθελα να προσθέσω και τον δικό μου προβληματισμό. Που απευθυνόμαστε, ποιο είναι το κοινό μας;

Νομίζω ότι πολλές φορές στο τέλος η οπτική γωνία από την οποία βλέπουμε τα πράγματα είναι κάπως ουτοπική και ψάχνουμε μόνο το ιδανικό, επιμένουμε στο βέλτιστο, σ' αυτό που ξέρουμε εμείς ότι είναι το καλύτερο.

Κάπου στη πορεία νομίζω ότι ξεχνάμε ότι δεν απευθυνόμαστε σε έμπειρους προγραμματιστές αλλά σε μαθητές Γ Λυκείου, που διδάσκονται πρώτη φορά τις έννοιες των αλγορίθμων και του προγραμματισμού. Και που πρέπει στο αμελητέο διάστημα των 8 μηνών να μάθουν όλες αυτές τις νέες έννοιες "άριστα" για να αποδώσουν το καλύτερο.

Επιπλέον, δεν ασχολούνται μόνο με το δικό μας μάθημα όλη τη χρονιά αλλά έχουν στο κεφάλι τους άλλα 5 μαθήματα ( στην πλειοψηφία τους με μεγάλες απαιτήσεις) με τα οποία πρέπει να ασχοληθούν και να πετύχουν.
Και ας μη γελιόμαστε ακόμη και άριστα μυαλά κάτω από τέτοια πίεση "λυγίζουν".

Τι πρέπει να περιμένουμε από τα παιδιά; Που είναι τα όριά μας σε όλες τις φάσεις των εξετάσεων;
Τα θέματα που τους δίνονται σε αυτό το τρίωρο να διαγωνιστούν ως που πρέπει οι θεματοδότες να τα ''τραβήξουν";
Βάζοντας στο σύνολό τους τόσο απαιτητικά στη λεπτομέρεια, διφορούμενα στην ερμηνεία και ασαφή θέματα ωφελούνται πρωτίστως οι μαθητές μας και έπειτα εμείς κάτι (στη μάθηση εννοώ);


Υ.Γ. Και εκεί που έχουν φτάσει οι εξετάσεις τα τελευταία 5 χρόνια βάζω και τον εαυτό μου σε αυτούς που έχουν πολλές απαιτήσεις από τα παιδιά μέσα στην τάξη. Σημασία στην κάθε μικρή λεπτομέρεια. Πολλές παραλλαγές περιπτώσεων και βουνό ασκήσεων κατά τη διάρκεια της χρονιάς.
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 679
Απ: ΘΕΜΑ Γ
« Απάντηση #84 στις: 10 Ιούν 2014, 04:04:39 μμ »
Θα ήθελα να προσθέσω και τον δικό μου προβληματισμό. Που απευθυνόμαστε, ποιο είναι το κοινό μας;

Νομίζω ότι πολλές φορές στο τέλος η οπτική γωνία από την οποία βλέπουμε τα πράγματα είναι κάπως ουτοπική και ψάχνουμε μόνο το ιδανικό, επιμένουμε στο βέλτιστο, σ' αυτό που ξέρουμε εμείς ότι είναι το καλύτερο.

Κάπου στη πορεία νομίζω ότι ξεχνάμε ότι δεν απευθυνόμαστε σε έμπειρους προγραμματιστές αλλά σε μαθητές Γ Λυκείου, που διδάσκονται πρώτη φορά τις έννοιες των αλγορίθμων και του προγραμματισμού. Και που πρέπει στο αμελητέο διάστημα των 8 μηνών να μάθουν όλες αυτές τις νέες έννοιες "άριστα" για να αποδώσουν το καλύτερο.

Επιπλέον, δεν ασχολούνται μόνο με το δικό μας μάθημα όλη τη χρονιά αλλά έχουν στο κεφάλι τους άλλα 5 μαθήματα ( στην πλειοψηφία τους με μεγάλες απαιτήσεις) με τα οποία πρέπει να ασχοληθούν και να πετύχουν.
Και ας μη γελιόμαστε ακόμη και άριστα μυαλά κάτω από τέτοια πίεση "λυγίζουν".

Τι πρέπει να περιμένουμε από τα παιδιά; Που είναι τα όριά μας σε όλες τις φάσεις των εξετάσεων;
Τα θέματα που τους δίνονται σε αυτό το τρίωρο να διαγωνιστούν ως που πρέπει οι θεματοδότες να τα ''τραβήξουν";
Βάζοντας στο σύνολό τους τόσο απαιτητικά στη λεπτομέρεια, διφορούμενα στην ερμηνεία και ασαφή θέματα ωφελούνται πρωτίστως οι μαθητές μας και έπειτα εμείς κάτι (στη μάθηση εννοώ);


Υ.Γ. Και εκεί που έχουν φτάσει οι εξετάσεις τα τελευταία 5 χρόνια βάζω και τον εαυτό μου σε αυτούς που έχουν πολλές απαιτήσεις από τα παιδιά μέσα στην τάξη. Σημασία στην κάθε μικρή λεπτομέρεια. Πολλές παραλλαγές περιπτώσεων και βουνό ασκήσεων κατά τη διάρκεια της χρονιάς.

καλησπέρα σε όλους...θα συμφωνήσω μαζί σου συνάδελφε....όμως για εμένα παραμένει άλυτο το βασικό ερώτημα που έχουμ εσυζητήσει σε πολλά θέματα...ΠΟΙΕΣ είναι οι λεπτομέρειες αυτές, ποια είναι τα όριο του μαθήματος κτλ κτλ ... και πρωσοπικά πιστεύω πως ένα παλιό θέμα με τίτλο "ΑΣΑΦΕΙΕΣ ΑΕΠΠ" πρέπει να ανανεωθεί, γιατί στην ουσία, μάλλον τα περισόοτερα που διδάσκουμε εντάσσονται σε αυτό το θέμα.... δηλαδή εμένα μου είναι προβληματισμός να μην μπορώ να εξηγήσω με μία απάντησηαν το διάγραμμα ροής του Β2 """είναι σωστό""" (σε πολλά εισαγωγικά) με μέχρις_ότου... ή αν το θέμα Γ μπορεί να λυθεί με πίνακα.....υπάρχουν επιχειρήματα εκατέροθεν, όλα σωστά στα σημεία τους....τι λέτε ???

Obelix

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
Απ: ΘΕΜΑ Γ
« Απάντηση #85 στις: 10 Ιούν 2014, 07:10:54 μμ »
Το 2010 ήμουν από αυτούς που υποστήριζα ότι δεν έπρεπε να κοπούν μονάδες σε λύσεις με χρήση πινάκων.
Για το φετινό θέμα Γ είναι σαφές πως πρέπει να κοπούν μονάδες και όχι μόνο 2....
Μιλάμε για διαφορετικές περιπτώσεις κατά την άποψή μου....

Για το πόσες κόβονται τελικά και πόσες θα έπρεπε να κοπούν θα ήθελα την άποψή σας...

demy pap

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #86 στις: 11 Ιούν 2014, 08:43:33 μμ »
Μια σκέψη για τη χρήση πίνακα στο συγκεκριμένο θέμα: δεν είναι η πρώτη φορά. Υπάρχει το προηγούμενο του 2010. Τότε ο μαθητής θα μπορούσε να μη φανταστεί ότι η χρήση πίνακα μπορεί να το κοστίσει μονάδες. Τώρα, όμως, έχοντας αυτή τη γνώση, θεωρώ πως μαθητής που μπορούσε να το λύσει χωρίς πίνακα και επέλεξε πίνακα "πήγαινε γυρεύοντας" (ας μου συγχωρεθεί η φράση), αφού το ασφαλές ήταν η μη χρήση πίνακα. Αν, από την άλλη δυσκολευόταν, καλώς έκανε, αφού δεν άφησε αναπάντητο ερώτημα δείχνοντας ότι έστω κι αν δεν κατέχει το θέμα στο σύνολό του, μπορεί κάπως να το διαχειρισθεί ελαχιστοποιώντας το βαθμολογικό κόστος.

Dinos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 86
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ΘΕΜΑ Γ
« Απάντηση #87 στις: 11 Ιούν 2014, 10:03:26 μμ »

ασυνεννοησία μεταξύ βαθμολογικών κέντρων.
 
Στα δικά μας: Δυστυχώς μετά από 15 περίπου έτη ύπαρξης του μαθήματος, ακόμα δεν υπάρχει κοινή γραμμή μεταξύ μας στην αντιμετώπιση ενός θέματος είτε αυτό είναι διάγραμμα ροής είτε χρήση πίνακα. Αναρωτιέμαι :
δεν θέλουμε να υπάρχει συνεννόηση;
δεν μας βολεύει;
 Είμαστε όλοι αυθεντίες στον χώρο μας και δεν ακούμε κάποιον άλλον;

Το θέμα με τους πίνακες είναι πολυσυζητημένο. Νόμιζα ότι ήταν μια ταινία παραγωγής 2010, αλλά τελικά τείνει να γίνει serial, με πιθανότητα μάλιστα να παιχτεί κι άλλο επεισόδιο το επόμενο (και ίσως τελευταίο) έτος.
Πρέπει λοιπόν να σπάσει αυτός ο Γόρδιος δεσμός.
Πώς;
είτε αν συμφωνήσουμε σε κάτι (έστω κι αν διαφωνούν-ούμε)     ΔΥΣΚΟΛΟ!!
είτε να αναφέρει ρητά η επιτροπή όταν θέλει (και πρέπει;;;) να λυθεί το θέμα με δομή επανάληψης να μην το προσεγγίσουν οι μαθητές κάνοντας χρήση στατικής δομής δεδομένων.
 

NIKODIM

  • Νέος
  • *
  • Μηνύματα: 9
Απ: ΘΕΜΑ Γ
« Απάντηση #88 στις: 12 Ιούν 2014, 04:50:55 μμ »
Θα συμφωνήσω ότι το συγκεκριμένο θέμα πρέπει να λυθεί. Η λύση όμως είναι αυτή που δόθηκε στα περισσότερα βαθμολογικά;
Μήπως στερούμαστε επιχειρηματολογίας (επιστημονικά τεκμηριωμένης) για το συγκεκριμένο θέμα;
Συζητώντας με συναδέλφους άκουσα τα εξής:
α) Οι πίνακες είναι στατική δομή και στο συγκεκριμένο θέμα ο αριθμός των στοιχείων δεν είναι γνωστός άρα όποιος χρησιμοποιεί πίνακα λάθος.
β) Το θέμα μπορεί να λυθεί και χωρίς πίνακα και επειδή στο Κεφ9 το βιβλίο σαφώς αναφέρει πότε πρέπει να χρησιμοποιούνται πίνακες πάλι λάθος.
γ) Το ερώτημα Γ1 εξετάζει την ικανότητα του μαθητή να εισάγει δεδομένα στον αλγόριθμο (3 μονάδες). Αν - αν ξαναλέω- δεχτούμε ότι η χρήση  πίνακα είναι λάθος στο εν λόγω ερώτημα γιατί πρέπει να κόψουμε τόσες πολλές μονάδες;
   αυτό έχει και συνέχεια..
   Αν το πλήθος, το μέγιστο και τα άλλα τα κάνει μέσα σε μία επανάληψη (μαζί με το διάβασμα) να του κόψουμε μία δύο μονάδες αν τα κάνει σε ξεχωριστές επαναλήψεις κόψτε 5 και άνω.
δ) στα άλλα βαθμολογικά κόβουν 5-6 μονάδες άρα πρέπει να κόψουμε και μεις γιατί τα "δικά μας παιδιά" θα αδικηθούν (ισοτιμία το είπανε).

α)
Παραθέτω από το βιβλίο μαθητή Κεφ 9 που αναφέρεται σε πρόγραμμα στην ΓΛΩΣΣΑ δηλ. στο πρόγραμμα και όχι στον αλγόριθμο.
      Κάθε πίνακας πρέπει υποχρεωτικά να περιέχει δεδομένα του ιδίου τύπου, δηλαδή ακέραια, πραγματικά, λογικά, ή αλφαριθμητικά.
      Ο τύπος του πίνακα δηλώνεται μαζί με τις άλλες μεταβλητές του προγράμματος στο τμήμα δήλωσης μεταβλητών.
      Εκτός από τον τύπο του πίνακα πρέπει να δηλώνεται και ο αριθμός των στοιχείων που περιέχει ή
      καλύτερα ο μεγαλύτερος αριθμός στοιχείων που μπορεί να έχει ο συγκεκριμένος πίνακας και
αυτό για να δεσμευτούν οι αντίστοιχες συνεχόμενες θέσεις μνήμης.

Συνάδελφοι: Ο μεγαλύτερος αριθμός στοιχείων που μπορεί - μπορεί - να περιέχει. Σημαίνει εκτίμηση για το πόσα στοιχεία μέγιστο μπορεί να περιέχει ο πίνακας.

β)
παράδειγμα τετράδιο μαθητή σελ 30. :( :o
 Πόσες μονάδες θα κόψουμε που χρησιμοποιεί πίνακα για να βρει το μέγιστο; >:(
Διάβασε ΜΙΣ[1]
MAX <- MIS[1]
Για i από 2 μέχρι 200
   Διάβασε MIS
   Αν MIS>MAX τότε
        MAX <- MIS
   Τέλος_αν
Τέλος_επανάληψης
 
γ) Δηλαδή ένας μαθητής χρησιμοποίησε πίνακα και θα είχε την αφέλεια να στριμώξει όλες τις λύσεις σε μια επανάληψη; ;D

δ) Κρίμα που δεν ήμασταν εμείς το πρώτο βαθμολογικό που θα παρασέρναμε και τους άλλους και δεν θα κόβαμε τίποτα.
Μπορούμε να καταργήσουμε την επιστήμη για να διαφυλάξουμε την ισοτιμία!!!!! 
Αρκεί να σκεφτούμε : όταν μεταξύ μας δεν υπάρχει ξεκάθαρη θέση για το θέμα θα απαιτήσουμε από τους μαθητές μας ........
Το ότι κάποιοι μαθητές των οποίων τα γραπτά θα είναι άριστα (και είδα τέτοια γραπτά) και όχι μόνο αυτοί, θα χάσουν τόσες μονάδες δεν μας απασχολεί καθόλου; Την  αγωνία αυτών των παιδιών και των οικογενειών τους την φανταζόμαστε που είμαστε αποφασισμένοι να τους στερήσουμε αυτό που μια χρονιά αγωνίστηκαν για να κερδίσουν;

Συνάδελφοι επιτρέψτε μου να θέσω κάποια ερωτήματα (που έχουν τεθεί ξανά εδώ παλιότερα) και ας μου απαντήσει κάποιος τεκμηριώνοντας επιστημονικά την απάντησή του.

-Ο αλγόριθμος απαιτεί δήλωση των μεταβλητών ή των πινάκων;
Αν ναι πείτε μου σας παρακαλώ:
      - Ποια η μέγιστη χωρητικότητα της μνήμης και που αναφέρεται στο σχολικό βιβλίο περιορισμός όσον αφορά την χωρητικότητα της μνήμης;
      - Αν στο θέμα Γ ένας μαθητής επέλεγε να κάνει πρόγραμμα και δήλωνε ένα πίνακα -πόσα προϊόντα μπορεί ν' αγοράσει κάποιος- 10000 θέσεων ή 100000 θέσεων ή ....... πόσες μονάδες θα του κόβαμε για την δήλωση;
-Όταν στα παραδείγματα του βιβλίου αναφέρει Δεδομένα //Α, Ν// βλέπε ταξινόμηση Κεφ 3 π.χ. αυτό το Ν που είναι το πλήθος των στοιχείων του πίνακα πόσο μεγάλο μπορεί να είναι; φαίνεται κάπου ότι απαγορεύεται να τείνει σε μια μια οσοδήποτε μεγάλη τιμή;
-Να προσθέσω ένα ερώτημα στο θέμα Γ.
       Να εμφανιστούν τα προϊόντα ταξινομημένα κατά το ποσό που θα κοστίσουν (τιμή * τεμάχια για κάθε προϊόν).
       Εφ' όσον οι πίνακες είναι στατική δομή πως ακριβώς θα γίνει η ταξινόμηση συνάδελφοι;
       Ελπίζω ότι δεν θα βρεθεί κάποιος που να υποστηρίξει ότι δεν μπορεί να τεθεί τέτοιο πρόβλημα ή ότι το πρόβλημα αλγοριθμικά ή προγραμματιστικά δεν λύνεται. 
-και τέλος ποια η διαφορά αλγορίθμου και προγράμματος;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Γ
« Απάντηση #89 στις: 12 Ιούν 2014, 05:42:35 μμ »
Το θέμα με τους πίνακες είναι πολυσυζητημένο. Νόμιζα ότι ήταν μια ταινία παραγωγής 2010, αλλά τελικά τείνει να γίνει serial, με πιθανότητα μάλιστα να παιχτεί κι άλλο επεισόδιο το επόμενο (και ίσως τελευταίο) έτος.
Πρέπει λοιπόν να σπάσει αυτός ο Γόρδιος δεσμός.
Πώς;
είτε αν συμφωνήσουμε σε κάτι (έστω κι αν διαφωνούν-ούμε)     ΔΥΣΚΟΛΟ!!
είτε να αναφέρει ρητά η επιτροπή όταν θέλει (και πρέπει;;;) να λυθεί το θέμα με δομή επανάληψης να μην το προσεγγίσουν οι μαθητές κάνοντας χρήση στατικής δομής δεδομένων.0

Ευτυχώς υπάρχει και άλλος τρόπος. Άλλωστε, ό,τι δε λύνεται κόβεται με το μαχαίρι.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #90 στις: 12 Ιούν 2014, 07:02:31 μμ »
Μου κάνει εντύπωση ότι σε κάτι τέτοιες περιπτώσεις όλοι σκέφτονται τα "παιδάκια" που το έλυσαν με πίνακες και θα χάσουν μονάδες.

Τα παιδάκια που κατάφεραν και το έλυσαν χωρίς πίνακες δεν είδα να τα σκέφτεται κανένας. Τι είπατε?? Α ναι ξέχασα είναι λιγότερα...

Τα παιδάκια που έφτασαν στο Γ4 και δεν το έλυσαν γιατί ήξεραν ότι δεν μπορούν να χρησιμοποιήσουν πίνακες, ποιος τα σκέφτεται?

Ας έχουμε στο μυαλό μας ότι οι εξετάσεις είναι κατατακτήριες, όταν πριμοδοτείς έναν μαθητή αδικείς κάποιον άλλον.

ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #91 στις: 12 Ιούν 2014, 08:22:15 μμ »

ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

Εμφάνισε 'Πού είσαι ρε μάγκα ftsak'
Εμφάνισε + αλφαριθμητική σταθερά

Άρα σωστό είναι το Εμφάνισε 1
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

arisbasil

  • Θαμώνας
  • ***
  • Μηνύματα: 28
  • 1+1=10
Απ: ΘΕΜΑ Γ
« Απάντηση #92 στις: 12 Ιούν 2014, 08:28:32 μμ »
ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις.

Πλάκα κάνεις... :o

demy pap

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #93 στις: 12 Ιούν 2014, 11:52:49 μμ »

ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

Διακρίνω κάποια δόση "έμπειρης" ειρωνείας;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Γ
« Απάντηση #94 στις: 13 Ιούν 2014, 10:50:12 πμ »
ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

To

1

δεν είναι έκφραση;;

ΥΓ: θυμάσαι πριν κάποια -πολλά-χρόνια που μου την έλεγες για το topic "αυθεντίες και άλλα;"

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #95 στις: 13 Ιούν 2014, 01:53:02 μμ »
Εγώ??? αποκλείεται. Είσαι σίγουρος?
Μήπως με μπερδεύεις με κανέναν άλλον   :angel:

ΥΓ: θυμάσαι πριν κάποια -πολλά-χρόνια που μου την έλεγες για το topic "αυθεντίες και άλλα;"

αν και τώρα είναι δύσκολοι καιροί για τέτοια topic
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 548
  • There can be only one...may it be AEPP.
Απ: ΘΕΜΑ Γ
« Απάντηση #96 στις: 14 Ιούν 2014, 10:51:13 πμ »
Καλημέρα σε όλους.
Αν κάποιος έδινε τον παρακάτω κώδικα ως λύση στο θέμα Γ (αν εξαιρέσουμε τη χρήση προγράμματος αντί για αλγόριθμο) πόσο θα έχανε ο μαθητής/η μαθήτρια;
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πλ, ι, ΑΡ[10], αριθμός, κωδ, συνολο, copy_συνολο, κ
  ΠΡΑΓΜΑΤΙΚΕΣ: Τ[10], τιμή, σ, μαχ, copy_μαχ
ΑΡΧΗ
  πλ <- 0
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΑΡ[ι] <- 0
    Τ[ι] <- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  copy_μαχ <- -1
  ι <- 1
  ΔΙΑΒΑΣΕ κωδ
  ΟΣΟ κωδ <> 0 ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ αριθμός, τιμή
    ΑΡ[ι] <- αριθμός
    Τ[ι] <- τιμή
    σ <- σ + τιμή* αριθμός                                    !για το ερώτημα Γ2
    ΑΝ τιμή > 10 ΤΟΤΕ
      πλ <- πλ + ΑΡ[ι]
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ι = 10 ΤΟΤΕ
      μαχ <- Τ[1]
      ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ 10
        ΑΝ Τ[ι] > μαχ ΤΟΤΕ
          μαχ <- Τ[ι]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      συνολο <- 0
      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
        ΑΝ Τ[ι] = μαχ ΤΟΤΕ
          συνολο <- συνολο + ΑΡ[ι]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
        ΑΡ[ι] <- 0
        Τ[ι] <- 0
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ copy_μαχ <> μαχ ΤΟΤΕ
        copy_μαχ <- μαχ
        copy_συνολο <- συνολο
      ΑΛΛΙΩΣ
        copy_συνολο <- copy_συνολο + συνολο
      ΤΕΛΟΣ_ΑΝ
      ι <- 1
    ΤΕΛΟΣ_ΑΝ
    ι <- ι + 1
    ΔΙΑΒΑΣΕ κωδ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  μαχ <- Τ[1]
  ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ ι - 1
    ΑΝ Τ[ι] > μαχ ΤΟΤΕ
      μαχ <- Τ[ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  συνολο <- 0
  ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ ι - 1
    ΑΝ Τ[ι] = μαχ ΤΟΤΕ
      συνολο <- συνολο + ΑΡ[ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ copy_μαχ = μαχ ΤΟΤΕ
    copy_συνολο <- copy_συνολο + συνολο
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ πλ                                                           !ερώτημα Γ3
  ΓΡΑΨΕ copy_συνολο                                                  !ερώτημα Γ4
!...συνεχίζουμε με το ερώτημσα Γ2 κατα τα γνωστά
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

NIKODIM

  • Νέος
  • *
  • Μηνύματα: 9
Απ: ΘΕΜΑ Γ
« Απάντηση #97 στις: 14 Ιούν 2014, 11:28:54 πμ »
 :D :D :Dnikolasmer καλό!!!!!  ;D ;D ;D ;Dπολύ καλό!!!!!!
Ας απαντήσει κάποιος ρε παιδιά στο συνάδελφο.

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #98 στις: 14 Ιούν 2014, 12:59:56 μμ »
Και οι πιθανές σωστές λύσεις που μπορούν να δώσουν οι μαθητές είναι ατελείωτες. Ακόμη και με χρήση πινάκων!!! Αντιγράφω το κομμάτι του υπολογισμού του πλήθους των μεγίστων.

Αλγόριθμος ΘΓ
! Θεωρώ ως μέγιστο μέγεθος πίνακα το 100.
Αρχή_επανάληψης
Διάβασε Ν!στο Ν δίνουμε τη τιμή του μεγέθους του πίνακα που θέλουμε να χρησιμοποιήσουμε
Μέχρις_ότου Ν ≥ 1 και Ν ≤ 100

max_previous ← 0
pmax_previous ← 0
Για κ από 1 μέχρι Ν
  Τ[κ] ← 0
Τέλος_επανάληψης
πλ_επ ← 1
ι ← 1
Διάβασε κωδ
Όσο κωδ ≠ 0 επανάλαβε
  Διάβασε Τ[ι], αρ_τεμ[ι]
  ι ← ι + 1
  Διάβασε κωδ

  Αν ι = πλ_επ* Ν + 1 ή κωδ = 0 τότε
    max ← Τ[1]
    Για κ από 1 μέχρι Ν
      Αν max < Τ[κ] τότε
        max ← Τ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    pmax ← 0
    Για κ από 1 μέχρι Ν
      Αν max = Τ[κ] τότε
        pmax ← pmax + αρ_τεμ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    Αν max_previous = max τότε
      pmax_previous ← pmax_previous + pmax
    αλλιώς_αν max_previous < max τότε
      max_previous ← max
      pmax_previous ← pmax
    Τέλος_αν
    Για κ από 1 μέχρι Ν
      Τ[κ] ← 0
    Τέλος_επανάληψης
    ι ← 1
    πλ_επ ← πλ_επ + 1
  Τέλος_αν

Τέλος_επανάληψης
Εμφάνισε pmax_previous
Τέλος ΘΓ

Νομίζω ότι υπάρχει μια παρανόηση σχετικά με τη χρήση πινάκων. Το θέμα είναι πως ο μαθητής θα χρησιμοποιήσει τους πίνακες.
Προφανώς ένας μαθητής που έχει χρησιμοποιήσει πίνακα όπως προτείνει ο aperdos είναι σίγουρα αρκετά καλός για να βρει τη λύση και χωρίς πίνακες.

Συνάδερφοι το θέμα έχει τεθεί παραπάνω και έχει απαντηθεί. Όχι μόνο φέτος αλλά και το 2011. Βέβαια τότε είχε ακουστεί η άποψη ότι είναι απίθανο να το σκεφτεί μαθητής αλλά ακόμη και αν συνέβαινε αυτό ο διορθωτής δεν θα έκοβε τίποτα.

Έχουμε και λέμε λοιπόν
Ερμηνεία 1η: Η επιτροπή θεωρεί την ψευδογλώσσα ΓΛΩΣΣΑ και επιβάλει να είναι γνωστός ο αριθμός των δεδομένων προς επεξεργασία πριν από την εκτέλεση του "αλγορίθμου" για να μπορέσει να χρησιμοποιηθεί πίνακας. Γράφει στην οδηγία της προς τους βαθμολογητές "όσα ερωτήματα βαθμολογήθηκαν με πίνακα δεν πρέπει να βαθμολογηθούν με το σύνολο των μονάδων"
Ερμηνεία 2η: Ο βαθμολογητής πρέπει να ερμηνεύσει την οδηγία ως "όλα τα δεδομένα δεν πρέπει να μπουν σε πίνακα όχι ένα μέρος τους".

Και έτσι λοιπόν γίνεται της ερμηνείας.

Θέλω να κάνω και ένα σχόλιο πολιτικού - κοινωνικού περιεχομένου. Η άγνοια των πολλών ή η παρανόηση που έχουν για κάποιο θέμα δεν είναι μειονέκτημα της δημοκρατίας. Από την άλλη οι "'άριστοι" αν όντως είναι οφείλουν να διαφωτίσουν τους πολλούς.

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: ΘΕΜΑ Γ
« Απάντηση #99 στις: 14 Ιούν 2014, 03:14:55 μμ »
Μου κάνει εντύπωση ότι σε κάτι τέτοιες περιπτώσεις όλοι σκέφτονται τα "παιδάκια" που το έλυσαν με πίνακες και θα χάσουν μονάδες.

Τα παιδάκια που κατάφεραν και το έλυσαν χωρίς πίνακες δεν είδα να τα σκέφτεται κανένας. Τι είπατε?? Α ναι ξέχασα είναι λιγότερα...
Έχω την εντύπωση ότι σε αντίθεση με το 2010 οι περισσότεροι το έλυσαν/προσπάθησαν χωρίς πίνακες.
 
ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

ΤΡΑΓΙΚΟ!

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #100 στις: 14 Ιούν 2014, 03:42:23 μμ »
Καλημέρα σε όλους.
Αν κάποιος έδινε τον παρακάτω κώδικα ως λύση στο θέμα Γ (αν εξαιρέσουμε τη χρήση προγράμματος αντί για αλγόριθμο) πόσο θα έχανε ο μαθητής/η μαθήτρια;

Δυο ερωτήσεις πρώτα
1) Την έδωσε αυτή τη λύση μαθητής?
2) Γιατί πρέπει να χάσει? δεν το είδα διεξοδικά αλλά δεν βλέπω κάτι λάθος. Τώρα αν έχει κάποιο λάθος σε κάνενα δείκτη ή άκρο επανάληψης στο τέλος που κοιτάει αυτά που περισσεύουν δεν με ενδιαφέρει, η σκέψη είναι σωστή, οπότε πρέπει να πάρει 20/20

Άλλο όμως το τι πρέπει να πάρει και άλλο το τι θα πάρει, έτσι δεν είναι?
Παίζει απλά που θα πέσει
οπότε εγώ λέω απλά μια εκτίμηση. Αν του κόψουν θα του κόψουν στην χειρότερη περίπτωση μέχρι 5, δεν νομίζω παραπάνω. (προφανώς επειδή δεν έχουν καταλάβει τι λύση, και ούτε θέλουν να την καταλάβουν :-( )
« Τελευταία τροποποίηση: 15 Ιούν 2014, 12:23:28 πμ από evry »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 548
  • There can be only one...may it be AEPP.
Απ: ΘΕΜΑ Γ
« Απάντηση #101 στις: 14 Ιούν 2014, 04:51:23 μμ »
Δυο ερωτήσεις πρώτα
1) Την έδωσε αυτή τη λύση μαθητής?
2) Γιατί πρέπει να χάσει? δεν το είδα διεξοδικά αλλά δεν βλέπω κάτι λάθος. Τώρα αν έχει κάποιο λάθος σε κάνενα δείκτη ή άκρο επανάληψης στο τέλος που κοιτάει αυτά που περισσεύουν δεν με ενδιαφέρει, η σκέψη είναι σωστή, οπότε πρέπει να πάρει 20/20

Μία μαθήτριά μου έδωσε - κατά τα λεγόμενά της - την παρπάνω λύση με τη χρήση αλγορίθμο φυσικά όπως το λέει η εκφώνηση. Εμπιστεύομαι τον κωσικά της και την σκέψη της. Ήταν μια επιπολαιότητα της στιγμής η χρήση πίνακα στο θέμα της. Επίσης το θέμα Δ το έλυσε με πίνακα 10χ7 μέσα σε μια επανάληψη "Για" για κάθε εβδομάδα. Έχει ξανα θιγεί η λύση αυτή σε άλλο topic. Όπως επίσης και η λύση της σε παρόμοιο μήνυμα του κυρίου Πέρδου πιο πάνω το οποίο δεν το είχα πάρει χαμπάρι.
Τα παιδιά, τώρα που χαλάρωσαν τα πράγματα, αναμοχλεύουν παλιές καταστάσεις για να προβλέψουν αποτελέσματα. Η ίδια έχασε μόνο ενα Σ/Λ. Αυτά και μόνο αυτά χάνει συν το κομμάτι του θέματος Γ. Υπομονή... ότι βγάλει η μαντανία που λένε... άλλωστε θα γίνει μια πολύ καλή ηλεκτρολόγος, το πιστεύω.   
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής