Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 15209 φορές)

themata

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: ΘΕΜΑ Γ
« Απάντηση #30 στις: 06 Ιούν 2014, 03:20:53 μμ »
Γεια σας,

Επειδή ακούγονται ΠΑΛΙ (όπως το 2010) διάφορα, To θέμα ΔΕΝ πρέπει να λυθεί με πίνακες.
Και αναφερόμαστε στην χρήση πινάκων με βαση την ύλη του μαθήματος όχι με βάση την επιστήμη της πληροφορικής.

Dimitrissl

  • Νέος
  • *
  • Μηνύματα: 1
Απ: ΘΕΜΑ Γ
« Απάντηση #31 στις: 06 Ιούν 2014, 03:58:59 μμ »
Γεια σας,

Επειδή ακούγονται ΠΑΛΙ (όπως το 2010) διάφορα, To θέμα ΔΕΝ πρέπει να λυθεί με πίνακες.
Και αναφερόμαστε στην χρήση πινάκων με βαση την ύλη του μαθήματος όχι με βάση την επιστήμη της πληροφορικής.

Συμφωνώ απολύτως. Η λύση με πίνακες δεν οδηγεί μόνο σε μη υλοποιήσιμη εκτέλεση αλλά διευκολύνει (σχετικά) και το ερώτημα Γ4. 

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: ΘΕΜΑ Γ
« Απάντηση #32 στις: 06 Ιούν 2014, 04:03:55 μμ »
Συμφωνώ απολύτως. Η λύση με πίνακες δεν οδηγεί μόνο σε μη υλοποιήσιμη εκτέλεση αλλά διευκολύνει (σχετικά) και το ερώτημα Γ4. 

Μα λόγω του Γ4 οι περισσοτεροι οδηγήθηκαν σε πίνακα. θεωρω ότι καποια μορια πρεπει να κοπουν. σε καμια περιπτωση όμως ολόκληρη ή η μιση ασκηση. 2 μορια θεωρω ειναι αρκετα! όσα θα εχαναν αν δεν εγραφαν:
αλλιως_αν τιμή = max τοτε
     s<- s + ατ

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: ΘΕΜΑ Γ
« Απάντηση #33 στις: 06 Ιούν 2014, 04:11:03 μμ »
Για το συγκεκριμένο ζήτημα έχω εκφράσει την άποψή μου παλαιότερα εδώ μέσα και δεν έχει νόημα να επαναλαμβανόμαστε.
 Η ουσία είναι ότι τελικά παρά τις ατέρμονες συζητήσεις, οι μεν δεν έχουν πείσει τους δε, και οι περισσότεροι συμβιβάζονται με τη γραμμή που λέει ποινή 1 με 2 μόρια. Φυσικά υπάρχει ένα  ποσοστό βαθμολογητών που δεν κόβει ούτε μόριο και ένα άλλο που κόβει τα μισά μόρια του ερωτήματος.
Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: ΘΕΜΑ Γ
« Απάντηση #34 στις: 06 Ιούν 2014, 04:16:47 μμ »
Δε νομίζω να λέει κάποιος ότι πρέπει να κοπεί όλη η άσκηση (ή ακόμα και η μισή). Το κρίσιμο ερώτημα με το max έπιανε 6 μονάδες (από το οποίο περίπου οι μισές φαντάζομαι είναι να βρεις σκέτο max με ένα Αν, ενώ αν κάνεις και το αλλιώς_αν τιμή=max θα πάρεις και τις άλλες 3). Άρα όντως μιλάμε για 1-2 μονάδες πιστεύω (αυτός που το έκανε με πίνακα έχει καταλάβει ακριβώς τι ζητά η άσκηση).
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: ΘΕΜΑ Γ
« Απάντηση #35 στις: 06 Ιούν 2014, 04:29:57 μμ »
Παιδιά μην μπερδεύετε το συγκεκριμένο θέμα με του 2010, δεν μοιάζουν. Φέτος έχουμε επανάληψη με τιμή φρουρό.

Είναι ξεκάθαρο ότι πρέπει να κοπούν κάποιες μονάδες για τη χρηση πίνακα.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

GEG

  • Βετεράνος
  • ****
  • Μηνύματα: 88
Απ: ΘΕΜΑ Γ
« Απάντηση #36 στις: 06 Ιούν 2014, 04:32:39 μμ »

Κάποιοι μαθητές θεώρησαν οτι έχουμε πολλούς πελάτες με ένα προιον ο καθένας ενω προφανώς προκειται για έναν πελάτη που αγοράζει αρκετά προιόντα. Έτσι υπολόγισαν το λογαριασμό καθενός ως τεμχ*τιμή και για τον κάθε λογαριασμό αυτό υπολόγισαν σωστά το πλήθος των δόσεων μέσα στην Όσο (ή την Μέχρις_οτου).
Νομίζω πρέπει να υπάρξει κάποια επιείκια όπως σε ανάλογες περιπτώσεις στο παρελθόν  (Θέμα Δ 2012)
Hey! It compiles! Ship it! :-)

dg69

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 71
  • Όλα καλά, όλα ανθηρά
Απ: ΘΕΜΑ Γ
« Απάντηση #37 στις: 06 Ιούν 2014, 04:34:01 μμ »
Πόσες όμως; Ειδικά το Γ4 είναι πιθανό πολλοί μαθητές να χρησιμοποίησαν πίνακες για βρούνε το max...Θα δούμε αύριο στις συναντήσεις μας

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΘΕΜΑ Γ
« Απάντηση #38 στις: 06 Ιούν 2014, 04:34:21 μμ »
Κάποιοι μαθητές θεώρησαν οτι έχουμε πολλούς πελάτες με ένα προιον ο καθένας ενω προφανώς προκειται για έναν πελάτη που αγοράζει αρκετά προιόντα. Έτσι υπολόγισαν το λογαριασμό καθενός ως τεμχ*τιμή και για τον κάθε λογαριασμό αυτό υπολόγισαν σωστά το πλήθος των δόσεων μέσα στην Όσο (ή την Μέχρις_οτου).
Νομίζω πρέπει να υπάρξει κάποια επιείκια όπως σε ανάλογες περιπτώσεις στο παρελθόν  (Θέμα Δ 2012)

Μα αναφέρεται 2 φορές η λέξη "πελάτης"
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

GEG

  • Βετεράνος
  • ****
  • Μηνύματα: 88
Απ: ΘΕΜΑ Γ
« Απάντηση #39 στις: 06 Ιούν 2014, 04:42:45 μμ »
Μα αναφέρεται 2 φορές η λέξη "πελάτης"
Πέτρο Ναι αναφέρεται ρητά ειδικά στην αρχη της εκφώνησης .... απλά νομίζω οτι δεν πρέπει να αφαιρεθούν περισσότερες απο 2 μονάδες
Hey! It compiles! Ship it! :-)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΘΕΜΑ Γ
« Απάντηση #40 στις: 06 Ιούν 2014, 04:44:33 μμ »
Λυπάμαι τους βαθμολογητές κάθε χρόνο γιατί οι παρερμηνείες των μαθητών και τα πιθανά λάθη είναι ατελείωτα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #41 στις: 06 Ιούν 2014, 04:59:26 μμ »
Και οι πιθανές σωστές λύσεις που μπορούν να δώσουν οι μαθητές είναι ατελείωτες. Ακόμη και με χρήση πινάκων!!! Αντιγράφω το κομμάτι του υπολογισμού του πλήθους των μεγίστων.

Αλγόριθμος ΘΓ
! Θεωρώ ως μέγιστο μέγεθος πίνακα το 100.
Αρχή_επανάληψης
Διάβασε Ν!στο Ν δίνουμε τη τιμή του μεγέθους του πίνακα που θέλουμε να χρησιμοποιήσουμε
Μέχρις_ότου Ν ≥ 1 και Ν ≤ 100

max_previous ← 0
pmax_previous ← 0
Για κ από 1 μέχρι Ν
  Τ[κ] ← 0
Τέλος_επανάληψης
πλ_επ ← 1
ι ← 1
Διάβασε κωδ
Όσο κωδ ≠ 0 επανάλαβε
  Διάβασε Τ[ι], αρ_τεμ[ι]
  ι ← ι + 1
  Διάβασε κωδ

  Αν ι = πλ_επ* Ν + 1 ή κωδ = 0 τότε
    max ← Τ[1]
    Για κ από 1 μέχρι Ν
      Αν max < Τ[κ] τότε
        max ← Τ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    pmax ← 0
    Για κ από 1 μέχρι Ν
      Αν max = Τ[κ] τότε
        pmax ← pmax + αρ_τεμ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    Αν max_previous = max τότε
      pmax_previous ← pmax_previous + pmax
    αλλιώς_αν max_previous < max τότε
      max_previous ← max
      pmax_previous ← pmax
    Τέλος_αν
    Για κ από 1 μέχρι Ν
      Τ[κ] ← 0
    Τέλος_επανάληψης
    ι ← 1
    πλ_επ ← πλ_επ + 1
  Τέλος_αν

Τέλος_επανάληψης
Εμφάνισε pmax_previous
Τέλος ΘΓ

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: ΘΕΜΑ Γ
« Απάντηση #42 στις: 06 Ιούν 2014, 05:12:23 μμ »
Την παραπάνω λύση την έδωσε μαθητής ή την προτείνεις ως σωστή; Τι είναι το Ν; Γιατί μέγιστο 100; κλπ κλπ
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #43 στις: 06 Ιούν 2014, 05:21:58 μμ »
Την παραπάνω λύση την έδωσε μαθητής ή την προτείνεις ως σωστή; Τι είναι το Ν; Γιατί μέγιστο 100; κλπ κλπ

Παραθέτω τη λύση επειδή βλέπω ότι καταγράφεται γενικά η άποψη, ότι η χρήση πινάκων είναι λάθος.
Το Ν είναι το μέγεθος ενός προσωρινού πίνακα που χρησιμοποιείται για την εύρεση του μεγίστου. Το μέγεθος του εξαρτάται αποκλειστικά από τον προγραμματιστή.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3163
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #44 στις: 06 Ιούν 2014, 05:53:45 μμ »
Νομίζω ότι υπάρχει μια παρανόηση σχετικά με τη χρήση πινάκων. Το θέμα είναι πως ο μαθητής θα χρησιμοποιήσει τους πίνακες.
Προφανώς ένας μαθητής που έχει χρησιμοποιήσει πίνακα όπως προτείνει ο aperdos είναι σίγουρα αρκετά καλός για να βρει τη λύση και χωρίς πίνακες.
Το πρόβλημα εδώ είναι το εξής
Αν ο μαθητής χρησιμοποιεί πίνακα και θεωρεί γνωστό πλήθος οπότε έχει Για τότε ακυρώνει σχεδόν τα μισά ερωτήματα, οπότε εκεί θα κοπούν μονάδες από όλα τα ερωτήματα. Υπολογίζω σε αυτή την περίπτωση να χάνει 8-10 μονάδες

Αν όμως ο μαθητής χρησιμοποιεί πίνακα ο οποίος μεγαλώνει δυναμικά σε κάθε επανάληψη (άρα έχει κάνει κανονικά την ΌΣΟ όπως προβλέπεται) τα πράγματα είναι διαφορετικά. Εκεί θα πρέπει να κοπούν πολύ λιγότερες μονάδες και πάντα σε συνάρτηση με την εικόνα του γραπτού, δηλαδή σε αυτή την περίπτωση υπολογίζω το πολύ 5 μονάδες δεδομένου ότι ο μαθητής ξεγλιστράει μόνο από το τελευταίο ερώτημα και όχι από τα άλλα.

Γενικά πάντως όποιος χρησιμοποιεί πίνακα με γνωστό μέγεθος από την στιγμή που υπάρχει τιμή φρουρός θα χάσει πολλές μονάδες. Αυτό το λέω όχι ως άποψη αλλά ως συμπέρασμα από την συζήτηση που κάναμε σήμερα στο βαθμολογικό

Επίσης κατά τη γνώμη μου υπάρχει πρόβλημα στην εκφώνηση του θέματος Γ . Έτσι όπως δίνεται πολλοί μαθητές νόμισαν ότι ο λογαριασμός δεν είναι ο συνολικός αλλά είναι διαφορετικός για κάθε προιόν, άρα τα έκαναν όλα μέσα στην επανάληψη. Αυτό είναι πρόβλημα της εκφώνησης.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr