Αποστολέας Θέμα: ΘΕΜΑ Β  (Αναγνώστηκε 17360 φορές)

SuperTz

  • Βετεράνος
  • ****
  • Μηνύματα: 51
Απ: ΘΕΜΑ Β
« Απάντηση #15 στις: 06 Ιούν 2014, 11:42:14 πμ »
Το Β2 πιστεύω ότι γίνεται και με ΓΙΑ:
Για i από 1 μέχρι 200

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3178
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Β
« Απάντηση #16 στις: 06 Ιούν 2014, 11:44:17 πμ »
Το Β2 πιστεύω ότι γίνεται και με ΓΙΑ:
Για i από 1 μέχρι 200

απο τετραδιο μαθητη σελ 24
γινεται και με Για φυσικα

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 652
Απ: ΘΕΜΑ Β
« Απάντηση #17 στις: 06 Ιούν 2014, 11:49:53 πμ »
Συμφωνώ κι εγώ αυτό βρήκα. Με τη διόρθωση στο τελευταίο βέβαια, που νομίζω κι εγώ πως είναι Π[θ], Π[κ]

ναι....σωστά

stavrax

  • Ομάδα διαγωνισμάτων 2011
  • *
  • Μηνύματα: 35
Απ: ΘΕΜΑ Β
« Απάντηση #18 στις: 06 Ιούν 2014, 12:13:57 μμ »
Αν το b2 το κανει κανεις με μεχρις οτου πειραζει? τι λετε?

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3178
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Β
« Απάντηση #19 στις: 06 Ιούν 2014, 12:15:08 μμ »
Αν το b2 το κανει κανεις με μεχρις οτου πειραζει? τι λετε?

αν η ψευδογλώσσα υπολογίζει σωστά το s γιατι να είναι λάθος;;

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: ΘΕΜΑ Β
« Απάντηση #20 στις: 06 Ιούν 2014, 01:39:23 μμ »
νομίζω ότι είναι σωστό και αυτό

Για κ από 1 μέχρι 29
  θ ← κ + 1
  Για ι από κ μέχρι 30
    Αν Π[ι] > Π[θ] τότε
      θ ← ι
    Τέλος_αν
  Τέλος_επανάληψης
  Αντιμετάθεσε Π[θ], Π[κ]
Τέλος_επανάληψης
VR in Computing

Aris_v

  • Νέος
  • *
  • Μηνύματα: 9
Απ: ΘΕΜΑ Β
« Απάντηση #21 στις: 06 Ιούν 2014, 02:07:42 μμ »
1. κ
2. >
3. i
4. Π[κ]
5. Π[θ]

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: ΘΕΜΑ Β
« Απάντηση #22 στις: 06 Ιούν 2014, 02:10:39 μμ »
νομίζω ότι είναι σωστό και αυτό

Για κ από 1 μέχρι 29
  θ ← κ + 1
  Για ι από κ μέχρι 30
    Αν Π[ι] > Π[θ] τότε
      θ ← ι
    Τέλος_αν
  Τέλος_επανάληψης
  Αντιμετάθεσε Π[θ], Π[κ]
Τέλος_επανάληψης
Και εγώ έτσι νομίζω...καμιά άλλη άποψη γι αυτή τη λύση?
Ανδροκλής Πολυμένης

Πληροφορικός

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: ΘΕΜΑ Β
« Απάντηση #23 στις: 06 Ιούν 2014, 02:15:03 μμ »
νομίζω ότι είναι σωστό και αυτό

Για κ από 1 μέχρι 29
  θ ← κ + 1
  Για ι από κ μέχρι 30
    Αν Π[ι] > Π[θ] τότε
      θ ← ι
    Τέλος_αν
  Τέλος_επανάληψης
  Αντιμετάθεσε Π[θ], Π[κ]
Τέλος_επανάληψης

Είσοδος
1
2
3
4
5
6
7
8
9
10


Έξοδος
10
9
8
7
6
5
4
3
2
1
VR in Computing

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3178
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Β
« Απάντηση #24 στις: 06 Ιούν 2014, 02:18:52 μμ »
Το εμφωλευμενο για βρίσκει το max
Οποιαδήποτε σχετική αρχικοποίηση του θ ειναι σωστη
Πχ το 30

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Β
« Απάντηση #25 στις: 06 Ιούν 2014, 02:25:01 μμ »
είναι λάθος στο διάγραμμα να χρησιμοποιηθεί Αρχή_Επανάληψης...Μέχρις_Ότου;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2214
Απ: ΘΕΜΑ Β
« Απάντηση #26 στις: 06 Ιούν 2014, 02:26:13 μμ »
Στο συγκεκριμένο, όχι
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

alpapanto

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • ΗΟΜΕ μοναχομ
Απ: ΘΕΜΑ Β
« Απάντηση #27 στις: 06 Ιούν 2014, 02:33:33 μμ »
Στο συγκεκριμένο, όχι
???
γιατί να είναι σωστό?
έχεις συνθήκη στην αρχή της επανάληψης, επιστρέφεις στη συνθήκη από εντολή...

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2214
Απ: ΘΕΜΑ Β
« Απάντηση #28 στις: 06 Ιούν 2014, 02:39:14 μμ »
Και κάποιοι το έκαναν ορθώς με Για
Το ίδιο είναι και τα 3 στο συγκεκριμένο παράδειγμα
Αν χρειάζονταν περίεργες μετατροπές, τότε ναι
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: ΘΕΜΑ Β
« Απάντηση #29 στις: 06 Ιούν 2014, 02:45:26 μμ »
???
γιατί να είναι σωστό?
έχεις συνθήκη στην αρχή της επανάληψης, επιστρέφεις στη συνθήκη από εντολή...

Επιστρέφεις στην επανάληψη από το ψευδής. Δηλαδή, εκτελείς μέχρι να ισχύσει η συνθήκη, είναι και γνωστό πλήθος επαναλήψεων οπότε σίγουρα εκτελείται τουλάχιστον μία φορά. Άρα, όλο το διάγραμμα μπορεί να γραφεί με την ισοδύναμη Μέχρις_ότου.
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"