Αποστολέας Θέμα: Θέμα Γ  (Αναγνώστηκε 8393 φορές)

igeorgi

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Θέμα Γ
« Απάντηση #60 στις: 08 Ιούν 2013, 01:54:13 πμ »
Μίλησα με τον συντονιστή, αλλά τώρα μάλλον είναι αργά διότι η διόρθωση τελειώνει, έχω στην φύλαξη τον τελευταίο φάκελο του βαθμολογικού. Εγώ σαν δεύτερος βαθμολογητής διόρθωσα γραπτό με την μάσκα του πρώτου να έχει ξεκολλήσει και είδα ότι στο συγκεκριμένο θέμα ο συνάδελφος είχε βαθμολογήσει με το απόλυτο μηδέν. Κι επειδή είχε κόψει και κάποιες μονάδες ακόμα από άλλα ερωτήματα, στην τελική βαθμολογία προέκυψε διαφορά 10 μονάδων. Μετά σκέφτηκα ότι ίσως θα έπρεπε να βάλω +13 για να πάει σε αναβαθμολογητή το γραπτό, αλλά φαντάζομαι ότι αυτό δεν θα έσωζε την κατάσταση διότι την συγκεκριμένη λύση την έχουν δώσει το 40% των παιδιών των οποίων τα γραπτά διόρθωσα. Κι έχω διορθώσει 7 φακέλους, αρκετά αντιπροσωπευτικό το δείγμα.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2206
Απ: Θέμα Γ
« Απάντηση #61 στις: 08 Ιούν 2013, 09:56:44 πμ »
Ωραία πράγματα...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: Θέμα Γ
« Απάντηση #62 στις: 08 Ιούν 2013, 06:45:22 μμ »
Δεν νομίζω ότι δουλεύει το παραπάνω..
Το Γ3 είναι πολύ ασαφές.
Τι σημαίνει "μεγαλύτερη περιοχή τιμών" ;
Εγώ προσωπικά το καταλαβαίνω ως την περιοχή με το μεγαλύτερο εύρος.
Το παράδειγμα που δίνεται βέβαια δεν με επιβεβαιώνει.
Πολύ ατυχής διατύπωση  :(
Δεν νομίζω ότι δουλεύει το παραπάνω..

Συνάδελφε νομίζω ότι δουλεύει μια χαρά και αυτή η λύση.

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 89
Απ: Θέμα Γ
« Απάντηση #63 στις: 11 Ιούν 2013, 01:59:22 πμ »
Για i από 2 μέχρι 30
  Για j από 30 μέχρι i με_βήμα -1
     Αν ΜΟ[j-1,2]<ΜΟ[j,2] τότε
           Αντιμετάθεσε ΜΟ[j-1,1]<ΜΟ[j,1]
           Αντιμετάθεσε ΜΟ[j-1,2]<ΜΟ[j,2]
           Αντιμετάθεσε ΚΩΔ[j-1]< ΚΩΔ[j] 
    τέλος_αν
  τέλος_επανάληψης
τέλος_επανάληψης
Για i από 1 μέχρι 3
  εμφάνισε ΚΩΔ[ i ],  ΜΟ[i,2]
τέλος_επανάληψης

το " Αντιμετάθεσε ΜΟ[j-1,1]<ΜΟ[j,1] " μπορει να παραλειφθει. δεν χρειαζεται να διατηρηθει συσχέτιση απ τη στιγμη που η ασκηση τελειωνει.

CyberMove

  • Νέος
  • *
  • Μηνύματα: 8
  • 404 Error!
Απ: Θέμα Γ
« Απάντηση #64 στις: 17 Ιούν 2013, 03:41:55 μμ »
Καλησπέρα σε όλους!

Ορίστε η λύση μου για το Γ.4


Για κ από 1 μέχρι 3
          MAX_ΚΕΦΑΛΙ<--ΜΟ[1,1]               !Εύρεση μεγίστου για το SAR κεφάλι.
          ΘΕΣΗ<--1
          Για i από 2 μέχρι 30
                  Αν ΜΟ[i,1]>MAX_ΚΕΦΑΛΙ τότε
                       MAX_ΚΕΦΑΛΙ<--ΜΟ[i,1]
                       ΘΕΣΗ<--i
                  Τέλος_Αν
          Τέλος_Επανάληψης
                  Εμφάνισε MAX_ΚΕΦΑΛΙ,ΚΩΔ[ΘΕΣΗ]
                  ΜΑΧ_ΚΕΦΑΛΙ<--0                         !Τέλος εύρεσης μεγίστου για το SAR κεφάλι.
                  MAX_ΑΚΡΟ<--ΜΟ[1,2]                  !Εύρεση μεγίστου για το SAR άκρο.       
          ΘΕΣΗ2<--1
          Για j από 2 μέχρι 30
                  Αν ΜΟ[j,2]>MAX_ΑΚΡΟ τότε
                      MAX_ΑΚΡΟ<--ΜΟ[j,2]
                      ΘΕΣΗ2<--j
                 Τέλος_Αν
          Τέλος_Επανάληψης
          Εμφάνισε MAX_ΑΚΡΟ,ΚΩΔ[ΘΕΣΗ2]
          ΜΑΧ_ΑΚΡΟ<--0                                    !Τέλος εύρεσης μεγίστου για το SAR άκρο.
Τέλος_Επανάληψης                                   

Απλά το έχω βάλει να βρίσκει κάθε φορά τα μέγιστα και από τα 2 SAR (δηλαδή όταν κ=1,το πρώτο MAX_SAR_ΚΕΦΑΛΙ και MAX_SAR_ΑΚΡΟ,όταν κ=2 τότε το δεύτερο MAX_SAR_ΚΕΦΑΛΙ και MAX_SAR_ΑΚΡΟ και όταν κ=3 τότε το τρίτο MAX_SAR_ΚΕΦΑΛΙ και MAX_SAR_ΑΚΡΟ)

Ελπίζω να μου το πάρουν σωστό στην βαθμολόγηση... :P
« Τελευταία τροποποίηση: 19 Ιούν 2013, 08:21:12 μμ από CyberMove »
If Grandma_Had_Rolls = TRUE Then
        MsgBox.Style ("Grandma = TROLLEY")
End_If

Dinos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 86
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #65 στις: 18 Ιούν 2013, 06:08:14 μμ »
Αγαπητέ CyberMove, σου εύχομαι ολόψυχα καλά αποτελέσματα και καλό καλοκαίρι.
Όσον αφορά στο Γ4, σου παραθέτω μια ενδεικτική λύση, βασισμένη στη δική σου πρωτότυπη αλλά λίγο "μπελαλίδικη" προσέγγιση.
ΠΡΟΣΟΧΗ: Κάθε φορά αναζητάς το μέγιστο από όλα εκτός από το ένα ή  τα δύο προηγούμενα μέγιστα[/color
Κώδικας: [Επιλογή]
Θ1 <-- 0, Θ2 <-- 0
Θ3 <-- 0, Θ4 <-- 0
Για κ από 1 μέχρι 3
MAX_ΚΕΦΑΛΙ <-- 0               !Εύρεση μεγίστου για το SAR κεφάλι.
Για i από 1 μέχρι 30
Αν ΜΟ[i,1] > MAX_ΚΕΦΑΛΙ  ΚΑΙ i<>Θ1 ΚΑΙ i<>Θ2 τότε
MAX_ΚΕΦΑΛΙ<--ΜΟ[i,1]
ΘΕΣΗ<--i
Τέλος_Αν         
Τέλος_Επανάληψης
Εμφάνισε ΜΑΧ_ΚΕΦΑΛΙ, ΚΩΔ[ΘΕΣΗ]                     
MAX_ΑΚΡΟ<--0                  !Εύρεση μεγίστου για το SAR άκρο.       
Για j από 1 μέχρι 30
Αν ΜΟ[j,2]>MAX_ΑΚΡΟ ΚΑΙ i <>Θ3 ΚΑΙ i <>Θ4 τότε
MAX_ΑΚΡΟ<--ΜΟ[j,2]
ΘΕΣΗ2<--j
Τέλος_Αν
Τέλος_Επανάληψης                        !
Εμφάνισε MAX_ΑΚΡΟ,ΚΩΔ[ΘΕΣΗ2]
Αν κ = 1 τότε
Θ1 <-- ΘΕΣΗ
Θ3 <-- ΘΕΣΗ2
Αλλιώς_αν κ = 2 τότε
Θ2 <-- ΘΕΣΗ
Θ4 <-- ΘΕΣΗ2
Τέλος_αν
Τέλος_Επανάληψης

CyberMove

  • Νέος
  • *
  • Μηνύματα: 8
  • 404 Error!
Απ: Θέμα Γ
« Απάντηση #66 στις: 19 Ιούν 2013, 08:29:19 μμ »
Αγαπητέ CyberMove, σου εύχομαι ολόψυχα καλά αποτελέσματα και καλό καλοκαίρι.
Όσον αφορά στο Γ4, σου παραθέτω μια ενδεικτική λύση, βασισμένη στη δική σου πρωτότυπη αλλά λίγο "μπελαλίδικη" προσέγγιση.
ΠΡΟΣΟΧΗ: Κάθε φορά αναζητάς το μέγιστο από όλα εκτός από το ένα ή  τα δύο προηγούμενα μέγιστα[/color
Κώδικας: [Επιλογή]
Θ1 <-- 0, Θ2 <-- 0
Θ3 <-- 0, Θ4 <-- 0
Για κ από 1 μέχρι 3
MAX_ΚΕΦΑΛΙ <-- 0               !Εύρεση μεγίστου για το SAR κεφάλι.
Για i από 1 μέχρι 30
Αν ΜΟ[i,1] > MAX_ΚΕΦΑΛΙ  ΚΑΙ i<>Θ1 ΚΑΙ i<>Θ2 τότε
MAX_ΚΕΦΑΛΙ<--ΜΟ[i,1]
ΘΕΣΗ<--i
Τέλος_Αν         
Τέλος_Επανάληψης
Εμφάνισε ΜΑΧ_ΚΕΦΑΛΙ, ΚΩΔ[ΘΕΣΗ]                     
MAX_ΑΚΡΟ<--0                  !Εύρεση μεγίστου για το SAR άκρο.       
Για j από 1 μέχρι 30
Αν ΜΟ[j,2]>MAX_ΑΚΡΟ ΚΑΙ i <>Θ3 ΚΑΙ i <>Θ4 τότε
MAX_ΑΚΡΟ<--ΜΟ[j,2]
ΘΕΣΗ2<--j
Τέλος_Αν
Τέλος_Επανάληψης                        !
Εμφάνισε MAX_ΑΚΡΟ,ΚΩΔ[ΘΕΣΗ2]
Αν κ = 1 τότε
Θ1 <-- ΘΕΣΗ
Θ3 <-- ΘΕΣΗ2
Αλλιώς_αν κ = 2 τότε
Θ2 <-- ΘΕΣΗ
Θ4 <-- ΘΕΣΗ2
Τέλος_αν
Τέλος_Επανάληψης

Κατ'αρχάς σε ευχαριστώ πολύ! Σου εύχομαι και εσένα (και όλους εδώ) ένα υπέροχο καλοκαίρι και καλή ξεκούραση (για όσους έδιναν,καλά αποτελέσματα).

Όντως η παραλλαγή αυτή είναι λίγο μπελαλίδικη.Μου πήρε πάνω-κάτω 10 λεπτά να κατανοήσω αυτό το κομμάτι:

Αν κ = 1 τότε
      Θ1 <-- ΘΕΣΗ
      Θ3 <-- ΘΕΣΗ2
   Αλλιώς_αν κ = 2 τότε
      Θ2 <-- ΘΕΣΗ
      Θ4 <-- ΘΕΣΗ2
   Τέλος_αν


Αν κατάλαβα σωστά,επειδή στις δομές επιλογής έχεις i<>Θ1 ΚΑΙ i<>Θ2,i <>Θ3 ΚΑΙ i <>Θ4 απλά όταν θα φτάσει στην θέση του πρώτου MAX δεν θα μπει γιατί δεν θα ικανοποιήτε η συνθήκη και πάει στο επόμενο στοιχείο (αν υπάρχει).
Το κ=3 δεν το έβαλες γιατί είναι τα τελικά MAX που θα εμφανίζει και εκεί μετά τελειώνει η άσκηση.

:)
If Grandma_Had_Rolls = TRUE Then
        MsgBox.Style ("Grandma = TROLLEY")
End_If