Αποστολέας Θέμα: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009  (Αναγνώστηκε 16382 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3012
  • to Iterate is human to Recurse divine
Το επαναληπτικό διαγώνισμα για τη χρονιά 2008-2009 στα κεφάλαια  1 και 2 από το στέκι των πληροφορικών
Ευχαριστούμε όσους βοήθησαν με τα σχόλια και την κριτική τους πάνω στα θέματα.

« Τελευταία τροποποίηση: 19 Ιαν 2009, 02:28:42 μμ από gpapargi »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 588
    • Ανάπτυξη Εφαρμογών
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #1 στις: 29 Δεκ 2008, 06:44:09 μμ »
Μπράβο σας παιδιά, πολύ καλή δουλειά με έμπνευση.


Έχω τρεις παρατηρήσεις.

Θέμα 1 β1, β2.

Παράθεση
Η πολλαπλή επιλογή  Αν…τότε …αλλιώς_αν  δεν μπορεί να αντικαταστήσει κάθε περίπτωση εμφωλευμένης δομής επιλογής.
Δεν έχω καταλάβει κάτι. Αν υποθέσουμε ότι ο μαθητής απαντήσει ότι δεν μπορεί, γιατί πρέπει να δικαιολογήσει ότι το β2 δεν γίνεται, αφού βλέπει ότι γίνεται;
μπορεί να έχει ένα άλλο παράδειγμα στο μυαλό του το οποίο δεν γίνεται.


Θέμα 3

Καλό θέμα, αλλά νομίζω ότι θα έπρεπε να απέχει από τον τζόγο.


Γενικά για όλα τα θέματα.

Η άποψη μου είναι ότι όλα είναι καλά εμπνευσμένα, αλλά ένας μέτριος μαθητής δεν ξέρω αν μπορεί εύκολα να πάρει τη βάση.

Ευχαριστώ και Χρόνια Πολλά.

 

« Τελευταία τροποποίηση: 29 Δεκ 2008, 08:03:11 μμ από ntzios kostas »
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 996
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #2 στις: 29 Δεκ 2008, 11:09:42 μμ »
Ευχαριστούμε για τα καλά σου λόγια.

Τα Θ1.Β1,Β2 και Θ1.Γ, Δ τα έχω βάλει σε διαγώνισμα.

Κανείς δε διαμαρτυρήθηκε για τη διατύπωση.

Οι σκεπτόμενοι ;  Τα απάντησαν.

Οι παπαγάλοι ;  Πολύχρωμα φτερά  στον αέρα !!!

Οι λύσεις τέλη Γενάρη 2009.


Καλή χρονιά.

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 588
    • Ανάπτυξη Εφαρμογών
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #3 στις: 30 Δεκ 2008, 01:02:05 μμ »
δηλαδή αν ένας μαθητής γράψει

Διάβασε α
Αν α > 100 τότε
     x <--2
αλλιώς_αν α<=10 τότε
     x<-- x+5
αλλιώς
     x<--x+5
     x<-- x * x
Τέλος_αν

πρέπει να γράψει ότι η πρόταση στο Β1 είναι λάθος;
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 82
  • !!!!...!!!
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #4 στις: 30 Δεκ 2008, 01:02:57 μμ »
Μπράβο παιδιά κι ευχαριστούμε για τη δουλειά που κάνατε.
Θα συμφωνήσω με το συνάδελφο που έχει αντιρήσεις στην εκφώνηση του Β2.
Ο μαθητής που δίνει απάντηση "Σωστή" στο ερώτημα Β1 μπορεί λανθασμένα να έχει στο μυαλό του κάποια περίπτωση εμφωλευμένης  δομής επιλογής που δεν μπορεί να αντικατασταθεί. Στο ερώτημα Β2 του δίνεται ένα συγκεκριμένο τμήμα αλγορίθμου που μπορεί να μετατραπεί. Αυτό δεν αναιρεί αυτό που λανθασμένα ο μαθητής έχει σκεφτεί. Για ποιο λόγο θα πρέπει λοιπόν να αιτιολογήσει;
Επίσης το ότι ένα θέμα έχει μπει σε διαγώνισμα και δεν ειχε αντιδράσεις από τους μαθητές δεν εγγυάται πάντα την ορθή διατύπωση του.

Καλή χρονιά να έχουμε!!

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2421
  • I 'm not young enough to know everything
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #5 στις: 07 Ιαν 2009, 10:34:03 πμ »

Παράθεση
Η πολλαπλή επιλογή  Αν…τότε …αλλιώς_αν  δεν μπορεί να αντικαταστήσει κάθε περίπτωση εμφωλευμένης δομής επιλογής.
Δεν έχω καταλάβει κάτι. Αν υποθέσουμε ότι ο μαθητής απαντήσει ότι δεν μπορεί, γιατί πρέπει να δικαιολογήσει ότι το β2 δεν γίνεται, αφού βλέπει ότι γίνεται;
μπορεί να έχει ένα άλλο παράδειγμα στο μυαλό του το οποίο δεν γίνεται.

Το 1Β1 και 1Β2 όταν το πρωτοδιάβασα το αντιλήφθηκα ως εξής:

Ρωτάμε αν κάθε εμφώλευση γίνεται με πολλαπλή. Για κάποιον που θα απαντήσει ότι γίνεται τότε το δεύτερο ερώτημα είναι το προφανές (δηλαδή να κάνει τη μετατροπή).
Για αυτό που θα απαντήσει ότι δε γίνεται το ερώτημα είναι να δώσει κάποιο λόγο. Ο λόγος αυτός είναι ανεξάρτητος από τον ψευδοκώδικα του 1Β2 (αυτός απευθύνεται μόνο σε αυτόν που απάντησε ότι γίνεται η μετατροπή). 

Δηλαδή να μας δώσει ένα σενάριο που έχει στο νου του στο οποίο η μετατροπή είναι αδύνατη (ένα αντιπαράδειγμα). Αν φυσική πιστεύει ότι δε γίνεται η μετατροπή στον κώδικα που αναφέρεται μπορεί να τον χρησιμοποιήσει και να δείξει που στραβώνει το πράγμα.

Για μένα η σωστή απάντηση είναι ότι πάντα γίνεται η μετατροπή. Το πλήθος των περιπτώσεων τις οποίες πρέπει να διακρίνουμε είναι πεπερασμένο. Μπορούμε λοιπόν να τις απαριθμήσουμε μια  προς μια και να τις βάλουμε σε μια πολλαπλή επιλογή. Όσες και να είναι οι μεταβλητές μας και σε όσα διαστήματα να χωρίζεται η κάθε μια,  πάντα μπορούν να φτιαχτούν όλοι οι πιθανοί συνδυασμοί διαστημάτων και να εντοπίσουμε τα βήματα που γίνονται σε κάθε περίπτωση. Υπέθεσα πως κάποια αντίστοιχη επιχειρηματολογία (ή ένα αντιπαράδειγμα) θα έδινε και κάποιος που υποστήριζε το αντίθετο, χωρίς να είναι αναγκαστική η αναφορά στον κώδικα που δίνεται.
Αν σας καλύπτει η θέση μου να συζητήσουμε πιθανή αναδιατύπωση.

Θέμα 3

Καλό θέμα, αλλά νομίζω ότι θα έπρεπε να απέχει από τον τζόγο.


Κώστα το βλέπω εντελώς αντίθετα  :) . Ο τζόγος είναι κάτι πιασιάρικο που θα τραβήξει το μαθητή και θα διαφημίσει το μάθημά μας. Πέρυσι βάλαμε τα φρουτάκια. Με αυτόν τον τρόπο θα δείξουμε ότι ο μαθητής μέσω της ΑΕΠΠ μπορεί να ασχοληθεί με ωραία πράγματα που θα του κεντρίσουν την προσοχή. Η καθηγητές πληροφορικής γενικά είναι πιο νέοι από τους άλλους και πιστεύω πως πρέπει να «χτυπήσουμε» στο ότι το χάσμα των γενεών που έχουν οι μαθητές με εμάς είναι μικρότερο.

Γενικά για όλα τα θέματα.

Η άποψη μου είναι ότι όλα είναι καλά εμπνευσμένα, αλλά ένας μέτριος μαθητής δεν ξέρω αν μπορεί εύκολα να πάρει τη βάση.


Εννοείς ότι κάποια θέματα από τα υποτιθέμενα "εύκολα" θέματα 1 και 2 είναι πιο δύσκολα από όσο θα έπρεπε, ή ότι τα 3 και 4 είναι πιο δύσκολα από όσο πρέπει;   
Γιώργος Παπαργύρης (gpapargi@hotmail.com)

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 108
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #6 στις: 07 Ιαν 2009, 11:18:24 πμ »
Η μετατροπή εμφωλευμένης σε πολλαπλή δεν γίνεται πάντα!
Π.χ.
Διάβασε Χ, A
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- A + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν
« Τελευταία τροποποίηση: 07 Ιαν 2009, 12:36:13 μμ από sstergou »

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #7 στις: 07 Ιαν 2009, 12:36:29 μμ »
Αυτό;

Κώδικας: Text
  1. Διάβασε Χ,Α
  2. Αν χ > 0 τότε
  3.   Εμφάνισε Χ
  4. αλλιώς_αν χ > -6
  5.   Χ <- Α + 3
  6.   Υ <- 5
  7. αλλιώς
  8.   Χ <- Α + 3
  9. Τέλος_αν
  10.  
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3012
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #8 στις: 07 Ιαν 2009, 12:38:17 μμ »
Νομίζω γίνεται κάπως έτσι. Η ιδέα είναι ότι οποιαδήποτε εμφωλευμένη ανάγεται σε ένα σύνολο από πεπερασμένες περιπτώσεις. Αυτό πρέπει να αποδεικνύεται και θεωρητικά. (Νομίζω ότι ο Παπαργύρης έχει μια απόδειξη στα σκαριά)

Κώδικας: Text
  1. Διάβασε Χ, A
  2. Αν Χ>0 τότε
  3.      Εμφάνισε Χ
  4. αλλιώς_αν Χ > -6 τότε
  5.      Χ <-- A + 3
  6.      Υ <-- 5
  7. αλλιώς
  8.      Χ <-- A + 3
  9. Τέλος_αν
  10.  

Η μετατροπή εμφωλευμένης σε πολλαπλή δεν γίνεται πάντα!
Π.χ.
Διάβασε Χ, A
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- A + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3012
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #9 στις: 07 Ιαν 2009, 12:39:02 μμ »
Καλά ρε Στάθη, συννενοημένοι είμασταν?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2421
  • I 'm not young enough to know everything
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #10 στις: 07 Ιαν 2009, 12:49:06 μμ »
Τώρα είδα και τους άλλους... Ποστάρω και εγώ και βλέπουμε  :)

Κοίτα η συγκεκριμένη πρέπει να γίνεται. Βασικά πρέπει να προσέξεις ότι οι ενέργειες που γίνονται διαφέρουν ανάλογα με το αν το Χ είναι πάνω από 0, από -9 ως 0 ή κάτω από -9. Δηλαδή

Διάβασε Χ
Αν Χ>0 τότε
  Εμφάνισε Χ
Αλλιώς_αν Χ<=0 και Χ>-9 τότε
  Χ<-Χ+3
  Υ<-5
Αλλιώς_αν Χ<=-9 τότε
  Χ<-Χ+3
Τέλος_αν

Ελπίζω να μη μου ξέφυγε κάτι. Πάντως γενικά με τις μετατροπές έχω πολλές ενστάσεις καθώς εγώ πιστεύω ότι για να είναι ισοδύναμες 2 κωδικοποιήσεις θα πρέπει και οι 2 να κάνουν ακριβώς τα ίδια πράγματα και με ακριβώς την ίδια σειρά…αλλά αυτό είναι άλλο θέμα.

edit:

Ουπς μόλις είδα ότι άλλαξες το αρχικό παράδειγμα Ηλία. Η μετατροπή που έγραψα αφορά το αρχικό που είναι το:
Διάβασε Χ
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- Χ + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν

Θα δω και το άλλο καθώς και τα άλλα μηνύματα και τα λέμε
Γιώργος Παπαργύρης (gpapargi@hotmail.com)

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #11 στις: 07 Ιαν 2009, 12:54:16 μμ »
Α, όλα κι όλα, εγώ με τον Παπαργύρη δεν έχω σχέσεις, έχει αποδείξεις για όλα :)

Καλά ρε Στάθη, συννενοημένοι είμασταν?
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 108
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #12 στις: 07 Ιαν 2009, 01:01:52 μμ »
Νομίζω γίνεται κάπως έτσι. Η ιδέα είναι ότι οποιαδήποτε εμφωλευμένη ανάγεται σε ένα σύνολο από πεπερασμένες περιπτώσεις. Αυτό πρέπει να αποδεικνύεται και θεωρητικά. (Νομίζω ότι ο Παπαργύρης έχει μια απόδειξη στα σκαριά)

Κώδικας: Text
  1. Διάβασε Χ, A
  2. Αν Χ>0 τότε
  3.      Εμφάνισε Χ
  4. αλλιώς_αν Χ > -6 τότε
  5.      Χ <-- A + 3
  6.      Υ <-- 5
  7. αλλιώς
  8.      Χ <-- A + 3
  9. Τέλος_αν
  10.  

Η μετατροπή εμφωλευμένης σε πολλαπλή δεν γίνεται πάντα!
Π.χ.
Διάβασε Χ, A
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- A + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν

Δεν μπορεί να γίνει έτσι γιατί στην 2η περίπτωση δεν μιλάμε για το αρχικό Χ αλλά το Α + 3

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3012
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #13 στις: 07 Ιαν 2009, 01:13:27 μμ »
ωχ, έχεις δίκιο, κάτι μου ξέφυγε, για να δούμε, το παρακάτω είναι δεκτό?

Κώδικας: Text
  1. Διάβασε Χ, A
  2. Αν Χ>0 τότε
  3.      Εμφάνισε Χ
  4. αλλιώς_αν Α+3 > -6 τότε
  5.      Χ <-- A + 3
  6.      Υ <-- 5
  7. αλλιώς
  8.      Χ <-- A + 3
  9. Τέλος_αν
  10.  

Δεν μπορεί να γίνει έτσι γιατί στην 2η περίπτωση δεν μιλάμε για το αρχικό Χ αλλά το Α + 3
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
« Απάντηση #14 στις: 07 Ιαν 2009, 01:16:36 μμ »
Ευριπιδη τώρα πρόλαβες εσύ!
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr