Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Δομή επανάληψης => Μήνυμα ξεκίνησε από: evry στις 29 Δεκ 2008, 12:09:14 μμ

Τίτλος: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: evry στις 29 Δεκ 2008, 12:09:14 μμ
Το επαναληπτικό διαγώνισμα για τη χρονιά 2008-2009 στα κεφάλαια  1 και 2 από το στέκι των πληροφορικών
Ευχαριστούμε όσους βοήθησαν με τα σχόλια και την κριτική τους πάνω στα θέματα.

Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ntzios kostas στις 29 Δεκ 2008, 06:44:09 μμ
Μπράβο σας παιδιά, πολύ καλή δουλειά με έμπνευση.


Έχω τρεις παρατηρήσεις.

Θέμα 1 β1, β2.

Παράθεση
Η πολλαπλή επιλογή  Αν…τότε …αλλιώς_αν  δεν μπορεί να αντικαταστήσει κάθε περίπτωση εμφωλευμένης δομής επιλογής.
Δεν έχω καταλάβει κάτι. Αν υποθέσουμε ότι ο μαθητής απαντήσει ότι δεν μπορεί, γιατί πρέπει να δικαιολογήσει ότι το β2 δεν γίνεται, αφού βλέπει ότι γίνεται;
μπορεί να έχει ένα άλλο παράδειγμα στο μυαλό του το οποίο δεν γίνεται.


Θέμα 3

Καλό θέμα, αλλά νομίζω ότι θα έπρεπε να απέχει από τον τζόγο.


Γενικά για όλα τα θέματα.

Η άποψη μου είναι ότι όλα είναι καλά εμπνευσμένα, αλλά ένας μέτριος μαθητής δεν ξέρω αν μπορεί εύκολα να πάρει τη βάση.

Ευχαριστώ και Χρόνια Πολλά.

 

Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: andreas_p στις 29 Δεκ 2008, 11:09:42 μμ
Ευχαριστούμε για τα καλά σου λόγια.

Τα Θ1.Β1,Β2 και Θ1.Γ, Δ τα έχω βάλει σε διαγώνισμα.

Κανείς δε διαμαρτυρήθηκε για τη διατύπωση.

Οι σκεπτόμενοι ;  Τα απάντησαν.

Οι παπαγάλοι ;  Πολύχρωμα φτερά  στον αέρα !!!

Οι λύσεις τέλη Γενάρη 2009.


Καλή χρονιά.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ntzios kostas στις 30 Δεκ 2008, 01:02:05 μμ
δηλαδή αν ένας μαθητής γράψει

Διάβασε α
Αν α > 100 τότε
     x <--2
αλλιώς_αν α<=10 τότε
     x<-- x+5
αλλιώς
     x<--x+5
     x<-- x * x
Τέλος_αν

πρέπει να γράψει ότι η πρόταση στο Β1 είναι λάθος;
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: vasiko στις 30 Δεκ 2008, 01:02:57 μμ
Μπράβο παιδιά κι ευχαριστούμε για τη δουλειά που κάνατε.
Θα συμφωνήσω με το συνάδελφο που έχει αντιρήσεις στην εκφώνηση του Β2.
Ο μαθητής που δίνει απάντηση "Σωστή" στο ερώτημα Β1 μπορεί λανθασμένα να έχει στο μυαλό του κάποια περίπτωση εμφωλευμένης  δομής επιλογής που δεν μπορεί να αντικατασταθεί. Στο ερώτημα Β2 του δίνεται ένα συγκεκριμένο τμήμα αλγορίθμου που μπορεί να μετατραπεί. Αυτό δεν αναιρεί αυτό που λανθασμένα ο μαθητής έχει σκεφτεί. Για ποιο λόγο θα πρέπει λοιπόν να αιτιολογήσει;
Επίσης το ότι ένα θέμα έχει μπει σε διαγώνισμα και δεν ειχε αντιδράσεις από τους μαθητές δεν εγγυάται πάντα την ορθή διατύπωση του.

Καλή χρονιά να έχουμε!!
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: gpapargi στις 07 Ιαν 2009, 10:34:03 πμ

Παράθεση
Η πολλαπλή επιλογή  Αν…τότε …αλλιώς_αν  δεν μπορεί να αντικαταστήσει κάθε περίπτωση εμφωλευμένης δομής επιλογής.
Δεν έχω καταλάβει κάτι. Αν υποθέσουμε ότι ο μαθητής απαντήσει ότι δεν μπορεί, γιατί πρέπει να δικαιολογήσει ότι το β2 δεν γίνεται, αφού βλέπει ότι γίνεται;
μπορεί να έχει ένα άλλο παράδειγμα στο μυαλό του το οποίο δεν γίνεται.

Το 1Β1 και 1Β2 όταν το πρωτοδιάβασα το αντιλήφθηκα ως εξής:

Ρωτάμε αν κάθε εμφώλευση γίνεται με πολλαπλή. Για κάποιον που θα απαντήσει ότι γίνεται τότε το δεύτερο ερώτημα είναι το προφανές (δηλαδή να κάνει τη μετατροπή).
Για αυτό που θα απαντήσει ότι δε γίνεται το ερώτημα είναι να δώσει κάποιο λόγο. Ο λόγος αυτός είναι ανεξάρτητος από τον ψευδοκώδικα του 1Β2 (αυτός απευθύνεται μόνο σε αυτόν που απάντησε ότι γίνεται η μετατροπή). 

Δηλαδή να μας δώσει ένα σενάριο που έχει στο νου του στο οποίο η μετατροπή είναι αδύνατη (ένα αντιπαράδειγμα). Αν φυσική πιστεύει ότι δε γίνεται η μετατροπή στον κώδικα που αναφέρεται μπορεί να τον χρησιμοποιήσει και να δείξει που στραβώνει το πράγμα.

Για μένα η σωστή απάντηση είναι ότι πάντα γίνεται η μετατροπή. Το πλήθος των περιπτώσεων τις οποίες πρέπει να διακρίνουμε είναι πεπερασμένο. Μπορούμε λοιπόν να τις απαριθμήσουμε μια  προς μια και να τις βάλουμε σε μια πολλαπλή επιλογή. Όσες και να είναι οι μεταβλητές μας και σε όσα διαστήματα να χωρίζεται η κάθε μια,  πάντα μπορούν να φτιαχτούν όλοι οι πιθανοί συνδυασμοί διαστημάτων και να εντοπίσουμε τα βήματα που γίνονται σε κάθε περίπτωση. Υπέθεσα πως κάποια αντίστοιχη επιχειρηματολογία (ή ένα αντιπαράδειγμα) θα έδινε και κάποιος που υποστήριζε το αντίθετο, χωρίς να είναι αναγκαστική η αναφορά στον κώδικα που δίνεται.
Αν σας καλύπτει η θέση μου να συζητήσουμε πιθανή αναδιατύπωση.

Θέμα 3

Καλό θέμα, αλλά νομίζω ότι θα έπρεπε να απέχει από τον τζόγο.


Κώστα το βλέπω εντελώς αντίθετα  :) . Ο τζόγος είναι κάτι πιασιάρικο που θα τραβήξει το μαθητή και θα διαφημίσει το μάθημά μας. Πέρυσι βάλαμε τα φρουτάκια. Με αυτόν τον τρόπο θα δείξουμε ότι ο μαθητής μέσω της ΑΕΠΠ μπορεί να ασχοληθεί με ωραία πράγματα που θα του κεντρίσουν την προσοχή. Η καθηγητές πληροφορικής γενικά είναι πιο νέοι από τους άλλους και πιστεύω πως πρέπει να «χτυπήσουμε» στο ότι το χάσμα των γενεών που έχουν οι μαθητές με εμάς είναι μικρότερο.

Γενικά για όλα τα θέματα.

Η άποψη μου είναι ότι όλα είναι καλά εμπνευσμένα, αλλά ένας μέτριος μαθητής δεν ξέρω αν μπορεί εύκολα να πάρει τη βάση.


Εννοείς ότι κάποια θέματα από τα υποτιθέμενα "εύκολα" θέματα 1 και 2 είναι πιο δύσκολα από όσο θα έπρεπε, ή ότι τα 3 και 4 είναι πιο δύσκολα από όσο πρέπει;   
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ikariofil στις 07 Ιαν 2009, 11:18:24 πμ
Η μετατροπή εμφωλευμένης σε πολλαπλή δεν γίνεται πάντα!
Π.χ.
Διάβασε Χ, A
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- A + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: sstergou στις 07 Ιαν 2009, 12:36:29 μμ
Αυτό;

Κώδικας: Ψευδογλώσσα
  1. Διάβασε Χ,Α
  2. Αν χ > 0 τότε
  3.   Εμφάνισε Χ
  4. αλλιώς_αν χ > -6
  5.   Χ <- Α + 3
  6.   Υ <- 5
  7. αλλιώς
  8.   Χ <- Α + 3
  9. Τέλος_αν
  10.  
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: evry στις 07 Ιαν 2009, 12:38:17 μμ
Νομίζω γίνεται κάπως έτσι. Η ιδέα είναι ότι οποιαδήποτε εμφωλευμένη ανάγεται σε ένα σύνολο από πεπερασμένες περιπτώσεις. Αυτό πρέπει να αποδεικνύεται και θεωρητικά. (Νομίζω ότι ο Παπαργύρης έχει μια απόδειξη στα σκαριά)

Κώδικας: ΓΛΩΣΣΑ
  1. Διάβασε Χ, A
  2. Αν Χ>0 τότε
  3.      Εμφάνισε Χ
  4. αλλιώς_αν Χ > -6 τότε
  5.      Χ <-- A + 3
  6.      Υ <-- 5
  7. αλλιώς
  8.      Χ <-- A + 3
  9. Τέλος_αν
  10.  

Η μετατροπή εμφωλευμένης σε πολλαπλή δεν γίνεται πάντα!
Π.χ.
Διάβασε Χ, A
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- A + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: evry στις 07 Ιαν 2009, 12:39:02 μμ
Καλά ρε Στάθη, συννενοημένοι είμασταν?
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: gpapargi στις 07 Ιαν 2009, 12:49:06 μμ
Τώρα είδα και τους άλλους... Ποστάρω και εγώ και βλέπουμε  :)

Κοίτα η συγκεκριμένη πρέπει να γίνεται. Βασικά πρέπει να προσέξεις ότι οι ενέργειες που γίνονται διαφέρουν ανάλογα με το αν το Χ είναι πάνω από 0, από -9 ως 0 ή κάτω από -9. Δηλαδή

Διάβασε Χ
Αν Χ>0 τότε
  Εμφάνισε Χ
Αλλιώς_αν Χ<=0 και Χ>-9 τότε
  Χ<-Χ+3
  Υ<-5
Αλλιώς_αν Χ<=-9 τότε
  Χ<-Χ+3
Τέλος_αν

Ελπίζω να μη μου ξέφυγε κάτι. Πάντως γενικά με τις μετατροπές έχω πολλές ενστάσεις καθώς εγώ πιστεύω ότι για να είναι ισοδύναμες 2 κωδικοποιήσεις θα πρέπει και οι 2 να κάνουν ακριβώς τα ίδια πράγματα και με ακριβώς την ίδια σειρά…αλλά αυτό είναι άλλο θέμα.

edit:

Ουπς μόλις είδα ότι άλλαξες το αρχικό παράδειγμα Ηλία. Η μετατροπή που έγραψα αφορά το αρχικό που είναι το:
Διάβασε Χ
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- Χ + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν

Θα δω και το άλλο καθώς και τα άλλα μηνύματα και τα λέμε
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: sstergou στις 07 Ιαν 2009, 12:54:16 μμ
Α, όλα κι όλα, εγώ με τον Παπαργύρη δεν έχω σχέσεις, έχει αποδείξεις για όλα :)

Καλά ρε Στάθη, συννενοημένοι είμασταν?
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ikariofil στις 07 Ιαν 2009, 01:01:52 μμ
Νομίζω γίνεται κάπως έτσι. Η ιδέα είναι ότι οποιαδήποτε εμφωλευμένη ανάγεται σε ένα σύνολο από πεπερασμένες περιπτώσεις. Αυτό πρέπει να αποδεικνύεται και θεωρητικά. (Νομίζω ότι ο Παπαργύρης έχει μια απόδειξη στα σκαριά)

Κώδικας: ΓΛΩΣΣΑ
  1. Διάβασε Χ, A
  2. Αν Χ>0 τότε
  3.      Εμφάνισε Χ
  4. αλλιώς_αν Χ > -6 τότε
  5.      Χ <-- A + 3
  6.      Υ <-- 5
  7. αλλιώς
  8.      Χ <-- A + 3
  9. Τέλος_αν
  10.  

Η μετατροπή εμφωλευμένης σε πολλαπλή δεν γίνεται πάντα!
Π.χ.
Διάβασε Χ, A
Αν Χ>0 τότε
     Εμφάνισε Χ
αλλιώς
     Χ <-- A + 3
     Αν Χ >-6 τότε
          Υ <-- 5
     Τέλος_αν
Τέλος_αν

Δεν μπορεί να γίνει έτσι γιατί στην 2η περίπτωση δεν μιλάμε για το αρχικό Χ αλλά το Α + 3
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: evry στις 07 Ιαν 2009, 01:13:27 μμ
ωχ, έχεις δίκιο, κάτι μου ξέφυγε, για να δούμε, το παρακάτω είναι δεκτό?

Κώδικας: ΓΛΩΣΣΑ
  1. Διάβασε Χ, A
  2. Αν Χ>0 τότε
  3.      Εμφάνισε Χ
  4. αλλιώς_αν Α+3 > -6 τότε
  5.      Χ <-- A + 3
  6.      Υ <-- 5
  7. αλλιώς
  8.      Χ <-- A + 3
  9. Τέλος_αν
  10.  

Δεν μπορεί να γίνει έτσι γιατί στην 2η περίπτωση δεν μιλάμε για το αρχικό Χ αλλά το Α + 3
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: sstergou στις 07 Ιαν 2009, 01:16:36 μμ
Ευριπιδη τώρα πρόλαβες εσύ!
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ikariofil στις 07 Ιαν 2009, 01:21:00 μμ
Ευριπίδη μου φαίνεται μια χαρά η απάντησή σου, αλλά αν υποστηρίξουμε ότι όλες οι μετατροπές γίνονται πως μπορούμε να το στηρίξουμε;
Αν πάλι υπάρχει κάποια που δεν μπορεί να μετατραπεί και δεν το σκεφτήκαμε;
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ntzios kostas στις 07 Ιαν 2009, 02:18:16 μμ
Καλησπέρα ,

για δείτε αν γίνεται και αυτό

διάβασε χ
αν χ>0 τότε
   διάβασε β
   αν β>0 τότε
      γράψε β
   τέλος_αν
αλλιώς
   γράψε χ
τελος_αν


Παράθεση
Παράθεση
Παράθεση από: ntzios kostas στις 29 Δεκ  2008, 06:44:09 μμ
Γενικά για όλα τα θέματα.

Η άποψη μου είναι ότι όλα είναι καλά εμπνευσμένα, αλλά ένας μέτριος μαθητής δεν ξέρω αν μπορεί εύκολα να πάρει τη βάση.


Εννοείς ότι κάποια θέματα από τα υποτιθέμενα "εύκολα" θέματα 1 και 2 είναι πιο δύσκολα από όσο θα έπρεπε, ή ότι τα 3 και 4 είναι πιο δύσκολα από όσο πρέπει;   

Μιλάω για τον συνδυασμό της δυσκολίας τους.

Παράθεση
Δηλαδή να μας δώσει ένα σενάριο που έχει στο νου του στο οποίο η μετατροπή είναι αδύνατη (ένα αντιπαράδειγμα). ....

Νομίζω ότι αυτό δεν φαίνεται από την εκφώνηση του θέματος.




Παράθεση
Παράθεση από: ntzios kostas στις 29 Δεκ  2008, 06:44:09 μμ
Θέμα 3

Καλό θέμα, αλλά νομίζω ότι θα έπρεπε να απέχει από τον τζόγο.


Ο τζόγος είναι κάτι πιασιάρικο που θα τραβήξει το μαθητή και θα διαφημίσει το μάθημά μας. Πέρυσι βάλαμε τα φρουτάκια. Με αυτόν τον τρόπο θα δείξουμε ότι ο μαθητής μέσω της ΑΕΠΠ μπορεί να ασχοληθεί με ωραία πράγματα που θα του κεντρίσουν την προσοχή. Η καθηγητές πληροφορικής γενικά είναι πιο νέοι από τους άλλους και πιστεύω πως πρέπει να «χτυπήσουμε» στο ότι το χάσμα των γενεών που έχουν οι μαθητές με εμάς είναι μικρότερο.

Πλάκα κάνεις???. :) :)
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ikariofil στις 07 Ιαν 2009, 02:52:38 μμ
Διάβασε χ, β
Αν χ<=0 τότε
     γράψε χ
αλλιώς_αν β>0 τότε
     γράψε β
Τέλος_αν

Μήπως θα μπορούσα έτσι;
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: sstergou στις 07 Ιαν 2009, 03:00:22 μμ
Διάβασε χ, β
Αν χ<=0 τότε
     γράψε χ
αλλιώς_αν β>0 τότε
     γράψε β
Τέλος_αν

Μήπως θα μπορούσα έτσι;

και αν το β έχει κάποια τιμή πριν τις εντολές; Εξάλλου στον κώδικα του Κώστα το β δεν διαβάζεται πάντα.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: gpapargi στις 07 Ιαν 2009, 03:03:14 μμ
Θα το δω και θα απαντήσω μεθαύριο. Πάντως το επιχείρημα που έγραψα παραπάνω αναφέρεται σε πεπερασμένες περιπτώσεις οι οποίες εννοείται ότι πρέπει να είναι διαθέσιμες στην αρχή (για να μπορείς να πεις "αυτές είναι όλες οι περιτπώσεις μας και ας τις περιγράψουμε με μια πολλαπλή". Αν υπάρχει εντολή διάβασε μέσα σε επιλογές τότε δεν είναι διαθέσιμες στην αρχή οι περιπτώσεις και ενδεχομένως να μην εφαρμόζεται το σκεπτικό. Θα στο σκεφτώ. Επίσης πρέπει να ελεγχθεί και η περίπτωση που αλλάζουν δυναμικά οι συνθήκες μέσα. Θέλει σκέψη το πράγμα. Φαίνεται πάντως πως ισχύει για στατικές συνθήκες.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ikariofil στις 07 Ιαν 2009, 03:07:10 μμ
Διάβασε χ, β
Αν χ<=0 τότε
     γράψε χ
αλλιώς_αν β>0 τότε
     γράψε β
Τέλος_αν

Μήπως θα μπορούσα έτσι;

και αν το β έχει κάποια τιμή πριν τις εντολές; Εξάλλου στον κώδικα του Κώστα το β δεν διαβάζεται πάντα.
Σημασία έχει που διαβάζεται το β ή αν οι εντολές είναι ισοδύναμες δηλ. ανά περίπτωση κάνουν ακριβώς τα ίδια;
Αλλά εν πάσει περίπτωσή τι απαντάμε στους μαθητές και πως το στηρίζουμε από κοινού;
Γίνεται η μετατροπή κάθε εμφωλευμένης σε πολλαπλή ή όχι;
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: sstergou στις 07 Ιαν 2009, 03:15:11 μμ
Εγώ πάντως δε θα το ρίσκαρα να πω ότι "πάντα" γίνεται η μετατροπή.
Ίσως αν παρεμβάλλονται εντολές ανάμεσα στις εμφωλεύσεις τα πράγματα να μην είναι τόσο απλά.

Στην αντίθετη περίπτωση πάντως (μη παρεμβολής εντολών) εντελώς διαισθητικά θα έλεγα ότι η μετατροπή είναι εφικτή... Αυτό πάλι ίσως μέχρι κάποιος να παραθέσει κάποιο αντιπαράδειγμα.

Σε καμία περίπτωση όμως δεν θα το έλεγα ως κανόνα, τουλάχιστον μέχρι κάποιος να μας δείξει την απόδειξη!
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: evry στις 07 Ιαν 2009, 05:39:22 μμ
Ναι, οκ κατάλαβα τι θες να πεις και έχεις δίκιο. Λογικά πρέπει να γίνεται πάντα, αλλά αυτό το "λογικά" μάλλον δε φτάνει, ακόμα και αν το αποδείξουμε σίγουρα δεν περιμένουμε από τον μαθητή να σκεφτεί κάτι τέτοιο. Ίσως αν αφήναμε μόνο το παράδειγμα. Δεν ξέρω, μπορούμε να το συζητήσουμε.

Ευριπίδη μου φαίνεται μια χαρά η απάντησή σου, αλλά αν υποστηρίξουμε ότι όλες οι μετατροπές γίνονται πως μπορούμε να το στηρίξουμε;
Αν πάλι υπάρχει κάποια που δεν μπορεί να μετατραπεί και δεν το σκεφτήκαμε;
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: pgrontas στις 07 Ιαν 2009, 05:51:13 μμ
Θα συμφωνήσω και εγώ με όσους ισχυρίζονται ότι το πάντα είναι πολύ βαρύ.
Ίσως θα ήταν καλύτερο να περιοριστούμε στο συγκεκριμένο παράδειγμα.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: evry στις 07 Ιαν 2009, 06:53:14 μμ
Λογικά πρέπει να γίνεται πάντα,

Νομίζω ότι όταν σκεφτόμασταν μια τέτοια μετατροπή κάποιοι (εγώ σίγουρα) κάναμε τη σιωπηλή παραδοχή (λανθασμένα φυσικά) ότι η μεταβλητές που εμφανίζονται στις συνθήκες της δομής επιλογής δεν μεταβάλλονται μέσα στο σώμα της επιλογής. Αν κάνουμε αυτή την παραδοχή πιστεύω ότι γίνεται σε κάθε περίπτωση. Στις άλλες θέλει λίγο σκέψη ή τουλάχιστον θέλει πολύ δουλειά η απόδειξη, αν υπάρχει

Τώρα στο παράδειγμα που έδωσε ο Κώστας η απάντηση του Ηλία δεν είναι σωστή γιατί ενώ θα έπρεπε να διαβάζει το β μόνο όταν το χ είναι θετικό τώρα το διαβάζει σε κάθε περίπτωση. Νομίζω κάτι που βγάζει ισοδύναμα αποτελέσματα και δεν περιέχει εμφωλευμένες μέσα θα μπορούσε να είναι το παρακάτω

Κώδικας: ΓΛΩΣΣΑ
  1. διάβασε χ
  2. αν χ>0 τότε
  3.    διάβασε β
  4. τέλος_αν
  5. αν χ>0 και β>0 τότε
  6.    γράψε β
  7. τέλος_αν
  8. Αν χ <= 0 τότε
  9.    γράψε χ
  10. τελος_αν
  11.  

το οποίο προφανώς δεν έχει τη δομή Αλλιώς_αν. Τώρα με Αλλιώς_Αν δεν μου έρχεται κάποια λύση τώρα και φοβάμαι πως δεν θα μου έρθει ούτε αύριο :(
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: lykos στις 07 Ιαν 2009, 07:26:12 μμ
Μια λεπτομέρεια για τον έλεγχο των δεδομένων στο 3ο θέμα: "οι ζαριές να είναι ακέραιοι από 1 μέχρι 6"
Μήπως ο εξυπνος μαθητής προσπαθήσει να αποκλείσει και πραγματικούς?
Νομίζω σωστότερη διατύπωση θα ήταν: "οι ζαριές να είναι αριθμοί από 1 μέχρι 6"

Οσο για το τζόγο, είμαι και γω της άποψης να αποφεύγουμε τέτοια θέματα. Εγώ μείωσα το "κακό" μετατρέποντας το σχετικό οπως στο επισυναπτόμενο. Παράλληλα τόκανα κάπως ευκολότερο.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: P.Tsiotakis στις 07 Ιαν 2009, 07:52:17 μμ
διάβασε χ
αν χ>0 και όχι β > 0 τότε
   διάβασε β
Αλλιώς_αν χ > 0 και β>0 τότε
   διάβασε β
   γράψε β
Αλλιώς_αν  όχι (χ>0) τότε
   γράψε χ
τελος_αν


Η μετατροπή μάλλον γίνεται πάντα, αν διαχωριστούν όλες οι διαφορετικές περιπτώσεις και υπάρξουν και εντολές που επαναλαμβάνονται.
Ωστόσο, αν δεν είμαστε σίγουροι εμείς, πως θα απαντήσουν οι μαθητές.

Μάλλον το συγκεκριμένο ερώτημα θα έπρεπε να αντικατασταθεί με κάποιο άλλο, τα μόρια να δοθούν στο νέο ερώτημα και η μετρατροπή να παραμείνει ως ξεχωριστό ερώτημα. Για υποψήφιο ΝΕΟ ερώτημα προτείνω κάποιο ερώτημα ανάπτυξης κάποιου ορισμού.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: Laertis στις 07 Ιαν 2009, 08:42:37 μμ
Θα συμφωνήσω και εγώ με όσους ισχυρίζονται ότι το πάντα είναι πολύ βαρύ.
Ίσως θα ήταν καλύτερο να περιοριστούμε στο συγκεκριμένο παράδειγμα.


Θα συμφωνήσω κι εγώ με τον Παναγιώτη (Γροντά). Ας αφήσουμε μόνο τη μετατροπή χωρίς το θεωρητικό σκέλος.

διάβασε χ
αν χ>0 και όχι β > 0 τότε
   διάβασε β
Αλλιώς_αν χ > 0 και β>0 τότε
   διάβασε β
   γράψε β
Αλλιώς_αν  όχι (χ>0) τότε
   γράψε χ
τελος_αν

Στην 1η συνθήκη τι τιμή έχει το β ; (όχι β > 0)
Δε νομίζω ότι είναι σωστό. Το β διαβάζεται μόνο όταν το χ είναι θετικό.

Υ.Γ. Είναι αρκετά ευχάριστο που γίνονται τόσα σχόλια και προτάσεις για το διαγώνισμα ώστε να τελειοποιηθεί. Είναι δυσάρεστο όμως ότι γίνονται εκπρόθεσμα (αφού δημοσιεύθηκε) ενώ εδώ και πάνω απο ένα μήνα περίπου ήταν υπό διόρθωση και διαπραγμάτευση....
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: P.Tsiotakis στις 07 Ιαν 2009, 08:59:41 μμ
Ναι ρε Γιώργο, το είχα στο μυαλό μου το πρωι και το ξέχασα.
Μάλλον το ωραίο παράδειγμα του Κώστα δεν γίνεται να μετατραπεί
σε πολλαπλή επιλογή, άρα όντως τελικά δεν ισχύςι πάντα η πρόταση.

Κατά τα άλλα, κρίνω οτι τα θέματα 1 και 2 είναι πολύ ωραία...
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: gpapargi στις 08 Ιαν 2009, 02:26:55 μμ
Τελικά πιστεύω κι εγώ πως αν υπάρχει διάβασε μέσα σε συνθήκη η μετατροπή δε γίνεται. Μάλιστα η πλάκα είναι ότι στο τρίτο θέμα έψαξα να βρω μια περίπτωση που γίνεται μόνο με εμφώλευση και όχι με πολλαπλή για να τους τσεκάρουμε υποχρεωτικά σε εμφωλεύσεις. Έτσι κατέληξα στο διάβασε υπό συνθήκη. Αλλά για ένα περίεργο λόγο όταν μιλάω  για μετατροπή μεταξύ εμφωλευμένων και πολλαπλών, το μυαλό μου πάει ασυναίσθητα σε συνθήκες που είναι δεδομένες εξαρχής και δε έχουν διάβασε.
Το σκεπτικό που ανέφερα στο αρχικό ποστ μου περί πεπερασμένων συνδοιασμών δεν εφαρμόζεται αφού αναφέρεται στους πεπερασμένους συνδυασμούς των μεταβλητών που είναι  γνωστοί εξαρχής. Εδώ το β παίρνει τιμή στην πορεία.

Προτείνω και εγώ να ζητηθεί απλά η μετατροπή και για μένα καλό είναι σε τέτοιες μετατροπές να μην υπάρχουν εντολές «σκέτες». Η εμφώλευση να γίνεται σύνθετη συνθήκη σε μια πολλαπλή ή το αν μέσα στο αλλιώς να ανεβαίνει πάνω και να γίνεται αλλιώς_αν. Μέχρι εκεί. Τα υπόλοιπα νομίζω πως ξεφεύγουν από το σκοπό του μαθήματος.   
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: gpapargi στις 08 Ιαν 2009, 02:34:42 μμ
Μια λεπτομέρεια για τον έλεγχο των δεδομένων στο 3ο θέμα: "οι ζαριές να είναι ακέραιοι από 1 μέχρι 6"
Μήπως ο εξυπνος μαθητής προσπαθήσει να αποκλείσει και πραγματικούς?
Νομίζω σωστότερη διατύπωση θα ήταν: "οι ζαριές να είναι αριθμοί από 1 μέχρι 6"

Η σκέψη που είχα στο νου μου όταν πρότεινα αυτή την άσκηση ήταν να αποκλειστούν και οι πραγματικοί. Αν θυμάμαι καλά έχει πέσει και στις εξετάσεις.

Οσο για το τζόγο, είμαι και γω της άποψης να αποφεύγουμε τέτοια θέματα. Εγώ μείωσα το "κακό" μετατρέποντας το σχετικό οπως στο επισυναπτόμενο. Παράλληλα τόκανα κάπως ευκολότερο.

Γιατί; Θα ήθελα να ακούσω απόψεις σε αυτό. Δε βρίσκω κάτι κακό αν και κάποιες φορές έχω ακούσει εντάσεις.
Θυμάμαι όταν ήμουν φοιτητής και έκανα πιθανότητες παράτησα το διάβασμα για τις εξετάσεις και άρχισα να υπολογίζω πιθανότητες σε όλα τα τυχερά παιχνίδια που ήξερα (λοττο, πόκερ ζάρια κλπ). Πήρε αμέσως χρώμα το μάθημα. Κάτι τέτοιο θα επιδίωκα και τώρα... να τραβήξουμε την προσοχή των μαθητών... ειδικα των αδύναμων. Ένα άλλο θέμα που συζητάμε με τους καλούς είναι να εκτυπωθούν όλοι οι συνδυασμοί του joker. Τι πάει στραβάμε όλα αυτά;
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: pgrontas στις 08 Ιαν 2009, 07:25:43 μμ
Τελικά πιστεύω κι εγώ πως αν υπάρχει διάβασε μέσα σε συνθήκη η μετατροπή δε γίνεται.
Πάντως για το παράδειγμα που τέθηκε από τον Κώστα συμφωνώ με τον evry ότι δεν είναι αντιπροσωπευτικό και δεν είναι αυτό που θέλει να ελέγξει η άσκηση γιατί δεν υπάρχει εμφώλευση για την μεταβλητή χ.
Αυτό που έχω εγώ αντίρρηση είναι ότι το παντα θέλει κάποιου είδους απόδειξη που δεν είναι σε θέση να σκεφτούν οι μαθητές.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: P.Tsiotakis στις 08 Ιαν 2009, 07:50:56 μμ
Στην πρόταση:
"Η πολλαπλή επιλογή  Αν…τότε …αλλιώς_αν  δεν μπορεί να αντικαταστήσει κάθε περίπτωση εμφωλευμένης δομής επιλογής."

δεν υπάρχει χαρακτηριστική περίπτωση. Αναφέρεται σε κάθε περίπτωση..
Όντως δεν υπάρχει απόδειξη, αν υπάρχει όμως πάράδειγμα που ΔΕΝ γίνεται αρκεί για να απαντήσουμε οτι ΔΕΝ γίνεται πάντα...
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: pgrontas στις 08 Ιαν 2009, 08:46:17 μμ
Στην πρόταση:
"Η πολλαπλή επιλογή  Αν…τότε …αλλιώς_αν  δεν μπορεί να αντικαταστήσει κάθε περίπτωση εμφωλευμένης δομής επιλογής."

δεν υπάρχει χαρακτηριστική περίπτωση. Αναφέρεται σε κάθε περίπτωση..
Όντως δεν υπάρχει απόδειξη, αν υπάρχει όμως πάράδειγμα που ΔΕΝ γίνεται αρκεί για να απαντήσουμε οτι ΔΕΝ γίνεται πάντα...
Ένα αντιπαράδειγμα ΠΡΟΦΑΝΩΣ καταρρίπτει μια υπόθεση, αλλά αυτό που εννοώ είναι ότι καταρρίπτει μια υπόθεση διαφορετική από αυτήν που ήθελε να ελέγξει ο εμπνευστής της άσκησης.
Αυτό συμβαίνει επειδή η διατύπωση είναι προβληματική.

Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ntzios kostas στις 09 Ιαν 2009, 12:29:57 πμ
Παράθεση
Πάντως για το παράδειγμα που τέθηκε από τον Κώστα συμφωνώ με τον evry ότι δεν είναι αντιπροσωπευτικό και δεν είναι αυτό που θέλει να ελέγξει η άσκηση γιατί δεν υπάρχει εμφώλευση για την μεταβλητή χ.

Ας δούμε και το επόμενο.

αν χ>0 τότε
    χ<--χ+1
αλλιώς
    διάβασε χ
    αν χ>8 τότε
      χ<--χ-1
    τέλος_αν
τέλος_αν
γράψε χ

Πάλι νομίζω ότι έχουμε πρόβλημα, παρ΄όλο που έχει εμφώλευση του χ.   

Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: pgrontas στις 09 Ιαν 2009, 10:47:00 πμ
Αν καταχραστούμε την ελευθερία της ψευδογλώσσας μπορούμε να γράψουμε το εξής

Αλγόριθμος ΔΑ χ
   τ<-χ
   διαβασε χ
   δα<--χ
Τελος ΔΑ

τ<-0
Αν χ<=0 και (ΔΑ χ)>8 τοτε
   χ<-χ-1
   γραψε χ
αλλιως
  τ<-τ+1
  γραψε τ
τελος_αν

Προφανώς αυτό είναι εντελώς εκτός του σκοπού του μαθήματος (γι αυτό είπα αρχικά ότι το πάντα είναι βαρύ)
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: ntzios kostas στις 09 Ιαν 2009, 12:19:39 μμ
Έκανα μία προσπάθεια για να περιγράψω την εμφωλευμένη δομή επιλογής σε πολλαπλή. Για δείτε την!!!
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: gpapargi στις 19 Ιαν 2009, 02:33:50 μμ
Μετά από συζήτηση μεταξύ των μελών της ομάδας έγιναν οι 2 διορθώσεις στα σημεία που εντοπίστηκαν από τον Κώστα και τον lykos. Συγκεκριμένα άλλαξε το θέμα 1Β και έγινε αλλαγή διατύπωσης στο θέμα 4.

Το καινούργιο αρχείο με το διαγώνισμα μπορεί να το βρει κανείς στην αρχή του συγκεκριμένου θέματος.

Ευχαριστούμε πολύ τους 2 φίλους για τις εύστοχες επισημάνσεις τους και ζητάμε συγνώμη για την όποια αναστάστωση. Περιμένουμε και άλλα σχόλια/διορθώσεις για το διαγώνισμα.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: aggeloni στις 11 Οκτ 2010, 02:23:12 πμ
Αν και καπως αργα για ερωτησεις-διευκρινησεις, υπαρχουν λυσεις για το συγκεκριμενο διαγωνισμα??

Επισης, στο Θεμα 3ο δεν καταλαβαινω ακριβως τη διατυπωση στα ΣΤ και Ζ. Στο Στ οταν λεει "αναμεσα" εννοει πχ στη ζαρια 1 και 4, αν η τριτη ειναι 2 ή 3 (ανοικτο διαστημα δλδ) ή μπορει να ειναι και το 1 ή 4. Επισης, στο Ζ παλι εξαιρουνται ή οχι η αρχικες ζαριες, δλδ στη ζαρια 1 και 4, αν φερω 5 ή 6 κερδιζω το μισο ποσο ή και με 4 παλι κερδιζω το μισο ποσο??
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: mouzzikos στις 16 Νοέ 2013, 02:23:53 μμ
Μηπως εχουν βγει οι λυσεις για αυτο το τεστ; ευχαριστω
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: stamos_andreas στις 17 Φεβ 2014, 09:45:08 πμ
πολυ ενδιαφερον διαγωνισμα ωστοσο εχω καποιες αποριες..μπορω να βρω καπου τις απαντησεις του διαγωνισματος?
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: Laertis στις 17 Φεβ 2014, 09:33:21 μμ
Απ' όσο θυμάμαι δε δημοσιεύτηκαν λύσεις για το συγκεκριμένο διαγώνισμα, όπως και για τα προγενέστερα. Οι λύσεις συμφωνήθηκε και άρχισαν να δημοσιεύονται για το τελικό διαγώνισμα κάθε χρονιάς απο τη συγκεκριμένη χρονιά και έπειτα.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: stamos_andreas στις 18 Φεβ 2014, 12:14:08 μμ
μαλιστα,ευχαριστω πολυ..μηπως καποιος μπορει ωστοσο απο καποιο αρχειο αν υπαρχει να ανεβασει τις λυσεις του 3 και 4 θεματος ή δεν υπαρχουν ?
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: tdrivas στις 19 Φεβ 2014, 12:54:52 μμ
ενδεικτική λύση θέματος 4.. θεωρώ ότι δεν παραμένει στην ίδια πίστα ποτέ. Εκτός φυσικά αν χάσει.
Τίτλος: Απ: Επαναληπτικό Διαγώνισμα κεφ.1-2 για το 2008-2009
Αποστολή από: stamos_andreas στις 05 Μάρ 2014, 02:56:14 μμ
σας ευχαριστω πολυ για την λυση σας η οποια μπορω να πω προσεγγιζει σε καποιο βαθμο εκεινη που ειχα και εγω σκεφτει..σας ειναι ευκολο να ανεβασετε μια ενδεικτικη λυση για το θεμα 3?σας ευχαριστω εκ των προτερων !