Αποστολέας Θέμα: ΑΝ <λογική_μεταβλητή> ΤΟΤΕ  (Αναγνώστηκε 479 φορές)

mchatzinikolaou

  • Νέος
  • *
  • Μηνύματα: 2
ΑΝ <λογική_μεταβλητή> ΤΟΤΕ
« στις: 02 Σεπ 2020, 01:59:36 μμ »
Καλησπέρα συνάδελφοι με το πρώτο πόστ (ελπίζω από πολλά  :D )

Θα είμαι λακωνικός :

μεταβλητή <- Αληθής
ΑΝ μεταβλητή ΤΟΤΕ
     ΓΡΑΨΕ "Εκτελείται"
ΤΕΛΟΣ_ΑΝ

Στο παραπάνω κομμάτι κώδικα θα εμφανιστεί το "Εκτελείται" στην έξοδο;

Σύμφωνα με τον ΔΙΕΡΜΗΝΕΥΤΗ , έχουμε είσοδο στο βρόχο, πού βρίσκεται όμως αυτό στη θεωρία ;

Ευχαριστώ.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2823
  • Πύργος Ηλείας
Απ: ΑΝ <λογική_μεταβλητή> ΤΟΤΕ
« Απάντηση #1 στις: 02 Σεπ 2020, 02:23:52 μμ »
Καλώς ήρθες συνάδελφε!

Καλησπέρα συνάδελφοι με το πρώτο πόστ (ελπίζω από πολλά  :D )

Θα είμαι λακωνικός :

μεταβλητή <- Αληθής
ΑΝ μεταβλητή ΤΟΤΕ
     ΓΡΑΨΕ "Εκτελείται"
ΤΕΛΟΣ_ΑΝ

Στο παραπάνω κομμάτι κώδικα θα εμφανιστεί το "Εκτελείται" στην έξοδο;

Σύμφωνα με τον ΔΙΕΡΜΗΝΕΥΤΗ , έχουμε είσοδο στο βρόχο, πού βρίσκεται όμως αυτό στη θεωρία ;

Ευχαριστώ.

Στην ΑΝ μπαίνει μια συνθήκη, δηλαδή μια λογική έκφραση, δηλαδή μία έκφραση που η αποτίμησή της δίνει αποτέλεσμα Αληθής ή Ψευδής. Μία έκφραση μπορεί να αποτελείται από μία μόνο μεταβλητή (σχολικό, σελ. 31). Αυτή είναι η περίπτωσή σου! Είναι σωστό και μάλιστα κάτι παρόμοιο έχει πέσει ως υποερώτημα σε θέμα Α' πανελληνίων το 2011, την ίδια χρονιά που είχε μπει και σε επαναληπτικό διαγώνισμα του Στεκιού !

https://alkisg.mysch.gr/steki/index.php?topic=3839.0  (διάβασε και τα σχόλια)


Θέμα Α4 πανελληνίων 2011


∆ίνεται το παρακάτω τμήμα αλγορίθμου:
 
Αν Χ>1 τότε
 Κ <- Αληθής
Αλλιώς
 Κ <- Ψευδής
Τέλος_αν

Να γράψετε στο τετράδιό σας συμπληρωμένη την παρακάτω
εντολή εκχώρησης, ώστε να έχει το ίδιο αποτέλεσμα με το
παραπάνω τμήμα αλγορίθμου.

 Κ <- .....
« Τελευταία τροποποίηση: 02 Σεπ 2020, 02:36:39 μμ από Νίκος Αδαμόπουλος »

mchatzinikolaou

  • Νέος
  • *
  • Μηνύματα: 2
Απ: ΑΝ <λογική_μεταβλητή> ΤΟΤΕ
« Απάντηση #2 στις: 05 Σεπ 2020, 08:52:29 μμ »
Ευχαριστώ συνάδελφε.

Ναι τα σχόλια ήταν κατατοπιστικά.

Ως πρωτάρης έχω λίγο άγχος αλλά και εμπιστοσύνη στις γνώσεις μου , θα τα καταφέρουμε και φέτος να τα πάμε καλά συνολικά.

Καλή συνέχεια !