Αποστολέας Θέμα: Προβλημα με πινακες  (Αναγνώστηκε 1082 φορές)

Mxalis

  • Νέος
  • *
  • Μηνύματα: 2
Προβλημα με πινακες
« στις: 17 Ιαν 2020, 12:38:30 μμ »
Καταρχας οριστε ο αλγοριθμςο μου μεχρι στιγμης

Αλγόριθμος ασκ14
!διαβαζει χωρες και φπα
Για ι από 1 μέχρι 3                                          !χωρες και φπα [24]
  Γράψε "Δωσε χωρα και φπα"
  Διάβασε χωρ[ι], φπα[ι]
Τέλος_επανάληψης
!διαβασει μοντελα , εργοστασιακη τιμη , πωλησεις σε καθε χωρα
Για ι από 1 μέχρι 2              !μοντελα αυτοκινητων και εργοστασιακη τιμη [10]
  Γράψε "δωσε μοντελα αυτοκινητων και την εργοστασιακη τους τιμη"
  Διάβασε μον[ι], εργ[ι]
  Για ξ από 1 μέχρι 3                               ! πωλησεις σε καθε χωρα [24]
    Γράψε "τωρα δωσε ποσες πωλησεις εκανε στην ", χωρ[ξ]
    Διάβασε πωλ[ι, ξ]
  Τέλος_επανάληψης
Τέλος_επανάληψης

Για ι από 1 μέχρι 3                                                   ! 24 χωρες
  Σ ← 0                                       !συνολο αυτοκινητων που πουληθηκαν
  Για ξ από 1 μέχρι 2                                               ! 10 μοντελα
    Σ ← Σ + πωλ[ξ, ι]
  Τέλος_επανάληψης
  Γράψε "για την χωρα ", χωρ[ι], " πουληθηκαν συνολο ", Σ
Τέλος_επανάληψης

Για ι από 1 μέχρι 3                                                    !24 χωρες
  μαξ ← -1
  μαξθ ← 99
  Για ξ από 1 μέχρι 2                                               ! 10 μοντελα
    Αν πωλ[ξ, ι] > μαξ τότε
      μαξ ← πωλ[ξ, ι]
      μαξθ ← ξ
    Τέλος_αν
  Τέλος_επανάληψης
  Γράψε "Στην χωρα ", χωρ[ι], " καλύτερες πωλήσεις ειχε το μοντέλο ", μον[μαξθ]
Τέλος_επανάληψης

μαξ ← 0
μαξμ ← 0
Για ι από 1 μέχρι 2                                                 ! 10 μοντελα
  αθρ ← 0
  Για ξ από 1 μέχρι 3                                                  !24 χωρες
    αθρ ← αθρ + πωλ[ι, ξ]
  Τέλος_επανάληψης
  Αν αθρ > μαξ τότε
    μαξ ← αθρ
    μαξμ ← ι
  Τέλος_αν
Τέλος_επανάληψης
Γράψε "το μοντελο ", μον[μαξμ], " ειχε την μεγαλυτερη ζητηση στην ευρωπη"

Για ι από 1 μέχρι 2                                                  !10 μοντελα
  Για ξ από 1 μέχρι 3                                                  !24 χωρες
    Γράψε "για την χωρα ", χωρ[ξ], " το μοντελο ", μον[ι], " κοστιζει ", (εργ[ι] + (φπα[ξ]*εργ[ι]))
  Τέλος_επανάληψης
Τέλος_επανάληψης

Τέλος ασκ14
Το προβλημα το εχω στο τελος της ασκησης οπου προσπαθω να κανω πραξεις με πινακες , οταν διαβαζει το φπα εχω δοκιμασει να γραφω 25/100 η 0.25 και στον πινακα εργ (εργοστιασιακη τιμη) βαζω ακεραιους αριθμους πχ 100000
Για καποιο λογο μου πεταξει συνεχεια ειτε οτι ο πινακας φπα ειναι εκφραση ειτε οτι προσπαθω να κανω πραξεις με εκφρασεις
Καμια βοηθεια;

Mxalis

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Προβλημα με πινακες
« Απάντηση #1 στις: 17 Ιαν 2020, 02:52:15 μμ »
Εν τελη το ελυσα με το να βαζω την πραξη (εργ[ι] + (φπα[ξ]*εργ[ι])) σε μια μεταβλητη κοστος
Δηλαδη
κοστος <- (εργ[ι] + (φπα[ξ]*εργ[ι]))
και μετα γραψε κοστος
για καποιο λογο το ελυσε δεν ξερω γιατι

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1128
Απ: Προβλημα με πινακες
« Απάντηση #2 στις: 20 Ιαν 2020, 07:42:41 πμ »
Αν θεωρήσουμε ότι δεν υπάρχει λογικό λάθος καλό είναι να αναφέρεις το περιβάλλον προγραμματισμού στον οποιον έγραψες τον κώδικά σου και τον δοκίμασες