Αποστολέας Θέμα: Πανελληνιες 2016-Ερωτηση!  (Αναγνώστηκε 2936 φορές)

bausdrum

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Πανελληνιες 2016-Ερωτηση!
« Απάντηση #15 στις: 29 Μάι 2016, 11:58:13 πμ »
Δηλαδή, το ότι το λάθος μου βρίσκεται στην αρχή και "καταστρέφει" όλο τον κώδικα δεν επιφέρει απώλεια μεγαλύτερη της μιας μονάδας, ε; Μακάρι, θεούλη μου!
« Τελευταία τροποποίηση: 29 Μάι 2016, 12:13:31 μμ από bausdrum »

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: Πανελληνιες 2016-Ερωτηση!
« Απάντηση #16 στις: 29 Μάι 2016, 06:49:53 μμ »
Έτσι βαθμολογούνται τα γραπτά του προγραμματισμού
Σε διαφορετική περίπτωση, θα έπρεπε να μηδενίζονται ολόκληρα θέματα για ένα συντακτικό ή λογικό λάθος
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

dion

  • Θαμώνας
  • ***
  • Μηνύματα: 20
Απ: Πανελληνιες 2016-Ερωτηση!
« Απάντηση #17 στις: 05 Ιούν 2016, 09:15:33 μμ »

Δ3. Να υπολογίζει και να καταχωρίζει σε πίνακα ΣΧ το συνολικό ετήσιο χρόνο πρόσβασης κάθε μαθητή. (Μονάδες 3)
Η απάντηση που πρέπει να δοθεί είναι:
Για Ι από 1 μέχρι 150000
  ΣΧ[Ι] ← 0
  Για J από 1 μέχρι 12
    ΣΧ[Ι] ← ΣΧ[Ι] + ΧΡ[Ι, J]
  Τέλος_επανάληψης
Τέλος_επανάληψης

Ο φίλος μας αν έχω καταλάβει σωστά έχει γράψει
Για Ι από 1 μέχρι 150000
  ΣΧ[Ι] ← 0
  Για J από 1 μέχρι 300
    ΣΧ[Ι] ← ΣΧ[Ι] + ΧΡ[Ι, J]
  Τέλος_επανάληψης
Τέλος_επανάληψης 
Η εκφώνηση ήταν ξεκάθαρη και μιλούσε για μήνες(12) ενώ εδώ έχει βάλει ημέρες (300) συνεπώς δεν βγάζει το ίδιο αποτέλεσμα, και δεν γίνεται να πάρει τους ίδιους βαθμούς με κάποιον που το έκανε όπως το ζητάει η εκφώνηση. Προσωπικά θεωρώ ότι από τις 3 μονάδες του ερωτήματος δεν πρέπει να πάρει κάτι.

Να αναπτύξετε συνάρτηση ΘΕΣΗ_ΜΑΧ η οποία:
α) να δέχεται ως παραμέτρους: τον πίνακα του φύλου, τον πίνακα του συνολικού ετήσιου χρόνου πρόσβασης των μαθητών και…


Σε αυτό το ερώτημα η συνάρτηση δέχεται τον πίνακα ΣΧ[150000] ο οποίος όμως έχει λάθος δεδομένα καθώς έχει υπολογιστεί λάθος. Οκ δεν υποστηρίζω ότι πρέπει να χάσει όλο το ερώτημα (8 μονάδες) αλλά κάτι πρέπει να χάσει και από εδώ καθώς δεν είναι σωστά τα επιστρεφόμενα αποτελέσματα.
Είμαι βαθμολογητής στις πανελλαδικές και θα ήθελα να απαντήσω (στον μαθητή) μιας και το λάθος στο Δ3 το είδα σε 3-4 γραπτά. Χάνει μόνο 1 μονάδα εφόσον το άλλο είναι σωστό. Στο θέμα Δ5 δεν χάνει τίποτα.