Αποστολέας Θέμα: Ταξινόμηση εισαγώγης  (Αναγνώστηκε 725 φορές)

theoni

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 116
Ταξινόμηση εισαγώγης
« στις: 09 Μάι 2016, 11:05:37 πμ »
Καλημέρα η ταξινόμηση όπως δίνεται στο παράδειγμα στο βιβλίο του καθηγητή είναι σωστή?????

Λάμπρος Παπαδόπουλος

  • Βετεράνος
  • ****
  • Μηνύματα: 63
Απ: Ταξινόμηση εισαγώγης
« Απάντηση #1 στις: 10 Μάι 2016, 04:09:42 μμ »
Όχι. Βγάζει τον πίνακα εκτός ορίων.
Μια υλοποίηση θα μπορούσε να είναι η παρακάτω (αύξουσα)

Κώδικας: [Επιλογή]
Αλγόριθμος  Ταξινόμηση_με_εισαγωγή
Δεδομένα // Α, Ν //
Για i από 2 μέχρι N
  στοιχείοΓιαΤοποθέτηση ← A[i]
  θέση ← i
  ΣυνέχισηΜετατόπισης ← Αληθής
  Όσο θέση > 1 και ΣυνέχισηΜετατόπισης επανάλαβε
    Αν A[θέση - 1] > στοιχείοΓιαΤοποθέτηση τότε
      A[θέση] ← A[θέση - 1]
      θέση ← θέση - 1
    αλλιώς
      ΣυνέχισηΜετατόπισης ← Ψευδής
    Τέλος_αν
  Τέλος_επανάληψης
  A[θέση] ← στοιχείοΓιαΤοποθέτηση
Τέλος_επανάληψης
Αποτελέσματα // A //
Τέλος Ταξινόμηση_με_εισαγωγή