Αποστολέας Θέμα: Πρόβλημα στη συνθήκη της ΟΣΟ  (Αναγνώστηκε 5382 φορές)

petepan

  • Επισκέπτης
Απ: Πρόβλημα στη συνθήκη της ΟΣΟ
« Απάντηση #15 στις: 03 Ιούν 2006, 10:34:07 μμ »
.... Ή ΜΗΠΩΣ ΑΥΤΟ:

ΠΡΟΓΡΑΜΜΑ ΑΣΕΠ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: διαγ, Σ
ΑΡΧΗ
  Σ <- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΔΩΣΤΕ ΑΡΙΘΜΟ ΔΙΑΓΩΝΙΖΟΜΕΝΩΝ'
      ΔΙΑΒΑΣΕ διαγ
       ΑΝ (1500-(Σ+διαγ)) < 0 ΤΟΤΕ
       ΓΡΑΨΕ 'ΔΕΝ ΜΠΟΡΕΙΤΕ ΝΑ ΕΙΣΑΓΕΤΕ ΠΑΡΑΠΑΝΩ ΑΠΟ ',1500-Σ , 'ΔΙΑΓΩΝΙΖΟΜΕΝΟΥΣ'
       ΤΕΛΟΣ_ΑΝ
       ΑΝ διαγ < 0 ΤΟΤΕ
       ΓΡΑΨΕ 'ΔΕΝ ΜΠΟΡΕΙΤΕ ΝΑ ΕΙΣΑΓΕΤΕ ΑΡΝΗΤΙΚΟ ΑΡΙΘΜΟ ΔΙΑΓΩΝΙΖΟΜΕΝΩΝ'
       ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ (1500-(Σ+διαγ)) >= 0 ΚΑΙ διαγ >= 0
    ΓΡΑΨΕ 'ΑΡΙΘΜΟΣ ΕΠΙΤΗΡΗΤΩΝ: ', υπολ(διαγ)
    Σ <- Σ+διαγ
  ΜΕΧΡΙΣ_ΟΤΟΥ Σ=1500
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
ΣΥΝΑΡΤΗΣΗ υπολ(χ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: χ
ΑΡΧΗ
  ΑΝ χ <= 15 ΤΟΤΕ
    χ <- 1
  ΑΛΛΙΩΣ_ΑΝ χ <= 23 ΤΟΤΕ
    χ <- 2
  ΑΛΛΙΩΣ
    χ <- 3
  ΤΕΛΟΣ_ΑΝ
  υπολ <- χ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3244
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Πρόβλημα στη συνθήκη της ΟΣΟ
« Απάντηση #16 στις: 04 Ιούν 2006, 05:36:49 μμ »

Διαβάζουμε τη ΧΩΡΗΤΙΚΟΤΗΤΑ της αίθουσας.
ΜΠΟΡΕΙ τελικά να ξεπεραστεί η τιμή 1500, αφού η συνολική χωρητικότητα ΕΠΑΡΚΕΙ για τους υποψηφίους. Η τελευταία αίθουσα δεν θα είναι γεμάτη (ή θα έχει ακριβώς όσους περίσσεψαν)

Αν το σύνολο_θέσεων είναι 1480 και διαβαστεί η τιμή 30 (το 1510 είναι >= 1500, ΕΠΑΡΚΕΙ δηλαδή). Στην τελευταία αίθουσα θα κάτσουν 20 άτομα ενώ χωράνε 30 και χρειάζονται 3 επιτηρητές

Και γω νομίζω οτι είναι σαφέστατη η σημείωση

Η συνθήκη "Μέχρις_ότου σύνολο = 1500" είναι λάθος και παραβιάζεται η περατότητα

Δεν είναι κακό να διαφωνούμε, το σωστό ποιο είναι όμως;

Με εκτίμηση,
 
Παναγιώτης ΤσιΩτάκης (είναι ωμέγα)

klitos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 133
Απ: Πρόβλημα στη συνθήκη της ΟΣΟ
« Απάντηση #17 στις: 05 Ιούν 2006, 01:51:39 μμ »
Ο Τσιωτάκης εχει δίκαιο ..
Οι οδηγιες που δόθηκαν στο βαθμολογικο ηταν προς την σωστή κατεύθυνση
πρεπει η συνθήκη να ειναι
"Μέχρις_ότου σύνολο >= 1500"  ή αντίστοιχα
"Οσο συνολο <1500"

κλητος χατζηγεωργιου

filippos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 139
Απ: Πρόβλημα στη συνθήκη της ΟΣΟ
« Απάντηση #18 στις: 05 Ιούν 2006, 11:07:34 μμ »
Τι εννοείς "οι οδηγίες που δόθηκαν στο βαθμολογικό" ;;;

ΑΠό ποιόν δόθηκαν οδηγίες προς το βαθμολογικό;;; Στο δικό μας υπήρξε απλά συζήτηση με το συντονιστή.  Δε δόθηκαν όμως επιπλέον οδηγίες.

Σε σαςς klitos από ποιόν δόθηκαν οδηγίες;

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 789
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Πρόβλημα στη συνθήκη της ΟΣΟ
« Απάντηση #19 στις: 06 Ιούν 2006, 12:33:50 πμ »
Εσύ σε ποιό βαθμολογικό είσαι Φίλλιπε;
Εφέτος έγινε προσπάθεια ενός πανελήνιου συντονισμού των συντονιστών του μαθήματος.  Ο δικός σου συντονιστής μάλλον δεν συμμετείχε σε αυτό  (ίσως χωρίς δική του ευθύνη).  Εκεί λοιπόν συμφωνήθηκαν ορισμένες κοινές οδηγίες όπως αυτή με την συνθήκη.
Κάποια στιγμή (αφού ηρεμίσουμε) θα γίνει μαι πλήρη περιγραφή της όλης προσπάθειας. 

filippos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 139
Απ: Πρόβλημα στη συνθήκη της ΟΣΟ
« Απάντηση #20 στις: 06 Ιούν 2006, 10:43:30 πμ »
Η προσπάθεια συντονισμού που αναφέρει ο Βαγγέλης ήταν πράγματι μια πολύ καλή ιδέα.  Μας ενημέρωσε σχετικά ο συντονιστής μας και είχε την αποδοχή του συνόλου των βαθμολογητών.  Επιτέλους, κάποια στιγμή να υπάρχει σύγκλιση της βαθμολογίας σε εθνικό επίπεδο.

Όμως αυτές δεν ήταν "οδηγίες" με την αυστηρή έννοια του όρου, αλλά κοινές "διαπιστώσεις" - αποφάσεις που λήφθηκαν κατόπιν συνεννόησης των συντονιστών.

Σκεφτόμουνα μήπως ο klitos αναφερόταν σε άλλου είδους οδηγίες που δώθηκαν κεντρικά.  Γιατί κάτι τέτοιο δεν έγινε στο δικό μας.  Οι μόνες "οδηγίες"ήταν αυτές που προέκυψαν από τη συζήτηση βαθμολογητών με συντονιστή και συντονιστών μεταξύ τους.

Όμως είναι λυπηρό, ακόμα και μετά από αυτή την αξιόλογη προσπάθεια σ΄θγκλισης, να υπάρχουν βαθμολογητές που λένε ... "εγώ έτσι βαθμολογώ !!!... δεν πά' να λέτε εσείς !"