Αποστολέας Θέμα: Θέμα Α  (Αναγνώστηκε 15764 φορές)

alpapanto

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • ΗΟΜΕ μοναχομ
Απ: Θέμα Α
« Απάντηση #30 στις: 01 Ιούν 2012, 05:50:32 μμ »
Υπάρχουν πουθενά οι λύσεις της ΚΕΕ να τις δούμε.
Έτσι για ενημέρωση.
τι να δεις...???
Μεχρι και 2 πινακες 2 θεσεων χρησιμοποίησαν στο θεμα Γ για να κρατανε τα πλήθη και τα συνολα... Λες και το πλ1, πλ2, αθρ1, αθρ2 ειναι πολυ δυσκολο...

manpap

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 126
  • Είμαι χαζομπαμπάς...
Απ: Θέμα Α
« Απάντηση #31 στις: 01 Ιούν 2012, 05:51:39 μμ »
ΘΕΜΑ Α3Β
ΓΙΑ Ι ΑΠΟ 6 ΜΕΧΡΙ 10
    ΑΝΤΙΜΕΤΑΘΕΣΕ Α[Ι],Α[11-Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Και βέβαια είναι σωστό.
Ποιος μαθητής όμως θα σκεφτεί να το γράψει?
Σωστό είναι και το παρακάτω...
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 6
    ΑΝΤΙΜΕΤΑΘΕΣΕ Α[Ι-1],Α[12-Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
κλπ...

Συντηρώ το μυαλό μου ακοίμητο, λαγαρό, ανήλεο. Το αμολώ να παλεύει ακατάλυτα. Άλλο αργαστήρι να κάνω το σκοτάδι φως δεν έχω.
Ν. Καζαντζάκης

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Απ: Θέμα Α
« Απάντηση #32 στις: 01 Ιούν 2012, 06:05:44 μμ »
Μα αυτό είναι το ωραίο ...
Η φαντασία των μαθητών και η έμπνευση που πολλές φορές μας ξαφνιάζει.
Ας μην είναι και τέλεια από τεχνικής άποψης.

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Θέμα Α
« Απάντηση #33 στις: 01 Ιούν 2012, 06:08:02 μμ »

Ποιος μαθητής όμως θα σκεφτεί να το γράψει?


Γιατί?? Χαρτί, μολύβι και τρέξιμο να δεις τι βγάζει... έτσι λύνονται οι ασκήσεις, όχι μόνο με την σκέψη
Νομίζω αυτή η απάντηση είναι και η πιο απλή....

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2787
  • Πύργος Ηλείας
Απ: Θέμα Α
« Απάντηση #34 στις: 01 Ιούν 2012, 06:12:12 μμ »
Η άσκηση δεν ζητούσε τι θα εμφανιστεί στην οθόνη όμως

Τα εισαγωγικά δεν αποθηκεύονται μέσα στη μεταβλητή! Όταν γράφεις Χ<-'ΑΛΗΘΗΣ' τι ακριβώς αποθηκεύεται μέσα στη μεταβλητή; Πόσοι χαρακτήρες; Το αναφέρει το βιβλίο; Συμφωνώ με τον merlin παραπάνω!

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: Θέμα Α
« Απάντηση #35 στις: 01 Ιούν 2012, 06:17:21 μμ »
Αν ήμουν μαθητής και έδινα σήμερα, θα σκεφτόμουν ότι δεν μπορεί να υπάρχει η ίδια ακριβώς τιμή σε μια λογική και σε μια αλφαριθμητική μεταβλητή που μου έδωσαν να συμπληρώσω σε έναν πίνακα
Δηλαδή, αν αντί για εντολή εκχώρησης μας έδιναν την μνήμη και σε κάποια θέση μνήμης υπήρχε η τιμή ΑΛΗΘΗΣ, θα λέγαμε ότι μπορεί να είναι Χαρακτήρες;;; Με την ίδια λογική, και η τιμή 2 σε μια θέση μνήμης μπορεί να είναι αλφαριθμητική
Το κλείνω εδώ γιατί το ξεχειλώσαμε
 
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

GtakriZ

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Θέμα Α
« Απάντηση #36 στις: 01 Ιούν 2012, 06:26:48 μμ »
Έχασα τσάμπα 5 μόρια από το Α2.. :(
Κατά τη γνώμη μου ήταν 'χαζή' ερώτηση και υπήρχε ασάφεια σε αυτό που ζητούσαν για το 'περιεχόμενο' της μεταβλητής. Λίγοι από εμάς βγήκαν με σιγουριά για την επιλυσή του και ακόμη πιο λίγοι με σωστή λύση.. Ας έλεγαν τουλάχιστον 'το αποτέλεσμα' της μεταβλητής..

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: Θέμα Α
« Απάντηση #37 στις: 01 Ιούν 2012, 06:28:54 μμ »
Πέτρο και εγώ που δεν είμαι μαθητής έτσι σκέφτηκα ότι θα "ήθελαν" να το γράψω οι θεματοδότες. Δηλαδή το ένα με εισαγωγικά και το άλλο όχι (έτσι το έγραψα όταν τα έλυνα). Όμως η πραγματική πληροφορία που υπάρχει στη μεταβλητή είναι τα γράμματα (οι χαρακτήρες), όχι τα εισαγωγικά.
Για να το προχωρήσουμε λίγο, όλα είναι 0 και 1 στη μνήμη είτε είναι χαρακτήρες, είτε ακέραια είτε πραγματική (μονής - διπλής ακρίβειας κλπ).

Γι' αυτό το λόγο είπα ότι δε θα έπρεπε να "αγγίξουμε" τέτοιο θέμα γιατί θα αρχίσουμε να μιλάμε για την qbasic που έγραψε ένας φίλος πιο πάνω ή γιατί στη C το true υλοποιείται διαφορετικά σε σχέση με τη Java κλπ κλπ.

Απλά για μένα πρέπει να δοθούν και τα 2 σωστά, εισαγωγικά ή όχι.
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 117
Απ: Θέμα Α
« Απάντηση #38 στις: 01 Ιούν 2012, 08:19:42 μμ »
Λέει μία πρόταση στο πρώτο ερώτημα:

«Η χρήση των πινάκων σε ένα πρόγραμμα αυξάνει την απαιτούμενη μνήμη.»

Η αυθόρμητη απάντηση είναι ΣΩΣΤΟ, συμφωνώ, αλλά ένας μαθητής μου έρχεται και μού λέει ότι το έβαλε ΛΑΘΟΣ, γιατί είτε βάλεις έναν πίνακα πχ 10 κελιών, είτε βάλεις 10 απλές μεταβλητές, την ίδια μνήμη θα φας, κι έχει δίκιο το παιδί...

Σκέφτομαι λοιπόν, μήπως η διατύπωση έπρεπε να έλεγε «Η χρήση των πινάκων σε ένα πρόγραμμα όπου δεν είναι απαραίτητη, αυξάνει την απαιτούμενη μνήμη.»

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Θέμα Α
« Απάντηση #39 στις: 01 Ιούν 2012, 09:09:34 μμ »
Καλησπέρα και απο μένα... Στο Α3.β ένας μαθητής μου έκανε το εξής...
       
          Για i απο 1 μέχρι 11 - i
               Αντιμετάθεσε Α , Α[11 - i]
          Τέλος_επανάληψης

Πώς σας φαίνεται?? Θα θεωρηθεί σωστό???

ipoulis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 56
  • Dum spiro spero
Απ: Θέμα Α
« Απάντηση #40 στις: 01 Ιούν 2012, 09:54:40 μμ »
Καλησπέρα και απο μένα... Στο Α3.β ένας μαθητής μου έκανε το εξής...
       
          Για i απο 1 μέχρι 11 - i
               Αντιμετάθεσε Α , Α[11 - i]
          Τέλος_επανάληψης

Πώς σας φαίνεται?? Θα θεωρηθεί σωστό???
Υπάρχει διευκρύνηση που λέει ότι στην Για α απο β μέχρι γ με_βημα δ
δεν πρέπει να αλλάζει κανένα
Νομίζω -1 μόριο


Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2787
  • Πύργος Ηλείας
Απ: Θέμα Α
« Απάντηση #41 στις: 01 Ιούν 2012, 10:06:41 μμ »
Καλησπέρα και απο μένα... Στο Α3.β ένας μαθητής μου έκανε το εξής...
       
          Για i απο 1 μέχρι 11 - i
               Αντιμετάθεσε Α[ i ] , Α[11 - i]
          Τέλος_επανάληψης

Πώς σας φαίνεται?? Θα θεωρηθεί σωστό???

Μα πώς να θεωρηθεί σωστό;

anasta

  • Βετεράνος
  • ****
  • Μηνύματα: 58
  • Ok, yes... Ok, yes...
Απ: Θέμα Α
« Απάντηση #42 στις: 01 Ιούν 2012, 10:12:49 μμ »
Ένας μαθητής στο Α3.β. έγραψε:

Για ι από 1 μέχρι 5
      αντιμετάθεσε Α[ι],Α[Α[ι]]
Τέλος_επανάληψης

Αν και εξαρτάται από την υλοποίηση του αλγορίθμου (π.χ. με διαδικασία swap), δε μπορώ παρά να τον συγχαρώ για την πρωτοτυπία του. Ελπίζω να μην του κόψουν μονάδες πάντως...

όταν ι=1 τότε Α[1]=1 και Α[Α[1]]=Α[1]=1
όταν ι=2 τότε Α[2]=2 και Α[Α[2]]=Α[2]=2
κτλ κτλ...
οπότε δεν γίνεται καμία αντιμετάθεση

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Θέμα Α
« Απάντηση #43 στις: 01 Ιούν 2012, 10:15:53 μμ »
Μα πώς να θεωρηθεί σωστό;
Άν αυτό μετατραπεί σε όσο και εκτελεστεί δε θα γίνει σωστά η αντιμετάθεση??

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: Θέμα Α
« Απάντηση #44 στις: 01 Ιούν 2012, 10:16:24 μμ »
όταν ι=1 τότε Α[1]=1 και Α[Α[1]]=Α[1]=1
όταν ι=2 τότε Α[2]=2 και Α[Α[2]]=Α[2]=2
κτλ κτλ...
οπότε δεν γίνεται καμία αντιμετάθεση

Όταν ι=1, Α[ι]=10
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20