Αποστολέας Θέμα: Διαίσθηση της τελευταίας στιγμής ...  (Αναγνώστηκε 10235 φορές)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #15 στις: 19 Μάι 2011, 11:04:29 πμ »
Μια άλλη, ίσως πιο απλή, προσέγγιση
Κώδικας: [Επιλογή]
Για i από 1 μέχρι 10
   Για j από 1 μέχρι 12  ! μήνας
      S <- 0
      Για μ από 1 μέχρι 30  ! μέρες μήνα
         S <- S + ΔΙΑΦΗΜΙΣΕΙΣ[ι, (j-1) * 30 + μ]
      Τέλος_επανάληψης
      ΕΣΟΔΑ[i, j] <- S
   Τέλος_επανάληψης
Τέλος_επανάληψης

dimpapadop

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 60
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #16 στις: 19 Μάι 2011, 11:56:17 πμ »
Μια άλλη, ίσως πιο απλή, προσέγγιση
Κώδικας: [Επιλογή]
Για i από 1 μέχρι 10
   Για j από 1 μέχρι 12  ! μήνας
      S <- 0
      Για μ από 1 μέχρι 30  ! μέρες μήνα
         S <- S + ΔΙΑΦΗΜΙΣΕΙΣ[ι, (j-1) * 30 + μ]
      Τέλος_επανάληψης
      ΕΣΟΔΑ[i, j] <- S
   Τέλος_επανάληψης
Τέλος_επανάληψης


ωραία προσσέγιση και πλησιέστερη στον τρόπο σκέψης των μαθητών. Ίσως και

Για i από 1 μέχρι 10
   Για j από 1 μέχρι 12  ! επαναλήψεις  μήνα
      S ←  0
      Για μ από (j-1)*30+1 μέχρι j*30 ! μέρες συγκεκριμένου μήνα μόνο // ή Για μ από j*30-29 μέχρι j*30 επίσης
         S ←  S + ΔΙΑΦΗΜΙΣΕΙΣ[i, μ]
      Τέλος_επανάληψης
      ΕΣΟΔΑ[i, j] ←  S
   Τέλος_επανάληψης
Τέλος_επανάληψης

για να χρησιμοποιήσουν απλούστερα τους δείκτες των πινάκων.

kpde

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #17 στις: 19 Μάι 2011, 12:04:50 μμ »

depy_f

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #18 στις: 19 Μάι 2011, 12:49:45 μμ »
Μια ενδεικτική λύση που που προτείνω είναι:
(με την θεώρηση ότι κάθε μήνας έχει 30 μέρες)

Για i από 1 μέχρι 10
Eμφάνισε "Τα έσοδα της ζώνης ", ΖΩΝΗ [i, 1]
  ημ <-- 0
  Για k από 1 μέχρι 12
    ΕΣΟΔΑ [ i , k ] <-- 0
    Για j από 1 μέχρι 30
      ΕΣΟΔΑ [ i, k ] <-- ΕΣΟΔΑ [ i, k ] + ΔΙΑΦΗΜΙΣΕΙΣ [ i, j + ημ] * ΤΙΜΗ [ i ]
    τέλος_επανάληψης
    ημ <-- ημ + 30
  Eμφάνισε " για το μήνα ", k , "είναι",  EΣΟΔΑ [i, k]
τέλος_επανάληψης

PE19

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #19 στις: 19 Μάι 2011, 01:58:41 μμ »
μήπως είναι πιο απλό για τα παιδιά αυτό:

! μηδενισμός συνόλου κάθε μήνα
Για ι από 1 μέχρι 10
    Για μήνας απο 1 μέχρι 12
   Σ[ι,μήνας]<--0
   Τέλος_επανάληψης
Τέλος_Επανάληψης
!σύνολο διαφημίσεων κάθε μήνα
Για ι από 1 μέχρι 10
   Για j από 1 μέχρι 360
      Μήνας<--j div 30
      Αν j mod 30>0 τότε
         Μήνας <--Μήνας+1
      Τέλος_Αν
      Σ[ι,μήνας]<--Σ[ι,μήνας]+Δ[ι,j]
   Τέλος_Επανάληψης
Τέλος_Επανάληψης


ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 128
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #20 στις: 19 Μάι 2011, 02:56:20 μμ »
μια άλλη λύση.....

Για i από 1 μέχρι 10
     Σ <-- 0
     κ <-- 0
     Για j από (κ+1) μέχρι (κ+30)
          Σ <-- Σ + Δ[i, j] * Τ
     Τέλος_επανάληψης
     κ <-- κ + 30
     Π[i, κ div 30] <-- Σ
     Τέλος_επανάληψης
Τέλος_επανάληψης
« Τελευταία τροποποίηση: 19 Μάι 2011, 03:13:57 μμ από ikariofil »

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #21 στις: 19 Μάι 2011, 03:08:22 μμ »
Μια λύση , δεν το έτρεξα

Κώδικας: [Επιλογή]
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΑΡΧ <- 1 !ΞΕΚΙΝΑΕΙ ΑΠΟ ΤΟ 1ο ΣΤΟΙΧΕΙΟ
    ΤΕΛ <- 30  !ΤΕΛΕΙΩΝΕΙ ΜΕ ΤΟ 30ο ΣΤΟΙΧΕΙΟ
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
        ΑΘΡ <- 0 !ΜΗΔΕΝΙΖΩ ΑΘΡΟΙΣΜΑ
        ΓΙΑ Λ ΑΠΟ ΑΡΧ ΜΕΧΡΙ ΤΕΛ
            ΑΘΡ <- ΑΘΡ + ΤΙΜΗ[Ι]*ΔΙΑΦΗΜΙΣΕΙΣ[Ι,Λ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΕΣΟΔΑ[Ι,Κ] <- ΑΘΡ
        ΑΡΧ <- Λ  !ΘΑ ΞΕΚΙΝΗΣΕΙ ΑΠΟ ΤΗΝ 31ο ΣΤΟΙΧΕΙΟ  (Λ=ΤΕΛ+1)
        ΤΕΛ <- ΤΕΛ + 30 !ΚΑΙ ΘΑ ΤΕΛΕΙΩΣΕΙ ΜΕ ΤΟ 60ο ΣΤΟΙΧΕΙΟ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #22 στις: 19 Μάι 2011, 05:00:38 μμ »
και η δική  μου...
όπου τα έσοδα δημιουργούνται ανα στήλη (ανα μήνα δηλαδή) με το σκεπτικό ότι βρίσκουμε τα έσοδα για ένα μήνα και στη συνέχεια το επαναλαμβάνουμε 12 φορές.

Για k από 1 μέχρι 12
  ΓΙα i από 1 μέχρι 10
   s<-- 0
   Για j από k*30-29 μέχρι k*30
    s<-- s+ΔΙΑΦΗΜΙΣΕΙΣ[i,j] * ΤΙΜΗ
   Τέλος_ επανάληψης
   ΕΣΟΔΑ[i,k]<-- s
 Τέλος_επανάληψης
Τέλος_επανάληψης
Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

johngreek

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #23 στις: 19 Μάι 2011, 06:12:29 μμ »
Stefan δύο λύσεις βρήκα :

( Θεωρώ δεδομένο οτι μιλάμε για 12 μήνες 30 ημερών  , πράγμα που θα πρέπει βέβαια να διευκρινιστεί στην εκφώνηση )

Μία αυτή που δίνει ο Π. Τσιωτάκης  , η οποία έχει τριπλή ΓΙΑ και μου φαίνεται οτι δύσκολα θα την συλλάβει μαθητής σε συνθήκες Πανελληνίων ( τη θεωρώ δηλαδή δύσκολη ακόμα και για τελευταίο υποερώτημα στο 4ο θέμα ) και μια ακόμα η οποία  έχει διπλή ΓΙΑ αλλά  έχει  ΄και μια μπανανόφλουδα .


! Μηδενίζω τον πίνακα ΕΣ
ΓΙΑ ζώνη ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ μέρα ΑΠΟ 1 ΜΕΧΡΙ 360
          μήνας <-- μέρα DIV 30 + 1
          AN μέρα MOD 30 = 0 ΤΟΤΕ
               μήνας <-- μήνας - 1
         ΕΣ[ζώνη , μήνας] <-- ΕΣ[ζώνη,μήνας] + ΔΙΑΦ[ζώνη,μέρα] * Τιμή[ζώνη]
    ΤΕ
ΤΕ

δεν το έχω τρέξει βέβαια και το έστησα λίγο βιαστικά  , διορθώσεις ευπρόσδεκτες.


Θα παρακαλούσα για τη γνώμη όλων σας ως προς τη δυσκολία της άσκησης ( Πάντα έχοντας στο μυαλό μαθητές σε συνθήκες πανελληνίων ,και έχοντας ίσως στο μυαλό το δεδομένο οτι τα φετινά θέματα  , ως τώρα είναι πιο ζόρικα σε σχέση με παλαιότερα ) . Επίσης θα ήθελα να ρωτήσω αν πιστεύεε οτι ενδείκνυται μια τέτοια άσκηση για ένα τελευταίο μάθημα  ( το οποίο είναι βασικά μάθημα ψυχολογίας )

Ολα αυτά με κάθε σεβασμό στη δουλειά της ( ? ) depy την οποία ευχαριστώ που μοιράστηκε την άσκηση

johngreek

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #24 στις: 19 Μάι 2011, 06:12:54 μμ »
ξεχασα ένα ΤΕΛΟΣ_ΑΝ παραπάνω

alepap76

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #25 στις: 19 Μάι 2011, 06:19:12 μμ »
γιατί να μην ασχοληθούμε και λίγο με συγχώνευση; εξ' άλλου έχει ζητηθεί σε επαναληπτικές και ήταν πανέξυπνο θέμα...ή πχ έξυπνη ταξινόμηση...

johngreek

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #26 στις: 19 Μάι 2011, 06:24:33 μμ »
PE19 μόλις  πρόσεξα τη λύση σου  :)

johngreek

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #27 στις: 19 Μάι 2011, 06:26:12 μμ »
alepap μου θυμίζεις πότε έπεσε το θέμα που λές ;

alepap76

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #28 στις: 19 Μάι 2011, 06:30:28 μμ »
επαναληπτικές του 2008 4ο θεμα με υποπρογράμματα (είσοδος και ταξινόμηση) και δημιουργία των πινάκων του τελικού με ονόματα και χρόνους

johngreek

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: Διαίσθηση της τελευταίας στιγμής ...
« Απάντηση #29 στις: 19 Μάι 2011, 06:41:23 μμ »
Ναι το θυμήθηκα . Αρκετά δυνατό θέμα



Α και κάτι άλλο  : Τι περιμένετε ( αν περιμένετε ) να πέσει αυτούσιο από το βιβλίο ; ( Οπως πέρσι ο αλγόριθμος με τα αθροίσματα δισδιάστατου από τη σελίδα 68 ) . Πιο πολύ για να το κάψω ρωτάω  :) , αυτά τα θέματα παπαγαλίας δεν μου αρέσουν